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Introduction
INTRODUCTION

HOW TO USE THIS MANUAL

Like any other manual, this manual is not intended to be read through from the first to the last 
page; however, we hope that its internal logic may make you want to do just that.

Following this introduction, you can find these three chapters:

"What Is New in Déjà Vu X3 Workgroup?" on page 15—an overview of some of the most 
outstanding new features of Déjà Vu X3 Workgroup.

"The Déjà Vu X3 Workgroup Interface" on page 19—an introduction to Déjà Vu X3 
Workgroup’s user interface. 

"Workflow" on page 75—a suggested workflow model for translation with Déjà Vu X3 
Workgroup. 

The Workflow chapter is followed by chapters that detail some of the features discussed in the 
Workflow chapter:

"Translation Features in Déjà Vu X3 Workgroup—The Details" on page 139

"Editing Features in Déjà Vu X3 Workgroup—The Details" on page 233

"Review Features in Déjà Vu X3 Workgroup—The Details" on page 239

"Teamwork Features in Déjà Vu X3 Workgroup—The Details" on page 249

"Security Features in Déjà Vu X3 Workgroup—The Details" on page 297

"Analysis Features in Déjà Vu X3 Workgroup—The Details" on page 311

Next comes a chapter dealing with how to work with different file formats, and one that 
specifically discusses working with SGML/XML files:

"Working with Different File Formats" on page 325

"Creating and Maintaining XML Filter Files" on page 409

The next three chapters are concerned with the creation and maintenance of Déjà Vu X3 
Workgroup’s databases:

"The Lexicon" on page 425

"Creating and Maintaining Translation Memories" on page 441
Déjà Vu X3    9
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"Creating and Maintaining Termbases" on page 485

Some of the more complex technical aspects for the very advanced user are discussed in the last 
chapter

"Digging In—Advanced Topics" on page 533

The Appendix contains an overview, a listing of the menu commands, and a glossary.

Finally, there is a very comprehensive index at the end of the manual that is meant to be a 
substantial aid in finding relevant topics. We encourage you to use it extensively.

WHERE DO I START?

Where you’ll start depends on who you are, what your goals for Déjà Vu X3 Workgroup are, and 
how experienced you are with translation memory tools in general and Déjà Vu in particular.

THE BEGINNER—WHEN YOU’RE STARTING FROM SCRATCH

If you’re a new user who has never worked with computer-assisted translation tools (commonly 
abbreviated as CAT tools), it would probably be a good idea to start with "The Déjà Vu X3 
Workgroup Interface" on page 19.

If you stumble on terms that you are not familiar with, turn to the "Glossary" on page 580.

When you feel familiar with the basic concepts, you can continue by looking at "Workflow" on 
page 75 in this manual. There you can see which steps you may not be familiar with and read 
about the relevant features in the details sections on pages p. 139-p. 325. To find specific topics in 
these chapters, it may be a good idea to use the index at the end of this manual.

"Working with Different File Formats" on page 325 will familiarize you with the specific types of 
files that you will be working with.

When you are comfortable with the general concepts of how to translate in Déjà Vu X3 
Workgroup, you should then look into optimizing your databases in the database section, ranging 
from pages p. 425-p. 533. Again, the index will help you to navigate through these sections.

If you are interested in more advanced features, refer to the section for the power user on page p. 
12.

Please be aware that there is no need to learn everything about this program. Imagine 
Déjà Vu X3 Workgroup as a big tool box from which you can choose the tools that 
make sense for your specific needs. Do not overload yourself with information that you 
will not need later on.
Déjà Vu X3    10
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THE CONVERT—WHEN YOU’RE NEW TO DÉJÀ VU X3  BUT FAMILIAR WITH OTHER 
CAT TOOLS

First of all: we’re glad you’re reading this, and we feel confident that you’ll like what you see. One 
thing you should be aware of is that Déjà Vu X3 Workgroup does things a little differently from 
other tools, so you may need to try to free your mind as much as you can from what you know 
about how other translation memory tools work.

The "Glossary" on page 580 should be helpful for you to familiarize yourself with how Déjà Vu X3 
Workgroup refers to concepts that the creators of other tools named differently (or didn’t know 
about!).

From there we would suggest the following learning path: Start with  "The Déjà Vu X3 Workgroup 
Interface" on page 19. This will give you a good idea of how Déjà Vu X3 Workgroup works and 
how it’s unique.

When you feel confident with the basic concepts, you can continue by looking at "Workflow" on 
page 75 in this manual, see which steps you may not be familiar with, and read more about them 
in the details sections on pages 139-325. To find specific topics in these chapters, it may be a good 
idea to use the index at the end of this manual.

More about the specific kinds of files you will be translating can be found in the corresponding 
sections of "Working with Different File Formats" on page 325.

When you are comfortable with the general concepts of how to translate in Déjà Vu X3 
Workgroup, you should then look into optimizing your databases in the database section, ranging 
from pages 425-533. Again, the index will help you to navigate through these sections. The first of 
these chapters, "The Lexicon" on page 425, should be of particular interest because this is a 
concept that is unique to Déjà Vu X3 Workgroup.

If you are interested in more advanced features, refer to the section for the power user on p. 12.

THE UPGRADER—WHEN YOU’RE FAMILIAR WITH DÉJÀ VU X2

Your first questions will probably be: What’s new and what’s different? The short answer: Quite a 
bit. But we do have a special section just for you: "What Is New in Déjà Vu X3 Workgroup?" on 
page 15.

Please be aware that there is no need to learn everything about this program. Imagine 
Déjà Vu X3 Workgroup as a big tool box from which you can choose the tools that 
make sense for your specific needs. Do not overload yourself with information that you 
will not need later on.
Déjà Vu X3    11
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After reading this section, you will probably want to look up individual chapters on topics that 
you’re not yet familiar with. You will find that the index in this manual is more extensive than 
earlier manuals to give you a quick reference point on where to look.

If you are interested in more advanced features, refer to the section for the power user on page p. 
12. 

THE POWER USER—WHEN YOU WANT TO MAXIMIZE THE SOFTWARE’S POTEN-
TIAL AND YOU’RE NOT AFRAID OF THE HAIRY STUFF

If you’re familiar with some of the advanced features of Déjà Vu X2, you know that there is hardly 
anything you cannot do with Déjà Vu. Well, the best has gotten better.

After you have familiarized yourself with how the new and more powerful Déjà Vu X3 works 
and how it differs from earlier versions, you can find some meaty stuff in the section "Digging In—
Advanced Topics" on page 533. Topics include customizing the HTML filter, working with SQL, or 
refining the export filter.

Good luck!

CONVENTIONS USED IN THIS MANUAL

USER INTERFACE CONTROLS

All user interface controls, such as buttons, menus, ribbon tags, tabs, or dialogs, are bolded. 

MENU COMMANDS

Menu commands, such as File> Options> Display, are identified by the greater-than sign.

PATH NAMES AND SAMPLE TEXT

All path names and user-entered sample text are in Courier New.

NOTES

SCREENSHOTS

The screenshots that are used in this documentation may not necessarily reflect the actual 
appearance in the version of Déjà Vu X3 Workgroup that you are using.

Notes contain important information that you need to be aware of or additional 
information on maximizing a specific feature. They are delineated by the thumbtack 
symbol.
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RELATED DOCUMENTATION

README

Please consult the Readme file after the installation of Déjà Vu X3 Workgroup for the latest 
information on the product and any possible issues with the program along with their work-
arounds.

WEBSITE

On www.atril.com you can find information about training seminars, user support, new versions of 
the product, and freely downloadable updates. 

USER GROUPS

The Déjà Vu user group at http://groups.yahoo.com/group/dejavu-l is a highly supportive and 
caring community of worldwide Déjà Vu users. You are strongly encouraged to join this group.
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What Is New in Déjà Vu X3 Workgroup?
WHAT IS NEW IN DÉJÀ VU X3 WORKGROUP?

Déjà Vu X3 Workgroup unveils a radically redesigned user interface and usability concept as well 
as a number of exciting new features. Following are the most outstanding changes. 

USABILITY

USER INTERFACE

A new Start screen provides a visual set of options that can be understood even by users 
with no experience. It provides quick access to all of your recent files and the creation of 
new modules.

The new ribbon interface clusters commands intuitively, grouping them by tasks and 
showing only applicable commands in each context. Aside from its improved user-
friendliness, the ribbon lets you discover features of Déjà Vu X3 Workgroup that might 
otherwise be hidden away in menus. 

With the customizable Quick Access Toolbar you can access all features you need in a 
single click.

A new simplified Translate and AutoTranslate feature brings Scan, Lookup, Assemble, 
fuzzy match repair and machine translation together, giving you greater control over 
which translation resources to use.

INLINE FORMATTING

Apply formatting of your text directly through the ribbon or shortcut keys, which are consistent 
with those of Microsoft Office.

Inline formatting also contributes to a considerable decrease in tags within the translation grid.

MANAGE ALL OF YOUR RESOURCES IN ONE GO

Déjà Vu X3 Workgroup centralizes all of your resources. So you can customize their configuration.

Configure everything with a few clicks through the new Translate feature and apply it directly to 
AutoTranslate to use any of the following:

Fuzzy repair or AutoAssemble

Machine translation for fuzzy match repair or entire segments

Separate fuzzy scores for translation memory and termbase

Restriction on client, subject and or sub-language specific entries from your databases
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Many other possibilities

LIVE PREVIEW & SOURCE CONTEXT

MULTI-FILE LIVE PREVIEW FOR OFFICE WORD, EXCEL AND POWERPOINT

With Déjà Vu X3 Workgroup’s new Live Preview, you can follow your translation progress within 
Office Word, Excel and PowerPoint files in real time, even without Office installed!

Unlike other products, it is also possible to use the Live Preview feature while displaying many files 
at a time.

MULTI-FILE SOURCE CONTEXT

For non-Office file formats, the Preview window shows the source context of your segment. This is 
particularly useful for IT-related formats.

QUALITY ASSURANCE

INLINE SPELL-CHECKER

Déjà Vu X3 Workgroup’s built-in spell checker, Hunspell, highlights spelling mistakes for you. 
Right-click on the underlined word and choose the appropriate solution from the available 
suggestions.

Dictionaries for a total of 35 languages are included from the get-go, and it’s possible to add or 
download additional dictionaries to include them in your proofing options.

VIEWING TERMBASE ATTRIBUTES

The AutoSearch window now displays all the information related to your terms, such as gender, 
context and all attributes of your termbases.

NEW SEGMENT STATUSES: TRANSLATED, PROOFREAD, APPROVED

You can now set your translation mode in Déjà Vu X3 Workgroup to indicate if you are translating, 
proofreading or validating the segments while confirming them. The new segment statuses 
Translated, Proofread and Approved mirror the different workflow steps typically required for 
translation best practices.
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FILTERS AND INTEROPERABILITY

OFFICE WORD, EXCEL AND POWERPOINT

Déjà Vu X3 Workgroup has new Office filters that considerably reduces the number of tags in the 
translation grid.

XLIFF

The new XLIFF filter converts embedded HTML in tags, contributing to a neater translation 
environment. The filter also supports the special XLIFF configurations that SDL Trados Studio, 
memoQ or WorldServer produce.

YAML

This new human-readable data serialization format can now be imported directly into Déjà Vu X3 
Workgroup.

QUICKSILVER

For improved handling of Quicksilver files, use this updated filter.

TRANSIT NXT

It is now possible to import Transit NXT packages without having to have Star Transit installed on 
your computer.

WORDFAST TXML

You can now process Wordfast Pro translation files up to version 3.x.

PDF

The import and processing of PDF files is supported via a third-party PDF converter or the MS 
Office 2013-internal converter for surprisingly usable results.

AUTOMATION

DATABASE RESTRICTION

Set in your projects an automatic database restriction according to client, subject and/or sub-
languages for an optimized process with both TEAMserver and large local databases.
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18
UPDATE NOTIFICATIONS

Atril will be releasing regular updates for your Déjà Vu X3 license. With the automatic update 
notification you can trust that you are working with the latest available Déjà Vu X3 version and 
always benefit from the latest improvements and features.
Déjà Vu X3   18



The Déjà Vu X3 Workgroup Interface
THE DÉJÀ VU X3 WORKGROUP INTERFACE

Unlike its previous versions Déjà Vu X3 Workgroup has only one interface from which you create, 
open, and edit all necessary files. The seven Déjà Vu internal file types are:

Déjà Vu Project Files (.dvprj)—the files in which you import the files that need to be 
translated, translate them, and from which you export them into their original formats. 
This file can contain only one source language but several target languages.

Déjà Vu Satellite Files (.dvsat)—the protected files which contain only one source and 
one target language plus all the information needed by the translator. These files can be 
exported from the main project and re-imported after translation.

Pack & Go Packages (.dvpng)—highly compressed exports from project files that are 
ideal for the transmission of Déjà Vu X3 Workgroup data. Like the satellite files, Pack & 
Go packages can be exported from the main project and re-imported after translation.

Déjà Vu Translation Memories (.dvmdb)—the files that store all previously translated 
segments (sentences, headings, cell content, bullet points, etc.) in source and target. This 
file is completely multilingual, i.e., it can have several target languages. You will notice 
that in the folder where the .dvmdb is created, other files are also created—one with the 
extension .<language>.dvmdi for each language used and one with the extension 
.dvmdx. These files contain the index and language-specific material. You may not delete 
or rename them.

Alignment Files (.dvapr)—intermediary database files in which data from already 
translated files is paired. Once the alignment is completed, this file is fed into a 
translation memory.

Déjà Vu Termbases (.dvtdb)—the files that contain pairs of terms or short expressions 
(source and target) which you have added. Each pair is associated by additional 
information that is freely configurable. Like the translation memories, the termbase is 
completely multilingual, i.e., it can have several target languages.

XML Filters (.dvflt)—files that you will need and use only when you translate files that 
follow the XML (or SGML) definition. Because each XML file or group of XML files is 
unique, you will have to create a unique filter for them. You can do that by having Déjà 
Vu either analyze the XML files or read the DTD file, an associated file that contains all 
the relevant information.

You will notice that the ribbons change according to what kind of file you open.
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THE PROJECT INTERFACE

Let’s first have a look at the default Déjà Vu X3 Workgroup’s appearance with an open project file.

To switch the user interface language of Déjà Vu X3 Workgroup

1 Select File> Options> General.

2 Under User Interface Language you can change the user language of Déjà Vu X3 Workgroup.
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3 If you want to switch that language, click the dropdown arrow and select the language of your 
choice. The available languages are:

English

German

French

Russian

Spanish

Chinese

Dutch

THE QUICK ACCESS TOOLBAR

The Quick Access Toolbar gives you access to the most often-used commands, independent of the 
ribbon that is currently displayed. The default commands are New, Open, Undo and Redo, but 
you can customize which commands are displayed on the Quick Access Toolbar.

To customize the Quick Access Toolbar

1 Select the down arrow to the right of the toolbar and click More Commands. 
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2 Within the Customize dialog, select the Quick Access Toolbar tab.

3 Select the appropriate category under Choose commands from and highlight the command 
that is supposed to be displayed in the Quick Access Toolbar. 

4 Click the Add button to copy the command over to the right pane.

5 Click Close to close the dialog.

THE RIBBON

As in many modern Windows applications, most of Déjà Vu X3 Workgroup’s functions are 
accessible through different tabs on a ribbon ("ribbon tabs").

You can also select to display the Quick Access Toolbar underneath the ribbon by 
selecting the appropriate command.
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THE HOME RIBBON TAB

The Home ribbon tab contains shortcuts to most of the relevant actions during the translation 
process, including the commands for the clipboard (copy, cut and paste); text formatting; the 
different translation options through termbase, translation memory and machine translation and 
where to send the finalized translation (lexicon, termbase, translation memory); navigation within 
the translation interface; actions for individual or all segments (split/join, assign status, or clear 
translations); and search, filter and sort options.

You can find a complete list of Home ribbon tab commands as well as the available keyboard 
shortcuts in the Appendix under "Keyboard Shortcuts" on page 575.

THE PROJECT RIBBON TAB

The Project ribbon tab contains shortcuts to the project-specific Properties dialog as well as other 
commands that relate to the complete project, including adding and exporting files, opening the 
Advanced Project Explorer, dealing with duplicate segments, analysis, pretranslation, 
pseudotranslation, sending of the complete project to the translation memory, saving the project 
settings as a template for other projects and executing project-wide SQL commands.

You can find a complete list of Edit ribbon tab commands as well as the available keyboard 
shortcuts in the Appendix under "Keyboard Shortcuts" on page 575.

THE LEXICON RIBBON TAB

The Lexicon ribbon tab contains shortcuts to generate, maintain and import/export a lexicon.

You can find a complete list of Lexicon ribbon tab commands in the Appendix under "Keyboard 
Shortcuts" on page 575.
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THE INSERT RIBBON TAB

The Insert ribbon tab contains shortcuts to create and leverage AutoText and AutoCorrection 
records, commands to fine-tune how you populate and assemble segments and to open the 
Windows Character Map.

You can find a complete list of Insert ribbon tab commands as well as the available keyboard 
shortcuts in the Appendix under "Keyboard Shortcuts" on page 575.

THE REVIEW RIBBON TAB

The Review ribbon tab contains the shortcuts you need to run quality assurance. These include 
shortcuts for spell checking, word counts, comments, bookmarks and verification of terminology, 
numerals, tags and spaces. Here you can also delete warnings and batch-accept underlined 
multiple matches.

You can find a complete list of Review ribbon tab commands in the Appendix under "Keyboard 
Shortcuts" on page 575.

THE VIEW RIBBON TAB

The View ribbon tab contains the commands to open the Project Explorer, the File Properties, and 
the AutoSearch pane (by default they’re all located toward the right side of the translation table) as 
well as the Preview pane (which in the default setting is located underneath the translation table). 
You can also find commands to re-organize the layout and switch between different assets (files, 
translation memories, termbases, etc.) that are currently open.

You can find a complete list of View ribbon tab commands in the Appendix under "Keyboard 
Shortcuts" on page 575.
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To customize the ribbon tabs

1 Select the down arrow to the right of the Quick Access Toolbar and click More Commands. 

2 Within the Customize dialog, select the Customize Ribbon tab.

3 Select the appropriate category under Choose commands from and highlight the command 
that is supposed to be displayed in one of the ribbon tabs. 

4 Select the ribbon tab and the existing groups of commands to which you would like to add 
the command.

- Or -

5 Create a new group and/or ribbon tab by clicking New Group or New Tab.

6 Click the Add button to copy the command over to the right section.

7 Click Close to close the dialog.

You can also import or export ribbon settings in the form of an XML document by 
clicking on Import/Export.
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THE FILE MENU

Under the File menu you can find categories of commands to create or open a new project or any 
other kind of Déjà Vu X3 file, close a currently open file to save a Déjà Vu X3 project file as a 
Create & Go package, or share it in a number of formats. Here you can also export project-specific 
subsets of translation memories or termbases, export the translated files out of a project file, access 
tools to maintain or repair the different Déjà Vu X3 file formats, access the product and licensing 
information, login into a protected project and access the Déjà Vu X3 Options dialog.

FILE> NEW

This gives you access to creating a new project file (with or without a template) or a new 
translation memory, termbase or XML filter or you can create a new or open an existing alignment 
file. Any of these commands will start a wizard that will guide you through the appropriate process.
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FILE> OPEN

This gives you access to open any kind of Déjà Vu X3 file (project, translation memory, termbase, 
alignment file, XML filter). You can choose from a list of recently opened files or from anywhere on 
your computer or network.

FILE> SAVE AS

This allows you to save a Déjà Vu X3 project file to a Pack & Go Package (see p. 274).
Déjà Vu X3    27



28
FILE> SHARE 

This gives you access to the various options to share a Déjà Vu X3 project with someone else either 
in a format specific to Déjà Vu X3 (packages or satellite files) or formats that can be handled with 
users equipped with Trados Workbench/Wordfast Classic, tools that support XLIFF or with no CAT 
tool support. It also allows you to export subsets of the attached termbases and translation 
memories to aid in the translation process and gives options for reimporting the shared files once 
they are translated.
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FILE> DELIVER

This allows you to export any or all translated files within a Déjà Vu X3 project to the original 
format. You can select from various format-specific export options (for more information, see 
"Working with Different File Formats" on page 325).
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FILE> TOOLS 

Here you can find options to compact or repair project files (with the extensions *.dvproj and 
*.dvsat), termbases, translation memories and XML filter files (only compact options for those). For 
more information on compacting and repairing, see "Repairing and Compacting Files" on page 
140.

FILE> CLOSE

This command allows you to open any kind of Déjà Vu X3 file (project, translation memory, 
termbase, alignment file, XML filter). You can choose from a list of recently opened files or from 
anywhere on your computer or network.
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FILE> ACCOUNT

Under Account you can find information about the version of Déjà Vu X3 you are currently using, 
and the activation key. You can activate or deactivate the license or request a floating license and 
you can log on (which is important if you are working with files with access protection). Lastly, you 
can also see whether there is a new version of Déjà Vu X3 that you can download.

FILE> OPTIONS

This command opens the multi-tabbed Déjà Vu X3 Options dialog that gives you access to all 
important settings for the program.
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THE CONFIRM AS DROPDOWN

The Confirm As dropdown is located in the upper right-hand corner, right above the ribbon.

It allows you to assign different categories of confirmation to segments within the project. The 
three pre-configured categories are Translated, Proofread and Approved. Selecting one of these 
categories ensures that every time you confirm a segment, it will be confirmed in that category.

This is a helpful feature if you have a workflow with several stages of translation, editing and 
approval, or even if you work on a project on your own and want to classify some segments as 
completely done and some as still to be looked at.

KEYBOARD SHORTCUTS

It is a good practice to learn the keyboard shortcuts for the Déjà Vu X3 Workgroup functions you 
use most often, since this will let you work faster and more efficiently. You will find the default 
keyboard shortcut for each function (if there is one) beside the function’s name on the menu. An 
additional expanded list can be found under "Keyboard Shortcuts" on page 575.

All keyboard shortcuts can be customized to fit your particular preferences. 

To customize the keyboard shortcuts

1 Right-click in the ribbon bar and select Customize Quick Access Toolbar.

- Or -

Click the down arrow to the right of the Quick Access Toolbar and select More Commands.
Déjà Vu X3    32



The Déjà Vu X3 Workgroup Interface
2 Select the Keyboard tab in the Customize dialog.
 

3 Select the relevant category and then the command. In the edit box under Press New 
Shortcut Key, you can edit existing shortcuts or add shortcuts to commands that do not have 
an assigned shortcut.

4 Position your cursor in the edit field and press the new key combination.

5 Click Assign and Close.

THE TRANSLATION GRID

The main module of Déjà Vu X3 Workgroup’s translation interface is the translation grid, the 
interface in which you actually perform any translation activity.

By clicking on Reset All, you can reset the keyboard shortcut values to the original 
values.
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Translation activities are by default performed directly within the grid, which resizes itself 
automatically to accommodate differing lengths of segments.

EDIT AND SELECTION MODES

There are two different modes in a Déjà Vu X3 Workgroup project: the edit and the selection 
mode. The edit mode is the default mode that you work in as you translate and edit segments. In 
that mode you can select text in the source and/or target of the current segment, but you cannot 
select (highlight) the complete segment. To do that you will have to switch into the selection mode.

To switch into the selection mode

1 Make sure your cursor is in a specific segment.

2 Press the Esc or the Enter key.

3 You can see that the complete segment is now highlighted.

To switch back into the edit mode

1 Press the Enter key or double-click the source or target segment.

2 You can see that the segment is not highlighted anymore. 

To help you find your current position within the open file or project, the current 
segment is marked with a little blue arrow ( ) to the left of the source segment and is 
surrounded with emphasized segment borders.

The colors of the translation grid lines can be changed to any color you prefer. For more 
information on changing colors, see "To change the colors of the indicator bars" on page 46.
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TRANSLATING IN A SEPARATE TEXT AREA

Some translators prefer to work in a vertical manner, i.e., with source and target positioned on top 
of each other. You can do that by selecting File> Tools> General> Edit document translations in a 
separate area below the translation grid> Split the separate area vertically.

Other benefits of this display mode include a more obvious highlighting of the currently selected 
segment and the fact that you never have to scroll to find the currently selected segment.

If you choose to work in this manner, the actual grid will automatically switch into 
selection mode so that you cannot edit directly within the cells.
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THE PROJECT EXPLORER

The Project Explorer is presented in a small pane on the right of your screen. It displays all the files 
and the lexicon in your project so you can easily switch from one file to the next. This is especially 
helpful because in Déjà Vu X3 Workgroup projects you can import and process any file of any file 
type that is supported by Déjà Vu X3 Workgroupfrom anywhere on your local machine or 
network.
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THE AUTOSEARCH WINDOW

Below the Project Explorer, the AutoSearch window displays the relevant matches from the 
translation memories, the termbases and the lexicon. Each record is associated with a number, 
which in combination with the Ctrl key copies the respective term to the target window. A color 
signifies the origin of the term (by default: red=translation memory, blue=termbase, 
white=lexicon).

At the bottom of the window, you can see related information, such as client, subject, date/time 
stamp, and database origin of the selected term displayed.

If you select an entry from a translation memory, you will see additional rows in which the 
differences between the record in the translation memory and the original source segment are 
highlighted.

As with all other colors, these colors can be changed under Tools> Options> Display.

You can find information on each of the cells in these additional rows under "Scanning 
the Translation Memories" on page 146. The cells in the Scan Results window described 
in that section have the same structure as the ones in the AutoSearch window.
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To minimize the amount of mouse work, you can use the keyboard to navigate through the 
AutoSearch window and to paste a selected portion into the target text box.

To navigate through the AutoSearch window

Press Ctrl+Shift+UpArrow to move to the previous portion.

–Or–

Press Ctrl+Shift+DownArrow to move to the next portion.

SPLITTING THE AUTOSEARCH WINDOW

By default, the AutoSearch window contains relevant matches from the translation memories, the 
termbases, and the lexicon. Depending on the length of the source segments, the extent of your 
databases and your personal preferences, you can split the AutoSearch window into an 
AutoSearch - Portions and an AutoSearch - Segments window.
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To split the AutoSearch window

1 Select File> Options> General> Show segments and portions in separate windows.

2 The former AutoSearch window has now become the AutoSearch - Portions window which 
will only display matches from the termbase, the lexicon and portions from the translation 
memorty (if selected under File> Options> General> Display portions from Translation 
Memory). The new AutoSearch - Segments window with exact and fuzzy matches from the 
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translation memory (and, if selected, machine translation suggestions), is displayed at the 
bottom of the screen.
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To hide the column headers 

To maximize some of the room for the displays in the AutoSearch windows, you can now 
select File> Options> General> Hide column headers, to hide the column headers.
 

To navigate through the split AutoSearch windows

AutoSearch - Portions:

Press Ctrl+Shift+UpArrow to move to the previous portion.

–Or–

Press Ctrl+Shift+DownArrow to move to the next portion.

AutoSearch - Segments:

Press Alt+Shift+UpArrow to move to the previous segment.

–Or–

Press Alt+Shift+DownArrow to move to the next segment.
Déjà Vu X3    41



42
To access the AutoSearch context options

1 Right-click on any entry in the AutoSearch window.

2 The context menu appears.

3 You are presented with the following options:

Edit—switches the selected segment in to the edit mode so that text becomes editable.

Delete—deletes the current segment from the lexicon, termbase, or translation memory.

Refresh—refreshes the view of the AutoSearch window.

THE SELECTOR SEGMENT

Above the source and the target cells, you will find a segment with three boxes: text locator, rows 
selector, and target language selector.

From left to right, you will find:

Text/Record Locator

Segment Selector

Language Selector

THE TEXT/RECORD LOCATOR

If your sort order is the default "natural" order—the order in which the segments appear in the 
source document—you can use this segment to enter the number of the record project line you 
would like to jump to.
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If your sort order is "alphabetical"—the alphabetical order of the segments in the source 
document—you can type the first few letters of the first word of the line you want to jump to.

To switch between natural and alphabetic order

1 To sort alphabetically, click the language indicator on top of the source column.

–Or–

To reset to the natural sort, click the language indicator on top of the source column again.

THE SEGMENT SELECTOR

You can choose to filter and display only certain kinds of rows, e.g., exact matches, fuzzy matches, 
pending rows, etc. You can see that each status is associated with a colored status indicator bar 
that matches the color indicator in the translated cells.

The available status filters are:

Generally you will want to translate in the natural order because it allows you to see 
how each particular segment fits into the flow of the document.

When you switch from one mode to the other, Déjà Vu X3 Workgroup will keep the 
same current record.
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All Segments

All Unpainted Segments (default grey indicator bar)

All Except Locked Segments

All Empty Segments

All Unconfirmed Segments

Multiple Exact Match Segments (default indicator: blue, underlined font)

Exact Match Segments (default: dark green indicator bar)

Guaranteed Matches (default: orange indicator bar)

Fuzzy Match Segments (default light green indicator bar)

Usually, fuzzy matches are not displayed with a solid light green bar, but with a split 
green/grey bar that indicates the percentage of fuzziness.
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Assembled Segments (default: dark blue indicator bar)

Machine Translated Segments (default: brown indicator bar)

Repaired Fuzzy Match Segments (indicator symbol: )

Fuzzy Propagated Segments (default gold indicator bar)

Exact Propagated Segments (default light blue indicator bar)

Translated Segments (indicator symbol: )

Proofread Segments (indicator symbol: )

Approved Segments (indicator symbol: )

Confirmed Segments (all segments with the Translated, Proofread or Approved status)

Pending Segments (Indicator symbol: 

Locked Segments (indicator symbol:  )

Segments with Comments (indicator symbol: blue  or, if combined with marker for 

inconsistent terminology: violet  ) 

Segments with Comments in Source (indicator symbol: blue ) 

Segments with Comments in Target (indicator symbol: blue  or, if combined with 

marker for inconsistent terminology: violet )

Segments with Inconsistent Terminology (indicator symbol: red  or, if combined with 

comments: violet )

Wrong Codes Segments (indicator symbol: )

Duplicate Segments (default indicator: grey vertical bar to the left of source)
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SQL Statement (opens the Select SQL dialog. For more information, see "To use the SQL 
Statement view" on page 49.)

To change the colors of the indicator bars

1 Select Tools> Option> Display.

2 The Display tab in the Options dialog is displayed.

This dropdown box also provides an instant overview of the meaning of each of the 
colors displayed in the status indicator bar in each segment.

Another helpful way of instantly reviewing the status of a certain segment is to place 
your mouse cursor over the indicator bar section. A tooltip-like window will appear in which you 
can review the status information of the current segment, the user who last modified it, the date 
and timestamp of the last modification, as well as various other bits of information.
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3 Select the status segment whose indicator color you want to change.

4 Click the down arrow to the right of the color you want to change.
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5 A display of different colors appears.
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6 Select the desired color and the selected segment is now displayed with the new color setting.

7 Click Apply and/or OK.

To remove the segment status indicators

To reset the segment status to the unpainted segment status, you can right-click the segment 
in question and select Segment Status> Reset Status.

–Or–

Press Ctrl+Shift+U.

To use the SQL Statement view

The idea of the SQL Statement view is to give you complete flexibility as to what subset of rows in 
your project you would like to view.

This will remove all status indicators with the exception of Wrong Codes, Comments, 
and Terminology Mismatch.
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1 Select SQL Statement from the Segment Selector dropdown list.

2 The SQL Filter dialog appears.

3 If you are familiar enough with SQL and the database structure of Déjà Vu X3 Workgroup, 
you can directly enter an SQL expression starting after the WHERE clause.

–Or–
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You can select Build Expression to open the Build Status Expression dialog.

4 In this dialog you can check (include) or uncheck (exclude) certain status criteria. The 
Translation Status criteria are mutually exclusive and so are the criteria under Progress Status 
(i.e., they have an OR relationship), but the criteria from the two different groups are 
Déjà Vu X3    51



52
combinable. For instance, if you want to view all rows that are empty and not locked, you 
make the following selection:

5 Upon clicking OK, you will see the following expression entered into the SQL Filter dialog:
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6 If you want to save this statement for later use, enter a name into the name field:

7 Press the Save button that is now enabled. 

From now on you can access this saved filter in one of two ways:

As an additional option in the Segment Selector:
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8 Selecting Apply will now display all rows that are empty but not locked.

THE LANGUAGE SELECTOR

You can use the language selector to switch between the different target languages that you may 
have in your project.

THE STATUS BAR

This is Déjà Vu X3 Workgroup’s status bar explained from left to right:

Six little shortcut buttons— —which can be clicked to activate and 
deactivate AutoWrite, AutoTranslate, AutoSearch, AutoPropagate, AutoSend and 
AutoCheck (in that order).

Information about the position in the project and in the current segment. The numbers 
in the screenshot above have the following significance:

There are 12 characters in the source segment (12),

The cursor is at position 14 of 18 in the target (14/18), and

The current record position is 17 of 71 (17/71) in the currently selected file.

To the right of the position information, the Current user will be displayed. The displayed 
user name will be the user name that is selected in the security settings (see "Security 

If you prefer to change this expression, you can easily modify it manually.

Some of this information can be especially helpful when translating files in which the 
target text is not supposed to be longer than the source.
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Features in Déjà Vu X3 Workgroup—The Details" on page 297) or—if the security 
settings are not enabled—the default Windows logon name will be displayed.

The user under Last modified by is the user who previously worked on this particular 
segment (if applicable).

The date and time setting to the very right of the status bar refers to the date and time 
this particular segment was worked on before (if applicable).

REARRANGING THE WINDOWS

Déjà Vu X3 Workgroup’s integrated development environment (IDE) has two types of windows, 
tool windows and document windows. 

The tool windows—which include the Project Explorer, the AutoSearch window(s), the Properties 
window, or the Preview window—are freely dockable. This means that you can place them 
anywhere outside the main window on your desktop and use the standard docking features (see 
"Docking the Tool Windows" on page 56).

The document windows have to stay within the main window. They can be minimized within the 
main window and are subject to the commands in the Window menu.

Every entry into the databases will also be associated with the current user name. 

If you are viewing the whole project instead of a single file (see "Selecting the Complete 
Project" on page 61), you can also see the file name you are currently working on to the 
very left of the lower status bar.
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This allows you to arrange the windows so they fit your particular work environment.

DOCKING THE TOOL WINDOWS

Dockable windows are windows that align themselves with the edge of another interface element, 
usually a window or a pane.

To dock a tool window

1 Click the window title bar and keep the mouse button pressed.

2 Drag the selected window to another location in the main window.

With this feature you can even work on more than one monitor.
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3 Once you start dragging the window, you’ll be able to see placement indicators on which you 
can place the window for the desired location.

If you want to move a window without the aid of the placement indicators, press the 
Ctrl key while you drag the window.
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To arrange tool windows within the main window

1 If you choose to have your tool windows within your main window, you can stack them in a 
tabbed interface.

2 You can bring underlying windows to the front by clicking the tabs at the bottom.

–Or–

You can close individual windows by clicking the  button on the title bar.

SETTING THE FONT

The default font setting that Déjà Vu X3 Workgroup comes with is Tahoma 10. You can change 
both font and size information.
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To change the font setting

1 Select File> Options> Display.

2 Click the Language drop-down arrow and select a language.

3 Click the Window Type drop-down arrow and select a window type.

4 Click Change.

This option allows you to define different fonts or font sizes to the main project, 
translation memory, or termbase view (the primary windows) and the AutoSearch, 
lookup, or scan windows (the secondary windows).
Déjà Vu X3    59



60
The Font dialog appears.

5 Select the font, style, and size you want Déjà Vu X3 Workgroup to use when displaying text in 
this language.

You should be able to see the new font in the Sample area of the Font dialog.

6 Click OK to accept the font settings.
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MOVING AROUND

There are several ways to move around within Déjà Vu X3 Workgroup.

SELECTING INDIVIDUAL TRANSLATION FILES

You can select any of the imported files or the lexicon by double-clicking on the file name in the 
Project Explorer or the Advanced Project Explorer. The file will be opened in the main area of the 
Déjà Vu X3 Workgroup interface.

SELECTING THE COMPLETE PROJECT

One of the great strengths of Déjà Vu X3 Workgroup is batch processing. While it allows you to 
work in individual files, it also allows you to view the complete project and work in it as if it were 
one file. We call this the All Files view. 

To view all files, double-click the name of the project in the Project Explorer pane.

As soon as you switch to the All Files view, the name of the file you are currently working on 
appears in the status bar.
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SELECTING OPEN TRANSLATION FILES, PROJECTS AND DATABASES

You can select already-opened files by clicking on the respective link right under the toolbars.

JUMPING TO A SPECIFIC RECORD IN THE PROJECT

You can enter the record number or the first few letters of the first word of the record you want to 
jump to in the Text/Record Locator. For more information, see "The Text/Record Locator" on page 
42.

SWITCHING LINES WITHIN A TRANSLATION FILE OR PROJECT

As you translate, there are a number of keystrokes that you may want to use to go from one 
segment to the next:

Ctrl+DownArrow (or Ctrl+Enter) to go to the next segment.

If AutoSend is enabled, the segment pair is sent to the translation memory.

If AutoTranslate is enabled, Déjà Vu X3 Workgroup assembles a translation for the 
next segment.

If AutoPropagate is enabled, the translation is propagated to segments with identical 
source text.

If AutoCheck is enabled, the terms in the translated segments are automatically 
verified against the lexicon, termbase, and/or translation memory.

Alt+DownArrow (or Alt+Enter) to go to the next untranslated segment. AutoPropagate, 
AutoSend, and AutoTranslate are launched if enabled.

Ctrl+UpArrow to go to the previous segment.

Alt+UpArrow to go to the previous untranslated segment.

Alt+RightArrow to go to the next segment. The segment status will not be changed and 
none of the automated features will be enabled.

Ctrl+Alt+DownArrow enables the same processes, with the addition that it will 
overwrite any existing content in the target cells, regardless of its content and status 
(Ctrl+DownArrow only adds content to empty or propagated target cells).
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Alt+LeftArrow to go to the previous segment. The segment status will not be changed 
and none of the automated features will be enabled.

If you want to move to different sections of your current file, you can do that with the help of 
keystrokes by switching into the selection mode (see "Edit and Selection Modes" on page 34).

To jump to different sections of the open file in the selection mode

The following keystrokes are available:

Ctrl+PgUp to go to the beginning of the file

Ctrl+PgDown to go to the end of the file.

SELECTING SEGMENTS

SELECTING SEGMENTS IN THE SELECTION MODE

You can select a segment in a Déjà Vu X3 Workgroup project file by switching into the selection 
mode. You can find more information about this under "To switch into the selection mode" on 
page 34. 

If you select File> Options> Lock vertical scrolling in the translation grid, your segment 
selection will always be in the same relative position in the project table, i.e., if you 
have selected a segment in the middle of the project table, moving to the next segment 
will shift the table instead of your position in the table.

The scrollbar also offers a convenient way to quickly change position within your 
current file or project either in selection or edit mode. Clicking on the up and down 
arrows on the top and bottom of the scroll bar will scroll one segment up or down in 
your project, or you can drag the selection button in the scroll bar to anywhere in your 

project. You can also right-click the scrollbar and select one of the following options:
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If you press the control key, you can select several rows at a time, and pressing Ctrl+Shift allows 
you to select a range of rows.

Other segment selection keyboard shortcuts in combination with a mouse selection include:

Shift+Home (or Shift+Ctrl+Home) to select all the rows from the current selection up to 
the beginning of the current file (or project in the All Files view)

Shift+End (or Shift+Ctrl+End) to select all the rows from the current selection down to 
the end of the current file (or project in the All Files view)

Shift+PgUp (or Shift+Ctrl+PgUp) to select all the rows from the current selection up to 
the top of the current screen

Shift+PgDown (or Shift+Ctrl+PgDown) to select all the rows from the current selection 
down to the bottom of the current screen

SELECTING SEGMENTS BY STATUS

As described under "The Segment Selector" on page 43, Déjà Vu X3 Workgroup allows you to 
select any number of rows according to their status.

SELECTING SEGMENTS BY FILTERING

You can display only those rows that contain a certain word or phrase, either in source or in target. 
This will allow you to concentrate on a subset of your project if, for example, you are having a 
problem with that particular word or phrase.

To filter the project on a word or phrase

1 Select the desired text in the source and/or target cell.

2 Right-click the selection and select Filter> Filter by Source (Target) Selection.
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-Or-

Press Ctrl+Alt+S for Filter by Source Selection.

--Or-

Press Ctrl-Alt+T for Filter by Target Selection.

3 Only rows that contain that particular word or phrase will be displayed.

To clear the filter

Right-click the source box or the target box and click Filter> Remove Filter or press Ctrl+Alt+R (or 
Ctrl+Alt+U). The highlight on the Source (Target) Selection option will disappear and all rows will 
be displayed again.

THE ADVANCED PROJECT EXPLORER

The Advanced Project Explorer is the Windows Explorer-like interface within Déjà Vu X3 
Workgroup that allows you to manage your files within a project. You can use the Advanced 
Project Explorer to import and export files into a project and to delete files out of a project.

To access the Advanced Project Explorer

1 Select Advanced Project Explorer from the Project ribbon tab.

-Or-

Right-click the project icon in the Project Explorer window and select Advanced Project 
Explorer.

This feature is also extremely valuable for editing work because it allows the editor to 
quickly view the translation of a certain word or phrase in all occurrences within the 
project.

It is important to learn the difference between the Project Explorer and the Advanced 
Project Explorer. While the Project Explorer allows you to navigate within your existing 
project, the Advanced Project Explorer allows you to explore the folder structure of 
your local and network drives to build your project. 
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2 The Advanced Project Explorer view appears.

To import files with the Advanced Project Explorer

1 In the upper left-hand pane, select the directory where you have saved the file that you want 
to have translated.
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2 Click the file and drag it over to the lower right-hand pane.

3 Select the file name and set the format-specific properties in the Properties window to the 
right of the Advanced Project Explorer. For more information on this, see "To apply specific 
import options" on page 331.

4 Right-click the file name and select Import.

- Or -

Select the file name and click the Import button in the Home ribbon tab.

You can select several items by pressing the Ctrl key as you select them, or a range of 
items by pressing Ctrl+Shift as you select the first and the last item in that range.
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5 When the import is finished, close the Advanced Project Explorer by clicking on the  
symbol in the upper right-hand corner of the Explorer window. 

To import folders with the Advanced Project Explorer

1 In the upper left-hand pane, select the directory where you have saved the folder that 
contains all the translatable files.

2 Click the file and drag it over to the lower right-hand pane.

If you notice that the segmentation of the source files is not adequate, i.e., individual 
segments are not being split in the desired manner, this can have two reasons: the 
original file may been formatted badly (e.g., soft or hard returns may have been used to 
force line breaks) or your segmentation rules may have to be adjusted. Depending on 

the situation, it may be advisable to either go to the source files and correct some of the poor 
formatting or adjust your segmentation rules (see "Sentence Segmentation" on page 217) and 
reimport the files.
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3 The Add Folder dialog is displayed.

4 Check the Only add files with the following extensions check box if you would like to exclude 
certain file types from translation.

If you check the check box, you can enter any file name and/or extension to which you 
would like to limit your import. You will have to use a semicolon if you use several file names/
extensions and it is possible to use wildcards. As an example,

*.ht*;c*.txt

would include all files with an extension starting with .ht (such as .htm or .html) and all 
.txt files with a file name starting with c (such as correction.txt or cd.txt).

Check the Include subfolders check box if you would like to include all subfolders in the 
exact same structure as the original.

5 Select OK. 

You do not have to worry about files that are not translatable within Déjà Vu X3 
Workgroup, such as graphics files. These files will automatically be excluded. 
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6 You are returned to the Advanced Project Explorer.

7 You can now see that serval folders were brought over into the lower part of the Advanced 
Project Explorer, as well as only files adhering to the extension definition.

8 Select the folder and set the available properties in the Properties window to the right of the 
Advanced Project Explorer.

It is possible to change the default import properties for each extension/specific file format. 
For more information on this, see "To apply specific import options" on page 331 and "To 
apply global or project-wide import options for each file extension" on page 333.

9 Right-click the folder name and select Import.

- Or -

Select the folder name and click the Import button in the Home ribbon tab.

10 The import progress is displayed in the Import Progress dialog.
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11 When the import is finished, close the Advanced Project Explorer by clicking on the  
symbol in the upper right-hand corner of the Explorer window. 

You can now see all the imported files in the Project Explorer.

To export files or folders with the Advanced Project Explorer

1 In the lower right-hand pane, select the file(s) or the folder(s) that you want to export.

2 Right-click the file or folder name and select Export.

- Or -

You can select several items by pressing the Ctrl key as you select them, or a range of 
items by pressing Ctrl+Shift as you select the first and the last item in that range.

You can also select an entire folder for export. If you do that, Déjà Vu X3 Workgroup 
will export all translated files within that folder and all of its subfolders with the default export 
options.
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Select the file or folder name and click the Export button in the Home ribbon tab.
 

3 The Export Options dialog appears.
Déjà Vu X3    72



The Déjà Vu X3 Workgroup Interface
4 Under Destination, select the folder to which you want your files to be exported.

5 Under Languages, select the languages you want to export.

6 If applicable, you can define filter-specific options for the files within your project. For 
information about these options, see the corresponding sections in "Working with Different 
File Formats" on page 325.

If you have selected more than one file type with filter-specific export options, both sets of 
options will be listed and you will have to make sure that you set all available options.

7 Select OK.

8 Déjà Vu X3 Workgroup will verify if there are any discrepancies 

in tags (see p. 209) and/or 

spaces at the end of segments.

9 For each language you are exporting, Déjà Vu X3 Workgroup will create a subfolder inside 
the export folder, named after the code for the specific locale of that target language. For 
example, if you were translating the file into German (Germany), the new folder would be 
called C:\My Projects\DE_DE.

If you have exported a complete folder, Déjà Vu X3 Workgroup will recreate the structure of 
that folder with all of its subfolders, containing all the files you have translated. 

10 Once the export is finished, close the Advanced Project Explorer by clicking on the  symbol 
in the upper right-hand corner of the Explorer window. 

To delete files with the Advanced Project Explorer

1 Select any file(s) or folder(s) listed in the Advanced Project Explorer and press the delete key.

If Déjà Vu X3 Workgroup finds a discrepancy in spaces following periods, question 
marks or exclamation marks, it will offer to fix that discrepancy automatically.
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–Or–

Right-click on any file(s) or folder(s) listed in the Advanced Project Explorer and select Delete.

2 A confirmation dialog appears.

3 Select Yes.

4 Once the deletion is completed, close the Advanced Project Explorer by clicking on the  
symbol in the upper right-hand corner of the Explorer window. 

You are returned to the Project Explorer, in which you can see that the files are deleted from 
the project.
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WORKFLOW

The following describes the steps of a typical workflow within Déjà Vu X3 Workgroup which 
consists of 

Preparation (including the import of existing translation memory and termbase data)

Project building (including the selection or creation of a project file, import of the source 
files and generating the Lexicon)

Pretranslation of the source files

Translation with the help of the associated linguistic assets (translation memories, 
termbases, lexicon. machine translation engines)

Editing and quality assurance within and outside of Déjà Vu X3 Workgroup  

Export of the translated files

PHASE I: PREPARATION

The preparation phase consists of preparing the memory and termbases by optionally importing 
existing material into them (see "Import of Existing Third-Party Databases into the Translation 
Memory" on page 75, "Import of Existing Translations into the Translation Memory" on page 76, 
and "Import of Existing Third-Party Glossaries into the Termbase" on page 76), as well as selecting 
the source files for import (see "Source Files" on page 77). 

IMPORT OF EXISTING THIRD-PARTY DATABASES INTO THE TRANSLATION 
MEMORY

This component is optional and will not have to be performed every time you work on a 
translation project. Situations where you may want to import existing databases could include the 
following:

you have received external databases from your client

you own existing databases in other formats

you are sharing databases with fellow translators

A number of these steps are optional
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The formats of these databases can vary widely, including:

Déjà Vu X3 Translation Memory—for merging other Déjà Vu X3 translation memories 
into the existing one.

Text—for importing delimited text files (tab, comma, etc.).

Access—for importing databases from various versions of Microsoft Access.

ODBC Database—for importing databases from various ODBC databases, including 
TermStar databases.

Excel—for importing databases from various versions of Microsoft Excel.

Trados Workbench—for importing translation memories from the Trados Workbench .txt 
format.

TMX—for importing databases from the Translation Memory EXchange format, an XML-
based exchange format between different CAT tools.

For more information on importing external databases, see "Importing External Data" on page 457.

IMPORT OF EXISTING TRANSLATIONS INTO THE TRANSLATION MEMORY

The alignment module in Déjà Vu X3 Workgroup allows you to take the source and the target texts 
of an existing translation and create a translation memory from them.

IMPORT OF EXISTING THIRD-PARTY GLOSSARIES INTO THE TERMBASE

As with the option of importing external databases into the translation memories, this component 
is optional and will not have to be performed every time you work on a translation project. 
Situations where you may want to import existing glossaries would include the following:

you have received external glossaries from your client

you own existing glossaries in other formats

you are sharing glossaries with fellow translators

The formats of these glossaries can vary widely, including:

As a rule of thumb, it’s a good idea to primarily rely on building databases by actually 
doing translation within the Déjà Vu X3 Workgroup translation environment. But the 
alignment feature can be a very powerful tool when translating documents for which 
you have very similar file pairs.
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Plain text (delimited by any ASCII character)

Excel

Access

Déjà Vu X3 Workgroup termbases

For more information on importing external glossaries, see "Importing External Data" on page 509.

SOURCE FILES

Déjà Vu X3 Workgroup can import a great variety of source files, including:

tagged formats (SGML/XML, HTML, ASP)

word processing, presentation, and spreadsheet formats (Microsoft Word, Microsoft 
PowerPoint, Microsoft Excel, and the corresponding formats from the LibreOffice/
OpenOffice suite)

exchange formats (RTF, TMX)

desktop publishing formats (Adobe FrameMaker, Adobe PageMaker, Adobe InDesign, 
Interleaf/Quicksilver, QuarkXPress)

database formats (Microsoft Access)

help formats (WinHelp RTF, Help content files)

software development formats (Resource files, C/C++/Java source files, Java Properties, 
VBScript, JavaScript, GNU gettext, RESX)

subtitling formats (EBU files)

When importing external glossaries, make sure that these glossaries are useful in Déjà 
Vu’s workflow. Glossaries of most other tools are mere dictionaries, but in Déjà Vu X3 
Workgroup’s case they are active entities that automatically insert text into segments. 
That means that if you have two different translations in one target field, Déjà Vu X3 

Workgroup would insert both of them.
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preprocessed files from other TM tools (Trados Workbench RTF, Trados TTX, Trados BIF, 
IBM TranslationManager)

The unique power of Déjà Vu X3 Workgroup is that you can take any number of files of any variety 
of the above-listed formats from any location of your computer or network and import them into 
one project!

PHASE II: PROJECT BUILDING

The project building phase consists of selecting an existing project file (see "Selecting an Existing 
Project File" on page 78) or creating a new project file ("Creating a New Project File" on page 81)—
which includes importing the source files and associating the file with translation memories and 
termbases—as well as building the lexicon (see "Generating the Lexicon" on page 96).

SELECTING AN EXISTING PROJECT FILE

The source files for a large translation project are rarely delivered in one batch. Typically they 
come in one large batch and several later ones. 

To import many files from many locations into an existing project

1 Open the project file.

2 Select Project> Advanced Project Explorer.

-Or-

Right-click the project icon in the Project Explorer window and select Advanced Project 
Explorer.

For more information on each of these file formats, see "Working with Different File 
Formats" on page 325.

From a file management perspective, it may still make sense to have the files located in 
one folder or group of subfolders.

In most cases you do not need the originating applications installed on your machine. 
That means you can process QuarkXPress, PageMaker, or FrameMaker files without actually having 
to have the actual (and very expensive!) applications. However, there are exceptions that include 
Word, Excel, and PowerPoint of the versions 2000 and before. If you are planning to process any 
files that originate from these applications, you will have to have them installed.
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3 Select the files or the folder(s) that you would like to import in the upper half of the window 
(Explorer) and drag them into the lower half (Project).

4 Select the file name and set the format-specific properties in the Properties window to the 
right of the Advanced Project Explorer. For more information on this, see "To apply specific 
import options" on page 331.

5 Right-click the file or folder name and select Import.

-Or-

Select Home> Import.

6 The files or folder(s) are imported into the project.

To import one file or several files from a single location into existing projects

1 Open the project file.

You can also select an entire folder for import. For more information on this, see "To 
import folders with the Advanced Project Explorer" on page 68.
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2 Select Project> Add File> Add File.

3 A selection dialog appears.

4 Select the source file and click Open.

5 The file appears in the Project Explorer grayed out and with no status percentage indicator.
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6 Right-click the file in the Project Explorer and select Import to import the file. 

CREATING A NEW PROJECT FILE

To create a new project file, Déjà Vu X3  Workgroup assists you with a powerful wizard that allows 
you to create a project file and associate it with existing databases and/or new databases.

To create a new project file

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.

3 Select the Project button under Translation Project.

-Or-

Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.

You can disable the Start screen under File> Options> General> Start-up options. In 
the same location you can also enable or disable whether Déjà Vu X3  Workgroup 
should automatically look for a possible program update.
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4 The New File dialog appears.

5 Double-click Project or select Project and click OK.

6 The Create a New Project wizard appears with the first page in which you are prompted to 
name your project select a location for it.

7 In the steps that follow, the wizard will guide you through the process of creating a project file 
by
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selecting the languages,

You will notice that there are a great number of languages and sub-languages. Déjà Vu 
X3 Workgroup ranks the sub-languages hierarchically. If the program finds a exact or an 
equally fuzzy match with the same subject and client properties and the same source 
sub-language (English (United States), for instance) in the translation memory, it will 

choose it over another with a different source sub-language (English (United States) vs. English 
(United Kingdom), for instance). Further, it will prefer that constellation (different source sub-
languages, equal target sub-languages) to a constellation where the source sub-languages are equal 
but the target sub-languages are different (French (Standard) vs. French (Belgian)).

It is possible to only retrieve matches with the specified sublanguage by selecting File> Options> 
Translation> Only show matches with the requested sublanguage.

The list of displayed languages changes dynamically to display the last chosen languages at the top 
of the list.
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selecting or creating the associated translation memory(s) ,

selecting or creating the associated termbase(s) ,
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selecting the machine translation engines (if applicable),

and selecting a subject and a client.
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8 Click Next and select the files that need to be translated.

9 When you have made your selections click Next and Close.

You can access specific import properties (see p. 331) for each individual or all files by 
selecting Properties in this dialog. The default settings in the wizard are activated 
segmentation (i.e., all current segmentation rules are turned on) and all other format-
specific options are turned off. For information on format-specific import options, see 

"Working with Different File Formats" on page 325.
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10 The Project Explorer is opened, displaying the imported files.

11 To start the translation, double-click on either of the file names or on the project name.

CREATING A NEW PROJECT FILE ON THE BASIS OF A TEMPLATE

Rather than having to create every new project from scratch, Déjà Vu X3 Workgroup allows you to 
create a new project file on the basis of the template of a previous project.

For this to happen, you’ll need to save the settings of a previous project.

To save the settings of a project in a settings file

1 Select Project> Properties> Templates (in the lower left-hand corner of the Project 
Properties dialog) in the previous project.
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2 The Project Templates dialog appears.

3 Click Save. 
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4 You are prompted to enter a new template name or accept the existing one.

5 Click OK when you have made your selection.
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6 The following settings are saved:

source and target languages 

translation memories 

termbases 

client

subject

7 Click OK.

Once a template is saved, you can now create a project on the basis of those settings.

To create a project on the basis of a template

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.

Templates have the extension .dvprt (Déjà Vu project template) and are located in the 
\Templates folder (by default C:\ProgramDataAtril\Deja Vu X on an English Windows 
installation—if you can’t view this folder you will need to unhide it by opening Folder 
Options in the Windows Control Panel and selecting View> Show hidden files, folders, 

and drives). You can change the default location of the termbase templates under File> Options> 
General> Shared data location.
Déjà Vu X3    90



Workflow
3 Select the Project from Template button under Translation Project.

-Or-

Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.

You can disable the Start screen under File> Options> General> Start-up options.
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4 The New File dialog appears.

5 Double-click Project From Template or select Project From Template and click OK.

6 The Create a New Project wizard appears.

7 Select the template you want to assign to your project and click Next.
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8 Click Browse to select a name and location for your project. 
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9 Click Next and select the files that need to be translated.

10  When you have made your settings, click Next and Done.
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11 The Project Explorer is opened, displaying the imported files.

12 To start the translation, double-click on either of the file names or on the project name.
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GENERATING THE LEXICON

The project’s lexicon is a list of all the source language words or phrases present in the project—in 
other words, an index of all terms and phrases. Once you have created this index, you can 
translate the terms that seem relevant to you, batch delete all other terms (for instance, terms like 
"the" or "to" in the image below), and Déjà Vu X3 Workgroup will use what remains as the primary 
glossary for your project.

The lexicon is a very useful tool, but as indicated in the light shading in the workflow chart on page 
p. 75, it is an optional component.

Clients will often ask you to provide them with a glossary for a project you’ve translated 
for them; this will help them keep a record of the terminology used, ensuring that the 
same terminology is used in future projects. With Déjà Vu X3 Workgroup, creating a 
glossary for your client is as simple as exporting the lexicon to a text file.

For project managers, the lexicon can provide an extremely valuable tool for quickly generating 
glossaries for large projects with multiple translators.
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To create the lexicon

1 Select Lexicon> Create Lexicon.

2 The Build Lexicon dialog appears.

3 You are offered the following options:

Specify the maximum number of words for a lexicon entry.

Specify whether Déjà Vu X3 Workgroup should try to translate the lexicon entries as it 
creates them, using the termbases and translation memories for the project.

Specify whether you want a lexicon for the current or all files.

4 Select the options you want, and click OK.

Generally you will want to select 2 or 3 for this option. Higher numbers tend to result in 
a great deal of useless entries. Déjà Vu X3 Workgroup does not linguistically evaluate 
the words; it simply lists all occurrences in all combinations. For example, "The cat is 
black" with a maximum number of 4 would be listed as "The," "cat," "is," "black," "The 

cat," "cat is," "is black," "The cat is," "cat is black," and "The cat is black." Of those entries, 
only "cat," "black," and arguably "cat is black" would be useful entries in the lexicon.
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Depending on the size of the project, building the lexicon may take some time because Déjà Vu 
X3 Workgroup has to process each segment in the project a number of times. While Déjà Vu X3 
Workgroup is working on creating the lexicon, you will see a progress indicator in the Build 
Lexicon dialog and finally a notification how many entries have been generated.

Once Déjà Vu X3 Workgroup has finished building the lexicon, you can view it by double-clicking 
on Lexicon from the Project Explorer.

The first column on the table, with the heading Words Freq, shows the number of words in the 
lexicon entry, and the frequency, i.e., the number of times it appears in the project.

To translate the lexicon

There are several ways to translate a lexicon:

Once the lexicon is generated, you can select Lexicon> Resolve to leverage the content 
of your databases against the lexicon. For more information on this, see "Resolving the 
Lexicon with the Databases" on page 427.

You can manually translate it by entering the translation into the target column.
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Either way, you will want to translate only those terms that are helpful for you to have in the 
lexicon and delete the remaining lexicon entries.

To remove rows from the lexicon

To avoid a large number of useless entries in the lexicon, you will probably want to delete the 
lexicon entries that appear only rarely in the project, or those that contain a very large number of 
words.

1 Select Lexicon> Remove Lexicon.

2 The Remove lexicon entries dialog appears.

3 You are offered the following options:

Remove the entire lexicon.

Remove those lexicon entries for which you have not entered a translation.

Remove lexicon entries based on the number of words they contain and/or their 
frequency. You can also specify whether to remove those entries that satisfy these 
conditions and have not been translated, thereby preserving any special entries you 
decided to keep. The selection in the image above instructs Déjà Vu X3 Workgroup to 

Déjà Vu X3 Workgroup will use only translated rows in its translation processes, so it is 
possible to skip this step.

This is useful when you have finished translating the useful entries in the lexicon and 
want to remove the rest, or when you want to export the relevant entries in the lexicon 
to send to your client as a glossary.
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delete all rows with three or more words in the source field and ten or fewer 
occurrences.

4 Select the options you want and click OK.

When you are done building your lexicon, you have completed the project building phase.

For more information about the lexicon, see "The Lexicon" on page 425.

PHASE III: PRETRANSLATION

The third phase of a translation project in Déjà Vu X3 Workgroup is pretranslation. Pretranslation 
allows you to batch leverage the content of your databases—translation memory(s), termbase(s), 
and (optionally) the lexicon—against your source files. 

To pretranslate a project

1 On the Project ribbon tab, click Pretranslate.

–Or–

Press Ctrl+P.

This kind of setting may make sense for a very large project where you have some 
occurrences of several hundred.

While you could leverage on a segment-by-segment level as you translate (see "Phase 
IV: Translation" on page 103), pretranslation has the advantage of giving you a better 
idea of what to expect, i.e., how much actually needs to be translated.
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2 The Pretranslate dialog appears.

3 Set the different options as shown above and click OK.

By unchecking Accept only exact matches, you instruct Déjà Vu X3 Workgroup to scan 
the translation memory for exact and/or guaranteed matches; if it cannot find exact and/
or guaranteed matches, it will look for fuzzy matches.

By checking Assemble from portions, you instruct Déjà Vu X3 Workgroup to fill in 
portions (i.e., single words or short phrases) from the translation memory(s), the 
termbase(s), and (if available) the lexicon. Déjà Vu X3 Workgroup will also try to turn 
fuzzy matches into exact ones by supplying missing terms in whole segments from the 
translation memory with segments from the termbase(s) and the lexicon. 

The options under the Assemble option include Use DeepMiner statistical extraction to 
include subsegments and their combinations from the translation memory(s), Use 
Machine Translation to enter machine translation where no other matches are found, 
and Insert source text to copy over portions that are not found in any of the databases.

The options under Overwrite allow you to pretranslate segments that have already been 
processed and have either an exact, fuzzy or assembled status. Though these options are 

You can set separate degrees of fuzziness for translation memories and termbases under 
Fike> Options> Translation.
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not relevant for our particular aim that we hope to achieve with pretranslating, they may 
be helpful when you receive a Déjà Vu X3 Workgroup project file that has already been 
translated, but you feel that your own database(s) has a greater amount of and more 
accurate project-specific terminology.

By checking Lock guaranteed matches and setting the context size to a number higher 
than 0, you activate Déjà Vu X3 Workgroup’s Guaranteed Match feature during the 
pretranslate process, determine how much context should be considered for a 
guaranteed match and make sure that guaranteed matches are locked.

Checking the option Check for inconsistent terminology will activate Déjà Vu X3 
Workgroup’s automated terminology check even during the pretranslate process. With 
this feature, X3 Workgroup will check any of the pretranslated material for 
inconsistencies in any of the attached databases and warn you with a red exclamation 
mark if it finds any. For more information on the inconsistency checks, see "Consistency 
Checks" on page 115. 

Limit to current record selection may be helpful if you only wish to pretranslate a section 
of a file that you are displaying through filtering or the segment selector (see "Selecting 
Segments by Filtering" on page 64 and "Selecting Segments by Status" on page 64).

4 Once the pretranslation is finished, a status report will be displayed at the bottom of the 
Pretranslate dialog, informing you of how many segments have been processed at what 
status.

By setting the Context size in the Pretranslate dialog, you instruct Déjà Vu X3 
Workgroup to look for the number of context rows that it needs to guarantee a match. 
The higher the number, the more difficult it will be to find a guaranteed match.

To draw the full benefit from the Guaranteed Matches feature, you will have to select Store 
segment content information to enable Guaranteed Matches on the Translation tab in the Options 
dialog (see p. 177)
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You will notice a colored status indicator to the left of the translations. By default, every 
guaranteed match has an orange indicator, every exact match has a dark green indicator, every 
fuzzy match has a light green indicator and so forth. All of these display options are configurable 
under File> Options> Display.

PHASE IV: TRANSLATION

Although Déjà Vu X3 Workgroup may have done a great deal of your translation work for you, 
there will usually still be translation work left for you to do.

Translation—much like pretranslation—is a process where the translation work in the project file is 
greatly enhanced by the associated databases and the lexicon. You can manually access 
information in all these files and use it as a reference, but you can also let Déjà Vu X3 Workgroup 
do the work for you.

Essentially, there are two processes during the translation phase: leveraging from the databases, a 
process that can be largely automated in Déjà Vu (see "Automatically Communicating with the 
Databases" on page 104); and feeding to the databases (see "Feeding the Databases" on page 110).

Even if the pretranslation inserts an exact match, it is a good practice to check the 
translation for any mistakes (you might have translated it wrong in the past or translated 
it in an entirely different context).

If the actual match is blue and has an underline, it is an exact match for which several exact 
matches have been found in the database. Right-clicking on each of these records opens a context 
menu in which the other translation options are displayed. If you choose one of those over the 
existing one, you can select it by clicking on it. To jump to the next multiple exact match line, you 
can press Ctrl+F3. You are strongly encouraged to check each of these matches.

If you have checked all multiple matches and would like to delete the underline and blue coloring, 
you can right-click in the target field and select Accept all Multiple Matches.

Guaranteed matches, however, are matches for which Déjà Vu X3 Workgroup has automatically 
checked the context for you.
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AUTOMATICALLY COMMUNICATING WITH THE DATABASES

1 Before you start to translate, select Tools> Options> General
 

You can see that there are several "Auto-Features" available:

AutoWrite (see p. 174)

AutoTranslate (see p. 105),

AutoPropagate (see p. 200),

AutoCheck (see p. 119),

AutoSend (see p. 110), and
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AutoSearch (see p. 106)

AUTOWRITE

You can instruct Déjà Vu X3 Workgroup to automatically suggest matches it finds in the 
subsegments of the associated translation memory(s) and/or termbase. These matches will be 
shown as you type your translation, and you can accept them by clicking on them.

To activate AutoWrite

1 On the General tab in the Options dialog, click Enable AutoWrite.

-Or-

Click  on Déjà Vu X3 Workgroup’s status bar.

AUTOTRANSLATE

You can instruct Déjà Vu X3 Workgroup to automatically insert a match from the translation 
memory or to assemble a translation from smaller pieces that can be found in the project lexicon, 
termbase, translation memory or machine translation (in this order).

To activate AutoTranslate

1 On the General tab in the Options dialog, click Enable AutoATranslate.

-Or-

Click  on Déjà Vu X3 Workgroup’s status bar.

2 The next time you jump from one segment to the next by pressing Ctrl+DownArrow (or 
Ctrl+Enter), Déjà Vu X3 Workgroup will automatically assemble the segment for you.

3 You can recognize assembled segments by their status indicator. The default color is dark 
blue.

For more information on the AutoTranslate function, see "The "Translate" Process" on page 154.

For AutoCorrect, see "AutoCorrect" on page 224, and for AutoText, see "AutoText" on 
page 221.
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AUTOSEARCH

By activating AutoSearch, you can make Déjà Vu X3 Workgroup automatically scan (search) the 
translation memory for the current segment and search the translation memories, termbases and 
the project lexicon for any portions of the segment.

To activate AutoSearch

1 On the General tab in the Options dialog, click Enable AutoSearch.

-Or-

Click  on Déjà Vu X3 Workgroup’s status bar.

2 The AutoSearch pane appears on the right side corner of the screen.

At the bottom of the window, you can see related information, such as client, subject, date/time 
stamp and database origin of the selected term displayed.

If you prefer to view segments and portions displayed in two separate windows, you 
can activate this by selecting File> Options> General> Show segment and portion in 
separate windows. For more information on this, see "Splitting the AutoSearch window" 
on page 38.
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If you select an entry from a translation memory, you might see additional rows in which the 
differences between the record in the translation memory and the original source segment are 
highlighted.

The AutoSearch window will also display matches that have been turned from fuzzy to exact 
matches with the help of Déjà Vu X3 Workgroup’s advanced leverage technology. In these cases, 
the upper portion of the AutoSearch window will display the "fixed" segment rather than the 
original segment of the source. Any change you make to the translation of that string in the 
AutoSearch window would be considered a new entry to the translation memory instead of a 
change to the existing segment pair.

To navigate through the AutoSearch window

Press Ctrl+Shift+UpArrow to move to the previous portion.

–Or–

You can find information on each of the cells in these additional rows under "Scanning 
the Translation Memories" on page 146. The cells in the Scan Results window described 
in that section have the same structure as the ones in the AutoSearch window.
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Press Ctrl+Shift+DownArrow to move to the next portion.

To copy a term from the AutoSearch window into the target column

1 Press Ctrl+1 (or whichever number is associated with that entry).

-Or-

Double-click that entry.

-Or-

Press Ctrl+R to copy the currently selected entry from the AutoSearch window into the target 
cell (Ctrl+E for the AutoSearch - Segments window).

2 As soon as you move to a new segment in your project, Déjà Vu X3 Workgroup will begin 
searching the lexicon and the databases and display any matches. 

If you press Ctrl+Shift+1 (or whichever number is associated with that entry), you can 
copy the respective term into the target field by overwriting the existing content.

If you press Ctrl+Shift+R (or Ctrl+Shift+E for the AutoSearch - Segments window), 
you can copy the respective term into the target field by overwriting the existing 
content. 

The underlying color of the number indicates the source of the segment (blue=termbase, 
white=lexicon, and red=translation memory). As with all other colors, these colors can be 
changed under File> Options> Display.
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To adjust the AutoSearch settings

1 Select File> Options> General.

2 The options under AutoSearch include:

Enable AutoSearch—see "To activate AutoSearch" on page 106.

Show segments and portions in separate windows—Controls whether one or two 
AutoSearch segments will be displayed. For more information, see "Splitting the 
AutoSearch window" on page 38. 

Require Control key to Insert AutoSearch results—Controls whether matches form the 
AutoSearch window can be inserted from the numbers on the keypad with or without 
the Control key being pressed.

Display all subportions—Controls whether parts of portions should be displayed when 
larger portions are found. 

Display portions from the Translation Memory—Controls whether matches found in the 
translation memory(s) are also displayed, and whether or not the translation memory(s) 
will be used when performing terminology checks (for terminology checks, see 
"Consistency Checks" on page 115).
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Limit the number of Translation Memory segments displayed to—Determines how many 
matches from the translation memory(s) are being displayed simultaneously.

Show Machine Translation results for whole segments—Determines whether machine 
translation suggestions should be displayed (if a machine translation is associated with 
the project and, if so, in which scenarios:

Only if there are no matches from the translation memory

Only if there are no matches from the translation memory, or

Always

Hide tags—Removes any tags present in text retrieved from the databases before 
displaying it.

Hide column headers—Controls whether the AutoSearch language column headers are 
hidden to gain some additional user interface estatDéjà Vu X3 e. For more information, 
see "To hide the column headers" on page 41. 

Cache AutoSearch results for—Determines how often to clear the cache that holds 
information on matches that Déjà Vu X3 Workgroup has displayed in the past XX 
seconds. This speeds up the AutoSearch process because Déjà Vu X3 Workgroup will not 
have to look in the databases again. 

FEEDING THE DATABASES

As you can see, the databases allow you to greatly enhance your translation process; however, 
they can only do that because you feed them the information that they use to help you in the 
translation.

There are several ways to feed the databases. One is to create and translate a lexicon (see 
"Generating the Lexicon" on page 96), another is to feed the translation memory with the 
AutoSend feature (see "AutoSend" on page 110) and the manual feeding of the termbase (see 
"Adding Terms to the Termbase" on page 112).

AUTOSEND

If you want to automatically send segments to the translation memory when you are finished with 
their translation, you can activate the AutoSend feature.

If you prefer not to use the cache expiry period, do not enter 0 into the text field as this 
will cause the cache never to expire. Instead, enter a low number such as 1.
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To activate AutoSend

1 On the General tab in the Options dialog, enable AutoSend.

-Or-

Click  on Déjà Vu X3 Workgroup’s status bar.

2 The next time you jump from one segment to the next by pressing Ctrl+DownArrow (or 
Ctrl+Enter), Déjà Vu X3 Workgroup will automatically send the current segment pair to the 
translation memory.

Because you can simultaneously have several translation memories assigned in Déjà Vu 
X3 Workgroup, make sure that under Project> Properties> Translation Memories you 
assign the write attribute to the database(s) that is to contain all new material from the 
current project.

If you choose not to use the AutoSend feature, you can send individual segment pairs (or only 
highlighted selections of those) to the translation memory. To do that, select Add to TM on the 
Home ribbon tab or, click F12.
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ADDING TERMS TO THE TERMBASE

While it makes sense to automate the process of sending data to the translation memory, the 
termbase cannot be built automatically: you will have to teach the termbase which word or phrase 
in your translation corresponds to which term or phrase in the source. While entering terms into 
the termbase is probably the most manual process in Déjà Vu X3 Workgroup, it is still very easy 
and we encourage you to use it as much as possible.

Each termbase that you have associated with your project during the project creation or 
at a later point (see Project> Properties> Termbases) has a read or write attributes or 
both. Termbases with a read attribute will be used to retrieve data; those with a write 
attribute will have data written to them. This means that you can write to several 

termbases at the same time, thus allowing you, for instance, to have a copy of a large termbase on 
your local computer that you read and write from and the original termbase on a network server. 
You can choose to only write to the network termbases but not read from it, which would avoid 
increased network traffic and could have a significant impact on processing speed.
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To add terms to the termbase

1 Highlight a term or phrase in the source segment and the corresponding term or phrase in the 
target segment with your mouse.
 

2 Send the highlighted terms to the termbase.

3 On the Home ribbon tab, click Add to Termbase.

–Or–

Press F11.
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4 Add any specifications, including grammatical information (part of speech, gender or number) 
and semantical definition (such as context information, subject or client).

5 Click Add.

PHASE V: EDITING AND QUALITY ASSURANCE

The editing and quality assurance phase consists of employing Déjà Vu X3 Workgroup’s advanced 
integrated quality assurance features ("Déjà Vu X3 Workgroup’s Integrated Quality Assurance 
Features" on page 114) and editing the project by reading it through

on a hard copy ("Exporting into the Original Format for Proofing" on page 132),

in the External View format ("Proofing Outside of Déjà Vu X3 Workgroup" on page 133), 
and/or

within Déjà Vu X3 Workgroup’s own environment ("Proofing within Déjà Vu X3 
Workgroup" on page 133).

DÉJÀ VU X3 WORKGROUP’S INTEGRATED QUALITY ASSURANCE FEATURES

Déjà Vu X3 Workgroup uses several methods to assure the quality of the translation project. These 
include:

several levels of consistency checks between source and target and different targets

spell check 

Minimize your entry time by entering only the information that will be relevant for you 
or your co-workers later on. For instance, it obviously would not make sense to enter 
gender information if your language does not have a grammatical gender, or if any 
skilled translator or editor would be familiar with this kind of information anyway.

If you are certain that you do not need to enter any additional information (aside from the standard 
user and date/time information), you can also send the highlighted terms or phrases to the 
termbase by pressing Shift+F11 or by right-clicking and selecting Add to Termbase> Quick Add to 
Termbase on the Home ribbon tab. This method will not prompt you to enter any additional 
information.

For other ways to send information to the databases, see "Sending Text to the 
Databases" on page 177.
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CONSISTENCY CHECKS

Déjà Vu X3 Workgroup provides for a number of different consistency checks:

Spaces—to verify whether the number of spaces at the end of a segment is identical 
between the source and target segments

Tags—to verify whether the tags are identical between the source and target segments 
and whether they are in the same order/position of the segment

Numerals—to verify whether numbers between the source and target segments are 
identical

Terminology—to verify whether the terminology in the translation adheres to the 
terminology in user-defined resources

To define terminology resources

On the Translation tab in the Options dialog, you can define what databases will be considered 
during the different terminology consistency checks.

1 Select File> Options> Translation.

2 Under Quality Assurance options you can specify whether numbers should be included in the 
checks and whether the checks should be performed against data in the
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lexicon,

termbases, and/or

translation memories.

TO APPLY CONSISTENCY CHECKS

Déjà Vu X3 Workgroup provides for a number of different consistency check methods:

a batch check once the translation is finished (for terminology and numbers),

an automated check that can be used during the translation ("AutoCheck"),

a consistency check that selects the next available discrepancy, and

a consistency check during pretranslation (see p. 102).

To perform a batch terminology and numerical validation

Once you are finished with the translation or at any point during the translation, select Review> 
Batch QA.

–Or–

Press Ctrl+Q.

1 The Batch QA dialog appears.

2 Select whether you want the current or all languages checked; the current or all files; from the 
beginning of the file/project or from the current position; and whether you want to have only 
those rows checked that you are displaying through filtering or the segment selector (see 
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"Selecting Segments by Filtering" on page 64 and "Selecting Segments by Status" on page 64).

3 Select OK.

4 A process indicator shows you the progress of the validation.

5 Once the validation is finished, every segment with a terminological or numerical discrepancy 
(if selected under File> Options> Translation> Quality Assurance options) displays a red 

If you have existing, customized SQL filters (see p. 53) they will be listed under the SQL 
option. You can limit the QA efforts to only that subset by activating that SQL filter.
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exclamation mark (or a light violet exclamation mark if there is already a target comment on 
that segment). 

6 If you select the segment, you can see that the numbers and the source terms for which 
inconsistencies were found are painted red. If you hold your mouse cursor over one of the 
exclamation marks, you can see what kind of inconsistencies were found and in what kind of 
database they were found.

7 When you have reviewed that information and decided to make changes or leave the 
translation as originally intended, the exclamation mark will disappear (or become light blue if 
there is a comment in that segment) after you hit Ctrl+DownArrow (or Ctrl+Enter). 

To ease the process of finding the rows with inconsistencies in your project, 
you can filter the project to display only rows with inconsistencies by selecting 
Segments with Inconsistent Terminology or Segments with QA Warnings in 
the Segment Selector.
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8 To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.

9 Once you are done reviewing all rows, you can right-click in the target area and select Delete 
all Warnings.

To use the automated numerical and terminology check

If you would like to automatically check your translation for consistency with any of your 
databases as you translate, you can activate the AutoCheck function.

1 Select File> Options> General and activate AutoCheck.

–Or–

Click  on Déjà Vu X3 Workgroup’s status bar.

2 When you press Ctrl+DownArrow (or Ctrl+Enter) after translating a segment with 
inconsistent terminology or numbers (if selected under File> Options> Translation> Quality 
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Assurance options), you will not jump to the next available segment. Instead, you will be 
notified with a red exclamation mark (or a light violet exclamation mark if there is already a 
target comment on that segment) that there is a potential problem in that segment. 

3 The source terms for which inconsistencies were found are painted red. If you hold your 
mouse cursor over the exclamation marks, you can see the inconsistencies and in what kind 
of database they were found.

4 After you have reviewed the information and decided to make changes or leave the 
translation as originally intended, the exclamation mark will disappear (or become light blue if 
there is a comment in that segment) after you hit Ctrl+DownArrow (or Ctrl+Enter). 

5 To jump to the next segment and finally mark the segment as Finished, hit Ctrl+DownArrow 
again.

To check the current segment for a numerical or terminology mismatch

1 Press Ctrl+Alt+F7.

–Or–

Select Check Terminology> Check Terminology (Current Segment) on the Review ribbon tab.

2 Déjà Vu X3 Workgroup will check whether there is a terminology and numerical discrepancy 
(if selected under File> Options> Translation> Quality Assurance options) and will display a 
Déjà Vu X3    120



Workflow
red exclamation mark in that segment (or a light violet exclamation mark if there is already a 
target comment on that segment). 

3 The numbers and the source terms for which inconsistencies were found are painted red. If 
you hold your mouse cursor over the exclamation mark, you can see what kind of 
inconsistencies were found and in what kind of database they were found.

4 After you review the information and decide to make changes or leave the translation as 
originally intended, the exclamation mark will disappear (or become light blue if there is a 
comment in that segment) when you hit Ctrl+DownArrow (or Ctrl+Enter). 

5 To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.

To find the next numerical or terminology mismatch

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open 
file or project (see "Selecting Segments in the Selection Mode" on page 63).

2 Select Check Terminology on the Review ribbon tab.

–Or–

Press Ctrl+Alt+F7.

3 Déjà Vu X3 Workgroup will find the next terminology or numerical discrepancy (if selected 
under File> Options> Translation> Quality Assurance options) and will display a red 
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exclamation mark in that segment (or a light violet exclamation mark if there is already a 
target comment on that segment). 

4 The numbers and source terms for which inconsistencies were found are painted red. If you 
hold your mouse cursor over the exclamation mark, you can see what kind of inconsistencies 
were found and in what kind of database they were found.

5 After you review the information and decide to make changes or leave the translation as 
originally intended, the exclamation mark will disappear (or become light blue if there is a 
comment in that segment) when you hit Ctrl+DownArrow (or Ctrl+Enter). 

6 To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.

NUMERAL CONSISTENCY CHECKS

To find the next numeral discrepancy

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open 
file or project (see "Selecting Segments in the Selection Mode" on page 63)

2 Select Check Numerals on the Review ribbon tab.

–Or–

Press Ctrl+Shift+F7.
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3 Déjà Vu X3 Workgroup will find the next numeral discrepancy and display a red exclamation 
mark in that segment (or a light violet exclamation mark if there is already a target comment 
on that segment). 

4 The inconsistent target and source numbers are painted red. If you hold your mouse cursor 
over the exclamation mark, you can see a further description of the inconsistencies.

5 When you have reviewed the information and decided to make changes or leave the 
numbers as originally intended, the exclamation mark will disappear (or become light blue if 
there is a comment in that segment) after you hit Ctrl+DownArrow (or Ctrl+Enter). 

6 To jump to the next segment and mark the segment as Finished, hit Ctrl+DownArrow again.

7 Continue to check for number errors and, if appropriate, fix them until you reach the end of 
the open file or project.

Déjà Vu X3 Workgroup will not mark discrepancies between numbers caused by Déjà 
Vu’s automatic decimal conversion feature (see "Conversions" on page 214).

You can also check for discrepancies in numerals as you check for discrepancies in the 
terminology (see "Consistency Checks" on page 115). To do this, you will have to 
activate Also check numerals under File> Options> Translation> Check for consistent 
numbers as you check the terminology.
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MISSING SPACES CHECK

To check whether there are any discrepancies between the spaces at the end of a segment in 
source and target

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open 
file or project (see "Selecting Segments in the Selection Mode" on page 63).

2 Select Check Spaces on the Review ribbon tab.

3 Déjà Vu X3 Workgroup will jump to the next occurrence of a discrepancy between spaces at 
the end of a segment in source and target.

4 Make sure to fix any discrepancies.

TAG CONSISTENCY CHECKS

To check whether there are any discrepancies between tags in source and target

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open 
file or project (see "Selecting Segments in the Selection Mode" on page 63).

2 Select Check Tags on the Review ribbon tab.

–Or–

Press Ctrl+Shift+F8.

3 Déjà Vu X3 Workgroup will jump to the next occurrence of a discrepancy between tags in 
source and target.

Discrepancies include:

missing or additional tags,

tags that are in a different order than in the source segment, and

tags at the very beginning or the very end of the source segment that have something 
before or after them in the target segment.

4 You can quickly fix the tags by pressing Ctrl+F8 or selecting Check Tags> Fix Tags. This will 
copy all missing codes to the end of the current target segment.

5 Make sure that the tags are now located in the correct position.
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6 Continue to check for tag errors and fix them until you reach the end of the open file or 
project.

TRANSLATION CONSISTENCY CHECKS

To check whether there are any discrepancies in the translations of the same source

1 Select Project> Find Duplicates.

2 The Find Duplicate Segments dialog appears.

3 Select whether you want to Find (all) sets of duplicate source segments.

–Or–

Find sets of duplicate source segments with different translations.

4 If you select the second option, you will also have to select the target language.

5 Make the appropriate selections under Miscellaneous:

Ignore case—With this option, THIS SENTENCE would be considered a duplicate of 
this sentence.

Ignore numerals—With this option, A 100 m dash would be a duplicate of A 50 m 
dash.

Ignore inline tags—With this option, This {101}sentence{102} would be a 
duplicate of This sentence.

For more information about tags, see "Tags" on page 204.
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6 Click OK.

7 All duplicates are indicated with a grey indicator to the left of the source sentence.

8 To view duplicates and their differing translations (provided that you have selected that 
option) side by side, you can select Duplicate Segments in the Segment Selector.

–And/Or–

Highlight the source in question, right-click, and select Filter> Filter by Source Selection.

9 The duplicated rows with different translations are now displayed on top of each other.

The colors of the duplication indicator can be changed to any color you prefer. For 
more information on changing colors, see "To change the colors of the indicator bars" 
on page 46.
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10 You can now enter your correction if necessary.

11 Display all rows by selecting All Rows from the Segment Selector.

–And/Or–

Right-click in the source column and select Filter> Remove Filter.

To unmark duplicate segments

To remove the indicator in duplicate segments, select Project> Unmark Duplicates.

SPELL CHECKING

Integrated spell checking by Déjà Vu X3 Workgroup is provided by the Hunspell spell checker that 
is available for more than 120 versions. Déjà Vu X3 Workgroup comes preinstalled with the 
following languages: Afrikaans, Albanian, Bulgarian, Catalan, Croatian, Czech, Danish, Dutch 
(various), English (various), Estonian, Danish, Faroese, French (various), German (various), Greek, 
Hebrew, Hindi, Hungarian, Indonesian, Italian (various), Korean, Latvian, Lithuanian (various), 
Norwegian (various), Polish, Portuguese (various), Romanian (various), Russian (various), Serbian 
(various), Slovak, Slovenian, Spanish (various), Swedish (various), Tamil (various), Turkish, 
Ukrainian, Valencian, Vietnamese. 

–And/Or–

You can use the Microsoft Word spell checker if your version of Word provides the appropriate 
dictionary. For more information on this, see "To spell check an open file or project with Microsoft 
Office’s spell checker" on page 131.

If you require spell checkers for other languages, you can download them from ftp://
ftp.ussg.iu.edu/pub/openoffice/contrib/dictionaries/. To add them, follow the 
instructions under http://tinyurl.com/DVX3Spellcheck.
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To check spelling as you type

1 Select File> Options> Proofing and activate Check spelling as you type.

2 Any misspelled word in the translation grid is underlined with a squiggly red underline.

3 Right-click the underlined word and select one of the suggestions from the top of the shortcut 
menu to automatically replace the highlighted word

–Or–
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Select Ignore All to avoid making this and other instances of the word be marked as 
incorrectly spelled in the current project.

–Or–

Select Add to Dictionary to have the underlined word recognized as a correctly spelled word 
for this and all later projects.

To spell check an open file or project with Déjà Vu X3 Workgroup’s integrated spell checker after 
the translation

1 Select Ctrl+Home (or Ctrl+PgUp) in the selection mode to go to the beginning of your open 
file or project (see "Selecting Segments in the Selection Mode" on page 63).

2 On the Review ribbon tab, select Spelling.

–Or–

Press F7.
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3 At the next occurrence of a misspelled or unrecognized word, the Check Spelling dialog 
opens.

4 The misspelled or unrecognized word is displayed in the Not in dictionary box. The word is 
considered misspelled because it could not be located in any of the open dictionaries. 

5 You have the following options:

Change the word by selecting the correct word under Suggestions or entering the correct 
spelling in Change To box and clicking the Change button (Change All changes all 
occurrences of this word in the current file or project).

–Or–

Enter a correction into the Not in dictionary box and click the Suggest button to see whether 
the spell checker recognizes this alternative. If it does, click Change (or Change All) to change 
the word in the current file or project.

–Or–

Skip it by clicking the Ignore button (Ignore All skips all of the occurrences of this word during 
this session of the spell checker).

–Or–

Add it to the dictionary that is selected under Add words to by clicking the Add button (for 
more information on dictionaries, see "Dictionaries" on page 235) (this option is not available 
when using the Microsoft Office spell checker).
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6 According to the selection you made, the word is changed or remains unaltered and at the 
occurrence of the next misspelled or unrecognized word the Check Spelling dialog opens 
again.

For an in-depth discussion on spell checking options, see "Spelling Options" on page 233.

For languages that do not have a spell checking option in Déjà Vu X3 Workgroup, you also have 
the option to use Microsoft Word’s spell checking option.

To spell check an open file or project with Microsoft Office’s spell checker

1 Select File> Options> Proofing.

–Or–

Click Options in the Check Spelling dialog.

2 Select Use the Microsoft Office spell checker.

To use this option, you will have to have Word 2000 or higher as well as the 
appropriate Word spell checker installed on your computer.
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3 When you continue with spell checking, Déjà Vu X3 Workgroup will automatically use the 
dictionaries of the Microsoft Office spell checker for that particular language.

Loading the Microsoft Office spell checker

The very first time you started Déjà Vu X3 Workgroup, all the available Office spell checkers were 
loaded. To avoid the rather time-consuming process of having to reload them during each startup, 
they are stored. If you change your configuration of Office spell checkers (e.g., update, add or 
delete languages), these changes will not be automatically reflected within Déjà Vu X3 Workgroup 
until you select the Reload Office Proofing Tools button on the Proofing tab.

EDITING AND PROOFING

While the previous section described ways to use the integrated proofing tools that Déjà Vu X3 
Workgroup provides, translators typically want to edit and proof their translations manually as well. 
There are several ways of doing this.

EXPORTING INTO THE ORIGINAL FORMAT FOR PROOFING

Some translators/editors prefer to see the translated text in its original format for proofing 
purposes.

To do this, you can export an intermediary copy of your document(s) to use for proofing. If you 
choose this option, you should be aware of the following:

It is important to apply all changes to the Déjà Vu project file rather than the exported 
file. This is the only way to make sure that your modifications will be reflected in your 
translation memory and that you will be able to benefit from that later on.

There is certain text that you will not be able to see on the screen or in a printout copy, 
including index markers or text within scripts.

this process applies more to print and desktop publishing formats than online, database 
or resource formats. 

To locate segments that need to be modified, you can use the search function (press 
Ctrl+F or select Home> Editing> Find).
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PROOFING OUTSIDE OF DÉJÀ VU X3 WORKGROUP

There are several external formats (RTF table, Trados Workbench bilingual RTF, XLIFF) that are 
specifically created for proofing or checking unresolved issues outside of Déjà Vu X3 Workgroup. 
This allows you to export translated and commented rows into a format in which proofing can be 
performed and outstanding questions can be answered.

The main benefit of these formats is that they can be used across platforms and thus even by 
people who could not install a copy of Déjà Vu X3 Workgroup. For more information on the 
External View format, see p. 266 - p. 279).

PROOFING WITHIN DÉJÀ VU X3 WORKGROUP

Many translators and editors feel that the most efficient and safe way to edit and proof a document 
is directly in the Déjà Vu environment.

Here are some of the benefits:

All translated text is visible.

The Live Preview feature offers a real-time view of Microsoft Word, Excel and 
PowerPoint files and an in-context view for development and tagged formats (see 
"Microsoft Office (Live)" on page 351).

All tags are protected (for more information on codes, see "Tags" on page 204).

All text is organized in the tabular database view of Déjà Vu X3 Workgroup that can be 
viewed, sorted, and edited in all possible configurations:

You can choose to display only rows with a certain status (see "Selecting Segments 
by Status" on page 64).

You can choose to display all rows alphabetically (see "To switch between natural 
and alphabetic order" on page 43).

You can sort on a specific phrase or word to see the use of this phrase or word in the 
entire project (see "Selecting Segments by Filtering" on page 64).

Text can be marked and displayed as pending (see "Marking Segments as Pending" on 
page 241).

You can do entire database scans for a certain word if you are not sure about its use (see 
"Searching the Databases" on page 146).

You can make sure that your changes are being implemented in all identical rows 
through the Propagate function (see "Propagate" on page 199).
Déjà Vu X3    133



134
PHASE VI: EXPORT

When you are finished translating and editing your files, you will want to export them into their 
original format. Déjà Vu X3 Workgroup offers you three different ways to do that:

You can export the complete project via the Project ribbon tab and the Export Translated 
Project command.

You can export single files or folders through a right-click command from within the 
Project Explorer,

You can export single files or any subset of files from the Advanced Project Explorer.

For information on exporting with the Advanced Project Explorer, see "To export files or folders 
with the Advanced Project Explorer" on page 71.

To export files with the ribbon command

1 Select Project> Export Translated Project.

2 The Export Options dialog appears.

3 Under Destination, select the folder to which you want your files to be exported.

4 Under Languages, select the languages you want to export.
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5 If applicable, you can define filter-specific options for the files within your project under 
Filter-specific Options. For information about these options, see the respective sections in 
"Working with Different File Formats" on page 325.

If your project contains several file types with filter-specific export options, all sets of options 
will be listed and you will have to make sure that you set all available options.

6 Select OK.

7 Déjà Vu X3 Workgroup will verify if there are any discrepancies 

in tags (see p. 209) and/or 

spaces at the end of segments.

8 For each language you are exporting, Déjà Vu X3 Workgroup will create a subfolder inside 
the export folder, named after the code for the specific locale of that target language. For 
example, if you were translating the file into German (Germany), the new folder would be 
called C:\My Projects\DE_DE.

If Déjà Vu X3 Workgroup finds a discrepancy in spaces following periods, question 
marks, or exclamation marks, it will offer to automatically fix that discrepancy.
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To export files with the right-click command in the Project Explorer

1 Right-click on any single file or folder or the complete project in the Project Explorer.

2 Select Export.

3 The Export Options dialog appears.

4 Under Destination, select the folder to which you want your files to be exported.

5 Under Languages, select the languages you want to export.

6 If applicable, you can define filter-specific options for the files within your project under 
Filter-specific Options. For information about these options, see the respective sections in 
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"Working with Different File Formats" on page 325.

7 Select OK.

8 Déjà Vu X3 Workgroup will verify if there are any discrepancies 

in tags (see p. 209) and/or 

spaces at the end of segments.

9 For each language you are exporting, Déjà Vu X3 Workgroup will create a subfolder inside 
the export folder, named after the code for the specific locale of that target language. For 
example, if you were translating the file into German (Germany), the new folder would be 
called C:\My Projects\DE_DE.

If your project contained a complete folder, Déjà Vu X3 Workgroup will recreate the structure 
of that folder with all of its subfolders, containing all the files you have translated.

If Déjà Vu X3 Workgroup finds a discrepancy in spaces following periods, question 
marks, or exclamation marks, it will offer to automatically fix that discrepancy.
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Translation Features in Déjà Vu X3 Workgroup—The Details
TRANSLATION FEATURES IN DÉJÀ VU X3 WORKGROUP—THE DETAILS

While many of Déjà Vu X3 Workgroup’s features were discussed or mentioned in the previous two 
chapters ("The Déjà Vu X3 Workgroup Interface" on page 19 and "Workflow" on page 75), these 
and other features are presented in this resource chapter in more in-depth manner:

Database Performance on page 140

Searching the Databases on page 146

The "Translate" Process on page 154

The DeepMiner Engine on page 158

Machine Translation on page 165

AutoWrite on page 174

Sending Text to the Databases on page 177

Clients and Subjects on page 183

Propagate on page 199

Pseudotranslation on page 202

Tags on page 204

Context View on page 212

Conversions on page 214

Copying and Populate on page 215

Sentence Segmentation on page 217

AutoText on page 221

AutoCorrect on page 224

Common Windows Functions on page 227
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DATABASE PERFORMANCE

It is important to understand that all the different file formats that you can create and work in with 
Déjà Vu X3 Workgroup are databases that are based on Microsoft’s Jet database engine version 
4.0.

This is important for several reasons:

The databases are accessible with standard SQL (Structured Query Language) 
commands. This means that the only limitation to the way you can modify databases is 
your own creativity (and SQL knowledge).

The data exchange between the Déjà Vu X3 Workgroup databases and other formats is 
very advanced. You can import and export into many of the formats supported by the Jet 
engine as well as a number of translation-specific formats (Trados Workbench, TMX).

Because each of the files, including the Déjà Vu project files, are databases, a great 
variety of sorting, filtering, and batch processing options are available.

Many of the standard Jet engine utilities such as Compact Database and Repair Database 
are available for each of the components, as well as a great number of third-party 
utilities.

REPAIRING AND COMPACTING FILES

Each of the file types that are supported by Déjà Vu X3 Workgroup (project and satellite files, 
termbases and translation memories, as well as SGML/XML filters) can be compacted, and almost 
all can be repaired.

To compact a file

Because Microsoft’s Jet engine handles data by allocating unnecessary disk space, any of the files 
in question can grow very large. To save disk space and increase performance, it is advisable to 
compact the files at regular intervals. The result can be very impressive as files can be shrunk to a 
third or more of their original size. It specifically makes sense to compact a database, after you 
have performed the following actions:

deleted a large number of examples from an SGML/XML file

deleted a large number of lexicon entries from a project file

deleted one or several files from a project

added a large amount of data to any file

deleted any subset of data from a termbase or translation memory
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1 Select File> Tools> Compact> Project/Translation Memory/Termbase/Filter from anywhere 
within Déjà Vu X3 Workgroup.

2 Select the project/satellite/translation memory/termbase/XML filter file and click Open.

3 The compact process will start and Déjà Vu X3 Workgroup will notify you upon completion.

To repair a corrupted file

Repairing is necessary when a database file has become corrupted, probably because of an 
abnormal program ending caused by a power outage or by hardware problems.

1 Select File> Tools> Repair> Project/Translation Memory/Termbase from anywhere within 
Déjà Vu X3 Workgroup.

2 Select the project/translation memory/termbase file and click Open.

3 The repair process will start and Déjà Vu X3 Workgroup will notify you upon completion.

DATABASE AND FUZZINESS SETTING

On the Translations tab in the Options dialog, you can determine which resources are used and in 
what manner they are used.

Depending on the size of the original file, this process can take several minutes.

When compacting a file, data will be written to a new temporary file which is then 
copied back to the original file. This means that to successfully compact files, you need 

to have the necessary disk space for the temporary file.

This procedure involves time-consuming processes such as re-indexing the complete 
database and removing invalid entries. Depending on the size of the original file, this 
process can take a significant amount of time.

When repairing a file, data will be written to a new temporary file which is then copied back to the 
original file. This means that to successfully repair files, you need to have the necessary disk space 
for the temporary file.
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To select the resource for translation

1 Select File> Options> Translation.

2 Under When translating, use the following resources you have the following options:

Lexicon—If you select this option, the lexicon will be your preferred terminology 
resource. You will need to build a lexicon to take advantage of this option. For more 
information on building and utilizing a lexicon, see "The Lexicon" on page 425.

Termbase—If you select this option, the terminology database(s) that you have associated 
with your project will be queried for each segment that you translate. For information on 
how to assign termbases, see "Associating Termbases with a Project" on page 502. 

Translation Memory—If you select this option, the translation memory(s) that you have 
associated with your project will be queried for each segment that you translate. For 
information on how to assign translation memories, see "Associating Translation 
Memories with a Project" on page 450. 

Once you have selected this option, you will also have to make a choice whether you 
will Accept only exact matches (i.e., not try to have fuzzy matches from the translation 
memory(s) suggested to you). You can then select the level of fuzziness under Translation 
Memory options (see p. 141).
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Once you deselect that option (recommended), you can select whether Déjà Vu X3 
Workgroup should attempt to Repair fuzzy matches (i.e., to try to make necessary 
replacements in a fuzzy match to potentially convert it into an exact match—
recommended). Under Translation Memory Options, you can select whether you want 
to include DeepMiner suggestions (Use DeepMiner statistical extraction) and/or machine 
translation proposals (Use Machine Translation). For more information on repairing fuzzy 
matches, see p. 159. 

Machine Translation—If you select this option, the machine translation engine(s) that you 
have associated with your project will be queried for each segment that you translate. 
For information on how to assign machine translation engines, see p. 165. 

Assemble—The assemble process does not specify a separate resource but instead 
instructs Déjà Vu X3 Workgroup to use the previously selected resources to piece 
together a gist translation that can be useful as a basis for editing. For more information 
on the assemble process and other assemble options, see p. 161.

3 Under When retrieving matches, you can choose whether to query all of the termbase(s) and 
translation memory(s) or specifically:

Only show matches with the requested sublanguage—This option is applicable if your 
TM or termbase contains data from various sublanguages of one language (for instance, 
Chinese (PRC) and Chinese (Taiwan)), and for your project in Chinese (PRC) you only 
want to use records from that sublanguage rather than all sublanguages of Chinese.

Only show matches with the requested client—This option reduces the suggestion from 
the termbase and translation memory to those with the same client assigned to the 
project.

Only show matches with the requested subject—This option reduces the suggestion 
from the termbase and translation memory to those with the same subject assigned to 
the project.

For some sublanguages this is a highly recommended setting, as in the example 
mentioned above with Mainland Chinese vs. Taiwan Chinese. If you do have databases 
with records from both forms of Chinese, you would have a mixture of traditional and 
simplified characters if you did not choose this option.

Note that in the case of subjects with its hierarchical numbering system (see p. 193), 
only records of the exact same subject will be found rather than of any parent subject.
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To set the translation memory fuzziness setting

It is important for you to be able to control the level at which you want the translation memories to 
interact with your translation project. This level is generally called fuzziness, i.e., the degree of 
similarity of a TM match to the original. 

1 Select File> Tools> Translation.

Under Translation Memory Options, you can determine 

how you want to sort your matches: 

by the order of the translation memories that you have set under Project> Properties> 
Translation Memories

 –Or–

by the age of your database entries (i.e., whether older or newer database matches are 
preferred)

This setting only comes into effect when all other settings are of identical match quality, 
including sub-languages, client, and subject. If one match has the same fuzziness but a 
better matching sub-language, client, or subject, it will be preferred over the others 
regardless of their ages or database origin.
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what kind of Minimum Score (i.e., degree of fuzziness as a percentage) the matches are 
supposed to use. 

2 Make the desired settings and click OK.

To set the termbase fuzziness setting

Just like for the translation memory, it’s also important for you to be able to control the level at 
which you want the termbases to interact with your translation project.  

1 Select File> Tools> Translation.

Under Termbase options, you can determine

how you want to sort your matches: 

by the order of the termbases that you have set under Project> Properties> Termbases

 –Or–

The setting under Minimum Score will depend on your personal preference and the 
quality and extent of your databases. While the default setting is 75%, many users with 
extensive translation memories prefer a higher setting, while others try to benefit as 
much as possible from whatever they have in their translation memories.
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by the age of your database entries (i.e., whether older or newer database matches are 
preferred)

whether fuzzy termbase matches are also suggested (check Enable fuzzy terminology 
matches)

what kind of Minimum Score (i.e., degree of fuzziness as a percentage) the termbase 
matches are supposed to use. 

2 Make the desired settings and click OK.

SEARCHING THE DATABASES

There are several ways to search for a segment in your translation memory and termbases. Déjà Vu 
X3 Workgroup uses the terms scan for searching the translation memories and lookup for 
searching the termbases.

User typically pull data from your databases on the fly, i.e., as you translate. In the previous 
chapter you were introduced to:

Pretranslation (see "Phase III: Pretranslation" on page 100)—the process of batch 
leveraging data from your databases against your project.

AutoTranslate (see "AutoTranslate" on page 105)—the process of automatically inserting 
applicable data from your databases as you go from one segment to the next.

AutoSearch (see "AutoSearch" on page 106)—the process of automatically displaying all 
applicable data from your databases in the AutoSearch window and making this data 
easily accessible with mouse clicks or shortcut keys.

There are times, however, when none of the above options is applicable or you want to 
concordance search for only one subset of a segment.

SCANNING THE TRANSLATION MEMORIES

To manually scan the translation memory(s)

1 If you want to scan for a part of a segment, select the text you want to search for in the source 
segment. If you want to scan for the whole segment, do not select any text.

This setting comes into effect only when all other settings are of identical match quality, 
including sub-languages, client and subject. If one match has the same fuzziness but a 
better matching sub-language, client or subject, it will be preferred over the others 
regardless of their ages or database origin.
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2 On the Home ribbon tab, click Scan.

–Or–

Press Ctrl+S.

3 If Déjà Vu X3 Workgroup finds any matches in the translation memory, the Scan Results dialog 
appears.

The Scan Results dialog consists of the following elements:

Sought Source—The source language segment (or portion) you were searching for. Any words 
that are different from the match in the translation memory will be marked red.

Proposed Translation—The target language segment found in the translation memory with 
any changes that Déjà Vu X3 Workgroup has applied to it. This field can be edited.

Found Source—The source language segment (or portion) that was found in the translation 
memory. Any words that are different from the segment you are looking for will be crossed 
out.

Found Target—The target language segment found in the translation memory.

Matches—A list containing all the matches found by Déjà Vu X3 Workgroup, with their 
corresponding translations. The matches are sorted primarily by their fuzziness percentage 
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and secondarily by other criteria (subject, client, date, etc.). If you would like to review other 
matches, you can navigate through the list of matches by using the table’s scrollbar or the 
following keystrokes:

Ctrl+PageDown to go to the end of the list.

Ctrl+PageUp to go to the beginning of the list.

Ctrl+DownArrow (or Ctrl+Enter) to go to the next match.

Ctrl+UpArrow to go to the previous match.

Under the Matches list you can see information about the currently selected match, including 
Score (the percentage of fuzziness), Project, File, Subject, Client, Database (origin of match), 
Date (date and time the record was entered into translation memory), and User (who entered 
the term into the translation memory). 

The buttons to the right have the following function:

Replace—Replaces the text in the current target cell with the proposed translation.

Close—Closes the dialog without any changes.

Insert <<—Inserts the proposed translation to the left of any existing text in the current 
target cell (this button is only displayed if there is some text in the current target cell).

Insert >>—Inserts the proposed translation to the right of any existing text in the current 
target cell (this button is only displayed if there is some text in the current target cell).

Copy—Copies the proposed translation to the Windows clipboard.

Power Scan—Launches the Power Scan feature that will do another deeper search in the 
translation memory. The regular Scan feature saves time by not displaying fuzzy matches 
when an exact match is found. Power Scan will perform a new scan, resulting in matches 
in which single words will be displayed in context even if exact matches are found. The 
total number of matches that can be shown is not limited in this case.

4 Review the proposed translation, considering the information from the Sought Source and 
Found Source fields and, if applicable, scroll down the list of matches and select a different 
match.

The Power Scan feature is especially helpful when scanning for single words or short 
phrases.
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5 Make any necessary changes in the Proposed Translation text box and select the appropriate 
insertion button.

6 The dialog closes and the match is inserted into the current target cell.

To scan with wildcards

To widen the scope of your searches, you can use wildcards at the end of text you are looking for. 
The wildcards you can use to build search patterns are:

* — zero or more characters

? — one character

# — one digit

[a-m] — one character in the specified range

[!a-m] — one character outside the specified range

Examples:

If you have searched for a complete segment and found a match for that, you will 
probably want to click the Replace button. If you have searched for only a part of the 
segment, it would probably be a better choice to insert the match to the left or right of 
the current target, or copy it to the clipboard to paste it into the target with one of the 

standard paste features.

Kind of Match Pattern Match No Match

Multiple characters a*a aa, aBa, aBBBa aBC

Multiple characters *ab* abc, AABB, Xab aZb, bac

Multiple characters ab* abcdefg, abc cab, aab

Special character a[*]a a*a aaa

Single character a?a aaa, a3a, aBa aBBBa

Single digit a#a a0a, a1a, a2a aaa, a10a

Range of characters [a-z] f, p, j 2, &

Outside a range [!a-z] 9, &, % b, a
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1 Select a part of the text that you would like to search for.

2 Select Scan> Scan Translation Memory with Wildcards in the Home ribbon tab.

–Or–

Press Ctrl+Shift+S.

3 The Enter Search Expression dialog appears, displaying the selected text.

4 Enter the wildcard(s).

5 Click OK.

6 The Scan Results dialog appears with all matches that Déjà Vu X3 Workgroup has found in the 
associated translation memories.

7 For information on how to insert a match, see "To manually scan the translation memory(s)" 
on page 146.

Scan is one of the most helpful and frequently used functions in Déjà Vu X3 Workgroup.

Not a digit [!0-9] A, a, &, ~ 0, 1, 9

Combined a[!b-m]# An9, az0, a99 abc, aj0

The Scan Results dialog will also display matches that have been turned from fuzzy to 
exact matches with the help of Déjà Vu X3 Workgroup’s DeepMiner fuzzy repair 
feature.

Kind of Match Pattern Match No Match
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LOOKUP IN THE TERMBASES

To lookup a term in the termbases

In the same way that you can scan the translation memories for a segment or a part of a segment, 
you can search the termbases for data.

1 Select the term you want to look up.

2 On the Home ribbon tab, click Lookup.

–Or–

Press Ctrl+L.

3 If Déjà Vu X3 Workgroup finds any matches in the termbases, the Terminology Lookup dialog 
appears.

The Terminology Lookup dialog consists of the following elements:

Source—The source language terms you were searching for.

Target—The target language term found in the termbases.

Source Attributes—A list of all attributes that were entered for the source term.
Déjà Vu X3    151



152
Target Attributes—A list of all attributes that were entered for the target term.

If you would like to review other matches, you can navigate through the list of matches by 
using the table’s scrollbar or the DownArrow and UpArrow keys.

Under the Attributes you can see information about the currently selected match, including 
Date (date and time the record was entered into termbase), Subject, Project, File, Client, 
Database (origin of match), and User (who entered the term into the termbase). 

The buttons to the right have the following function:

Insert—Replaces the text in the current target cell with the proposed translation.

Close—Closes the dialog without any changes.

Insert <<—Inserts the proposed translation to the left of any existing text in the current 
target cell (this button is only displayed if there is some text in the current target cell).

Insert >>—Inserts the proposed translation to the right of any existing text in the current 
target cell (this button is only displayed if there is some text in the current target cell).

Copy—Copies the proposed translation to the Windows clipboard.

4 Review the proposed translation and, if applicable, scroll down the list of matches and select 
a different match.

5 Click the appropriate insertion button.

6 The dialog closes and the match is inserted into the current target cell.

To lookup with wildcards

To widen the scope of your searches, you can use wildcards at the end of text you are looking for. 
The wildcards you can use to build search patterns are:

* — zero or more characters

? — one character

# — one digit

For information on how to set up attributes, please see "Templates" on page 491.
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[a-m] — one character in the specified range

[!a-m] — one character outside the specified range

Examples:

1 Select a part of the text that you would like to search for.

2 Right-click on the selection and select Lookup with Wildcards.

–Or–

Press Ctrl+Shift+L.

–Or–

Select Translation> Lookup with Wildcards.

3 The Enter Search Expression dialog appears, displaying the selected text.

Kind of Match Pattern Match No Match

Multiple characters a*a aa, aBa, aBBBa aBC

Multiple characters *ab* abc, AABB, Xab aZb, bac

Multiple characters ab* abcdefg, abc cab, aab

Special character a[*]a a*a aaa

Single character a?a aaa, a3a, aBa aBBBa

Single digit a#a a0a, a1a, a2a aaa, a10a

Range of characters [a-z] f, p, j 2, &

Outside a range [!a-z] 9, &, % b, a

Not a digit [!0-9] A, a, &, ~ 0, 1, 9

Combined a[!b-m]# An9, az0, a99 abc, aj0
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4 Enter the wildcard(s).
.

5 Click OK.

6 The Terminology Lookup dialog appears with all matches that Déjà Vu X3 Workgroup has 
found in the associated termbases.

7 For information on how to insert a match, see "To lookup a term in the termbases" on page 
151.

THE "TRANSLATE" PROCESS

Déjà Vu X3 Workgroup’s Translate process uses a complex calculation when it weighs and 
considers the different resources that you have assigned.
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Assuming that under File> Options> Translation the Translation options and the Assemble options 
are set as follows:

Under When translating, use the following resources all available resources are activated:

Lexicon

Termbase

Translation Memory

Machine Translation

Assemble

And under Assemble options the following options are activated as well:

Use DeepMiner statistical extraction and
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Use Machine Translation

Déjà Vu X3 Workgroup would apply the following logic:

IF AN EXCACT TM MATCH IS FOUND, use that.

IF NO EXACT MATCH IS FOUND, look for a fuzzy TM match at or above the set 
fuzziness level (in this case 85%).

IF A FUZZY MATCH IS FOUND and the Repair fuzzy matches option is enabled, 
Déjà Vu X3 Workgroup will attempt to repair any fuzzy match. 

To be able to repair a fuzzy match, Déjà Vu X3 Workgroup has to be able to first 
identify the translated equivalent of the non-matching part of the segment. Once it 
is able to do that, it can attempt to replace it with a correct translation that it tries to 
locate in any of the standard resources (lexicon, termbase, translation memory) and, 
if enabled under Translation Memory options, statistical extraction from the TM 
(Use DeepMiner statistical extraction) and machine translation (Use Machine 
Translation).

IF NO FUZZY TM MATCH IS FOUND, use machine translation

8 IF MACHINE TRANSLATION IS NOT ACTIVATED, use all attached resources to assemble 
("piece together") a translation: resources project lexicon, termbases, the translation 
memories, statistically extracted phrases (DeepMiner), and -- if activated only under the 
Assemble options -- machine translation (in this order if the similarity and other properties are 
equal). For subsegments that are unknown the original source subsegment is inserted (if Insert 
source under Assemble option is enabled).

If Déjà Vu X3 Workgroup finds more than one match for any of the portions in the source, it 
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will fill in the match with the highest fuzziness rate and underline and color-code it. Right-
clicking that portion will display a context menu with the other possibilities.
 

You can choose to accept Déjà Vu X3 Workgroup’s choice or select one of the other choices 
by selecting it in the context menu.

LAUNCHING THE TRANSLATION PROCESS

Unlike with AutoTranslate (or the Assemble process during pretranslation, this process is started 
manually.

Déjà Vu X3 Workgroup’s Translate process can be used during pretranslation ("To pretranslate a 
project" on page 100), automatically while working on a project see "AutoTranslate" on page 105) 
or manually.

To manually launch Déjà Vu X3 Workgroup Translate process for a single segment

1 Select the segment for which you want to launch the Translate process.

2 On the Home ribbon tab, click Translate.

–Or–

Déjà Vu X3 Workgroup will also attempt to copy tags from the source to the target 
segment, particularly when it finds those at the beginning and/or end of the segment or 
around portions that it "knows" from any of the databases.
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Press Ctrl+T.

To manually launch Déjà Vu X3 Workgroup Translate process for a single segment without fuzzy 
match repair

1 Select the segment for which you want to launch the Translate process without fuzzy match 
repair.

2 On the Home ribbon tab, click Translate> Translate without Fuzzy Match Repair.

–Or–

Press Ctrl+Shift+Alt+T.

To manually launch Déjà Vu X3 Workgroup Assemble process for a single segment

1 Select the segment you want to assemble without first checking for an exact and/or 
guaranteed or fuzzy match in the TM or an MT suggestion.

2 On the Home ribbon tab, click Translate> Assemble from portions.

–Or–

Press Ctrl+Shift+A.

To quickly change the order of words

If a segment is assembled from a large number of portions, the word order may need to be 
changed. Déjà Vu X3 Workgroup offers several keyboard shortcuts to quickly change the word 
order.

1 Select the word or phrase that you would like to move to another position within the 
segment.

2 Press Ctrl+Shift+N to move the selected word or phrase forward one word at a time. 
Pressing Ctrl+Shift+N will continue to move the selected word or phrase forward.

–Or–

Press Ctrl+Shift+B to move the selected word or phrase one word backward. Pressing 
Ctrl+Shift+B again will continue to move the selected word or phrase backward.

THE DEEPMINER ENGINE

Déjà Vu X3 Workgroup’s DeepMiner engine allows you to unearth content from your translation 
memories that would otherwise be hidden. 
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A translation memory in its simplest form is nothing more than a collection of translated segments 
that occur most typically in sentence form. Some kinds of texts have a fairly high degree of 
repetition, including instructional text, legal boiler plates, and certain medical phrasing, but the 
repetition in the majority of texts does not happen on the sentence level. To get to that deeper 
kind of content, the DeepMiner engine processes the translation memories that are attached to a 
project to "discover" and present you with parts of segments that you can use for your translations.

How does it do that? In the simplest form: by using mathematical calculations!

The engine is able to isolate a certain phrase or word within a source segment if that word or 
phrase is also used in other segments.

There are various uses for this feature within Déjà Vu X3 Workgroup:

Repairing of fuzzy matches during translation or pretranslation

Assemble matches during translation or pretranslation

Extension of suggestion with the AutoWrite feature (see "AutoWrite" on page 174)

REPARING OF FUZZY MATCHES

This is our source document:

It’s not a very weighty text, but it has no repetition on a segment level, though it does contain 
repeated terminology (black, cat, brown).
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Since there is no content in our translation memory or termbase, we need to start translating from 
scratch. For the first few segments we might get some help from AutoWrite (see "AutoWrite" on 
page 174), but the translation memory does not bear much automated help:

However when we come to the last segment—which is a fuzzy match—we can see that the fuzzy 
match was automatically "corrected" and turned into an exact match (even though the status 
indicator to the left of the target segment still displays it as a fuzzy match):

What happened?
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Since both black and brown and their translations were repeated at least twice in the previous 
segments and then all sent to the translation memory, Déjà Vu X3 Workgroup’s DeepMiner engine 
was able to determine which term was to be deleted from the fuzzy match ("schwarz") and which 
term it should be replaced with ("braun"). While this might not sound special at first, think about it: 
only four segments ago, Déjà Vu X3 Workgroup "knew" nothing about the source and target 
languages; now it has "figured out" the translation of these two terms even though the user has 
never specifically entered that information (only indirectly as part of a segment).

In earlier versions of Déjà Vu, this self-repairing feature relied on what was entered into the 
termbases or lexicon; now the information is also generated from the translation memories.

ASSEMBLE AND THE DEEPMINER ENGINE

We can take the use of the DeepMiner engine one step further, though. Let’s imagine this 
document has an additional segment:
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We can see that there is no fuzzy match that can be "repaired," but by using the Assemble features 
(see "The "Translate" Process" on page 154) we can still getting to the content in the TM even 
though nothing is shown in the AutoSearch window ("ist braun" has been mined from the TM and 
"Her hair" has been taken over from the source):

 

To enable the assemble feature of the DeepMiner feature, see p. 164.
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To activate the DeepMiner engine for fuzzy match repair

1 Select File> Options> Translation.

2 Select Use DeepMiner statistical extraction under For fuzzy match repairs.

3 Click OK.

To activate the DeepMiner engine for fuzzy match repair during pretranslation

1 On the Project ribbon tab, click Pretranslate.

–Or–

Press Ctrl+P.

2 The Pretranslate dialog appears.

3 Unselect Accept only exact matches. 
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4 Select Use DeepMiner statistical extraction.

5 Click OK. 

To activate the DeepMiner engine for assembling matches

1 Select File> Options> Translation.

2 Select Use DeepMiner statistical extraction under Assemble options. 
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3 Click OK.

To activate the DeepMiner engine for assemble during pretranslation

1 On the Project ribbon tab, click Pretranslate.

–Or–

Press Ctrl+P.

2 The Pretranslate dialog appears.

3 Unselect Accept only exact matches. 

4 Select Assemble from portions> Use DeepMiner statistical extraction.

5 Click OK.

MACHINE TRANSLATION

The demand for a machine translation feature within Déjà Vu X3 Workgroup has risen significantly. 
At the same time, the availability and quality of machine translation output has increased. In fact, 
some professional translators find it helpful for some language combinations and subject matters to 
use MT for as a first gist translation that is then post edited. 
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Also, due to some of Déjà Vu X3 Workgroup’s unique features, such as assemble and fuzzy match 
repair, there are particular usage cases for machine translation in Déjà Vu X3 Workgroup that 
might make its use a real productivity gain.

There are four different usage cases for machine translation in Déjà Vu X3 Workgroup:

Machine translation of individual segments

Machine translation to repair fuzzy matches

Machine translation as part of the assemble process

Machine translation as part of the AutoWrite process (see p. 174)

MACHINE TRANSLATION ENGINES IN DÉJÀ VU X3 WORKGROUP

At this time there are seven preconfigured connections to machine translation engines available in 
Déjà Vu X3 Workgroup. These include the following engines:

Google Translate

Microsoft Bing Translator

iTranslate4.eu

MyMemory

SYSTRAN Enterprise Server

PROMT Translation Server

Asia Online Language Studio 

Independent of the machine translation engine you might want to use, please 
remember that results vary greatly according to language combination. While some 
language combination might have some usefulness, others will not.

Also, you also need to be aware that some clients might not permit the use of online-based 
machine translation engines because of the potential security risk: every text segment that is sent to 
these engines stays in their possession.
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You can view the different engines and enter their respective access codes under File> Options> 
Machine Translation.

For the last three of these engines (SYSTRAN, PROMT and Asia Online), you will need an access 
code to a private server. Once you receive that access code, you can enter it by pressing the 
respective options button.

The first four engines are publicly available but still require an access code. Here are some links to 
generate these codes:

Google Translate: https://cloud.google.com/translate/v2/getting_started

Microsoft Bing Translator: http://blogs.msdn.com/b/translation/p/gettingstarted1.aspx

iTranslate4.eu: http://itranslate4.eu/en/api/settings

MyMemory: http://mymemory.translated.net/doc/keygen.php

Google Translate in its present form supports more than 90 languages, and through the 
use of "bridge languages" more than 8,000 language pairs, and Bing Translator supports 
47 languages and more than 2,000 language combinations. These two are statistical MT 
engines.

iTranslate4.eu is a consortium of different rules-based machine translation vendors, including 
MorphoLogic, SYSTRAN, Linguatec, pwn.pl, SkyCode, Amebis, Sunda Systems Oy, PROMT and 
Trident MT. The system supports a total of 61 languages.

MyMemory is a mixture of a large collection of translation memories and MT via Google Translate, 
Microsoft Translator, a customized Moses engine and SYSTRAN.
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To activate machine translation engines for a translation project

1 You can select the machine translation engines for a project in the Create a New Project 
wizard while you create a project (see p. 166)

–Or–

You can select machine translation engines after the creation of a project by selecting 
Project> Properties> Machine Translation.

2 Click Add.
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3  Select as many of the desired MT engines as you would like and enter the respective keys 
(you will only have to do that the first time unless you need to change the keys).

4  Click OK.

5 All the selected MT engines are listed in the dialog.
 

6 Select OK and/or Apply.

To automatically translate individual segments with the help of machine translation

1 To have machine translation be considered as one of—or the only—linguistic resource during 
translation, select File> Options> Translation.

The order in which they are listed corresponds to the order of their use. You can 
change that by using the green up and down arrows to the right of the list.
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2 Select Machine Translation under Translation options.

3 According to your other settings, suggestions from your connected machine translation engine 
will now appear in the AutoSearch window and/or be entered as the translation in your 
current project.

To manually translate individual segments with the help of machine translation

1 While you are in the segment you want to machine translate, press Ctrl+G

- Or -

Select MT on the Home ribbon tab.

2 The machine translation is entered into the target segment and the status indicator changes to 
auburn.

This option overwrites any other possible translations or fragments you might gain from 
your own databases, so make sure to use this option only if you know that you will 
benefit more from the machine-translated content than from your own materials.
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To activate machine translation for fuzzy match repair

The fuzzy match repair feature allows you to fill in parts of a segment that cannot be translated by 
your own resources (translation memory, termbase, lexicon) with the help of machine translation.

1 To activate, select File> Options> Translation.

2 Select Use Machine Translation under For fuzzy match repairs.

3 Click OK.

To activate machine translation for fuzzy match repair during pretranslation

1 On the Project ribbon tab, click Pretranslate.

–Or–

Press Ctrl+P.

2 The Pretranslate dialog appears.

In any of the fuzzy repair options, you also have the opportunity to activate the 
DeepMiner engine. If there are DeepMiner results available, they will always take 
preference over the machine translation results.

If you also check the DeepMiner engine in this dialog, it will take preference over the 
machine translation function if there are DeepMiner results available.
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3 Unselect Accept only exact matches. 

4 Select Use Machine Translation.

5 Click OK. 

To activate machine translation for assembling matches

1 Select File> Options> Translation.

2 Select Use Machine Translation under For portions not found in databases. 
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3 Click OK.

To activate machine translation for assemble during pretranslation

1 On the Project ribbon tab, click Pretranslate.

–Or–

Press Ctrl+P.

2 The Pretranslate dialog appears.

3 Unselect Accept only exact matches. 

4 Select Assemble from Portions> Use Machine Translation.

5 Click OK.

You can also use machine translation as the primary translate option. To do that, select 
Machine Translation under Translation options and disable all other options in that 
section.

You can also use machine translation as a primary translate option. To do that, select 
Use Machine Translation for whole segments.
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AUTOWRITE

Déjà Vu X3 Workgroup’s AutoWrite feature serves two purposes: as a productivity boost and as a 
feature to increase consistency within your translation. 

Much like the AutoComplete feature from Microsoft Excel or the address bar of your browser, 
AutoWrite predicts the text you are entering based on the first couple of keystrokes. The difference 
is that it does not just base the prediction on the current project but on the associated translation 
memories, termbases, the lexicon and machine translation suggestions.

In suggesting the list of AutoWrite suggestions, Déjà Vu X3 Workgroup looks at the following 
criteria and accordingly gives them a preferential treatment:

occurrence in the current project

similarity of subject

client match

occurrence in a database (preferred order: lexicon, termbase, translation memory, 
machine translation)

age of record

DeepMiner results 
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The suggestions will come up right underneath your cursor as you type. You can select them by 
going down the list with the down-arrow key or with the mouse and enter them by pressing the 
Enter button.

If none of the suggestions is helpful, or if you decide that it’s faster to type rather than enter any of 
the suggestions, you can keep on typing. The AutoWrite suggestion will continue to change and be 
further filtered down with every additional keystroke you make:
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If you have the DeepMiner engine enabled, you will receive a greater number of suggestions 
based on the parameters with which it extracts additional and deeper lying data from the 
translation memories.

To enable AutoWrite

1 Select File> Options> General> AutoWrite.

- Or -

2 Click the AutoWrite button  in the status bar. 

To use AutoWrite with machine translation

Déjà Vu X3 Workgroup’s AutoWrite feature in combination with suggestions from machine 
translation engines offers a powerful option to work with machine translation and an alternative to 
the sometimes frustrating post-editing of machine translation. Rather than presenting your with 
one MT suggestion that you can edited, you can attach as many MT engines as you want and as 
are applicable. Déjà Vu X3 Workgroup will query them subsegment by subsegment for suggestions 
presented in the AutoWrite window. If those suggestions are not applicable, you can continue to 
type and new suggestions based on your keystrokes will be suggested if they are contained in the 
MT suggestions.
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In the following example, two different MT engines are assigned to the project and the AutoWrite 
suggestions are all derived from those suggestions. They are easy to ignore but can be very helpful 
if they match the translator’s intention.

SENDING TEXT TO THE DATABASES

SENDING INFORMATION TO THE TRANSLATION MEMORY

If you send information to the translation memory(s), your records not only contain source and 
target text, but also a date/time stamp, subject and client (if enabled), and user name, as well as 
various other project-specific data.

There are several options for sending records to the translation memory within Déjà Vu X3 
Workgroup:

By default, Déjà Vu X3 Workgroup will only store unique segment pairs in the 
translation memory to allow for a smaller size of the translation memory. However, if 
you would like to use the Guaranteed Match feature (see p. 102), you have to make 
sure that every string from every project is stored in the translation memory to allow 

Déjà Vu X3 Workgroup to recognize the necessary context. You can do this by selecting File> 
Options> General> Translation> Store segment context information to enable Guaranteed 
Matches.
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automatically during the translation with the AutoSend option (see "AutoSend" on page 
110) or

manually for every single segment or in a batch process.

MANUALLY SENDING SEGMENT PAIRS TO THE TRANSLATION MEMORY

To send a segment pair to the translation memory

After you have translated and/or edited a segment in Déjà Vu X3 Workgroup, click Add to TM 
on the Home ribbon tab.

–Or–

Each translation memory that you have associated with your project during the project 
creation or at a later point (see Project> Properties> Translation Memories) has a read 
or write attributes or both. Translation memories with a read attribute will be used to 
retrieve data; those with a write attribute will have data written to them. This means 

that you can write to several translation memories at the same time, thus allowing you, for instance, 
to have a copy of a large translation memory on your local computer that you read and write from 
and the original translation memory on a network server. You can choose to only write to the 
network translation memory but not read from it, which would avoid increased network traffic and 
could have a significant impact on processing speed.
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Press F12.

To send only a portion of the segment pair to the translation memory

1 Select the portion of the source segment and the portion of the target segment that you want 
to send to the translation memory.

2 Click Add to TM on the Home ribbon tab. 

–Or–

Press F12.

To send the whole project to the translation memory

1 On the Project ribbon tab, click Add to Translation Memory.

–Or–

Press Alt+F12.

2 The Send Project to Translation Memory dialog appears, offering you the following options:

If you send a segment pair to the translation memory multiple times, earlier instances of 
that specific segment pair will be overwritten. If you prefer to have two different 
translations in your translation memory instead of only the most current one, you can 
highlight the source and target segment and then send it. That way it will not overwrite 

earlier entries.
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Select whether you want to send the currently selected language or all the target 
languages for the project.

Select wether you want to send just the currently opened or all files in the project.

Select whether you want to select a certain section of the project to send to the 
translation memory (Limit to current view). For more information on how to select a 
certain subset of rows, see "Selecting Segments" on page 63.

Select whether you want to send any segment with a status other than the default 
options Confirmed Segments or Unmarked Manual Translation.

Delete all pairs previously sent from this project deletes everything in the translation 
memory that has been sent from the current project at an earlier time. You will not need 
to use this option if you just resend your project to the translation memory as all updated 
lines will overwrite earlier instances by default.

3 Click OK.

To prevent a segment from being sent to the translation memory

1 If you would like to single out certain rows (for instance, rows that contain code information) 
that you do not want to be sent to your translation memory, you can right-click the segment 
or the selection of segments you do not want in the translation memory and click Segment 
Status> Do Not Send.

–Or–

Press Ctrl+Shift+D.

2 The Do Not Send symbol ( ) appears in the target cell.

To remove the Do Not Send status

1 Select the segment you want to mark as normal.

2 Right-click the segment and click Segment Status> Do Not Send.

If you send a project/file to the translation memory, earlier instances of the segment 
pairs within that project/file you have already sent will be overwritten. Déjà Vu X3 
Workgroup is able to recognize earlier instances by assigning unique project, file, and 
segment IDs to each segment pair in the translation memory. If a file within a project is 

deleted and a new file is imported, the same project, file, and segment IDs could be assigned to 
the new file, resulting in the deletion of anything sent from the earlier file to the associated 
translation memory. To avoid this, you should create new projects for your newly translatable files.
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–Or–

Press Ctrl+Shift+D.

3 The  symbol disappears.

SENDING INFORMATION TO THE TERMBASE

For more information on sending terms to the termbase, see "Adding Terms to the Termbase" on 
page 112.

SENDING INFORMATION TO THE LEXICON

For more information on sending terms to the lexicon, see "To manually add entries to the lexicon" 
on page 427.

LOCKING SEGMENTS

It is possible to lock rows in the project so that you cannot accidentally change their target text.

To lock a group of segments

1 Select the segment(s) you want to lock.

2 Right-click the selection and select Segment Status> Locked ( ).

–Or–

Press Ctrl+Shift+K.

To unlock a group of segments

1 Select the segment(s) you want to unlock.

2 Right-click the selection and remove the checkmark from Segment Status> Locked ( ) by 
clicking on it.

–Or–

Press Ctrl+Shift+K.

For information on how to select rows, see "Selecting Segments in the Selection Mode" 
on page 63.
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Target text in locked rows is protected against any modification.

MODIFYING AND DELETING DATABASE RECORDS IN THE AUTOSEARCH WIN-
DOW

The primary use of the AutoSearch window is to give you a view of and easy access to the relevant 
contents of your databases (see "The AutoSearch Window" on page 37). However, as you view 
your database records you will often notice mistakes that need to be corrected or records that 
need to be deleted altogether.

To modify database records in the AutoSearch window

1 Select the record in the AutoSearch window that needs to be modified and switch into edit 
mode by pressing the Enter key.

2 Make the necessary modifications.

3 Leave the edit mode by hitting the Esc key.

To delete database records in the AutoSearch window

1 Select the record in the AutoSearch window that needs to be deleted.

2 Press the Delete key.

–Or–

Click Delete on the Home ribbon tab.

–Or–

Right-click on the record and select Delete. 

This feature should be used by project coordinators who need to lock target text before 
letting the translators begin to work with the project.

This feature can also be very helpful if you want to exclude a certain subset of rows for 
your view. You can lock these rows and then select All Except Locked Segments in the Segment 
Selector (see "The Segment Selector" on page 43).
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CLIENTS AND SUBJECTS

Déjà Vu X3 Workgroup has several ways to add additional information to the source and target 
segments in the termbase and translation memory. While some of that additional information is 
completely configurable for the termbases (see "Templates" on page 491), there is only a limited 
and pre-defined number of fields that can be added to the translation memories.

These include:

User—the name or nickname of the user who entered that record into the translation 
memory.

Date/Time stamp—the date and time the record was entered into the translation 
memory or termbase.

Project ID—the preassigned 7-digit project ID of every project file that accompanies 
every record that is entered from that project into the translation memory.

File ID—the name of the file that the translation originated from.

Subject—the user-assigned subject, or topic, of a record. This can be entered into the 
translation memories and termbases through the subject of a current project or manually.

Client—the user-assigned client of a record. This can be entered into the translation 
memories and termbases through the client of a current project or manually.

This additional information provides you with helpful data about each of these records when they 
are displayed in any of the database views, it allows you to specify subsets of your databases for 
exporting purposes, and it allows Déjà Vu X3 Workgroup to make choices when determining what 
match to use in any of its automated translation processes.

First and foremost, Déjà Vu X3 Workgroup will use similarity, or the degree of fuzziness, to decide 
which match to choose over another. However, with large databases, Déjà Vu X3 Workgroup will 
often encounter situations where there are two or more different exact matches or matches of the 
same fuzziness. In these situations, the program will use sophisticated algorithms to decide which 
of these matches to choose.

The hierarchy in which Déjà Vu X3 Workgroup will decide on the match is as follows:

1 fuzziness

2 target sub-language (see p. 83)

3 client

4 subject
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5 source sub-language (see p. 83)

6 case similarity (Atril vs. atril vs. ATRIL)

7 age 

The logic follows an exclusionary scheme: If the fuzziness of one match is of a higher percentage 
than that of another, the more identical match will be preferred, regardless of any other setting. If 
the match quality of the two matches is identical, and one has the same target sub-language as the 
source segment but the other has a differing sub-language (French () vs. French (Belgian), for 
instance), the one with identical target sub-languages would be preferred, regardless of any other 
setting, and so on.

STORING THE CLIENT AND SUBJECT SETTINGS

The client and subject settings, along with settings for AutoText, AutoCorrect, and segment 
delimitation (see p. 221, p. 224, and p. 217), are automatically stored in the settings.dvset file. In 
the default setting, this file is located in the Déjà Vu X3 Workgroup installation folder (on an 
English Windows system typically at C:\ProgramData\ATRIL\Déjà Vu X3). 

Regardless of Déjà Vu X3 Workgroup’s choice for a match, the other matches are 
always available in case you want to override Déjà Vu X3 Workgroup’s decision.

If you can’t view this folder you will need to unhide it by opening Folder Options in the 
Windows Control Panel and selecting View> Show hidden files, folders, and drives
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If you work with other users over a network on the same file and/or databases, you should save 
this file to an accessible point on the network and have the different Déjà Vu X3 Workgroup 
installations access that file by selecting File> Options> General.

Under Shared data location, you can see where the file is currently stored. If you choose to store it 
elsewhere, you can manually copy the Settings.dvset file to the new location and redirect Déjà Vu 
X3 Workgroup by clicking Modify and selecting the new path.
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WORKING WITH CLIENTS

Under File> Options> Clients, you will see an empty list of clients.

You can assign clients directly to database records during import and align processes or to 
individual records in the termbase or translation memory view, but most commonly you assign 
them to records through your project files. Every language pair record that you send to the 
databases from your project will by default have the client that you assigned in the project.

To assign clients to a project file and to add a client

1 If you have not assigned a client during the project creation process (see p. 85) or you want to 
change an already assigned client, Project> Properties> General.

–Or–

Right-click the project icon in the Project Explorer and select Properties.

–Or–

Press Alt+F7.
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2 The General tab of the Project Properties dialog appears.

You can see that the project name (the name of the project file), the Type of Project (whether 
it is a normal or a satellite project), and the Project ID are automatically filled in. You will have 
to select Client and Subject.

3 Since so far there are no clients created, select Add/Remove underneath Client.

If there would be existing clients, you would select them by clicking the down arrow in 
the Client line and selecting a client out of the list of existing clients.
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4 The Clients tab within the Options dialog opens.

5 Enter a code (which can be or does not have to be numerical) and the client’s name and click 
Add.
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6 Click OK and you are returned to the Project Properties dialog where you can now select the 
client.

To synchronize clients with TEAMServer

Synchronizing with TEAMserver (in either direction) will add new clients to the existing list of 
clients or update existing ones, but it won’t delete anything. The feature is particularly for a project 
manager to add a new client on his machine, update the TEAMserver list by synchronizing it (i.e. 
uploading it) and then have the rest of the team members update their local lists by synchronizing 
as well (i.e., downloading it).

To synchronize by uploading to TEAMServer, click Upload under Project> Properties> 
General> Client> Add/Remove (Or: File> Options> Clients)

To synchronize by downloading from TEAMServer, click Download under Project> 
Properties> General> Client> Add/Remove (Or: File> Options> Clients)
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To modify clients in the list of clients

1 Select File> Options> Clients and highlight the record that you want to modify.

2 Change the name in the Name field.

3 Click the Replace button which is now activated.
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4 The changed client now appears in the list.

5 Click OK.

To delete clients from the list of clients

1 Highlight the record that you want to delete.

2 Click Delete.

3 The record is deleted from the list.

4 Click OK.

To find a client in the list of clients

1 Enter any digit that is contained in the code or any character that is contained in the client 
name into the Filter field.
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2 The records that match the find sequence are displayed

You can use wildcards when looking for clients (for more information on wildcards, see 
"To scan with wildcards" on page 149).

Managing Clients—Tips and Tricks

The most important rule about clients is to apply them to every translation project and each other 
entry in the databases.

If you work within a large organization, instead of "company clients" it may make sense for you to 
use "department clients," or any other category that makes sense for your particular situation.

If you work as a freelancer, you should always use the end client (i.e., the company that the 
translation is actually produced for), even if that differs from the organization that you are directly 
performing your services for (a translation vendor, for instance). If you are performing legal, 
medical, and technical translations for one translation vendor, the client field becomes useless and 
potentially distorting if you use the name of the translation vendor rather than the end client’s 
name.
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WORKING WITH SUBJECTS

Under File> Options> Subjects, you will see that each of the listed subjects is associated with a 
numeric code. These codes are organized in a hierarchical structure of main topics and subtopics.

The code 6, for instance, is the code for Applied sciences. Medicine. Technology, of which 61, 
Medical sciences, is a subcategory, of which 611, Anatomy. Human and comparative anatomy, is 
yet another subcategory.

Déjà Vu X3 Workgroup’s matching algorithms would recognize that a record with the associated 
code 611 is closer to the code 61 (of which it is a subcategory) than for instance to 62 (of which it 
is not a subcategory) or even to 6 (of which it is only a subcategory of a subcategory). 611 is more 
closely related to 61, 62, or 6 than, for instance, to 7 (The Arts). 

You can also assign non-numeric codes to subjects, but this will result in the loss of the 
hierarchical structure.

The preset subjects and clients that come with Déjà Vu X3 Workgroup represent the 
UDC list. UDC stands for "Universal Decimal Classifications" and is the most commonly used 
bibliographic system. For more information about UDC, see www.udcc.org.

This means that the more sophisticated your system of classification is, the more precise 
the matches will be that Déjà Vu X3 Workgroup will be using.
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You can assign subjects directly to database records during import and align processes or to 
individual records in the termbase or translation memory view, but most commonly you assign 
them to records through your project files. Every language pair record that you send to the 
databases from your project will by default have the subject that you assigned in the project.

To assign subjects to a project file

1 In the open project file, select Project> Properties> General.

–Or–

Right-click the project icon in the Project Explorer and select Properties.

2 The General tab of the Project Properties dialog appears.

You can see that the project name (the name of the project file), the Type of Project (whether 
it is a normal or a satellite project), and the Project ID are automatically filled in. You will have 
to select Client and Subject.

3 Click the down arrow in the Subject line.
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4 The list of subjects opens.

5 Select the subject of your project and do the same with the Client field.

6 Click OK.

To add subjects to the list of subjects

1 Enter a new code into the Code field.

2 Enter a description into the Description field.
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3 Click the Add button which is now activated.

4 The new category, in this case a subcategory to 611, Anatomy, has been added to the list.

5 Click OK.

To synchronize subjects with TEAMServer

Synchronizing with TEAMserver (in either direction) will add new subjects to the existing list of 
subjects or update existing ones, but it won’t delete anything. The feature is particularly for a 
project manager to add a new subject on his machine, update the TEAMserver list by 
synchronizing it (i.e., uploading it) and then have the rest of the team members update their local 
lists by synchronizing as well (i.e., downloading it).

To synchronize by uploading to TEAMServer, click Upload under Project> Properties> 
General> Subject> Add/Remove (Or: File> Options> Subjects)

To synchronize by downloading from TEAMServer, click Download under Project> 
Properties> General> Subject> Add/Remove (Or: File> Options> Subjects)

To modify subjects in the list of subjects

1 Highlight the record that you want to modify.
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2 Change the description in the Description field.

3 Click the Replace button which is now activated.

4 The changed category now appears in the list.

5 Click OK.
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To delete subjects from the list of subjects

1 Highlight the record that you want to delete.

2 Click Delete.

3 The record is deleted from the list.

4 Click OK.

To find a subject in the list of subjects

1 Enter any digit that is contained in the code or any character that is contained in the subject 
description into the Filter field.

2 The records that match the find sequence are displayed

You can use wildcards when looking for subjects (for more information on wildcards, 
see "To scan with wildcards" on page 149).
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PROPAGATE

Once you have translated a segment, you can apply this translation to the same or similar 
segments within Déjà Vu X3 Workgroup. This process is called Propagation.

When searching for cells to propagate to, Déjà Vu X3 Workgroup only looks for linguistic matches 
and assumes that digits and tags are not to be changed between source and target languages. This 
means that the samples in the following screenshot are all considered to be exact matches, even 
though the number and codes differ from each other. 

There are several ways to propagate a segment with Déjà Vu X3 Workgroup:

AutoPropagate allows you to automatically propagate your segments throughout your 
current project.

The manual propagate option allows you to either propagate in your current file or 
throughout the project.

Managing Subjects—Tips and Tricks

The most important rule about subjects is to apply them to every translation project and each other 
entry in the databases.

The next most important consideration is how to set them up. Essentially, there are two ways to do 
that. You can use the existing list of subjects and either try to find subjects that are relevant to your 
projects or set them up within the preassigned order, or delete the list of subjects and build your 
own list with its own hierarchical structure from scratch.

While the second option may give you more flexibility in defining your choices (if, for instance, you 
only work with legal translation and you would like to fine-tune the whole range of subject codes 
to legal topics), only the first option allows you to effectively exchange Déjà Vu databases with 
other translators without having to redefine their structure.

No matter which way you choose to go, you should take your time to define (or fit) your subject 
structure as thoroughly as you can. Many translators find it helpful to do this planning on a piece of 
paper and then later transfer it into Déjà Vu X3 Workgroup.
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The overwrite option (see "To force propagate a translation" on page 201) allows you to 
overwrite any existing translation, regardless of its status.

There are differences between these three options in terms of how segments are overwritten:

AutoPropagate overwrites any empty segment, fuzzy match or assembled segment but 
does not do any fuzzy propagation.

Manual propagate overwrites any empty segment, fuzzy match or assembled segment 
and prompts for confirmation when it finds a fuzzy match.

The overwrite option overwrites anything, including exact and guaranteed matches and 
unmarked empty rows (i.e., manually translated rows), except finished and locked rows.

AUTOPROPAGATE

By activating AutoPropagate, you instruct Déjà Vu X3 Workgroup to automatically insert the 
translation you have just entered in the current segment into all targets where the sources are 
identical.

To activate AutoPropagate

1 Under File> Options> General, click AutoPropagate.

-Or-

Click  on Déjà Vu X3 Workgroup’s status bar.

2 The next time you jump from one segment to the next by pressing Ctrl+DownArrow or 
Ctrl+Enter (or to the next translatable segment by jumping Alt+DownArrow or Alt+Enter), 
Déjà Vu X3 Workgroup will automatically propagate the current segment into all other 
identical segments for you.

3 You can recognize autopropagated segments by their status indicator. The default color is light 
blue.

The advantage of AutoPropagate is that you don’t have to do anything but activate the option—
Déjà Vu X3 Workgroup does the rest for you. Because it does not ask for any user intervention, it 
would never propagate anything to a fuzzy match segment, i.e., a segment that is not completely 
identical. To do this you will have to use the manual propagation procedures.

Make sure that you review all AutoPropagated segments. Even though one segment 
may be identical to another, the context may require a completely different translation. 
If your text tends to have the same segment appear in different contexts, it may not 
always be an appropriate choice to activate AutoPropagate.
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When manually propagating a translation there are two different modes of propagation. 
"Propagation" only looks for empty target segments, where as "Force Propagation" looks for 
segments that are either empty or have already been translated (but don’t have the statuses 
Translated, Confirmed or Proofread).

To manually propagate a translation

1 Select the segment with the translation you want to propagate to empty segments.

2 On the Home ribbon tab, click Propagate (or: Propagate> Propagate to All Files if this is 
supposed to be propagated throughout the project).

–Or–

Press F9 (or: Alt+F9 if this is supposed to be propagated throughout the project).

3 After propagating to identical source rows, Déjà Vu X3 Workgroup will look for rows where 
the source text is only similar to the one being propagated. If any such rows are found, Déjà 
Vu X3 Workgroup will display the segment in question and the fuzzy match in the Confirm 
Fuzzy Propagation dialog.

4 Make any corrections in the Confirm Fuzzy Propagation dialog.

5 Click Yes, and the match will be inserted into the target segment.

To force propagate a translation

1 Select the segment with the translation you want to propagate to segments that are either 
empty or have already been translated (but don’t have the statuses Translated, Confirmed or 
Proofread).

You can see that Déjà Vu X3 Workgroup automatically placed the corrected tags into 
the target and gave that segment a different status indicator.
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2 On the Home ribbon tab, click Propagate> Force Propagate (or: Propagate> Force 
Propagate to All Files if this is supposed to be propagated throughout the project).

–Or–

Press Shift+F9 (or: Shift+Alt+F9 if this is supposed to be propagated throughout the project).

3 After propagating to identical source rows, Déjà Vu X3 Workgroup will look for rows where 
the source text is only similar to the one being propagated. If any such rows are found, Déjà 
Vu X3 Workgroup will display the segment in question and the fuzzy match in the Confirm 
Fuzzy Propagation dialog. For more information on this, see the description under "To 
manually propagate a translation" on page 201.

PSEUDOTRANSLATION

Pseudotranslation is a rather specialized process in which a "dummy" translation with target-
language-specific characters is performed and the length of the target text is increased by about 
20% of the source.

There are two main uses for this feature:

You can export the "dummy" file to verify that the special characters of the target 
language can be displayed appropriately in the original file format.

You can export the "dummy" file to verify whether the usual text expansion can be 
accommodated in the resulting original format files (this is especially useful for software 
development files, such as .rc files).

The groups of supported languages for which codepage-specific characters are used include: 
Arabic, Armenian, Baltic, Bengali, Burmese, Central European, Chinese (Simplified), Chinese 
(Traditional), Cyrillic, Devanagari, Ethiopic, Georgian, Greek, Gujarati, Gurmukhi, Hebrew, 
Japanese, Kannada, Khmer, Korean, Lao, Malayalam, Mongolian, Oriya, Sinhala, Syriac, Tamil, 
Telugu, Thaana, Thai, Tibetan, Turkish, Vietnamese, and Western European.

Asian double-byte languages (Chinese, Japanese, Korean) are excluded from this text 
expansion because these languages usually do not experience text expansion in the 
process of translation. In these cases, Déjà Vu X3 Workgroup replaces each word (or 
double-byte character) with one double-byte character.

Some of these languages—for instance, Vietnamese and Thai—may not be supported 
on a non-native version of Windows 98 or ME.
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To translate a text with the pseudotranslate feature

1 Select Pseudotranslation on the Project ribbon tab.

2 The Pseudotranslate dialog appears.

3 Select whether you want to translate the current or all languages, the current or all files, 
whether you would like to limit the pseudotranslation to the current selection (if applicable), 
and where you would like the translation to start. Under Type you can select whether you 
would just like to have the source copied over to target or whether you would like to 
Generate random strings. By selecting the latter, you would get results like the following (from 
left to right: French, Greek, and Thai):

Though none of the "translations" makes any linguistic sense, they can now be used for 
functionality testing.
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TAGS

When you work with most file types other than plain text, Déjà Vu X3 Workgroup only displays 
translatable text—everything else is hidden. However, in formats such as HTML or FrameMaker 
formatting information is often embedded within a segment, such as a particular word in bold, 
cursive, or small caps. Since Déjà Vu X3 Workgroup cannot automatically decide which formatting 
belongs to which word, it leaves the decision on where to place this formatting information to the 
translator. These are "tags." If you have created a Déjà Vu X3 Workgroup project for, say, HTML, 
you will probably have noticed that many segments contain tags such as {142} or {835}.

Consider the following example:

You can see that the translator chose to place the tags in the target around the corresponding word 
in the translation. 

In most cases you don’t need to worry about what the tags really contain, but it’s clear that—
whatever effect they have—they must be placed before and after the word gewartet (the German 
translation of waited).

It is important for anyone working with Déjà Vu X3 Workgroup to understand what 
"tags" are (in prior versions of  Déjà Vu they were called "embedded codes" ). They are 
arguably one of Déjà Vu X3 Workgroup’s most powerful features because they protect 
the integrity of your documents and allow you to leverage your translation across many 

formats—to a much greater degree than most other CAT tools.
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Take a look at the original text:

You can see that each of the instances of "waited" was formatted differently. Not only did this not 
make a difference to Déjà Vu X3 Workgroup when it processed the document (or the translators as 
they translated the document), but as indicated by the light blue status indicator, Déjà Vu X3 
Workgroup even allowed the translator to only translate the first instance of that line and to 
propagate that translation to the other lines as exact matches (for more information on 
propagation, including why the numbers are automatically copied over, see "Propagate" on page 
199).

After the export of the translated document, all the formatting is retained at the appropriate 
positions:
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Though Déjà Vu X3 Workgroup stores the "meaning" of each tag within a project—so that the 
correct formatting can be applied when you export the document—it treats the tags as mere 
placeholders when it propagates them or when it stores them in the translation memories or 
termbases. The effect of this is that Déjà Vu X3 Workgroup can be used across all file formats and 
internal format differences. Not only does 

I waited for 8 hours 

represent an exact match to 

I waited for 16 hours

within MS Word, but also to 

I waited for 24 hours 

within an HTML or FrameMaker file.

TAGS AND THE MICROSOFT OFFICE (LIVE) FILTER

If an Microsoft Office file is imported with Microsoft Office (Live) filter (see p. 351), Déjà Vu X3 
Workgroup is able to display the most common formatting (bold, italics, underline, superscript and 
suprascript) in actual formatting rather than with the aid of tags. 

Take this particular MS Word file, for instance:
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Once imported into Déjà Vu X3 Workgroup, the content is displayed this way:

The bold and italic characters are displayed in their original formatting, whereas the colored 
formatting is displayed with tags, since this is not among the formatting that Déjà Vu X3 
Workgroup can display.

For matching or propagation purposes, the real-time formatted text is processed the same as text 
with tags, so that 

I waited for 16 hours.

is a match for

I waited for 24 hours.

as well as for 

I {17}waited{18} for 8 hours.

RELATIVE POSITIONING OF TAGS AROUND TEXT

It is important to maintain the order of the tags relative to each segment in the source because 
each tag in the Déjà Vu X3 Workgroup project stores specific formatting information.

Here are a few examples where this becomes relevant. Assume that

I waited for 8 hours

from an HTML file (in HTML code: I <b>waited<\b> for 8 hours) is displayed in Déjà Vu 
X3 Workgroup as:

I {446}waited{447} for 8 hours.

The placement of tags in the translation can only be like this:

Ich habe 8 Stunden {446}gewartet{447}.
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If the codes were reversed in the translation:

Ich habe 8 Stunden {447}gewartet{446}

the resulting text would be corrupted because the tag that determines the beginning of the bold 
formatting (in our HTML example: <b>) would be preceded by the tag that closes it (in our HTML 
example: <\b>), with the result that the rest of the document would be in bold.

RELATIVE POSITIONING OF TAGS IN SHIFTED SYNTAX

Another thing to consider is the placement of tags when the syntax of the target language requires 
a re-arrangement of codes. Assuming that

I waited for 8 hours

from an HTML file (in HTML code: I <b>waited<\b> for 8 <i>hours<\i>) is displayed 
in Déjà Vu X3 Workgroup as:

I {446}waited{447} for 8 {448}hours{449},

the placement of tags in the translation can only be like this:

Ich habe 8 {448}Stunden{449} {446}gewartet{447}.

If the tags were reversed in the translation:

Ich habe 8 {446}Stunden{447} {448}gewartet{449}.

the resulting text after the export would have a reversed formatting:

Ich habe 8 Stunden gewartet.

COPYING AND MOVING TAGS

When you are translating a segment that contains tags, you must make sure that the target segment 
contains the same tags, or Déjà Vu X3 Workgroup will not be able to export the project files 
properly. 

In fact, Déjà Vu X3 Workgroup has several measures implemented to guarantee that the tags are 
not overlooked or deleted.

It marks rows with a warning symbol ( ) where it finds a discrepancy in tags between 
source and target.

It allows you to jump to rows with inconsistencies in tags through the selection of 
Translation> Check Tags.
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–Or–

Pressing Ctrl+Shift+F8.

It write-protects tags in the target cells and marks them by painting them in a light gray.

It allows for several ways to quickly insert tags into the target.

It warns when exporting documents with tags.

To automatically copy the next tag

1 Right-click in the target cell on the position you want the next available tag to be copied to, 
and click Copy Next Tag.

–Or–

Press F8 (or Ctrl+D).

2 Déjà Vu X3 Workgroup will insert the first tag that is in the current source segment and not 
already in the target segment at the position of the cursor.

To automatically copy all tags

1 Right-click the target box, and click Copy All Tags.

–Or–

Select Copy All Tags  on the Home ribbon tag.

–Or–
Déjà Vu X3    209



210
Press Alt+F8.

2 Tags found in the current source segment will be inserted at the cursor position in the current 
target segment.

To automatically fix all tags

1 Select the segment for which you want to fix the tags and select Check Tags> Fix Tags on the 
Review ribbon menu.

–Or–

Press Ctrl+F8.

2 Tags found in the current source segment will be inserted at the end of the current target 
segment and the numbering of the tags will be changed to match the consecutive order.

To manually copy a tag from source to target

1 Double-click the desired tag in the source segment.

2 Drag the selected tag to the target box, hold down the Ctrl key (otherwise the tag will be 
moved rather than copied), and release the mouse button at the position where you want the 
tag to be inserted.

–Or–

Press Ctrl+C (or Ctrl+Ins) and position the cursor in the appropriate position in the target cell 
and press Ctrl+V (or Shift+Ins).

–Or–

You should only use this option when you prefer to first copy the tags and then type 
around them. Just copying the tags into the segment will disable the warning features in 
Déjà Vu X3 Workgroup, but it will not guarantee the correct placement of the tags and 
the subsequent export of the file.

You should only use this option when you prefer to first copy the tags and then type 
around them. Just copying the tags at the end of a segment will disable the warning 
features in Déjà Vu X3 Workgroup, but it will not guarantee the correct placement of 
the tags the subsequent export of the file.

You also should be wary of the automatic renumbering. Especially when you translate between 
languages with very different syntaxes, a non-consecutive numbering of tags is often the correct 
one (see "Relative Positioning of Tags in Shifted Syntax" on page 208.
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Right-click, select Copy, position the cursor in the appropriate position in the target cell, right-
click, and select Paste.

To move a tag in the target cell

1 Double-click the tag you want to move.

2 Use drag and drop to move the selected tag to the desired position.

DELETING TAGS

In some cases, you may want to temporarily delete the tags from the target segment.

To delete a single tag

1 Select the entire tag (double-clicking on a tag will select it).

2 Press Ctrl+X (or Shift+Del).

To delete all tags in a segment

1 Right-click the target text box to bring up the context menu, and click Clear All Formatting.

–Or–

Press Ctrl+Space.

MODIFYING TAGS

Tags protected in such a way that it is difficult to tamper with them. If you were to delete even only 
one, the export function might not be able to reconstruct a valid DTP file. It is possible, however, 
to modify the contents of a tag in a target segment.

To modify the contents of a tag

1 Right-click anywhere on the tag and select Display Tag Markup from the shortcut menu.

–Or–

Highlight the tag and press Shift+F6.
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2 The Inline Tag dialog appears with the tag being displayed.

3 Enter your changes in the target box.

4 Click Accept.

CONTEXT VIEW

n some cases, it is helpful to have a more thorough context view than Déjà Vu X3 Workgroup 
offers in its project view. For these cases, Déjà Vu X3 Workgroup offers you two different 
possibilities.

You should only change the contents of tags when absolutely necessary and when you 
are very familiar with the coding of the file format you are working in.
Déjà Vu X3    212



Translation Features in Déjà Vu X3 Workgroup—The Details
You can enable the Live Preview by selecting View> Preview (see p. 133) or you can select the 
See in Context view for individual segments.

To see text in context

1 Select the segment for which you would like to see the context.

2 Select Edit> See in Context.

–Or–

Press F6.

3 The Source Segment in Context dialog appears.

4 You can see the source segment of your current selection in red and the surrounding text and 
tag in black.

The context view is not the same as you would see in a particular viewer, such as 
Internet Explorer or Microsoft Word; instead it is the view of the underlying code, in 
this case HTML.

File formats for which this view is not available include Access and Trados RTF.
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CONVERSIONS

Whenever Déjà Vu X3 Workgroup inserts a match into a translation, it automatically performs 
certain conversions, including:

tags (see "Tags" on page 204).

acronyms—Déjà Vu X3 Workgroup will assume that any word of two or less characters is 
an acronym that does not need to be translated and will thus take it over from source to 
target. For double-byte languages, this feature will only work with one-character words.

numbers—the assumption is made that numbers will not be translated and will be taken 
over from the source to the target, regardless of what is found in the databases.

Other conversion features are not performed automatically but are dependent on your settings.

To control the conversion features

1 Select File> Options> Translation.

Under Automatic conversion options, you can enable the following conversion processes:

While the acronym and number conversions are extremely helpful features, it is wise to 
verify any of these conversions. Examples of where an automatic conversion may not 
be successful would include toll-free telephone numbers that are valid for the region of 
the source language but not for the region of the target language.
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Adapt leading/trailing punctuation—Enables Déjà Vu X3 Workgroup to 
automatically fill in symbols such as punctuation marks or spaces at the beginning or 
end of a segment. This is a helpful setting if the punctuation systems of your 
languages match each other. Between English and Japanese, for example, this would 
not be a very helpful setting.

Allow decimal conversion—If enabled, Déjà Vu X3 Workgroup will automatically 
convert numbers, such as 1,000,000.00 (American English) to 1.000.000,00 
(Spanish) to 1 000 000,00 (French).

Allow case conversion—If enabled, Déjà Vu X3 Workgroup will automatically 
convert the case of a word in the target to the case of the source. While this is a 
helpful setting between languages of a similar capitalization system, it would not be 
a helpful setting between English and German, for instance.

2 Make the desired settings and click OK.

COPYING AND POPULATE

Déjà Vu X3 Workgroup employs the standard Windows commands and paths to copy, cut, and 
paste text. You can copy, cut, and paste text by:

Selecting the text and pressing Ctrl+C (or Ctrl+Ins) for Copy, Ctrl+X (or Ctrl+Ins) for Cut, or 
Ctrl+V (or Shift+Ins) for Paste.

–Or–

Selecting the text and selecting Edit> Copy, Edit> Cut, or Edit> Paste.

–Or–

Selecting the text and clicking Copy, Cut, or Paste on the Home ribbon tab.

–Or–

Selecting the text and pressing the Ctrl key while dragging and dropping the text elsewhere.

However, there are a number of copy functions available that are specific to Déjà Vu X3 
Workgroup. These are called "Populate."
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POPULATING SINGLE SEGMENTS

To copy the current source to the current target

1 Select the segment you want.

2 Select Populate> Populate Current Segment on the Review ribbon tab.

–Or–

Press F5.

To insert the current target with the current source

1 Select the segment you want.

2 Select Populate> Populate Current Segment (Insert) on the Review ribbon tab.

–Or–

Press Ctrl+F5.

3 The source segment is inserted to the beginning of the existing target segment.

To populate all the target columns for the current target language

On the Insert menu, select Populate> Populate Current Language on the Review ribbon tab.

–Or–

Populating single segments can be especially helpful when you have a segment with a 
lot of untranslatable text, such as product names, proper names, addresses, or tags.

You can also copy the content of several rows into the target with this command by 
selecting the desired rows in the selection mode (see "Selecting Segments in the 
Selection Mode" on page 63).

You can also copy the content of several rows into the target with this command by 
selecting the desired rows in the selection mode (see "Selecting Segments in the 
Selection Mode" on page 63).
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Press Alt+F5.

SENTENCE SEGMENTATION

Sentence segmentation rules are the rules by which Déjà Vu X3 Workgroup determines how text 
in a specific language should be segmented. You can change or add the default segmentation rules 
so that it corresponds to your specific language and the style of the author of your source 
documents. The segmentation rules allow you to specify for each language what rules are to be 
used as well as the exceptions to these rules.

Déjà Vu X3 Workgroup’s default rules are the most common rules for most languages. It segments 
text when it sees one of the following punctuation marks:

period,

question mark,

explanation mark,

colon, or

semi-colon

followed by a white space. For periods, questions marks, and explanation marks, Déjà Vu X3 
Workgroup also defines that they may not be followed by a lower-case letter.

Though these are good rules, in many cases they may only provide a starting point for your 
particular segmentation rules. Examples include the following:

Certain frequently occurring abbreviations in your source language, such as "P.O. Box," 
would be considered to be splittable by these rules.

You can also populate all target languages in the project by pressing Ctrl+Alt+F5 or 
selecting Populate> Populate All Languages on the Review ribbon tab.

You should be careful with this option because it can be difficult to batch delete a 
certain subgroup of segments again. The possibilities that Déjà Vu X3 Workgroup readily offers are 
to delete all translations, all assembled translations, and all fuzzy match translations. 

One significant difference between populating only one segment and all the segments of a 
language is that only in the first option are the contents of the segment in question overwritten. In 
the second option, only the empty rows are filled in.
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Certain languages may make very heavy use of some punctuation marks, such as the 
semi-colon, which then should probably be deleted as a delimitation rule for that 
language.

Certain languages may not make use of any of these rules because they use a completely 
different set of punctuation marks. That would include languages such as Chinese and 
Japanese.

In these cases you will have to define new rules.

To modify sentence segmentation rules

1 Select File> Options> Segmentation.

2 The Segmentation tab is displayed with the source language of your current project.

3 In the left part of the tab you can see the Rules, and in the right part the Exceptions to the 
rules.

To define rules you can use any actual character plus these symbols:

Symbol Meaning

^w white space

^# a digit (1, 2, 3...)
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The character string .^w would thus mean a period followed by a white space, or e.g.,^w 
would mean (the abbreviation) "e.g.," followed by a white space.

4 Select the desired language

5 Type the desired character and symbols in the Before Split and After Split fields.

6 Once you have entered or modified your rule, click Add.

To remove a rule or exception

1 Click the desired row on the table to select it.

2 Click Delete.T

SPLITTING AND JOINING SEGMENTS

After importing, it is possible that you may find that a segment has been incorrectly split. Déjà Vu 
X3 Workgroup splits the source text into segments using the rules and exceptions you set for the 
project’s source language (see "Sentence Segmentation" on page 217). However, even with the 
most carefully built set of rules and exceptions, there may be errors in the way Déjà Vu X3 
Workgroup breaks text into sentences. The most common reasons for these errors are 

^$ a letter (upper-case, lower-case, or any case)

^a a lower-case letter

^A an upper-case letter

^? any character

^^ the caret character (^) itself

Tips and Tricks on Sentence Segmentation:

For languages that do not use any of the typical punctuation marks, such as Chinese, you can 
delete all the existing rules and add new rules by typing the appropriate characters and the symbols 
that Déjà Vu X3 Workgroup uses. For Chinese, for instance, you can add "º" to have Déjà Vu X3 
Workgroup split segments every time that character is used in the document. Because typically 
spaces are not used after that character (or any other punctuation mark in Chinese), you would not 
have to add "^w."

The sentence segmentation settings are stored in the settings.dvset file. For more information, see 
"Storing the Client and Subject Settings" on page 184.
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uncommon abbreviations that are not included in your list of exceptions (see "To modify 
sentence segmentation rules" on page 218), and 

incorrectly placed soft or hard returns added by the author for formatting purposes.

You can correct such errors by:

editing the source file.

adding a new exception rule and importing the file(s) again.

manually splitting a segment at a certain point.

manually joining two segments together.

To split a segment

1 Place the insertion caret to the position in the source segment where you want to split the 
segment.

2 Select Split Segment from the Home ribbon tab.

–Or–

Press Ctrl+Shift+J.

3 The segment should now be split.

To join two segments

1 Click the segment that you want to have joined with the next segment.

2 Select Join Segments from the Home ribbon tab.

–Or–

Press Ctrl+J.
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3 The segments are now joined.

AUTOTEXT

AutoText is comparable to the AutoText option of Microsoft Word. Its purpose is to save typing 
effort by expanding abbreviations into longer text (for instance, "DV" to "Déjà Vu").

To manually add new AutoText entries

1 Highlight the term that you would like to add as an AutoText entry.

2 Right-click on the selection and select Add Selection to AutoText from the context menu.

–Or–

Select Insert> AutoText> Save Selection to AutoText.

3 The Add AutoText entry dialog appears with your selection already displayed under Replace 
with.

Depending on what is between the segments in the source file, Déjà Vu X3 Workgroup 
may or may not add a tag. If the undesired split is due to an incorrectly set sentence 
delimitation rule, Déjà Vu X3 Workgroup will typically not add a tag. If it is because of 
an incorrectly set soft or hard return, Déjà Vu X3 Workgroup will place a tag between 

the segments.

In general, it is not possible to join segments in certain file formats, including Trados, ODBC, and 
Access.

You can also choose to send the complete target segment as an AutoText entry. To do 
that, you don’t have to select anything.
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4 Enter the shortened form under Token.

5 Select whether this is supposed to be valid for all projects (Global entry) or only for the 
current project.

6 Click OK.

To expand AutoText entries

1 Type the token you have defined on the AutoText tab into the target field of the appropriate 
language

2 Press Ctrl+Shift+F3.

3 The expanded form appears.

To delete or modify AutoText entries

1 Select File> Options> Proofing.

2 In the AutoCorrect options section select the AutoCorrect Options button.

3 The AutoCorrect Option dialog is opened.
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4 Select the AutoText tab.

5 If you need to delete an entry, select the entry and click Delete (which will be activated once 
you select an entry.)

–Or–

If you need to modify an AutoText entry make the necessary modifications under Replace 
with and click Replace (which will appear once you modify an entry.)

6 Click OK.
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To import AutoText entries from Microsoft Word

To start the import process from Microsoft Word, you will have to select Import from Word on the 
AutoText tab.

AUTOCORRECT

AutoCorrect is comparable to the AutoCorrect option of Microsoft Word. Its purpose is to correct 
common spelling mistakes (for instance, "segement" to "segment" or "Deja Vu" to "Déjà Vu") but you 
can also use it like AutoText to abbreviate often used words. Unlike AutoText though, it is an 
automated function that can either be enabled or disabled.

To manually add new AutoCorrect entries

1 Highlight the term that you would like to add as an AutoText entry.

2 Right-click on the selection and select Add Selection to AutoText from the context menu.

–Or–

Select Insert> AutoText> Save Selection to AutoCorrect.

3 The Add AutoCorrect entry dialog appears with your selection already displayed under 
Replace with.

You should only choose to import from Word if you already have a significant number 
of custom AutoText entries. Some of the predefined AutoText entries in Word are very 
specific to Microsoft Word and may not be too useful.

Note also that Word does not define language-specific AutoText entries, i.e., you should only 
import AutoText entries into the language in which you added most of your AutoText entries in 
Word, if applicable.
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4 Enter the often misspelled or shortened form under Token.

5 Select whether this is supposed to be valid for all projects (Global entry) or only for the 
current project.

6 Click OK.

To use AutoCorrect

1 Select File> Options> Proofing.

2 In the AutoCorrect options section select the AutoCorrect Options button.

3 The AutoCorrect Option dialog is opened with the open AutoCorrect tab.

4 Make sure that you activate AutoCorrect enabled.
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Every time you now enter a token—i.e., an incorrectly spelled form that you have defined on the 
AutoCorrect tab—into the target field of the appropriate language, and hit the space bar, the 
correct form will appear.

To delete or modify AutoCorrect entries

1 Select File> Options> Proofing.

2 In the AutoCorrect options section select the AutoCorrect Options button.

3 The AutoCorrect Option dialog is opened with the open AutoCorrect tab.

4 If you need to delete an entry, select the entry and click Delete (which will be activated once 
you select an entry.)

–Or–

If you need to modify an AutoCorrect entry make the necessary modifications under Replace 
with and click Replace (which will appear once you modify an entry.)
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5 Click OK.

To import AutoCorrect entries

To start the import process from Microsoft Word, you will have to select Import from Word on the 
AutoCorrect tab.

COMMON WINDOWS FUNCTIONS

CHARACTER MAP

You can press Ctrl+K or select Insert> Character Map to display the Windows Character Map—a 
convenient way to enter special characters that you cannot type with your keyboard or whose 
ANSI code you don’t remember.

To enter characters with the Windows Character Map

1 Select a font and the character you want to enter.

2 Click Select and Copy.

Note that Word defines language-specific AutoCorrect entries, i.e., it will only import 
AutoCorrect entries if Word actually contains an AutoCorrect list for that specific 
language.
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3 The character is now on your clipboard and you can paste it into any position within your 
open file by placing your cursor at the appropriate location and

pressing Ctrl+V (or Shift+Ins)

–Or–

selecting Home> Paste.

SEARCH AND REPLACE FEATURES

If you are looking for a specific term, you can use the standard Windows Find features to find it. If 
you want to replace the term, you can use the standard "search and replace" features to locate and 
replace it.

To use the Find feature

1 Select Editing> Find on the Home ribbon tab.

–Or–

Press Ctrl+F.

2 The Find dialog appears.

3 Select whether you want to search the Source Text or the Target Text and/or the Current File 
or All Files by checking the appropriate check boxes.

4 In the Find box, enter the text you want to search for.

5 If you want to only search for complete words, check Find whole word only. If this option is 
not selected, words that begin with the search text will also be found.

By default, the text that you last entered will be displayed. You can also use the 
dropdown list to select any text you searched for recently, or you can highlight the text 
you want to search for and then open the Find dialog.
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6 If you want to only search for words with capitalization identical to what you entered, check 
Match case.

7 Click Find Next.

8 The next segment that contains the search word will be selected.

9 To continue searching for that word, you can continually click Find Next.

–Or–

Close the Find dialog and press F3.

–Or–

Close the Find dialog and select Editing> Find Next on the Home ribbon.

10 The next segment that contains the search word will be selected.

To use the search and replace feature

1 Press Ctrl+H.

–Or–

Select Home> Editing> Replace.

–Or–

Within the Find dialog, click Replace.

2 The Replace dialog appears.

3 Select whether you want to replace text in the Source Text or the Target Text and/or the 
Current File or All Files by checking the appropriate check boxes.
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4 Enter the text you are looking for into the Find box and the text you want to replace it with 
into the Replace With field.

5 If you want to only replace complete words, check Find whole word only. If this option is not 
selected, words that begin with the search text will also be replaced.

6 If you want to only replace words with capitalization that is identical to what you entered, 
check Match case.

7 Click Find Next.

8 The next segment that contains the search word will be selected.

9 If you want to replace the word that has been found, click Replace. If you want to have all 
occurrences of this word replaced, click Replace All.

REDO AND UNDO FEATURES

Déjà Vu X3 Workgroup supports an unlimited number of redo and undo actions.

To undo an action

Press Ctrl+Z.

–Or–

Click  on the Quick Access Toolbar.

To redo an action

Press Ctrl+Y.

–Or–

Click  on the Quick Access Toolbar.

SAVING THE PROJECT

One of the great benefits of working in a database environment is that the database saves itself 
automatically when a new cell is selected or the database is closed. Because even the Déjà Vu 
project file is a database, there is no need to ever save your project! 

By default, the text that you last entered will be displayed. You can also use the 
dropdown lists to select any text you searched for and replaced recently, or you can 
highlight the text you want to search for and then open the Replace dialog.
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CHANGE CASE

You can either change the case (capitalization) of a certain selection within a target segment or for 
the content of a whole target segment.

To execute a basic change of the case for a selection

1 Select the text whose case you want to have changed.

2 Press Shift+F3.

3 The case will change in the following cycle:

first letter uppercase, the rest lowercase

all lowercase

all uppercase

To execute an advanced change of the case for a selection

1 Select the text whose case you want to have changed.

2 Click on  on the Home ribbon bar. 

3 You can see a menu of various change case options:

Sentence case.—Capitalizes the first letter of the selection.

lowercase—Turns all letters of the selection lower case.

UPPERCASE—Turns all letters of the selection upper case.

Capitalize Each Word—Capitalizes each word in the selection.

tOGGLE cASE—Inverts the case of each individual letter.
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4 Select the appropriate option.

The change of case does not affect numbers and symbols. On a U.S. English keyboard 
layout, for instance, a single quote (’) will not change to a double quote (").
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EDITING FEATURES IN DÉJÀ VU X3 WORKGROUP—THE DETAILS

Déjà Vu X3 Workgroup includes a multitude of editing and quality assurance features, most of 
which are described in the workflow chapters (see p. 75). These include:

Terminological consistency check

Numeral consistency check

Tags check

Missing spaces check

Spell check

You can find information on all of these features under p. 114.

Below you will find an in-depth description of the customization of the spelling module of Déjà Vu 
X3 Workgroup.

SPELLING OPTIONS

There are several spelling options in Déjà Vu X3 Workgroup. 

To access the spelling options

1 Select Review> Spelling and click on Options in the Check Spelling dialog.

–Or–

Press F7 and click on Options in the Check Spelling dialog.

–Or–

Select File> Options> Proofing.
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2 The Proofing tab in the Options dialog is displayed.

Going from top to bottom, you will find the following options:

AutoCorrect options—See p. 224.

When checking spelling in Déjà Vu X3—You can choose between the integrated spell 
checker (which offers more than 40 languages preinstalled and a total of 120 
languages—see page p. 127) and the Microsoft Office spell checker (provided that you 
have Microsoft Office installed.

Reload Office Proofing Tools—This allows you to refresh the MS Office spell checker in 
your installation of Déjà Vu X3 Workgroup (if you for instance have loaded additional 
language engines in MS Office that you also want to use in Déjà Vu X3 Workgroup).

Check spelling as you type—This option activates the real-time spell checking that 
underlines incorrectly spelled words with a red squiggly underline: 

Any of the following options only apply to the Hunspell dictionaries.
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. You can correct the misspelled word by right-clicking on it and 
selecting one of the proposed spelling options or Ignore All or Add to Dictionary:

Ignore words in UPPERCASE—The spell checker will not check words that are all written 
in uppercase letters.

Ignore words that contain numbers—The spell checker will not check words that contain 
number such as "DVX3".

Ignore internet addresses—The spell checker will not check any URLs such as http://
www.atril.com.

Flag repeated words—The spell checker will mark repeated words as misspelled such as 
when when I repeat “when”.

Custom Dictionaries—Opens the Custom Dictionaries dialog where you can manage 
your custom dictionaries that will be used with the integrated Hunspell spell checker (see 
p. 127).

DICTIONARIES

Dictionaries are customized lists of words that you want to have automatically ignored by your 
spell checker.

The spelling options you check in this dialog also take effect in any spelling you may 
perform in your translation memories or termbases. For more information on this, see 
"Spell Checking the Translation Memory" on page 471 and "Spell Checking the 
Termbase" on page 530.

Note that dictionaries are only used with the integrated Hunspell dictionaries.
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Though Déjà Vu X3 Workgroup is pre-equipped with extensive dictionaries for the languages with 
supported spell check engines, there will always be words that you encounter during spell checks 
which are not included. You can choose to include those in your custom dictionaries.

To add words to user dictionaries

1 If a correctly spelled word is displayed in the Not in Dictionary box on the Check Spelling 
dialog (see "Spell checking" on page 127), the word should be added to a user dictionary. 

2 Select the desired dictionary under Add words to and click Add.

3 The word is added to the dictionary and will no longer be marked as misspelled.

To create a new dictionary

1 On the Check Spelling dialog, click Dictionaries.

2 The Custom Dictionaries dialog appears.

Typically you only have one dictionary per language and you don’t need to worry about 
selecting the dictionary. Exceptions to this rule would include situations when you are 
working on a project with a phraseology you need to train your spell checker to ignore 
for that project but not for other project. In that case you would create a new dictionary 

that you would use just for that project.
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3 Select the language that you want to create a dictionary for.

4 Click New in the Custom Dictionaries dialog.

5 Click Browse and select a name and path for your new dictionary.

6  Click OK.

To add existing dictionaries

1 On the Check Spelling dialog, click Dictionaries.

2 The Custom Dictionaries dialog appears.

3 Click Add in the Custom Dictionaries dialog.

4 The Select Name and Location of the User Dictionary dialog appears.

5 Select name and location of the new dictionary and click Save.

The default path for dictionaries is C:\ProgramData\Atril\Deja Vu 
X3\Spelling\<LanguageCode> (on an English Windows 7 or 8 installation) but 
you are free to save it elsewhere.

If you can’t view this folder you will need to unhide it by opening Folder Options in the Windows 
Control Panel and selecting View> Show hidden files, folders, and drives
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6 The dictionary is added.

If you want to add external data to the dictionary that is not present in a *.dic file you 
can create a text file, copy a simple list of data into that file (one word per line) and 
save it as a *.dic file in UTF-8 format.
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REVIEW FEATURES IN DÉJÀ VU X3 WORKGROUP—THE DETAILS

Translators often encounter passages that are difficult to translate. The more you think about them, 
the harder they become to translate. The best way to deal with this would probably be to forget 
about it for a while, continue translating, and come back to it when your mind is fresh. If you 
cannot come up with a good solution even then or you are still not certain about your solution, 
Déjà Vu X3 Workgroup provides tools to highlight these rows for an editor or another translator.

Also, project managers often have certain sections in their texts that need to be highlighted for 
translators, editors, or even for their own use. Déjà Vu X3 Workgroup provides several ways to 
highlight these rows for review or to add comments.

BOOKMARKING A SEGMENT

Déjà Vu X3 Workgroup allows you to set a "bookmark" to mark a position in a project. All the 
bookmark commands are available on the Review ribbon tab:

Bookmarks help you to select sentences on the fly that you can later easily locate.

To set a bookmark

1 Select the segment where you want to set a bookmark.

2 Select Review> Toggle Bookmark.

–Or–

Press Ctrl+F2.

–Or–

Right-click on the segment and select Bookmarks> Toggle Bookmark from the shortcut menu.

3 A Bookmark icon  will appear to the left of the segment.

To remove a single bookmark

1 Select the segment in which you have previously set a bookmark.

2 Select Review> Toggle Bookmark.
Déjà Vu X3    239



240
–Or–

Press Ctrl+F2.

–Or–

Right-click on the segment and select Bookmarks> Toggle Bookmark from the shortcut menu.

3 The Bookmark icon  at the left of the segment will disappear.

To remove all bookmarks

1 Select Review> Clear Bookmarks.

2 All Bookmark icons  will disappear.

To move to the next bookmark after the currently selected segment

1 Select Review> Next Bookmark.

–Or–

Press F2.

2 If there are only bookmarks above your current position, the following dialog is displayed:

To move to the previous bookmark before the currently selected segment

1 Select Review>Previous Bookmark.

–Or–

Press Shift+F2.
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2 If there are only bookmarks below your current position, the following dialog is displayed:

MARKING SEGMENTS AS PENDING

Déjà Vu X3 Workgroup allows you to mark questionable rows as "pending" so that you or someone 
else can come back at a later time to finish or review these rows.

To mark a segment as pending

1 Right-click the sentence you want to mark as pending and click Segment Status> Pending.

–Or–

Press Ctrl+Shift+P.

2 The Pending symbol ( ) appears in the target cell.

To remove the pending status

1 Select the sentence you want to mark as normal (non-pending).

2 Right-click the sentence table and click Segment Status> Pending.

3 The Pending symbol ( ) disappears.
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To view all your pending segments

Select Pending Segments from the Segment Selector. For more information, see "The Segment 
Selector" on page 43.

ADDING COMMENTS

It is often important to add notes to aid your own memory about a certain translation or to 
communicate something to translators or editors who work with you.

To add a comment

1 Right-click on the source or the target section of a segment to which you want to add a 
comment and select Comments> Edit Comment from the context menu. 

–Or–

Select Edit Comment on the Review ribbon tab.

–Or–

Place your cursor in the source and target section and press Ctrl+M.
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2 The Add Comment dialog appears. Here you can enter any appropriate comment.

3 Select Apply.

4 The light blue Comment icon  appears to the left of the source or the target section of the 
segment.

In case the target section already contains an inconsistency mark (see "Consistency 
Checks" on page 115), the exclamation mark will be light violet.
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To view all rows with comments

Select Segments with Comments, Segments with Comments in Source, or Segments with 
Comments in Targets from the Segment Selector. For more information, see "The Segment 
Selector" on page 43.

To review a comment

1 The easiest way to review a comment is to place your cursor over the left section of the 
source or target section of the segment.

2 A tooltip-like window will appear in which you can review the comment. 
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To edit a comment

1 Right-click on the source or the target section of a segment for which you want to edit a 
comment and select Comments> Edit Comment from the context menu. 

–Or–

Select Edit Comment on the Review ribbon tab.

–Or–

Place your cursor in the source and target section and press Ctrl+M.

2 The Edit Comment dialog appears. Here you can edit the existing comment or add a 
response to the comment.

3 Select Apply.

To delete a comment

Right-click on the source or the target section of a segment from which you want to delete a 
comment and select Comments> Delete Comment from the context menu. 

–Or–

Select Delete Comment on the Review ribbon tab.

–Or–

Place your cursor in the source and target section and press Ctrl+Shift+M.

To delete all comments

Select Delete Comment > Delete All Comments on the Review ribbon tab.
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USING CONFIRM STATUSES

It’s possible to modify your translation mode in Déjà Vu X3 Workgroup to indicate whether you 
are translating, proofreading or validating the segments while confirming them. The segment 
statuses Translated, Proofread and Approved can be used by individual translators to signify the 
stage that the translation project currently is in or can be used by collaborators with different roles 
(translators, editor, project manager).

THE CONFIRM AS DROPDOWN

The Confirm As dropdown is located in the upper right-hand corner, right above the ribbon.

This allows you to assign different categories of confirmation to segments within the project. The 
three pre-configured categories are Translated, Proofread and Approved. Selecting one of the 
categories every time you confirm a segment will confirm it in that category.

To apply the different confirm statuses automatically

1 Set the appropriate status in the Confirm As dropdown box

2 Confirm the segment by pressing Ctrl+DownArrow or Ctrl+Enter (or by selecting Home> 
Confirm and Move to Next) to confirm and jump to the next segment in the project.

–Or–

Confirm the segment by pressing Alt+DownArrow or Alt+Enter (or by selecting Home> 
Confirm and Move to Next> Confirm Segment and Move to Next Untranslated) to confirm 
and jump to the next non-confirmed segment in the project.

–Or–

Confirm the segment by pressing Ctrl+Alt+DownArrow (or by selecting Home> Confirm 
and Move to Next> Force Confirm Segment and Move to Next) to confirm, overwrite 
segments that have already been conformed and jump to the next segment in the project.

3 Depending on your selection in the Confirm As dropdown, the segment will display the 
appropriately colored check mark: 

Translated segments with a black check mark: )
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Proofread segments with a blue check mark: )

Approved segments with a green check mark: )

To apply the different confirm statuses manually

1 Right-click on the segment for which you want to change the confirm status and select 
Segment Status> Translated / Proofread / Approved. 

–Or–

Press the following keyboard shortcut for the different status:

Ctrl+Shift+T for Translated

Ctrl+Shift+R for Proofread

Ctrl-Shift+V for Approved 

2 The segment will display the appropriately colored check mark: 

Translated segments with a black check mark: )

Proofread segments with a blue check mark: )

Approved segments with a green check mark: 
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TEAMWORK FEATURES IN DÉJÀ VU X3 WORKGROUP—THE DETAILS

Déjà Vu X3 Workgroup provides several ways to create sub-projects and databases to pass on to 
team members—translators, editors, reviewers, or project managers.

There are many benefits to these files:

much smaller size resulting in faster transmission speed

added security by limiting the work of translators/editors to their specific language 
combination

added control by limiting database sharing to the necessary data

greater speed in local area networks by being able to split up files and have translators 
work on their local computers

possibility of cross-platform work

SHARING YOUR PROJECT

The ability to share your project in the various formats is accessible by selecting File> Share.

You’ll find the following sharing options:
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Divide & Dispatch—includes the ability to split projects between a list of users and 
export the sub-projects into a variety of formats, including Satellite files, Pack&Go 
projects, XLIFF files, bilingual RTF files and Trados Workbench files.

Satellite—allows you to export the complete or a part of the project into a Satellite file or 
a Pack & Go project. A satellite file contains only one source and one target language and 
optionally the underlying code as well as a project-specific translation memory and 
termbase. Satellite files can only be processed in Déjà Vu.

Pack & Go packages are highly compressed exports from project files that are ideal for 
the transmission of Déjà Vu X3 Workgroup data. Pack & Go packages optionally also 
contain a project-specific translation memory and termbase. Pack & Go packages can 
only be processed in Déjà Vu.

XLIFF—export of one file in the project or the complete project into the translation 
exchange format XLIFF. The translation exchange format XLIFF can be processed in any 
other CAT tool that supports this very common format.

Bilingual RTF—export of one file in the project or the complete project into an MS 
Word- (or OpenOffice/LibreOffice) compatible file that presents the data in a table 
format with columns for source and target text.

Trados Workbench—export of one file in the project or the complete project into the 
native translation format for Trados 2007 and earlier and Wordfast Classic. This format is 
also supported by a number of other CAT tools

There are two Déjà Vu-specific file formats mentioned here: 

Satellite files contain only one source and one target language and optionally the 
underlying code. They can only be processed in Déjà Vu. For more information, see 

"Satellite Files" on page 260.

Pack & Go packages are highly compressed exports from project files that are ideal for the 
transmission of Déjà Vu X3 Workgroup data. They also can only be processed in Déjà Vu. For 
more information, see "Pack & Go Packages" on page 274.

The difference between the satellite and the Divide & Dispatch option is the splitting 
facilities (which are accompanied by all the different analysis methods) with Divide & 
Dispatch.
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DIVIDE & DISPATCH

The Divide & Dispatch option offers a highly advanced method to split up a project between 
various translators and customize the project options to the individual translator’s needs.

To split up a project using Divide & Dispatch

1 Select File> Share> Export> Divide & Dispatch.
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2 The Divide & Dispatch dialog appears.

3 To start the distribution process 

Select the languages for which there are packages to be created under Languages (if the 
project contains more than one language),

Determine what the split percentage between the different packages is going to be based 
on under Division units, 

Set the number of desired packages under Number of Packages (or, if you prefer, the 
number of words per package under Package size).

The options are files (so that the same number of complete files would be included in 
each package), total words (or characters), translatable words (or characters), or 
estimated words (or characters). Translatable and estimated words (or characters) are 
determined by your selection under Non-Translatable Content and Workload 

Estimation Percentage (see below).
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Set the Default format (the options are compact or full Satellite, compact or full Pack & 
Go Satellite, Word RTF, Trados RTF or XLIFF).

Set which segments are supposed to be exported into the packages under Segments (by 
making a selection in the drop-list under All Segments) and which segments should be 
excluded (by making a selection among the Suppress options).

Set whether or not to include locked and duplicate segments as well as guaranteed and 
exact matches in the Translatable count (see p. 252) under Non-Translatable Content.

Base the estimated workload for the translation of each package not only on the number 
of words but on the presumed amount of effort. You can alter the percentages based on 
the level of fuzziness under Workload Estimation Percentages.

Under Sorting you can set whether the exported packages contain alphabetically sorted 
segments or segments that are sorted the same way they are in the source documents 
("natural").

For compact packages, none of the underlying coding information is exported. This 
results in a smaller file size. The downside is that the Preview, See in Context and 
Export options are disabled, unlike for full packages, that contain all the necessary 
information for these options as well.

You can combine the export of segments of different statuses by selecting the option 
SQL Statement under All Segments (see "To use the SQL Statement view" on page 49).

This option assumes that a translator needs 100% effort for segments that have no 
match. It is up to you to define under Workload Estimation Percentages what 
percentage exact (i.e., 100%) matches are, and then the different percentage categories 
below that. Depending on your selection, the numbers under Estimated in the 

Packages section (see p. 255) will vary.
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Finally, click Preview Packages.

4 Once the project has been split according to your settings, you can now for each language 
(under Target Languages) fine-tune the individual settings for size and format for each package 
in the Packages section by clicking in each of the cells and changing the cell content.

Under Name you can make changes to the name of the package.

Under Words you can change the total number of words in that package.

Under Translatable you can change the number of translatable words in a package (the 
Translatable count is determined by your selection under Non-Translatable Content you 
set previously).

Under % of project you can change the percentage of the project that is assigned to the 
individual package (the percentage varies according to the Division unit you selected 
previously).
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Under Estimated you can change the number of estimated words in a package (the 
Estimated count is determined by your selection under Workload Estimation Percentage 
you defined previously).

Under Format you can make individual selections for the file format of the exported 
package. Depending on the tools used by the respective translators, you can use Satellite 
or Pack & Go packages (if they use Déjà Vu), Trados RTF (if they use Trados 2007 or 
Wordfast), XLIFF (if they use any other CAT tool that supports that format) or Word RTF 
(if they don’t use a CAT tool).

5 In the Package Contents section, you can see from which original files the content within each 
of the packages originates. A check mark indicates that all of the content of the respective file 
is contained in the selected package, and a square mark indicates that only part of the file’s 

Any change to Words, Translatable, % of selection or Estimated for one package results 
in a change to all the other packages as well so that at all times the complete project is 
taken care of. For instance , if you have three packages of 33% of the selection each 
and you change one of the percentages to 50%, the two other percentages would 

automatically be changed to 25% each. Once a value has already manually been changed, no 
automatic change will be applied anymore. In the above example, this means that if you change 
one of the packages with 25% to 40%, the package with 50% would not be changed anymore, but 
the last package would be assigned 10%.
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content is contained in the selected package. It is possible to manually make changes if you 
only want complete files contained within each package.

6 Once you have made the desired changes, click Export Packages.
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7 The Dispatch Export Options dialog appears.

8 In this dialog, you’ll need to set the folder to which you’ll export the packages as well as the 
following settings:

You can Upload packages to TEAMServer where they will reside as a backup.

You can choose to Export Analysis results for each package into a CSV file so that it can 
be sent alongside the actual project to the translator.

You can choose to Export subsets of Translation Memories and Termbases for each of the 
packages.

For the subset export, Déjà Vu X3 Workgroup will go through all of the associated 
translation and termbases, detect any exact or fuzzy match (or corresponding term) and 
create new databases with that data. 

Please note that the termbase export is only applicable to Satellite and Pack & Go Satellite 
packages. For these formats, Déjà Vu X3-specific termbases are created. For all other formats, a 
TMX (translation memory exchange) file is created that contains data from the associated 
translation memories but not the termbases.
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If you have selected RTF Word as one of the export formats, there will be several options 
available for these kinds of packages:

Populate empty translations copies the source segments into the target column if 
there is no existing translation.

Include segment status adds an additional column that contains information about 
the status of the translation either in the form of a number or a color indicator (see 
p. 43). Since there are no preset colors for locked and pending segments, you can 
set those under Additional status colors.

Include file name adds an additional column with the name of the source file either 
with or without the complete directory path. This is helpful if your file contains a 
large number of original files that you want your translators to use as reference 
material for context.  

Hide source applies MS Word’s hidden property to the text in the source column.

If you have selected Trados Workbench as one of the export formats, you can select 
whether you want to Export locked / guaranteed segments as Xtranslated so that they will 
be shown within the Trados environment as untranslatable text.

9 After making your selections, click OK. 

If you have selected to export subsets of large translation and/or termbases, the export 
process can take several minutes.
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10 After the export, all the different files are displayed in the set directory folder. In this case you 
can see all the different formats and the way they appear:

The files named de_DE.solar2.1 are in the Satellite format. They include a CSV file (the 
analysis report), the actual satellite file (the *.dvsat file), four files that comprise a 
bilingual translation memory (*.dvmdb, *.dvmdx, and two *.dvmdi files) and the 
termbase (*.dvtdb).

The files named de_DE.solar2.2 are in the Trados RTF format. They include a CSV file 
(the analysis report), the Trados RTF file and a translation memory exchange file that can 
be imported into Trados Workbench or Wordfast Clasic (the *.tmx file).

The files named de_DE.solar2.3 are in the Word RTF format. They include a CSV file (the 
analysis report), the Trados RTF file and a translation memory exchange file that can be 
used as reference in a text or TMX editor (the *.tmx file).

The files named de_DE.solar2.4 are in the XLIFF format. They include a CSV file (the 
analysis report), the XLIFF file that can be processed in any compatible CAT tool  and a 
translation memory exchange file that can be imported into any CAT tool (the *.tmx file).

The files named de_DE.solar2.1 are in the Pack & Go Satellite format. They include a 
CSV file (the analysis report) and one more file (the *.dvpng file) that contains all of the 
translatable data as well as the translation memory and termbase data. Once that file is 
opened in Déjà Vu, the user is asked to specify or create a project file, a translation 
memory and a termbase into which the data can be imported.
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SATELLITE FILES

After a Déjà Vu X3 Workgroup project has been created and the external files have been 
imported, it is possible to generate satellite work files.

A satellite file contains only one source and one target language (as opposed to a full project file, 
which typically consists of the source language plus a number of target languages) with all the 
information needed by the translator. This information can exclude the formatting and image 
code, thus significantly reducing the file size and making it easier to transmit.

A satellite file contains a number of automatic restrictions. It is not possible to

delete files,

split/join rows,

edit the source, or

lock/unlock rows.

If the security options for the originating project file are enabled (for information on security, see 
"Security Features in Déjà Vu X3 Workgroup—The Details" on page 297), users of the satellite files 
will have to log in with a user name and password. This will give them access to a predefined 
security level, which in turn will either permit or prohibit the overwriting of translation entered by 
other users or the project owner.

Once the translation of a satellite is finished, it can be sent back to the project owner who can 
import it into its parent project file.

It is possible to translate satellite files that were created in  Déjà Vu X3 either in 
Déjà Vu X2 or in Déjà Vu X3.
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To create a satellite project for one user

1 Select File> Share> Export> Satellite.

2 The Satellite Export Wizard appears.

3 Select the export path for your satellite file(s).

4 Click Next.
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5 From the list of target languages in your project, select those languages for which you want to 
create satellite files.

6 Click Next.

7 Select which of the files in your project you would like to export into the satellite, and/or 
whether you would like to include the lexicon (if applicable).
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8 Click Next.

9 You now have the opportunity to select from several export options:

Compact or Full—Compact does not export any of the underlying coding information, 
with the result that the file is smaller. However, the See in Context and Export options are 
disabled, unlike Full, which contains all the necessary information for these options as 
well.

Pack & Go—This option allows you to export into a highly compressed export out of a 
satellite file (for more information on Pack & Go, see "Pack & Go Packages" on page 274). 
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If you select this option, you can also include subsets of your translation memories and 
termbases to be included in that package.

Export subset of Translation Memories to—When selecting this powerful option, Déjà Vu 
X3 Workgroup will scan all of your attached translation memories for relevant entries for 
this particular satellite file in all the relevant language combinations. This serves two 
purposes: it protects your non-relevant translation memory content from unnecessary 
sharing, and it creates smaller files that are much easier to transmit.

Export subset of Termbases to—When selecting this option, Déjà Vu X3 Workgroup will 
scan all of your attached termbases for relevant entries for this particular satellite file in all 
the relevant language combinations. As with the translation memories, it protects your 
non-relevant terminology assets from unnecessary sharing and creates smaller files that 
are much easier to transmit.

10 When you are finished with your selection, click Next.

You can also export a subset of the associated translation memories and/or termbases as 
individual processes. For more information on this, see "Exporting Subsets of Translation 
Memories and Termbases" on page 278.
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11 The wizard shows you the progress of each of the steps that it has to perform and will 
eventually display how many satellite projects have been created (depending on the number 
of target languages you selected).

12 Once the process is finished, click Close.

To import a translated satellite project

1 Select File> Share> Reimport> Reimport.

2 In the Reimport Package dialog that appears, select the satellite project you want to import.

3 Click OK. Déjà Vu X3 Workgroup will automatically merge the satellite project with the 
complete project.

Depending on the size of your project and databases, this process could take several 
minutes.
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XLIFF FILES

XLIFF is the leading exchange format for translation files that is supported by the vast majority of 
CAT tools. In Déjà Vu X3 Workgroup, it is possible to export one or any number of files or the 
complete project into the XLIFF format so that it can then be processed in a competing CAT tool.

To create an XLIFF file

1 Select File> Share> Export> XLIFF.

2 The Export External View dialog appears with the preselection of XLIFF as the export format.

3 Make the following settings in the dialog:

Select under Destination the directory to which you want to export the XLIFF file.

Select under Language which target language you’ll want to export (provided that your 
project contains more than one target language).

Select whether you want to export all files or the currently open file within your project 
under Files.
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Under Selection you’ll need to select whether you want to export all segments, only 
segments with empty or with non-empty targets (the non-empty target option is helpful 
when exporting the currently translated part of the project for editing or review 
purposes), only segments with comments (good option to send to a project manager or 
subject matter expert) or only pending segments.

Select whether you want to exclude (suppress) locked or duplicate segments or 
guaranteed or exact matches

4 Click OK and Close.

5 The XLIFF file can now be opened and translated in other CAT tools, in this case in Trados 
Studio:

BILINGUAL RTF

The bilingual RTF export allows you to share one or all the files in the project with someone who 
does not have access to a CAT tool. The resulting RTF file presents the data in a table format with 
columns for source and target text that can be edited in MS Word or OpenOffice/LibreOffice.

To create a bilingual RTF file

1 Select File> Share> Export> Bilingual RTF.
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2 The Export External View dialog appears with the preselection of Rich Text Format as the 
export format.

3 Make the following settings in the dialog:

Select under Destination the directory to which you want to export the RTF file.

Select under Language which target language you’ll want to export (provided that your 
project contains more than one target language).

Select whether you want to export all files or the currently open file within your project 
under Files.

Under Selection you’ll need to select whether you want to export all segments, only 
segments with empty or with non-empty targets (the non-empty target option is helpful 
when exporting the currently translated part of the project for editing or review 
purposes), only segments with comments (a good option to send to a project manager or 
subject matter expert) or only pending segments.

Select whether you want to exclude (suppress) locked or duplicate segments or 
guaranteed or exact matches.
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Under Sorting, you can select whether the rows should be exported alphabetically or 
naturally (i.e., in the order in which they appear in the source text).

Under Miscellaneous, you can select whether tags are to be suppressed or exported (this 
option is grayed out when the option Include segment ID is activated), whether segment 
IDs are to be included (these are necessary for the re-import!), whether the segment 
status is to be included (and if so, whether it should be displayed as a color and/or 
number) and whether you want the name and/or path of the originating file to be 
included.

Under Colors you can assign colors to Pending and Locked rows, which in the main grid 
view do not have any associated colors. For any of the other segment types, the colors 
that are defined under File> Options> Display will be used.

4 Click OK and Close.

It is imperative that you include the segment ID if you are planning to re-import the 
project (as you would after proofreading or editing), and instruct your proofreader not 
to change these.

If you are exporting locked rows, the complete segment, rather than just the 
appropriate field in the Status column, will be underlined with the appropriate color to 
emphasize the fact that this segment should not be touched. 
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5 The RTF file can now be opened and translated in a word processing application:

TRADOS WORKBENCH

To create a Trados Workbench file

1 Select File> Share> Export> Trados Workbench.
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2 The Export External View dialog appears.

3 Make the following settings in the dialog:

Select under Destination the directory to which you want to export the Trados 
Workbench RTF file.

Select under Language which target language you’ll want to export (provided that your 
project contains more than one target language).

Select whether you want to export all files or the currently open file within your project 
under Files.

Under Selection you’ll need to select whether you want to export all segments, only 
segments with empty or with non-empty targets (the non-empty target option is helpful 
when exporting the currently translated part of the project for editing or review 
purposes), only segments with comments (a good option to send to a project manager or 
subject matter expert) or only pending segments.

Under Sorting, you can select whether the rows should be exported alphabetically or 
naturally (i.e., in the order in which they appear in the source text).
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Select whether you want the segment ID included.

You can select whether you want to Export locked / guaranteed segments as Xtranslated 
so they will be shown within the Trados environment as untranslatable text.

Select whether you want to exclude (suppress) locked or duplicate segments or 
guaranteed or exact matches

4 Click OK and Close.

5 The Trados Workbench file can now be opened and translated in Trados 2007, Wordfast 
Classic or any other CAT tool that supports this format:

REIMPORTING A FILE

Once your shared file or project has been translated or edited, you need to reimport it using the 
option under File> Share> Reimport. 

In the resulting Reimport Package dialog, you can select any of the supported file formats:

It is imperative that you include the segment ID if you are planning to re-import the 
project (as you would after proofreading or editing), and instruct your proofreader not 
to change these.
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Satellite (*.dvsat)

Pack & Go (*.dvpng)

XLIFF (*.xlf)

Bilingual RTF (*.rtf)

Trados Workbench (*.rtf)

If you select Satellite and the Pack & Go format, the new translations and changes will be 
automatically transferred into your original project.

If you select XLIFF, bilingual RTF or the Trados Workbench RTF, the Merge External View Data 
dialog is displayed: 

 

In the main window of the dialog, you can find all rows listed that have been changed. Any 
discrepancy between Existing Source/Target (i.e., the source and target sentences of your Déjà Vu 
X3 Workgroup project) and New Source/Target are displayed with a strikethrough (Existing) and 
red formatting (New). 

You can choose to individually review and accept the changes by checking each of the check 
boxes in the Accept column, or you can accept or reject them all by selecting Accept All or Accept 
None in the lower part of the dialog. 

The other buttons on this dialog have the following functions:
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Previous Difference/Next Difference—highlights the previous or next segment with 
differences.

Show All Segments/Show Only Differences—shows rows with or without differences.

Once you make the appropriate selections you are returned to your Déjà Vu X3 Workgroup 
project, where you can see that the changes have replaced the original text.

PACK & GO PACKAGES

Pack & Go packages are highly compressed exports from project files that are ideal for the 
transmission of Déjà Vu X3 Workgroup data. The Pack & Go feature is available as a stand-alone 
feature for the transfer of complete projects, or as part of the satellite creation for the transfer of 
even smaller bilingual satellite projects (for more information on satellites, see "Satellite Files" on 
page 260).

Opening a Pack & Go package with Déjà Vu X2 or Déjà Vu X3 will start the Pack & Go Wizard, 
which will allow you to define where you want to have your new project stored. When the 
translation of the project is finished, you can once again export it into the Pack & Go format to 
transmit it back to the project owner.

To create a Pack & Go project

1 Open the project that you would like to export into a Pack & Go package.

2 Select File> Save As> Create Pack & Go.
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3 The Select Location of New Pack & Go Package dialog appears.

4 Click Save after you have selected the folder where you want this file to be stored and have 
named the file.

5 The Pack & Go Export Progress dialog appears.

6 When the export is finished, a new file with the extension .dvpng will have been placed in the 
specified folder. You will notice that the size of the .dvpng file is significantly smaller than the 
originating project file:

To open a Pack & Go package

1 Select File> Open.

–Or–
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Click  on the Quick Access Toolbar.

–Or–

Press Ctrl+O.

2 In the Open dialog, navigate to the location of your Pack & Go package, select All Déjà Vu X3 
Files or Pack & Go Projects, and select the .dvpng file. 

3 Click Open.
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4 Create a project to host your Pack & Go package.

5 Select Next.

6 Click Finish. The wizard shows you the import progress.

7 Déjà Vu X3 Workgroup displays the open project.

To translate a project created from a Pack & Go package

Once the file is open, you can start to work in it right away. It may be a good idea, however, to first 
re-adjust the settings of the current project.

1 Select File> Options.

2 On the Clients and Subjects tabs, make sure that the client and subject setting is set to match 
the configuration of your subjects and clients.

3 Select Project> Properties and make sure that the project is mapped to databases on your 
computer or network and—if you are using machine translation—that your machine 
translation engines are selected correctly.

For more information on subjects and client, see "Clients and Subjects" on page 183.
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To return a Pack & Go package

When you have finished with your work on the project file, you can create a new Pack & Go 
package (see "To create a Pack & Go project" on page 274) and return it to the project owner.

EXPORTING SUBSETS OF TRANSLATION MEMORIES AND TERMBASES

Déjà Vu X3 Workgroup gives you the option to scan all of the translation memories and/or 
termbases that are attached to your current project for relevant entries to create one project-
specific termbase and one project-specific translation memory.

This serves two purposes:

it protects your non-relevant database content from unnecessary sharing and 

it creates smaller files that are easier to transmit.

To create subsets of associated databases

1 From within an open translation project, select File> Share> Translation Memory 
(Termbase)> Export Subset.

2 The Export Subset dialog appears.

3 Select the language for which you want to have a translation memory created and the 
destination where you want it to be saved.

4 Click OK.

5 Repeat the same process for a termbase. 

Depending on the size of your databases, this process could take several minutes.

This process of creating subsets of databases creates the same databases that you would 
create if you exported a subset during the creation of a satellite file (see p. 263).
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USING DÉJÀ VU X3 WORKGROUP WITH TEAMSERVER 

TEAMserver is meant to be used primarily by project managers, reviewers and translators working 
with Déjà Vu X3 Workgroup. The use of TEAMserver from Déjà Vu X3 Workgroup is designed to 
be almost entirely transparent, providing users with the same advanced leveraging capabilities 
whether working with local or TEAMserver translation memories and termbases.

All of the translation and QA features of Déjà Vu X3 Workgroup (such as Scan, Lookup, 
Pretranslate, Assemble, AutoSearch, AutoSend, AutoCheck, AutoWrite, etc.) work exactly the 
same when connected to a TEAMserver as when using local translation memories and termbases.

CONNECTING TO TEAMSERVER FROM DÉJÀ VU X3 WORKGROUP

Connecting to TEAMserver from Déjà Vu X3 Workgroup is simply a matter of using the 
TEAMserver in the same way you would use a local translation memory and termbase in Déjà Vu 
X3 Workgroup.

PROJECTS

Connecting a Déjà Vu X3 Workgroup project to TEAMserver involves assigning a TEAMserver 
instance to the list of translation memories and termbases for a project.

To connect an existing project to TEAMserver

1 Open an existing project.

2 Select Project> Properties> Termbases.

3 Select Add Server TB to add a server-based TEAMServer termbase.
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4 The TEAMserver Login dialog prompts you to enter your login credentials.

5 In the Server URL text box, enter the address of the TEAMserver to which you want to 
connect. If you are connecting to a TEAMserver over the Internet, the URL should have the 
form http://teamserver.mycompany.com/TEAMserver/. If you are connecting to a TEAMserver 
on the local network using the Binary TCP protocol, the URI should have the form tcp://
teamserver/.

6 In the User text box, enter the user ID assigned to you by the TEAMserver administrator.

7 In the Password text box, enter the password assigned to you by the TEAMserver 
administrator.

8 (Optional) Check the Remember password checkbox to have Déjà Vu X3 Workgroup 
remember your login information.

9 Click OK.

10 The termbase will be displayed.
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11 Repeat the same procedure for the translation memory using the Translation Memories tab.

12 Click OK to close the Project Properties dialog.

To connect a new project to TEAMserver

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.

3 Select the Project button under Translation Project.

-Or-

Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.
Déjà Vu X3    281



282
4 The New File dialog appears.

5 Double-click Project or select Project and click OK.

6 The Create a New Project wizard appears with the first page in which you are prompted to 
name your project and select a location for it.

7 Click Next and select the language combination.

8 Click Next and select Add Server TM to add a server-based TEAMServer termbase.

9 The TEAMserver Login dialog prompts you to enter your login credentials.

10 In the Server URL text box, enter the address of the TEAMserver to which you want to 
connect. If you are connecting to a TEAMserver over the Internet, the URL should have the 
form http://teamserver.mycompany.com/TEAMserver/. If you are connecting to a TEAMserver 
on the local network using the Binary TCP protocol, the URI should have the form tcp://
teamserver/.

11 In the User text box, enter the user ID assigned to you by the TEAMserver administrator.

12 In the Password text box, enter the password assigned to you by the TEAMserver 
administrator.
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13 (Optional) Check the Remember password checkbox to have Déjà Vu X3 Workgroup 
remember your login information.

14 Click OK.

15 The translation memory will be displayed.

16 Click Next and repeat the same procedure for the termbase by selecting Add Server TB.
Déjà Vu X3    283



284
17 Click Next and select machine translation engines (if applicable).

18 Click Next and select a subject and a client.

For syncing subjects and clients with the TEAMServer, see p. 280.
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19 Click Next and select the files that need to be translated.

20 Select Next and Close.

Once a project is connected to TEAMserver, Déjà Vu X3 Workgroup will attempt to connect to 
TEAMserver every time the project is opened. Upon opening a project that connects to 
TEAMserver, Déjà Vu X3 Workgroup will display the TEAMserver Login window and  prompt you 
to enter your login details. If you chose to have Déjà Vu X3 Workgroup remember your password, 
you will only need to click OK to login; otherwise, you will need to enter your password in the 
Password text box and then click OK.

TRANSLATION MEMORIES

As part of the migration to TEAMserver, or when working with translation memories from users 
without access to TEAMserver, you may need to export data from a local translation memory to 
the TEAMserver. Using Déjà Vu X3 Workgroup, you can open a local Déjà Vu X3 Workgroup 
translation memory and export all or part of its contents to TEAMserver.

To export a Déjà Vu X3 Workgroup translation memory to TEAMserver

1 Select File> Open.

–Or–

Click  on the Quick Access Toolbar.

–Or–
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Press Ctrl+O.

2 The Open dialog appears.

3 Select Translation Memories under Files of type, select the database you want to use export to 
TEAMserver and click Open.

4 Select the External Data ribbon tab.

5 Select TEAMServer in the Export section on the ribbon tab.
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6 Enter the server URL, the user name and password in the Translation Memory Export Wizard.

7 Click Next.

For more information on entering the login data, see p. 280.
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8 In the Available languages list, select the languages you want to export and click Add to add 
them to the Export languages list.

9 Click Next.

10 (Optional) In the Filtering Conditions text box, enter a filtering expression to specify the subset 
of the TM entries that you want to export.

11 Click Next and Finish.

For more information on filtering, see p. 280.
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12 The Translation Memory Export Wizard displays a progress bar.

13 When the export is complete, you are shown how many entries have been exported.
 

14 Click Close.
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TERMBASES

As part of the migration to TEAMserver, or when working with termbases from users without access 
to TEAMserver, you may need to export data from a local termbase memory to the TEAMserver. 
Using Déjà Vu X3 Workgroup, you can open a local Déjà Vu X3 Workgroup termbase and export 
all or part of its contents to TEAMserver.

To export a Déjà Vu X3 Workgroup termbase to TEAMserver

1 Select File> Open.

–Or–

Click  on the Quick Access Toolbar.

–Or–

Press Ctrl+O.

2 The Open dialog appears.

3 Select Termbases under Files of type, select the database you want to export to TEAMserver 
and click Open.
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4 Select the External Data ribbon tab.

5 Select TEAMServer in the Export section on the ribbon tab.

6 Enter the server URL, the user name and password in the Termbase Export Wizard.

7 Click Next.

For more information on entering the login data, see p. 280.
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8 In the Available languages list, select the languages you want to export and click Add to add 
them to the Export languages list.

9 Click Next.

10 (Optional) In the Filtering Conditions text box, enter a filtering expression to specify the subset 
of the TM entries that you want to export.

11 Click Next and Finish.

12 The Termbase Export Wizard displays a progress bar.

13 When the export is complete, you are shown how many entries have been exported.

14 Click Close.

FLOATING LICENSES

Users who own a license of Déjà Vu X3 Workgroup can connect to the server-based translation 
memory and termbase to which they have been given access. If users do not own a license or 
need to upgrade a license (from Professional to Workgroup if you need to work on project 
management tasks), you can simply request a license from the license pool.

For more information on filtering, see p. 280.
Déjà Vu X3   292



Teamwork Features in Déjà Vu X3 Workgroup—The Details
To request a floating license in Déjà Vu X3 Workgroup 

1 To request a floating license, select File> Account> Request Floating License in Déjà Vu X3 
Workgroup.

2 Select Obtain a floating license from TEAMserver.

3 Enter the server URL, user name and password that was provided.

4 Click Activate.

5 Déjà Vu X3 Workgroup is activated according to the version you were assigned.

To return a floating license in Déjà Vu X3 Workgroup

1 To return a floating license, select File> Account> Request Floating License in Déjà Vu X3 
Workgroup.

2 Unselect Obtain a floating license from TEAMserver.

3 Your edition of Déjà Vu X3 Workgroup will revert to the same status it had before you 
activated a floating license.

TRACKING

To communicate the status of your project to TEAMserver, you can enable the Tracking feature in 
Déjà Vu X3 Workgroup.

For more information on entering the login data, see p. 280.
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To enable tracking in Déjà Vu  X3

1 Select Project> Properties in Déjà Vu X3 Workgroup.

2 Under Tracking, check the Track in TEAMserver checkbox.

3 Select a deadline for the project by selecting the calendar icon to the right of the Deadline 
box and clicking on a date.

4 Click on the ellipsis button to the right of the Server box.

5 The TEAMserver Login dialog appears.

6 Enter the login information you have been provided and click OK.

For more information on entering the login data, see p. 280.
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7 The correct information now is shown in the Properties dialog.

8 To upload data about the current status of your project, click Upload.
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SECURITY FEATURES IN DÉJÀ VU X3 WORKGROUP—THE DETAILS

Déjà Vu X3 Workgroup’s most basic user-based security feature, i.e., the tracking of any user’s 
activities, is enabled by default. Every process that any user performs in Déjà Vu X3 Workgroup 
will be associated with his or her computer or login name. 

Beyond these basic settings, Déjà Vu X3 Workgroup allows you to define different user roles and 
different levels of user access.

The different roles are 

project owner, 

administrator, and 

various levels of language users.

Project owners have access to all possible functions, including the ability to enable or disable 
project security. By default, the project owner role is assigned to the person who enables security 
in a project, translation memory, or termbase.

Administrators have the same set of rights as the project owners, excluding the ability to disable 
the project security features.

Users have a language-specific set of rights and are not allowed to perform the following activities:

delete files from the project

split/join rows in the project

edit the source in the project

lock/unlock segments and files in the project

merge segments in the translation memories and termbases

execute SQL statements

access the project/database configuration (the Project/Translation Memory/Termbase 
Properties dialogs)

Users can have nine different stages of permission levels, signified by the numbers 1-9. 
Of those, 1 has the highest security clearance (i.e., users with that level can overwrite 
anything from users of levels 2-9); the lowest level, 9, is not able to overwrite anything 
from any user except one with the same level.
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To enable project security

1 Select Project> Properties> Users.

2 Check Users must enter a user name and password to work on this project.

3 The User Login dialog appears.

4 Enter your user name and your password and click OK.

If you set up security for translation memories or termbases, the appropriate command 
would be Database> Properties> Users.
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5 The name you just entered appears in the user list.

6 As you are the project owner with unlimited rights, you do not have to add any further 
configuration to your profile.

7 If you would like to change your password or add a full user name, click Properties.

8 The User Properties dialog appears.
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9 You can now change your previous password by clicking on the Change Password button and 
making the appropriate changes in the Change Password dialog.

-And/Or-

10 You can enter a Full Name if you want that to be associated with your work.

To add an administrator

Although it is not necessary to add an administrator to a project, translation memory, or termbase, 
it may be a good idea to give that function to non-language-specific users, such as IT personnel.

1 Select Project> Properties> Users.

2 Your user name (as the project owner) appears in the user list.

3 Click Add.

If you add an administrator for translation memories or termbases, the appropriate 
command would be Database> Properties> Users.
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4 The New User dialog appears.

5 Enter the name of your administrator, enter and confirm a password and check Administrator.

6 Click OK.
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7 The newly added user is now displayed in the user list as well.

To add language users to your project

1 Select Project> Properties> Users.

If you add language users for translation memories or termbases, the appropriate 
command would be Database> Properties> Users.
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2 Your user name as the project owner (and, if applicable, the name of an administrator) 
appears in the user list.

3 Click Add.
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4 The New User dialog appears.

5 Enter the name of your new language user, enter a password, and confirm the password.

6 Select the appropriate language.
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7 Under Permissions, you can assign a general permission level and specific settings for the 
ability to import and export data.

8 When you are finished choosing the appropriate settings, select OK.

For the different levels of translation user access, see p. 297.

For projects "data" would include translatable files, and for translation memories or 
termbases this would refer to glossaries or external databases.
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9 The new user has been added to the user list.
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10 You can now continue to add users for all languages. As you probably want to have at least 
one editor and one translator for each language, you would have to add at least two for each 
available language. 

11 When you are finished with adding all of your translators, click OK.

To import existing lists of users

To avoid having to set up long lists of users for potentially identical or similar groups of translators, 
you can import existing lists of users.

1  Select Project> Properties> Users.

The editor or proofreader should always have a security clearance that is higher or the 
same than of the translator(s); otherwise he would be blocked from overwriting any of 
the translations.

If you add language users for translation memories or termbases, the appropriate 
command would be Database> Properties> Users.
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2 Select Import.

3 A file selector dialog appears where you can select the project, translation memory, or 
termbase from which you want to import the list of users.

4 Déjà Vu X3 Workgroup will only import users for the current languages of your project, 
translation memory, or termbase.

To change the settings for a user

1 If you need to change or verify any user setting, select that user’s name and click Properties. 

2 The User Properties dialog appears.

3 Make the necessary changes to that user.

4 Click OK. 

To delete a user from the project, translation memory, or termbase

1  Select Project> Properties> Users.

2 Select the user you want to delete.

3 Click Remove.

To delete language users for translation memories or termbases, the appropriate 
command would be Database> Properties> Users.
Déjà Vu X3    308



Security Features in Déjà Vu X3 Workgroup—The Details
To log into a project, translation memory, or termbase

1 Select File> Account> Log in.

2 The User Login dialog appears.

3 Enter your user name and password and click OK.

4 Every record that you edit or translate will now be associated with that user name

in the status bar of the project:

–Or–

in the translation memory or termbase:

and be protected by your particular set of rights.

Because the login will not notify you if your profile is not part of this project or 
database, it may be a good idea to try logging in again if you are blocked from activities 
that your security clearance should enable you to do.

To repeat a login, you do not have to first log out.
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To log out from a project, translation memory, or termbase

1 Select File> Account> Log out.

2 You are now logged out of the project.

You do not have to log out of a file to log into that file with a different logon. The 
function of the logout feature is merely a security feature that, for instance, allows an 
administrator to work on someone else’s computer, log in with the administrative 
password, and simply log out when the task is finished.
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ANALYSIS FEATURES IN DÉJÀ VU X3 WORKGROUP—THE DETAILS

Déjà Vu X3 Workgroup offers two different project analysis features that allow you 

to count words, characters, and tags in a number of different configurations and 

to analyze the repetition within your project and the number of exact and fuzzy matches 
from your existing translation memory(s).

THE COUNT FEATURE

Because of the different attributes that Déjà Vu X3 Workgroup applies to every segment within a 
project, word counts can be a very complex matter. While some attributes are mutually exclusive 
(e.g., a segment cannot be a fuzzy and an exact match at the same time, or a segment cannot be 
simultaneously locked and pending), the combination of other attributes makes sense and may be 
of interest to the user (e.g., a segment can be an exact match and be finished). To satisfy the need 
for an accurate overall word count as well as detailed word counts of all attributes and possible 
combinations, Déjà Vu X3 Workgroup offers two different count modes (Simple and Full) that use 
three different groups of categories.

The first mutually exclusive group is that of the flagged categories:

Completed ( , , and )

Locked ( )

Pending ( )

Unmarked (i.e., the non-flagged translation status)

The second mutually exclusive group is that of mutually exclusive translation status 
categories:

Empty (default grey indicator bar)

Manual (default grey indicator bar)

Exact (default dark green indicator bar)

Guaranteed Exact (default orange indicator bar)

Fuzzy (default light green indicator bar)

Assembled (default dark blue indicator bar)
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Machine Translated (default auburn indicator bar)

Exact Propagated (default light blue indicator bar)

Fuzzy Propagated (default gold indicator bar)

The third group consists of several unrelated categories that are counted by Déjà Vu X3 
Workgroup independently of the preceding categories (and are counted independently 
of the total count):

Multiple Matches (indicator: blue, underlined font)

Renumbered Matches (i.e., exact matches in which either tags or numerical values 
were renumbered)

Repaired Matches ( )

Stopped ( )

Wrong Codes ( )

Duplicates (i.e., duplicated source segments in a file or project)

What does all of this mean in practice?

Here is the simplest word count module (Current Language, All Files, Simple): 
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In this count, the flagged categories (Unmarked, Confirmed, Locked and Pending) are the main 
categories that make up the Total, and the status categories are treated as sub-categories of the 
Unmarked category.

All other categories are counted independently of the Total.

This count is most suitable for a quick overview of the dimensions of the project.

Following is the same word count module for the same project in Full mode:

In this count, the status categories are the main categories that make up the Total, and the flagged 
categories (Unmarked, Completed, Locked or Pending) are treated as sub-categories to the status 
categories.

To count the words and characters in a single file, for each individual file, or the whole project

1 In an open project, select Review> Word Count. 

–Or–

Press Ctrl+W.
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2 The Word Count dialog appears with individual tabs to display counts for Words, Characters 
and Tags. 

3 Make your selections from the following options:

Language—View the counts for the current language (the language combination that you are 
currently viewing) or all languages.

Files—View the counts for the currently displayed file (this option is disabled if you are 
viewing the complete project rather than an individual file), for each file or for all files.

Duplicates—Check whether you would like to have the words, characters and codes in 
duplicate rows counted and define what you want to be considered as a duplicate row 
(whether to consider differences in case, numerals or inline tags as differentiating factors and 
whether to take different translations into account as well).

Word Count—Decide whether you want to perform a word count according to Déjà Vu X3 
Workgroup’s internal logic or in line with MS Word’s logic (see p. 318).

If you only want to count the words in a single file, you will have to make sure that you 
view only that file. If you want to count words in the whole project, you can either 
choose the single file view or the project view.
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Output—View simple or full counts (see p. 311).

4 Select Calculate.

5 The desired word count is displayed.
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6 To view the corresponding character count, select the Character tab.

7 To view the corresponding count of tags, select the Tags tab.
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To save the results in an external file format

1 Select Copy in the Word Count dialog.

2 Open a text editor or word processor.

3 Paste the text into a new document.

–Or–

1 Select Save in the Word Count dialog.

2 A file selector dialog appears.

3 Choose the folder in which the file is going to be saved, name the file and select whether you 
want to save it as a text file or as a comma-separated value (.csv) file.

4 Click Save.

If you selected CSV as the output type and have Microsoft Excel installed on your computer, 
this file will open by default in Excel.
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USING THE WORD COUNT ACCORDING TO MS WORD

Under the option Word Count, you can select to count according to Déjà Vu X3 Workgroup’s 
internal word count logic or using the same parameters that MS Word uses.

While both word counts are internally logical and consistent, the benefit of the MS Word word 
count logic is that this is the way many clients count, providing a good way to avoid potential 
conflict.
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THE ANALYSIS FEATURE

The analysis feature allows you to analyze 

the number of matches from your translation memory(s) in a variety of degrees of 
fuzziness, 

the repetition within your project (intra-project) on both segment level and sub-segment 
level and 

the repetition between your project and other projects (inter-project) on a segment level.

To analyze the repetition of segments in a project

1 In a newly created project, select Project> Analyze.

–Or–

Press Ctrl+Shift+W.

You can perform the Analysis function at any point during the translation of your 
project (before pre-translation or well into the translation), but you will probably gain 
the best overview and the most benefit from the analysis if you do this before you start 
your actual translation work.
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2 The Analysis dialog appears.

3 Make your selections from the following options:

Language—Select whether to perform an analysis for only one or all target languages in 
the project.

Files—View the counts for the currently displayed file, for each file or for all files.

Duplicates—Check whether you would like to have the words, characters and codes in 
duplicate rows counted and define what you want to be considered as a duplicate row 
(whether to consider differences in case, numerals or inline tags as differentiating 
factors).

Translation Memories—Select which translation memory(s) you want to base the analysis 
on.

Additional Options—Under Word count you need to decide whether you want to 
perform an analysis according to Déjà Vu X3 Workgroup’s internal logic or in line with 
MS Word’s logic (see the description under p. 318).
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Furthermore, you need to select whether you want to perform an analysis based on the 
current project only (Intra-project analysis) or based on other projects to take potentially 
increased duplication into consideration (Inter-project analysis).

Also, you can decide to count (or exclude) locked segments. This is helpful when you 
have a great number of locked segments due to guaranteed matching or manual locking 
and you want to make sure that these don’t distort your analysis.

Once your options are selected, this dialog gives you access to an analysis of the following 
data for each language at the current state of the project:

number of guaranteed and exact matches from the translation memory(s);

duplicates within the project;

number of fuzzy matches in various levels (percentages) of fuzziness from the translation 
memory(s);

total number of (source) words in the project;

total number of no matches;

total number of locked segments (if that option was selected);

internal repetition of sub-segments in percentage.

If you want to see repetition both within the current and between the current projects 
and other projects, you will have to check both options.

If you select Inter-project analysis, the button Add/Remove is activated so that you can 
select other projects to include in the analysis.

The percentage of internal repetition is a very helpful number for you to consider. To 
arrive at this number, Déjà Vu X3 Workgroup looks at the project-internal  repetition of 
sub-segments. It analyzes all sub-segments of one, two or three words and gives you a 
good indication whether features like AutoWrite or the Lexicon would be helpful for 

this project. As a rule of thumb, any number of 10% or higher can be considered 
beneficial for those features.

To prevent the inclusion of words like articles or pronouns into this calculation, any word of three 
characters or less is automatically ignored (except in Chinese, Japanese or Korean).
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4 Select the language for which you want to perform the analysis and click Analyze.

5 Under All Files in the result field you can find the following information once the analysis is 
complete:

Number of files (under Files)

Average number of characters per word (Chars/word)

Number of Duplicates

Number of Guaranteed Matches, Exact Matches, various percentage of matches and 
anything below a 50% match (=No Match) in relation to matches in the specified 
translation memory(s), project-internal matches and matches between the current and 
other specified projects

Number of Locked rows

The percentage of Internal Repetition, i.e., the amount of subsegment repetition within 
your current project (see p. 321)

Note that this number includes only the duplicate segments that are not already 
covered by any of the following types. 
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To save the results in an external file format

1 Select Copy in the Analysis dialog.

2 Open a text editor or word processor.

3 Paste the text into a new document.

–Or–

1 Select Save in the Analysis dialog.

2 A file selector dialog appears.

3 Choose the folder in which the file is going to be saved, name the file and select whether you 
want to save it as a text file or as a comma-separated value (.csv) file.

4 Click Save.

If you selected HTML as the output type, the file will look similar to the following:
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 WORKING WITH DIFFERENT FILE FORMATS

One of Déjà Vu X3 Workgroup’s distinctive advantages is that you have the possibility of working 
with a wide range of file formats. Whatever type of file you work with, Déjà Vu X3 Workgroup 
presents you with a uniform interface, displaying only translatable text so you can work 
comfortably without having to worry about overwriting formatting and layout information.

Déjà Vu X3 Workgroup has built-in filters that allow you to work with:

Microsoft Word up to version 2003 (see p. 336 and p. 351)

RTF (see p. 341)

Microsoft PowerPoint up to version 2003 (see p. 342)

Microsoft Excel up to version 2003 (see p. 343)

Microsoft Office 2007 and above (see p. 345 and p. 351)

Apache OpenOffice/LibreOffice (see p. 353)

PDF (see p. 354)

Microsoft Access (see p. 357)

ODBC-compliant data sources (see p. 360)

FrameMaker (see p. 360)

PageMaker (see p. 367)

QuarkXPress (see p. 371)

InDesign (see p. 374)

Interleaf/Quicksilver (see p. 379)

Plain Text (see p. 380)

Help Content (CNT) (see p. 380)

Exceptions to this are Office files processed with the "Office (Live)" filter, PDF files and 
InDesign IDML files that are displayed in WYSIWYG mode (see p. 351). 
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HTML (including scripts and ASP) (see p. 381)

SGML/XML (for more information on SGML, see p. 385)

Java properties (see p. 391)

RC (see p. 391)

C/C++/Java source files (see p. 392)

RESX files (see p. 394)

YAML files (see p. 395)

GNU gettext files (see p. 396)

IBM TranslationManager (see p. 397)

Trados Workbench (see p. 399)

Trados TagEditor (see p. 400)

Transit NXT (see p. 403)

Wordfast TXML (see p. 404)

SDLX ITD (see p. 404) 

TMX (see p. 404)

XLIFF (see p. 402)

EBU subtitle files (see p. 406)

All of these formats are recognized by their appropriate extensions but can be reconfigured.

To reconfigure the default relationship between file format and file extension

1 If you need to change the default association between file format and file extension, select 
Project> Properties> Filters to change it for the current project.

–Or–
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Select File> Options> Filters to change it for all.

2 The Filters tab appears.

An example of when this may become necessary would include situations where you 
continuously have to work with Interleaf or Trados Workbench documents, both of 
which have the .doc extension, that by default is assigned to Word. 
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3 Select the extension for which you want to have the association changed.
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4 Select a new association from the drop-down list at the bottom of the screen.
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5 Click Replace.

6 Click Apply and/or OK.

7 A new default extension-filter association has been created. Now during the import process, 
the Interleaf filter will be applied to every .doc file.

To reconfigure the individual relationship between file format and file extension

When importing files, the default extension-filter association can be changed on an individual file 
basis.

1 When importing a file through the New Project Wizard, select Properties when you select the 
files that you are going to import.

–Or–

When importing selecting a file into an existing project, the default extension-filter association 
is displayed in a pane labeled Properties on the right side of the screen.
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2 Select the file in the Project Explorer pane and click the drop-down arrow that appears when 
you select the Filter segment, and select the desired filter for this specific file.

3 The new filter will be applied to this file during the import process.

To apply specific import options

All of the file formats have file-specific import options that you can select and apply to the import 
process.

1 When importing a file through the New Project Wizard, select Properties when you select the 
files that you are going to import.

–Or–
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When selecting a specific file in the Project Explorer pane, the import options for that format 
will be automatically displayed in a pane labeled Properties on the right side of the screen.

2 Make the appropriate selections by checking the check boxes.

3 Right-click the file name and select Import from the context menu.

In the Advanced Project Explorer its is possible to select many files at one time.
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4 The file is imported with the options you specified.

To apply global or project-wide import options for each file extension

Rather than specifying the format-specific import options for single or small numbers of files, it can 
be helpful to change the default option on a project-wide or even global basis.

You can change the options on the basis of the file extension. This means that although .htm files 
may be of the same format as .html files, they could have different import options.

1 Select Project> Properties> Filters to change the options for the current project.

–Or–

Select Tools> Options> Filters to change the import options globally.

2 The Filters tab appears.
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3 Select the extension for which you want to change the default import option for the current 
project.

4 Select the selector button ( ) to the right of the filter options in the lower part of the dialog.

5 The Default Filter Options dialog appears where you can make the desired changes.
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6 Click OK.

7 Click Apply and/or OK.

8 TIn this case the default filter options for every file with the extension .htm have now been 
modified.

GLOBAL IMPORT OPTIONS

Prevent Segmentation

There is one option that is common to all file formats: Prevent Segmentation. In fact, if you choose 
to import several files of more than one file format with the Advanced Project Explorer, this option 
will still be displayed in the Properties window.

By checking this option, you override all segmentation rules that you set under File> Options> 
Segmentation. For more information on setting up segmentation rules, see "Sentence 
Segmentation" on page 217.

The only segmentation rules that will still be followed when this option is checked are 

hard returns or their equivalents,

the end of cells (such as in tables or in Excel), or 

the end of other already-marked segments (such as in Trados Workbench or XLIFF files).

Encoding

Encoding is an import and export option for a variety of formats.

You should use this option sparingly. As a rule of thumb, the larger your translation 
segments become, the more difficult it will be for your translation memory to come up 
with good matches. Situations where this option may prove to be helpful could include 
software source files (RC, C/C++, Java) where existing glossaries often contain 

complete strings that encompass several segments, documents that are to be translated 
very freely (across source segment levels), or documents that are imported into Déjà Vu 
X3 Workgroup for the purpose of editing or proofreading.
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Clicking on the down-arrow at the end of the encoding line allows you to define a code page for 
the file(s) you are importing and/or exporting.

If a selection is not made during the import, Déjà Vu X3 Workgroup will select the code page that 
it recognizes in the source file (i.e., a Unicode UTF-8 file will be imported with that code page).

If you do not make a selection during the export, Déjà Vu X3 Workgroup will select the best code 
page based on the following information:

code page of the source file

the target language

the actual text found in the target file

the file format

MICROSOFT WORD 2003 AND BELOW

Déjà Vu X3 Workgroup includes support for Microsoft Word documents (.doc files). No special 
procedure is required to translate them; however, you must have Microsoft Word installed on your 
computer. 

It is recommended that you use the more versatile Office (Live) filter (see p. 351) for 
any kind of Word files. The Office (Live) filter is the default filter for .doc files. 
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WORD-SPECIFIC IMPORT OPTIONS

Ignore Hidden Text in Documents

This option controls whether hidden text in a Word document will be displayed in Déjà Vu X3 
Workgroup. 

Situations where this is a very helpful option include:

documents where you want to translate only a certain section and in which you can 
choose to hide the sections that are not translatable;

documents that contain hidden code, including WinHelp source files that contain 
hidden text defining "jumps" within the Help (see graphic below).

Ignore Field Results

This option refers to the rare situation where the result of a field needs to be translated.

Non-translatable Notes

The option for non-translatable notes refers strictly to WinHelp source files that contain footnotes, 
some of which are translatable and others which are not.

If you do not translate Help files, you do not have to worry about modifying this setting.
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In the following example of a WinHelp file, you can see both the hidden text and the markers for 
the footnotes.

Run CodeZapper

CodeZapper is a tool that was developed by CAT tool user David Turner to eradicate superfluous 
tags in MS Word-based files and Atril has to integrated CodeZapper directly into Déjà Vu X3 
Workgroup. This is how David Turner describes the tool on his website (www.asap-
traduction.com):

"CodeZapper" is a powerful, easy to use set of Word VBA macros designed to “clean up” 
Word files before being imported into a standalone translation environment. Word 
documents are often strewn with “rogue codes” or junk tags (so-called “smart tags”, language 
tags, track changes tags, spellchecker tags, soft hyphenations, scaling and spacing changes, 
redundant bookmarks, etc.).

This tagged information shows up in the translation grid as spurious codes{1}around{2}, or 
even in the mid{3}dle of, words, making sentences difficult to read and translate and 
generally negating many of the productivity benefits of the program. OCR’d files or PDF 
converted files are even worse and often end up as a “code soup”. CodeZapper attempts to 
safely remove as many of these unnecessary tags as possible while retaining formatting and 
layout.

You can activate the tool by selecting the Run CodeZapper checkbox.
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WORD-SPECIFIC EXPORT OPTIONS

When you export a Word document, you will be presented with the following filter-specific 
options:

Export source comments as Office comments—allows the export of source comments to Microsoft 
Word comments.

Export target comments as Office comments—allows the export of target comments to Microsoft 
Word comments.

Highlight text in exported files—allows the highlighting of text according to the translation status in 
Déjà Vu X3 Workgroup.

Selecting the option Highlight text in exported files activates two more options:

Highlight options—lets you access a dialog that allows you to select what kind of rows should be 
highlighted in what manner.

Highlight order of preference—lets you choose whether rows with Translation Status (pending, 
locked, etc.) or Match Type (exact, fuzzy, assembled, etc.) should take preference.

Clicking on the file selector button on the Highlight options row (the file selector only becomes 
activated when you actually select the row) brings up the Segment Highlight Options dialog.
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Clicking Add lets you select individual formatting options (including any combinations of bold, 
italics, underline, strikethrough, text color, or underlying color) for as many different Segment 
Types as you like.

When you are done with your selection, click OK.

Assuming that the Word file in the following Déjà Vu X3 Workgroup project had one pending line 
and one comment—
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—and the user chooses to display comments in Word and highlight pending segments in bright 
magenta, the exported file would look like this:

RTF (RICH TEXT FORMAT)

The options for RTF files are almost identical to that of Word (see "Microsoft Word 2003 and 
below" on page 336), only that there is no need to have an installation of Word on your computer 
and therefore the security settings in Word have no influence on the import process.

Tips and Tricks with Word

When importing Word documents, Déjà Vu X3 Workgroup will run macros in the Word program 
that you have installed. If your version is Word 2000 or 2003, you will have to set the security 
settings (Tools> Macro> Security) in Word to Medium or Low to be able to import and 
export Word files. 

If character spacing was used in your document, it is advisable to take it out before importing the 
document into Déjà Vu X3 Workgroup. You can do this by selecting the complete document 
(Ctrl+A) and then selecting Format> Font> Character Spacing> Spacing> Normal.

If you have used the Track Changes or the Comments function in Word, make sure that you accept 
all changes and delete all comments before you process the Word document. Otherwise, you will 
see both options (before and after edit) as well as the text of the comments displayed in Déjà Vu X3 
Workgroup.

Déjà Vu X3 Workgroup adheres strictly to the Microsoft RTF standard of Word 2007 
and lower, and will process any files that follow that standard. There are several non-
Microsoft applications that export RTF files; in some situations, these applications may 
export RTF files that do not conform to the standard. In such cases, it is possible that 

Déjà Vu X3 Workgroup may not be able to correctly import those RTF files.
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MICROSOFT POWERPOINT 2003 AND BELOW

As is the case with Word files, no special procedure is required to translate PowerPoint .ppt files. 
However, you must have Microsoft PowerPoint 97 (or later) installed on your computer.

POWERPOINT-SPECIFIC IMPORT OPTIONS

It is recommended that you use the more versatile Office (Live) filter (see p. 351) for 
any kind of PowerPoint files. The Office (Live) filter is the default filter for .ppt files. 

Because of the way in which Déjà Vu X3 Workgroup works with PowerPoint files, once 
a translation is finished and ready to be exported, the original, unaltered .ppt file must 
be in the location from which it was imported. This is essential, because any slight 
modification to the file may prevent Déjà Vu X3 Workgroup from being able to export 

the final translation.
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Ignore Master Slides

This option controls whether the Slide Master that contains formatting information is to be 
included in the translation project. Typically you do not need to translate the information on the 
Slide Master.

Ignore Slide Notes

This option controls whether PowerPoint notes are included in the translation project. To see 
whether you have notes in your project, open the PPT file in PowerPoint and select View> Notes 
Page.

MICROSOFT EXCEL 2003 AND BELOW

As with Word files, no special procedure is required to translate Excel .xls files. However, you must 
have Microsoft Excel 97 (or later) installed on your computer.

Because of the way in which Déjà Vu X3 Workgroup works with Excel files, once a translation is 
finished and ready to be exported, the original, unaltered .xls file must be in the location from 
which it was imported. This is essential, since any slight modification to the file may prevent Déjà 
Vu X3 Workgroup from being able to export the final translation.

Tips and Tricks with PowerPoint

PowerPoint files are often written by people who are inexperienced in formatting documents. 
Instead of using styles and correctly sized text boxes, they tend to use soft returns and hard returns 
to force line breaks. Déjà Vu X3 Workgroup will ignore soft returns by default, but it will break a 
segment in which a hard return occurs. To avoid that, it is a good practice to go through the 
PowerPoint document and replace all the unnecessary hard returns with soft returns.

PowerPoint files often contain graphics that at first sight look just like text. If there is a whole slide or 
a part of a slide that has not been imported into Déjà Vu X3 Workgroup, make sure that this is not 
a graphic or another non-translatable object. To do that, you can right-click that specific area in the 
open PowerPoint file. If one of the options is either Format Picture or Format Object, chances are 
that you will not be able to use Déjà Vu X3 Workgroup for the translation of this.

It is recommended that you use the more versatile Office (Live) filter (see p. 351) for 
any kind of Excel files. The Office (Live) filter is the default filter for .xls files. 
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EXCEL-SPECIFIC IMPORT OPTIONS

Ignore Red Text in Worksheet Cells

Excel files often contain both translatable information and other information that you do not want 
to have translated. Instead of having to go through an imported Excel file and manually sorting out 
the information that needs to be translated, you can open the file in Excel, highlight the cells that 
do not have to be translated, and paint them red by right-clicking and selecting Format Cells> 
Font> Color. 
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Déjà Vu X3 Workgroup will now ignore text in these cells when it imports the file. When the file 
has been translated and exported, you can remove the red formatting.

MICROSOFT OFFICE 2007 AND ABOVE (OPEN XML)

The formats between MS Office 2003 and later versions have dramatically changed. Whether it is 
Excel, PowerPoint or Word documents or templates, they are all based on XML and can all be 
processed with one filter. The supported file extensions include DOCM, DOCX, DOTM, DOTX, 
POTM, POTX, PPTM, PPTX, XLSM, XLSX, XLTM and XLTX.

MS OFFICE 2007/2010-SPECIFIC IMPORT OPTIONS

Tips and Tricks with Excel

It is not possible to join lines in Excel files between segments. However, you will be able to join two 
segments that originate from the same cell.

In situations where a target column has to be added to a source column (rather than overwriting 
the existing source), you can duplicate the source column within Excel and paint the first of the 
columns red. If you then enable Ignore Red Text in Worksheet Cells during the import into Déjà Vu 
X3 Workgroup, the first column will not be imported and thus not be changed, and the second 
column will be imported and translated.

It is recommended that you use the more versatile Office (Live) filter (see p. 351) for 
any kind of Office files. The Office (Live) filter is the default filter for Word, PowerPoint 
or Excel files. 
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The options associated with this filter are partly a combination of the MS Word filter (Ignore 
Hidden Text in Documents, Ignore Field Results, Non-translatable Notes, Run CodeZapper — see 
"Word-Specific Import Options" on page 337), the PowerPoint filter (Ignore Master Slides, Ignore 
Slide Notes — see "PowerPoint-Specific Import Options" on page 342), and the Excel filter (Ignore 
Red Test in Worksheet Cells — see "Excel-Specific Import Options" on page 344), but there are 
some powerful options that are only available in this filter.

Process embedded HTML

It is not uncommon for clients to paste HTML content into Excel files for translation purposes. The 
Process embedded HTML option allows you to have Déjà Vu X3 Workgroup convert HTML tags 
into protected tags for easier and more secure translation.

As a result, this Excel file 
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will be displayed like this in Déjà Vu X3 Workgroup:

Ignore Regex Matches

The option Ignore Regex Matches can be used in any of the Office formats. It allows you to 
exclude certain text that follows a pattern from the display in Déjà Vu X3 Workgroup or to convert 
that text into easily processed and secure tags. 

You will need some expertise in writing regular expressions to use that option. You can find a 
comprehensive tutorial for regular expressions at www.regular-expressions.info. A Déjà Vu X3 
Workgroup-specific tutorial can be found at https://www.youtube.com/watch?v=C2PUtObxsp8.

Ignore Document Properties

This option allows for the import of document properties into Déjà Vu X3 Workgroup. This is the 
meta-data about Office documents that’s available under File> Info within Office 2010 and above 
(Office 2007: Office Button> Prepare> Properties).

It you need to enter more than one regular expression statement into the field of the 
regex option, you will need to isolate each of the statements with (parentheses) and 
separate them from each other with a pipe character: |.

Here is an example:
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Document properties in a Office 2013 document:

The same properties imported into Déjà Vu X3 Workgroup:

Ignore Embedded Objects

Déjà Vu X3 Workgroup allows the processing of embedded Office documents within Office 
documents as long as they are supported by Déjà Vu X3 Workgroup. This means that either a 
Word, Excel or PowerPoint file can contain an embedded Word, Excel or PowerPoint file, which 
will also be processed and imported into Déjà Vu X3 Workgroup once the "master" file is imported.
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If you have a copy of Microsoft Office 2007 or above installed on the same computer on which 
you also have Déjà Vu X3 Workgroup installed, you will notice that there are additional ribbon 
tabs in Word, Excel or PowerPoint:

These commands have two purposes:

Check whether there are embedded Office files of the MS Office 2003 and earlier in 
your file (DOC, XLS, or PPT files) and convert them to the later format (DOCX, XLSX, 
and PPTX) and 

Reload the image of the embedded file that Word displays once the translation is 
finished.

To detect and convert legacy Office files

1 Open your Office document that contains an embedded Office file and click Check All 
Objects.

2 If there are embedded documents detected, you will be informed about their number and 
format in the ensuing dialog:

3 If there are any documents of the Office 2003 or earlier format among them, you will be 
advised to perform a conversion.
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4 Click Convert All Objects to Office 2007-2013.

5 You will be informed about the successful conversion.

6 If you now import the document with the embedded files into Déjà Vu X3 Workgroup, the 
content of the embedded files will be extracted.

To reload the image of the embedded file

Once your translation is finished and you have exported the file with the embedded and 
translated object, the objects will still appear to be untranslated once you open the original file. 
The reason for that is that rather than showing the live file, MS Office just shows an image of the 
(previous and untranslated version of the) file. 

1 To exchange the old image with the current one, click Refresh All Objects on the Déjà Vu X3 
ribbon tab in MS Office.

2 You will be informed that the embedded object(s) were refreshed.

3 And the image of the embedded object now corresponds to the translated file.

SPECIFIC EXPORT OPTIONS FOR WORD 2007 AND ABOVE

The export options are identical to "Word-Specific Export Options" on page 339.
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MICROSOFT OFFICE (LIVE)

The Microsoft Office (Live) filter is similar to the Microsoft Office 2007/2010 filter (see "Microsoft 
Office 2007 and above (Open XML)" on page 345) with two major differences and a few minor 
differences:

You can process Microsoft Office files of any version (DOC, DOCX, PPT, PPTX, XLS, 
XLSX files) and most RTF files with it.

It’s the only filter for Office files which the Live preview as well as the WYSIWYG 
formatting is enabled.

It allows you to process the text within comments that have been added with the 
comments function to Excel, PowerPoint and Word files.

It does not support the features Non-Translatable Notes, Run CodeZapper (the filter uses 
a different method to suppress unnecessary codes) and Ignore Document Properties (see 
p. 337, p. 347 and p. 338).

WYSIWYG (WHAT-YOU-SEE-IS-WHAT-YOU-GET) FORMATTING, LIVE PREVIEW AND 
IMPORTED COMMENTS

Documents that have been imported with the Microsoft Office (Live) filter will be displayed in the 
translation grid with the most common formatting (bold, italics, underline, superscript, and subscript) 
as well as tab characters in actual formatting rather than with the aid of tags. 
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The corresponding translated segment can have the same formatting (which can be applied with 
the corresponding icons under Text Formatting on the Home ribbon tab or with keyboard 
shortcuts—Ctrl+B for bold, Ctrl+I for italics, Ctrl+U for underline, Ctrl+= for subscript and 
Ctrl++ for superscript) but—unlike if and when you solely have to rely on inline tags—does not 
have to be identical. 

Take this imported MS Word file, for instance:

The formatting of the first segment has been changed from bold to italics.

The formatting of the second segment has been changed (italics to bold) and added to 
(superscript in the number).

The sixth segment contains formatting that cannot be displayed with Déjà Vu X3 
Workgroup’s (red font color). So the traditional approach with tags is being used.

Underneath the translation grid, you can see the Preview pane (which you have to 
enable under View> Preview) that displays a realtime preview of the document in its 
original formatting.
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The third segment contains text that is not immediately displayed in the Preview pane 
because it is a comment that has been imported because the option Import Comments 
in the Import Options was checked. 

SPECIFIC EXPORT OPTIONS FOR MICROSOFT OFFICE (LIVE)

The export options are identical to "Word-Specific Export Options" on page 339.

OPENOFFICE AND OPEN DOCUMENT

Déjà Vu X3 Workgroup supports the files of OpenOffice 1 with the OpenOffice filter. The 
supported file types include word processing (SXW), spreadsheets (SXC) and presentations (SCI). 
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Later version of OpenOffice and LibreOffice are supported with the OpenDocument filter. The 
supported file extensions for this filter include ODC, ODF, ODG, ODI, ODM, ODP, ODS, ODT, 
OTC, OTF, OTG, OTI, OTP, OTS, OTT.

PDF

Even though the PDF format is a very common format, it has always presented a lot of challenges 
for translators since the text is not easily accessible and therefore not easily importable into CAT 
tools. Like many of its competitors Déjà Vu X3 Workgroup offers possibilities to process PDF files 
through third-party tools but it’s important to keep in mind that the processing of PDF files is not 

Tips and Tricks with OpenOffice/LibreOffice files

If you have used the Record Changes or the Notes function in an OpenOffice document, make 
sure that you accept all changes and delete all comments before you process the document. 
Otherwise, you will see the corrected option displayed at the beginning of the document as well as 
the text of the notes displayed in Déjà Vu X3 Workgroup.

It’s possible to make good use of OpenOffice/LibreOffice’s AutoFormat option. It’s not possible to 
add formatting that is not contained in the source documents to your SWX/ODT documents 
directly within Déjà Vu X3 Workgroup, but you can enclose words with certain 
characters (such as _these_ for underline and *these* for bold formatting) and use OpenOffice/
LibreOffice’s AutoFormat feature (Tools> AutoCorrect Options> Options) to apply the desired 
formatting. Here are the preconfigured AutoFormat options that OpenOffice/LibreOffice offers:
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nearly as smooth as it is with other file formats. Depending on the complexity of the originating 
PDF file, it is typically necessary to spend time after the translation to format and clean up the 
resulting DOC file (the PDF file is internally converted to a DOC file). It is therefore always 
preferable to work in the originating format from which the PDF was created.

Déjà Vu X3 Workgroup offers two different internal modules to process PDF files:

The Aspose PDF converter (see www.aspose.com) and

The Microsoft Word 2013/365 PDF converter (requires an installation of Microsoft Office 
2013/365) 

PDF-SPECIFIC IMPORT OPTIONS

Use PDF converter in Word 2013

The default option for the import of PDF files is the Aspose PDF converter. For many types of PDF 
files, the Word 2013 might be better suited. 
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Here is an example. This is a file processed with the Aspose filter:
 

And here is the same file processed with the Office 2013 option selected:
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You can see that not only the segmentation is better with the Word 2013 option, but, since it 
internally uses the MS Office (Live) filter (see p. p. 351), the formatting contains actually formatted 
words (where applicable) rather than tags, plus the Preview feature (see p. 352) displays a much 
better formatted file.

Use textboxes for layout

This option is available only if you don’t use the Office 2013 option. If selected, it will place the 
translated text into individual text boxes rather than flowing text. This option is advisable if you are 
translating a PDF file that originated from a file that made heavy use of textboxes or stories for the 
purpose of separating different blocks of text. 

MICROSOFT ACCESS

Though the translation of database content has become very important, it still presents a great 
challenge to translation memory tools.

Typically, only a small part of the database—often only one field (of many hundred 
existing ones)—needs to be translated.

By overwriting the content of the translatable field, relationships may get lost.

The records may contain a variety of text—including HTML, RTF, and SGML, to only 
name a few—for which other specified filters are necessary.

Déjà Vu X3 Workgroup has found creative ways to deal with these challenges, and it supports 
Access97, 2000 and XP (2002) files. 

ACCESS-SPECIFIC IMPORT OPTIONS

If you are unsure which of the two PDF filter options to use, it might be a good idea to 
import a sample file or two of the files in question and see how they are being 
processed by Déjà Vu X3 Workgroup.
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When you select the Custom field, an ellipsis button appears to the right of that line. If you click 
that button, the ODBC Import Options dialog appears.

In this dialog, you can see the tables of the database in question (under Tables), the fields or 
columns in each of the tables (under Columns), and you can see samples of the content of the 
fields on the right side of the dialog. By default, all fields are selected as non-translatable; indeed, 
in this example, only one field, "s_content," needs to be translated.
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By selecting that field, checking the Translate check box, specifying the type of text that needs to 
be translated (in this example Plain Text), and specifying that the translation should be sent to the 
field "t_content" under Send translation to field, you can easily set up the translation of the relevant 
content of this database.

For options to define the code page during export and import, see "Encoding" on page 335.
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ODBC-COMPLIANT DATA SOURCES

If you have ODBC-compliant data sources installed on your computer, you can access them in the 
Advanced Project Explorer through Data Sources (ODBC).

Once you have connected your data source, the import and export processes are virtually 
identical to Microsoft Access. For more information, see "Microsoft Access" on page 357.

ADOBE FRAMEMAKER

Déjà Vu X3 Workgroup includes support for Adobe FrameMaker 5 and above MIF files.

To convert an FM file to MIF format

1 Open the file you want to convert in Adobe FrameMaker 5 and above.

2 On the File menu, click Save As.

Déjà Vu X3 Workgroup cannot import FrameMaker binary FM files; if you have an FM 
file that you want to translate in Déjà Vu X3 Workgroup, you must convert it to MIF 
format.
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3 The Save Document dialog appears.

4 Select the path you want to save the document to.

5 Click the Save as type dropdown list and select MIF (*.mif).

6 Click Save.

If available, you should save as a MIF 10.0 or above rather than a MIF 7.0 file, since 
only the former is fully Unicode compliant.

If you do not own a copy of FrameMaker, you should ask your client to send 
FrameMaker files in MIF format.
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FRAMEMAKER-SPECIFIC IMPORT OPTIONS

Exposable Markers

The default setting for exposable markers is 2 (index markers). This is a setting that you probably 
do not want to change, as index markers usually are the only translatable markers.

Ignore Variable Definitions

If checked, Déjà Vu X3 Workgroup will ignore all variable definitions, such as the book title.

Ignore Automatic Numbering

If checked, Déjà Vu X3 Workgroup will ignore all automatically generated automatic numbering 
information, such as Section 1.1.1.1 or Table 1.1.1.1.

Ignore Cross-Reference Definitions

If checked, Déjà Vu X3 Workgroup will ignore all automatically generated cross-reference format 
texts, such as See XX on page XX, etc.

Ignore Text on Master Page

If checked, Déjà Vu X3 Workgroup will ignore all text on the master page, including all non-
variable information in the header and footer.

Convert Hard Spaces to Soft Spaces

If checked, Déjà Vu X3 Workgroup will convert all non-breaking spaces (inserted into the 
FrameMaker document with the key combination Ctrl+Space) to regular spaces. If unchecked, 
Déjà Vu X3 Workgroup will embed all non-breaking spaces with a tag. Generally, this option 
should be enabled.
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FONT MAPPING

It may be necessary to change the fonts for translations into languages that use a completely 
different font system from your source language (i.e., from English to Chinese, or from Japanese to 
German). 

To access the MIF Font Mapping tab, select Project> Properties> MIF Font Mapping.

You can now see a list of all fonts and their properties used in the FrameMaker files within your 
project. 

To make changes to the individual fonts, select a different font by clicking the down arrow to the 
right of the Map to row and making the other appropriate changes in each of the other rows 
(Angle: regular or italic; Weight: regular or bold; Variant: regular, oblique, narrow, or condensed; 
Size; and—in the case of Japanese—Tsume: to move a character closer to the next).

When you are done with your changes, click Apply and/or OK.

You can also change the fonts globally by selecting Global Replacement and selecting a different 
font by clicking the down arrow to the right of the Map to row in the Global Font Replacement 
dialog.
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By using the up and down arrows to the right of the Size delta rows, you can make proportional 
adjustments to the size of the fonts.

FRAMEMAKER-SPECIFIC EXPORT OPTIONS

When you export a FrameMaker document, you will be presented with the following filter-specific 
options:

Export source comments as conditional text—allows the export of source comments to the 
DVXSourceComments condition.
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Export target comments as conditional text—allows the export of target comments to the 
DVXTargetComments condition.

Highlight text in exported files—allows the highlighting of text according to the translation status in 
Déjà Vu X3 Workgroup.

Selecting the Highlight text option activates two more options:

Highlight options—lets you access a dialog that allows you to select what kind of rows should be 
highlighted in what manner.

Highlight order of preference—lets you choose whether rows with Translation Status (pending, 
locked, etc.) or Match Type (exact, fuzzy, assembled, etc.) should take preference.

Clicking on the file selector button on the Highlight options row (the file selector only becomes 
activated when you actually select the row) brings up the Segment Highlighting Options dialog.

Clicking Add lets you select individual formatting options (including any combinations of bold, 
italics, underline, strikethrough, or text color) for as many different Segment Types as you like.

When you are done with your selection, click OK.
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Assuming that the FrameMaker file in the following Déjà Vu X3 Workgroup project had one 
pending line and one comment—

—and the user chooses to display target comments in FrameMaker and highlight pending rows in 
bright magenta, the exported file would look like this:

 

You can choose to display or hide conditions in FrameMaker with the command 
Special> Conditional Text> Show/Hide Conditional Text.
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ADOBE PAGEMAKER

Déjà Vu X3 Workgroup includes support for Adobe PageMaker 6.5 and 7 files.

To process Adobe PageMaker documents, you must first save the text you want to translate as a 
"tagged text" file.

To export a story

1 Open the file you want to process in PageMaker.

2 In Layout view, click anywhere on the story you want to export.

3 Select Edit> Edit Story.

4 The story appears as editable text. 

5 Select File> Export> Text.

Tips and Tricks with FrameMaker

If all files of your FrameMaker book follow one or possibly two sets of formats, you can avoid a 
large amount of repetition in your project by doing the following: Uncheck all the special "Ignore" 
options for one representative file and check them for all other files. Once you have exported all of 
your files, you can import the formats of the representative file to all other files (in FrameMaker, 
select, File> Import> Formats).

Make sure that your FrameMaker files do not contain any change bars (markers that indicate 
changes to the file). To delete existing change bars, select Format> Document> Change Bars> 
Clear All Change Bars. 
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6 The Export Document dialog appears.

7 Select the correct export location.

8 Accept the default name or enter a name for the export file.

9 Click the Save as type dropdown list and select Tagged text.

10 Make sure the options Entire story and Export tags are selected.

11 Click Save.

You can either repeat this procedure for each text chain (which constitutes a story) in the 
PageMaker document, or you can combine and export all stories within one document.

To combine and export stories

1 Open the PageMaker document from which you want to combine and export stories.

2 Select File> Save As. 

3 Save the document as A copy in 6.0 format (PageMaker 7: A copy in 6.5 format).

4 Open a new PageMaker publication by selecting File>New.
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5 In the Document Setup dialog, adjust the settings to match the settings from the original.

6 Select File>Place, select the formerly saved document, and then click OK.

7 The Place PageMaker Stories dialog appears, listing every story in the publication in the order 
in which they were placed.

8 If necessary, enter 1 into the characters field to include all stories and click Relist.

9 Click Select All to combine all stories in the document, or hold down the Shift key while 
clicking on the stories you want to combine, and then click OK.

10 The pointer changes to a loaded icon ( ).

11 Click the loaded icon. All the stories are pasted into the new document as one story.
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12 To export this story into a text file, see "To export a story" on page 367.

When you have imported, translated, and exported the tagged TXT file in Déjà Vu X3 Workgroup, 
you have to replace the text into the PageMaker document.

To re-import the story

1 Make a copy of the original file from which you exported the tagged text file.

2 Open the copy in PageMaker.

3 In Layout view, click anywhere on the original story you want to replace.

4 On the Edit menu, click Edit story.

5 On the File menu, click Place.

6 The Import to Story Editor dialog appears.

This procedure will not copy any non-text items (such as graphics) into the new 
document, so you will have to either manually paste those into the new document or 
revert to exporting each story individually in the old document.
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7 Select the TXT file which Déjà Vu X3 Workgroup has exported (the one containing the final 
translation).

8 Make sure that the following options are selected:

In the Place option group: Replacing entire story.

In the Options option group: Retain format, Convert quotes, and Read tags.

9 Click Open.

10 The translation is being imported.

Encoding

For general options to define the code page during export and import, see "Encoding" on page 
335.

Because PageMaker does not support Unicode, none of the Unicode code pages is offered. If you 
use the default encoding option, Déjà Vu X3 Workgroup will select the code page that is used in 
the file (import) or select one according to the target language (export).

QUARKXPRESS

Déjà Vu X3 Workgroup includes support for QuarkXPress 4 and higher.

To process QuarkXPress documents, you must first save the text you want to translate as an XPress 
Tag file.

To export text as an XTG file

1 Open the file you want to process in QuarkXPress.

Tips and Tricks with PageMaker

PageMaker files are often delivered in Mac format. Though it is usually no problem to open these 
files on a PC, your client may not want you to convert these files to PC files. To avoid problems 
with special characters in the original or translated TXT files, you will have to change the code page 
of the tagged file between Mac and Windows. Do this by selecting a Mac code page during the 
import and export processes.

Double-byte PageMaker files (Chinese, Japanese, Korean) can only be opened and processed on a 
native (Chinese, Japanese, or Korean) version of PageMaker.
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2 Make sure that the Content tool ( ) is selected. If it is not displayed, press F8.

3 Click the text box that contains the beginning of the text chain you want to export.

4 Select File> Save Text.

5 The Save Text dialog appears.

6 Select the correct export location.

7 Enter a name for the export file.

8 Click the Save as type dropdown list and select XPress Tags.

9 Make sure the option Entire Story is selected.

10 Click Save.

After you have imported, translated, and exported the .xtg file in Déjà Vu X3 Workgroup, you have 
to replace the text into the QuarkXPress document.

To re-import the XTG file

1 Make a copy of the original file from which you exported the .xtg file.

2 Open the copy in QuarkXPress.

3 Click the text box containing the beginning of the story you exported.

For each text chain (which constitutes a story) in the XPress document, you will have to 
repeat this procedure because QuarkXPress does not provide an automated way of 
exporting all the stories together.
Déjà Vu X3    372



Working with Different File Formats
4 Select File> Get Text.

5 The Get Text dialog appears.

6 Select the XTG file which Déjà Vu X3 Workgroup has exported (the one containing the final 
translation).

7 Make sure that the Include Style Sheets option is selected.

8 Click Open.

9 The translation is being imported.

Encoding

For general options to define the code page during export and import, see "Encoding" on page 
335.
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As QuarkXPress before version 7 did not support Unicode, none of the Unicode code pages are 
offered for those versions. If you use the default encoding option, Déjà Vu X3 Workgroup will 
select the code page which is used in the file (import) or select one according to the target 
language (export).

INDESIGN

Déjà Vu X3 Workgroup includes support for various versions of InDesign with different filters

InDesign 2 and CS with the Adobe InDesign Tagged Text filter

InDesign CS2 through CS4 with the Adobe InDesign INX filter

InDesign CS4 and higher with the Adobe InDesign IDML filter

INDESIGN 2 AND CS

To process Adobe InDesign documents, you must first save the text you want to translate as a 
"tagged text" file.

To export a story

1 Open the file you want to process in InDesign. 

2 Select the Type tool ( ) and click in the story you want to export. 

3 Select File> Export. 

Tips and Tricks with QuarkXPress

For jobs that contain a large number of stories, we recommend that you obtain a thirds-party tool.

CopyFlow Gold for Quark exports text from all the stories in the document to a single TTG file, a 
format that can be read by the XTG filter (for more information, see napsys.com). Presently 
CopyFlow only supports Quark files up to version 9.

Another third party product, ex TranslationFilter by CoDesCo (see www.codesco.com/en/ex-
translationfilter.html), converts Quark files into XLIFF files that then can be processed in Déjà Vu X3 
Workgroup. This product also supports Quark 10 and above. 
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4 The Export dialog appears.

5 Specify a name and location for the exported story, and select Adobe InDesign Tagged Text 
under Save as Type.

6 Click Save.

7 The Adobe InDesign Tagged Text Export Options dialog appears.

8 Select Verbose under Tag Form and the correct encoding under Encoding.

9 Click OK.

When you have imported, translated, and exported the tagged .txt file in Déjà Vu X3 Workgroup, 
you have to replace the text into the InDesign document.

Make sure that you select Unicode if you are translating into or from any non-Western 
language. 
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To re-import the story

1 Open the .indd file in InDesign.

2 Select the Type tool ( ) and click in the story you want to import. 

3 Select File> Place. 

4 The Place dialog appears.

5 Select Convert Quotes, Retain Format, and Replace Selected Items and navigate to the 
location of your translated file.

6 Select the file and click Open.

7 The translation is being imported.

Encoding

For general options to define the code page during export and import, see "Encoding" on page 
335.

There is no need to define a code page for the import because Déjà Vu X3 Workgroup will take 
that information from the header of each InDesign file. The possible export code pages include 
ANSII, ASCII, Unicode, ShiftJIS, and Big5. If you use the default encoding option, Déjà Vu X3 
Workgroup will select the code page according to the target language (export).
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INDESIGN CS2 THROUGH CS4

Starting with InDesign CS2, Adobe introduced the exchange format INX, which is XML-based and 
allows you to export all stories into one file. To save an InDesign .indd file as an .inx file, select 
File> Export in InDesign, select InDesign Interchange under Save as Type, and save the file in an 
appropriate location under Save as Type. 

Once the translation is finished, and the .inx file exported out of Déjà Vu X3 Workgroup, you can 
open it up in InDesign with the command File> Open and save as a .indd file.

INDESIGN CS4 AND HIGHER

Starting with InDesign CS4, Adobe introduced yet another exchange format. It’s called IDML and 
allows for an even more seamless conversion between different tools, including CAT tools. 

The IDML filter supports the same WYSIWYG capabilities as the MS Office (Live) filter does, 
though it does not support the Live Preview with full formatting (see p. 351).
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To save an InDesign .indd file as an .idml file, select File> Export in InDesign, select InDesign 
Markup under Save as Type and save the file in an appropriate location under Save as Type. 

Once the translation is finished, and the .idml file is exported out of Déjà Vu X3 Workgroup, you 
can open it up in InDesign with the command File> Open and save it as an .indd file.

IDML-SPECIFIC IMPORT OPTIONS

Ignore Locked Text Frames

You can lock specific text frames within InDesign (select Object> Lock) and prevent the import 
into Déjà Vu X3 Workgroup and the translation of certain parts of the InDesign document with the 
help of this option. This is particularly helpful when working with multilingual documents.

Ignore Line Breaks

This option prevents the break of a segment if the author of an InDesign document used soft or 
hard returns for line breaks in the middle of sentences.
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INTERLEAF/QUICKSILVER

Déjà Vu X3 Workgroup can process Interleaf/QuickSilver ASCII files exported with Interleaf 6 or 
later. Binary Interleaf/Quicksilver files are not supported, so make sure that you save the Interleaf/
QuickSilver documents as ASCII, or ask your client to do so if you do not own a copy of Interleaf/
QuickSilver.

To save an Interleaf /QuickSilver document in ASCII format

1 Open the document in Interleaf/QuickSilver.

2 On the File menu, click Save As.

3 The Save As dialog appears.

4 Select the correct folder and enter the name of the file you want to save to.

5 Click the Save as type dropdown list and select ASCII (*.doc).

6 Click Save.

INTERLEAF/QUICKSILVER-SPECIFIC IMPORT OPTIONS
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Ignore Hidden Text in Document

All components of an Interleaf/QuickSilver document are defined at the beginning of a file. These 
components include text. The option Ignore Hidden Text in Documents ignores any components 
that are marked as hidden.

Ignore Text in Neutral Language

The option Ignore Text in Neutral Language ignores any components with the marker "invariant 
culture," i.e. a language-neutral ID (127/0x007F).

Ignore Text in Other Languages

The option Ignore Text in Other Languages ignores any components with a language ID different 
from the source language of the Déjà Vu X3 Workgroup project.

Ignore Classes

The option Ignore Classes allows you to manually enter classes that you want to ignore during the 
import process. Classes might include common document elements such as body, paragraphs, 
titles, subheadings, captions, etc.

TEXT

Déjà Vu X3 Workgroup can, of course, process plain text files. For general options to define the 
code page during export and import, see "Encoding" on page 335.

All code pages that are supported by Windows can be selected for the export or import. If none is 
selected for the import, Déjà Vu X3 Workgroup will detect the code page in the file or choose the 
code page best suited for the language in the source file. If no code page is selected for the export, 
Déjà Vu X3 Workgroup will choose the best suitable code page for the target language and/or the 
actual content, with a preference to Unicode (UTF-16). 

HELP CONTENTS

Help content files are simple text files that automatically create the table of contents in a WinHelp 
file.
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View of a Help Contents .cnt file in a text editor:
 

Déjà Vu X3 Workgroup will ignore the non-translatable content following the equal signs and the 
numbers when importing these files.

HTML AND SCRIPT-BASED FILES

Déjà Vu X3 Workgroup includes extended support for HTML and script-based files. 

HTML-SPECIFIC IMPORT OPTIONS

Ignore Strings in Script

This option controls whether translatable text in scripts such as JavaScript or VBScript should be 
translated or excluded. 

Unless you know that there is no translatable text within any script, you should not 
enable this option.
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Déjà Vu X3 Workgroup will usually be able to separate translatable from non-translatable content 
in HTML files and display the translatable content correctly. Because of the nature of customizable 
and regularly re-defined scripting languages, there may be situations where some text is imported 
that should not be translated. You can choose to copy this text from the source to the target 
column and possibly lock those rows, but Déjà Vu X3 Workgroup also allows you to write simple 
regular expression files that would exclude these lines. For more information on this, see "Creating 
Customized HTML Import Files" on page 533.

HTML-SPECIFIC EXPORT OPTIONS

When you export a file that adheres to the HTML specification, you will be presented with the 
following filter-specific options:

Encoding—Regardless of the format of the imported file, you can choose to export the files in any 
of the code pages that are supported by Windows. When exporting the file, Déjà Vu X3 
Workgroup will not only change the actual code page but also the corresponding META tag (if 
applicable).

In the above example of a Thai file, after the export the meta tag will read:

There are a number of advanced options to import HTML files that require the creation 
of customized import files. You can find more information about that under "Creating 
Customized HTML Import Files" on page 533.
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<META http-equiv=Content-Type content="text/html; charset=windows-874">

Export special characters as entities—if you select this option, special characters will be exported 
in the appropriate code (© will, for instance, be exported as &copy;). 

Export source comments as pop-up text—allows the export of source comments to text in HTML 
pop-ups.

Export target comments as pop-up text—allows the export of target comments to text in HTML 
pop-ups.

Highlight text in exported files—allows the highlighting of text according to the translation status in 
Déjà Vu X3 Workgroup.

Selecting the Highlight text option activates two more options:

Highlight options—lets you access a dialog that allows you to select what kind of rows should be 
highlighted in what manner.

Highlight order of preference—lets you choose whether rows with Translation Status (pending, 
locked, etc.) or Match Type (exact, fuzzy, assembled, etc.) should take preference.

Clicking on the file selector button on the Highlight options row (the file selector only becomes 
activated when you actually select the row) brings up the Segment Highlight Options dialog.

If no code page is selected, Déjà Vu X3 Workgroup will select a code page suitable to 
the target language and actual language used, with a preference to the same code page 
used during the import.
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Clicking Add lets you select individual formatting options (including any combinations of bold, 
italics, underline, strikethrough, or text color) for as many different Segment Types as you like.

When you are done with your selection, click OK.

Assuming that the HTML file in the following Déjà Vu X3 Workgroup project had one pending line 
and one comment—
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—and the user chooses to display target comments in HTML and highlight pending rows in bright 
magenta, the exported file would look like this:

XML (SGML)

XML stands for Extensible General Markup Language, which is not a file type but a metalanguage 
used to define markup languages. These definitions are called Document Type Definitions or 
DTDs. Each set of XML documents has its DTD, which means that—unlike with Word, Excel, or 
FrameMaker—you will have to teach Déjà Vu X3 Workgroup how to interpret these files. You can 
do this by creating a specific XML filter for each XML project you work on. For more information 
on how to build an SGML/XML filter, see "Creating and Maintaining XML Filter Files" on page 409.

Tips and Tricks with HTML and Script-Based Files

When you translate a website that you have copied to your hard drive, and export it to a different 
path than the original files, the HTML files will look different than the original files because of 
missing graphic files. To display the images correctly in the webpages, you will have to copy the 
image folder(s) to the exact same relative position that they held in the folder structure of the 
source files (for instance, as a subfolder to the root of the website).

If you translate HTML files and need to open and save them in an application other than Déjà Vu 
X3 Workgroup or an Internet browser, make sure that you only open them in a simple text editor, 
an HTML editor that does not add any additional coding, or the HTML editor the files were 
originally created in. Otherwise you will run the risk of corrupting the files. 
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Déjà Vu X3 Workgroup includes support for all documents that follow the XML standard (this 
includes SGML files). Because XML is widely used in all kinds of applications of data storage and 
data exchange, the use of the XML filter goes far beyond the translation of files that have the 
default SGML, SGM or XML extension.

XML-SPECIFIC IMPORT OPTIONS

Filter Definition File

In the XML filter, you will have to select a project-specific filter definition file (for information 
about creating these files, see "Creating and Maintaining XML Filter Files" on page 409).

1 When you select the Filter Definition File line, a file selector button ( ) appears at the right 
of the line.

2 Click .

A good way to determine whether files can be imported with the XML filter is to open 
the file in question in a text editor and verify that it follows the basic structure of:

<TAG ATTRIBUTE1="translatable" ATTRIBUTE2="not translatable">translatable 
text</TAG>
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3 The Select Name and Location of Filter File dialog appears.

4 Select your filter definition file and click Open.

5 You can see that the filter is now selected.

Once you have selected the filter file, the import process is the same as with any other file.

For options to define the code page during import, see "Encoding" on page 335. 
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Process Embedded HTML

It’s very common to have HTML content within an Excel files for translation purposes. The HTML 
parts of the XML file have the enclosing less than (<) and greater than (>) characters for the HTML 
tags in the form of entities (&lt; and &gt;) to differentiate them from HTML tags.

The Process embedded HTML option allows you to have Déjà Vu X3 Workgroup convert HTML 
tags into protected tags for easier and more secure translation.

In the following image, you can see an XML file that was imported into Déjà Vu X3 Workgroup 
without the option to process embedded HTML selected:
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In the following screenshot, you can see the same file with the option selected. In the Preview 
pane at the bottom, you can see what the original file looks like: 

Ignore Regex Matches

The option Ignore Regex Matches allows you to exclude certain text that follows a pattern from the 
display in Déjà Vu X3 Workgroup or to convert that text into easily processed and secure tags. 

You will need some expertise in writing regular expressions to use that option. You can find a 
comprehensive tutorial for regular expressions at www.regular-expressions.info. A Déjà Vu X3 
Workgroup-specific tutorial can be found at https://www.youtube.com/watch?v=C2PUtObxsp8.

It you need to enter more than one regular expression statement into the field of the 
regex option, you will need to isolate each of the statements with (parentheses) and 
separate them from each other with a pipe character: |.

Here is an example:
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XML-SPECIFIC EXPORT OPTIONS

When you export a file that adheres to the XML specification, you will be presented with the 
following filter-specific options:

Encoding—Regardless of the format of the imported file, you can choose to export the files in any 
of the code pages supported by Windows. 

If no code page is selected, Déjà Vu X3 Workgroup will select a code page suitable to the target 
language and actual language used, with a preference to the same code page used during the 
import.

Export special characters as entities—If you select this option, special characters will be exported 
in the appropriate code (© will, for instance, be exported as &copy;)..

Tips and Tricks with XML

A good way to determine whether your settings for the XML filter file are correct is to import a few 
sample files and see whether you are satisfied with the segmentation. If not, determine where the 
problem occurs, fix the XML filter file and import your files again.
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JAVA PROPERTIES

Java Properties files are simple text files that are used in Java applications.

View of a Java Properties file in a text editor:

Déjà Vu X3 Workgroup will ignore the non-translatable content preceding the equal signs as well 
as all text preceded by the number sign (#), and it will use an HTML sub-filter to interpret the 
HTML coding in the file.

RC (RESOURCE TEMPLATE)

RC files (or DLG files) are simple text files that are compiled into binary files such as .exe’s and 
.dll’s.

To create an RC file from an .exe or .dll file, you will have to save the file in your development 
environment as an RC file.
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View of an RC file in a text editor:

Déjà Vu X3 Workgroup will ignore all non-translatable content. This includes everything outside 
quotation marks, with the exception of the copyright note (which is in quotation marks but should 
not be translated). 

C/C++/JAVA

C/C++ and Java files are simple text source files that are compiled into C/C++ and Java 
applications.

Tips and Tricks with RC Files

Because the syntax of RC files uses the quotation mark as a functional character, it requires a 
duplicated quotation mark ("") for every linguistic quotation mark ("Click on ""Next"" to 
continue"). To make the translation process easier, Déjà Vu X3 Workgroup will display every 
duplicated quotation mark ("") as a single quotation mark ("), and then replace those instances with 
a required duplicated quotation mark ("") during the export of the file.

RC files often have a limitation for the length of a string (for instance, a string may not be longer 
than 255 characters). For these situations, the current record position indicator on the status bar 
(see p. 54) is very helpful.
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View of a .cpp file in a text editor:

Déjà Vu X3 Workgroup will ignore all non-translatable content. This includes everything outside 
quotation marks.

File types that are supported by this filter by default include .cpp, .c, .h, and .hpp files.

C/C++/JAVA-SPECIFIC IMPORT OPTIONS

Import Comments

It’s possible to add comments into C/C++ or Java files or to "comment out" certain lines of code. 
In C/C++ the leading characters // are added to the beginning of each line when commenting one 
or more lines of code, or multiple lines can be commented out using the characters /* */. In Java 
comments begin with the /** symbol and end with the */ symbol. 
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Typically text within these lines is not slated for translation. If it does require translation you can 
activate the Import Comments option.

Ignore Text in Single Quotes

This option allows you to specify whether you would like to have text in ’single quotes’ treated the 
same as text in "double quotes" or ignored.

RESX FILES

RESX files are simple XML-based text source files that are used as resource files for .NET 
applications.

Déjà Vu X3 Workgroup will ignore all non-translatable content. 

RESX-SPECIFIC IMPORT OPTIONS

Exclude/Lock Strings Heuristically

Outwardly RESX files follow a simple structure: everything surrounded by <value> tags has to be 
translated. In many cases this rule is more complicated because many of these text strings, while 
following that basic rule, should in fact not be translated. 

Déjà Vu X3 Workgroup uses a heuristic system to evaluate which of these segments have to be 
translated. It allows you to specify whether you would like to have those strings excluded or 
included, but with the original text copied over and locked to give you a chance to evaluate 
whether they should in fact not be translated.
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The following file has been imported with the Lock feature in place:

And here is the same file with the Exclude feature activated: 

YAML FILES

YAML ("YAML Ain't Markup Language") YML files are data serialization files that are used in a large 
number of programming languages. Following the logic of the YAML architecture, Déjà Vu X3 
Workgroup imports the content that is preceded by a colon. See the following image for an 
imported YAML file with the original content visible in the Preview pane:
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YAML-SPECIFIC IMPORT OPTIONS

Import Comments

It’s possible to add comments into YAML files or to comment out certain lines or even parts of lines 
of code by preceding them with a hashtag (#). 

Typically this text is not slated for translation. If it does require translation, you can activate the 
Import Comments option.

GNU GETTEXT

GNU gettext PO and POT files are the translatable language resource files used in the free GNU 
gettext concept for translating software and documentation (from docbook or XML). GNU gettext 
is the de-facto standard in many open source projects, and it works with a large variety of 
programming languages.

PO files are typically translated or pretranslated files, whereas POT files are the translatable 
templates.
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View of a pretranslated POT file in a text editor:

Déjà Vu X3 Workgroup imports the pretranslated bilingual file that you can now edit and (where 
applicable) translate. View of the same passage in Déjà Vu X3 Workgroup:

When the translation is finished, the file will be exported back into its legal code page, Unicode 
(UTF-8).

IBM TRANSLATIONMANAGER/OPENTM2

Déjà Vu X3 Workgroup can process IBM TranslationManager/OpenTM2 untranslated segments 
files.
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To obtain the untranslated segments file for a particular file

1 Run IBM TranslationManager/OpenTM2.

2 Locate your folder in TranslationManager's Folder List.

3 Double-click it to open its list of files.

4 Right-click the desired file. Select Analyze.

5 Check the Create file containing untranslated segments box.

6 Click Analyze.

To translate IBM TranslationManager/OpenTM2files

1 Analyze the IBM TranslationManager/OpenTM2 documents to obtain the "untranslated 
segments" files.

2 Import these "untranslated segments" files into a Déjà Vu X3 Workgroup project.

3 Translate in Déjà Vu X3 Workgroup.

4 Export the finished translation from Déjà Vu X3 Workgroup.

5 Import the resulting files into the IBM TM//OpenTM2 translation memory.

6 Re-analyze the IBM TranslationManager/OpenTM2 documents. This will yield a fully 
translated document.

7 Return the IBM TranslationManager/OpenTM2 folder to your client. The folder contains all 
translated documents and a translation memory with all the material you have translated.

To export a translation memory from IBM TM/OpenTM2

1 Display IBM TM/OpenTM2's Translation Memory List.

2 Right-click the desired database. Select Export.

3 Select the External format.

4 Specify the destination file.

It is not possible to split and join segments from IBM TranslationManager/OpenTM2.
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5 Click Export.

TRADOS RTF/WORD FILES

Déjà Vu X3 Workgroup is able to import pre-processed Trados Word or RTF files and export them 
after the translation into the original Trados format. 

TRADOS-SPECIFIC IMPORT OPTIONS

Ignore Exact Matches

This options allows you to not import any exact matches. This is a helpful option if you are 
specifically instructed by your client not to edit any of the existing exact matches in the Trados file.

Even if you do not select this option, Déjà Vu X3 Workgroup is still  able to interpret the exact and 
fuzzy match setting from Trados and apply that to its own project:

View of pre-processed Trados file within Word (note the numbers between the segments 
that describe the level of fuzziness):

To process Trados Workbench files, you need Microsoft Word 97 or later installed on 
your computer; however, you do not need an installation of Trados.
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View of the same file in Déjà Vu X3 Workgroup (note the indicator bars for the fuzzy and 
the exact match):

Because of the way in which Déjà Vu X3 Workgroup works with Trados files, after a translation is 
finished and ready to be exported, the original, unaltered Trados file must be in the location from 
which it was imported. This is essential, because any slight modification to the file may prevent 
Déjà Vu X3 Workgroup from being able to export the final translation.

TRADOS TAGEDITOR FILES

Déjà Vu X3 Workgroup is able to import pre-processed Trados TagEditor BIF and TTX files and 
export them after the translation into the original BIF and TTX formats. 

Tips and Tricks with Trados RTF/Word Files

Make sure that during the Trados processing, the Trados setting Tools> Translate> Segment 
Unknown Sentences is checked. Otherwise, not all segments will be imported into Déjà Vu X3 
Workgroup.

Because Trados files typically have the extension .doc or .rtf, you should not import Trados files 
with the Import Wizard unless you have changed the default association for .doc or .rtf files (see "To 
reconfigure the default relationship between file format and file extension" on page 326). Import 
Trados files through the Advanced Project Explorer and change the association on an individual file 
level instead (see "To reconfigure the individual relationship between file format and file extension" 
on page 330). 

It is not possible to split and join segments from a Trados Workbench file.
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As with Trados Word files (see "Trados RTF/Word Files" on page 399), Déjà Vu X3 Workgroup is 
able to interpret the exact and fuzzy match setting from Trados and apply that to its own project. 

TAGEDITOR-SPECIFIC IMPORT OPTIONS

ISO Language Mapping

When importing a BIF or TTX file, Déjà Vu X3 Workgroup will recognize the languages that are 
present in the importable file(s) but will prompt you to map each language extension from the BIF 
file to one of the languages that are defined within Déjà Vu X3 Workgroup.

TAGEDITOR-SPECIFIC EXPORT OPTIONS

The options under Encoding are the three possible code pages for BIF and TTX files: US-ASCII, 
Unicode, and Unicode (UTF-8). For more information on the options defining the code page 
during export and import, see "Encoding" on page 335.

The protected XTranslated or PerfectMach units from the BIF and TTX documents will 
be imported as guaranteed matches.

You will notice that in most cases Déjà Vu X3 Workgroup has already made the correct 
choice for you.
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XLIFF FILES

Déjà Vu X3 Workgroup is able to import XLIFF files and export them after the translation into the 
original XLIFF format. 

XLIFF is the most widely used exchange format for translation files. Many of Déjà Vu X3 
Workgroup’s competitors use this format as an internal format (including Trados Studio with the 
.sdlxliff format or memoQ with the .mqxliff/.mqxlz formats and WorldServer with the .xlz format) 
or as an interim exchange format. Déjà Vu X3 Workgroup allows you to translate these files within 
its environment and continue to use them within the environment of other CAT tools.

Déjà Vu X3 Workgroup recognizes the statuses and the fuzziness information of each of the 
segments of the XLIFF file and displays it accordingly in its translation grid.
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XLIFF-SPECIFIC IMPORT OPTIONS

ISO Language Mapping

When importing an XLIFF file, Déjà Vu X3 Workgroup will recognize the languages that are 
present in the importable file(s) but will prompt you to map each language extension from the BIF 
file to one of the languages that are defined within Déjà Vu X3 Workgroup.

Déjà Vu X3 Workgroup also allows you to output its own translation projects as XLIFF files within 
the Sharing feature. This allows for the translation or review of Déjà Vu X3 projects with competing 
CAT tools. For more information, see p. 266.

TRANSIT NXT

Déjà Vu X3 Workgroup is able to import pre-processed Transit NXT PPF package files and export 
them after the translation into the expected delivery format TPF. Déjà Vu X3 Workgroup will 
import any number of target languages that the original PPF package contains but will separate 
them into individual target language TPF packages during export. 

You will notice that in most cases ,Déjà Vu X3 Workgroup has already made the correct 
choice for you.
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Déjà Vu X3 Workgroup is able to interpret the exact and fuzzy match setting from Star Transit and 
apply that to its own project. 

WORDFAST TXML

Wordfast Pro’s internal translation format TXML (used through version 3 of Wordfast Pro) can be 
seamlessly processed with the help of Déjà Vu X3 Workgroup’s TXML filter. The files can be 
translated, untranslated or partially translated for the import and translation into Déjà Vu X3 
Workgroup.

Déjà Vu X3 Workgroup recognizes the statuses and the fuzziness information of each of the 
segments of the Wordfast file and displays it accordingly in its translation grid.

SDLX ITD

SDLX, one of the early translation programs of SDL, is not officially supported anymore by SDL, 
but its internal translation format ITD is still relatively widely used. Déjà Vu X3 Workgroup supports 
the import, translation and export of ITD files with the SDLX ITD filter.

TMX FILES

You can translate TMX files in  Vu X3 Workgroup. TMX (Translation Memory eXchange) is widely 
used as an interchange format between different translation memory formats. This means that with 
this format filter you are able to translate TMX translation memories of any tool that supports this 
format and apply that translated translation memory in its original, native environment.

Because of the multi-lingual nature of TMX files, Déjà Vu X3 Workgroup will import source and, 
where applicable, target(s). You are free to edit or overwrite the target segments.

Should the original TPF package file contain termbase data, it will not be imported into 
Déjà Vu X3 Workgroup.

Some ITD files, including those that use format painting or those that are saved out of 
Trados Studio or other non-SDLX products, might be problematic to process. In those 
cases, the easiest workaround might be to save the files as TTX or SDLXLIFF files in 
other applications by SDL. Other workarounds are described right here: http://

en.wikibooks.org/wiki/CAT-Tools/DéjàVu_X/ITD_format.
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TMX-SPECIFIC IMPORT OPTIONS

ISO anguage Mapping

When importing a TMX file, Déjà Vu X3 Workgroup will recognize the languages that are present 
in the importable file(s) but will prompt you to map each language extension from the TMX file to 
one of the languages that are defined within Déjà Vu X3 Workgroup.

You will notice that in most cases Déjà Vu X3 Workgroup has already made the correct 
choice for you.
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TMX-SPECIFIC EXPORT OPTIONS

Because TMX files can have several target languages, Déjà Vu X3 Workgroup allows you to export 
individual bilingual files for every target language in your project, or one TMX file with several 
target languages.

If you want all target languages in one TMX file, you can leave the selection as presented in the 
Export Options dialog. If you prefer individual TMX files or any combination of languages, you can 
select the respective languages and make the appropriate choices under Export each language to a 
separate file.

The options under Encoding are the three possible code pages for TMX files: US-ASCII, Unicode, 
and Unicode (UTF-8). For more information on the options defining the code page during export 
and import, see "Encoding" on page 335.

EBU FILES

Subtitles are stored in subtitle files which contain the text and IN and OUT timecodes for the 
subtitles, as well as an information block describing the subtitle file. The most common format is 
the STL format of the EBU (European Broadcast Union).

If you choose to export more than one target language, Déjà Vu X3 Workgroup will 
export the file(s) into a subfolder named according to the source language rather than 
the usual target language naming convention.
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View of an STL file in an STL editor:

When importing the EBU file, Déjà Vu X3 Workgroup will import all translatable text. To give you 
the necessary context, Déjà Vu X3 Workgroup will also import all in and out times but it will 

automatically copy those over to the target, lock them ( ) and prevent them from being sent to 

the translation memory ( ).
. 
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CREATING AND MAINTAINING XML FILTER FILES

Unlike other file formats (FrameMaker, Word, Excel, etc.), XML (eXtensible Markup Language) is 
not a real file format; it’s a markup standard for tagging files, and for defining those tags. Since 
every set of XML files uses a different set of tags, an XML filter must be created for every set of XML 
files.

Both XML and HTML derive from "SGML" (Standard Generalized Markup Language)—which is 
also supported with this filter.

SGML defines a standard for creating DTDs (Document Type Definition). For example, the World 
Wide Consortium (W3C) has DTDs for the various specifications of HTML; this means that HTML 
is a markup language defined according to SGML rules. You will probably be somewhat familiar 
with the structure and tags in HTML, so we will use it as an example in our explanations.

TAGS AND ATTRIBUTES

XML files are text files that encode formatting, layout, and image information using tags. Tags are in 
the format of:

<TAGNAME ATTRIBUTE1="VALUE1" ATTRIBUTE2="VALUE2">

A tag can contain attributes that further define a value of the tag.

Because Déjà Vu X3 Workgroup does not need to interpret tags and keys, there are only two 
pieces of information that you must provide:

Embeddable tags—An embeddable tag is one that can appear in the middle of a 
segment, and Déjà Vu should not split the segment before or after this tag. For example, 
the <B> and <I> tags in HTML (which specify bold and italic attributes) are 
embeddable, while the <P> tag (which specifies a paragraph change) is not.

Extractable text between tags—It is possible to define whether text between certain tags 
is extractable (default) or not extractable, i.e., not translatable. For example, if text 
between certain tags always contains dates or numbers that may not need to be 
translated, you can choose to embed that text.

If you define a text between tags with nested subtags (for example, <tag1> text 
<tag2> text </tag2></tag1>) as non-extractable, text between the nested 
subtags will not be extracted either.

However, attributes (see below), are not affected by a choice to not extract text between tags (for 
example, the attributetext in: <tag1 attribute="attributetext"> text </
tag1> would be extracted if so defined, even though the text of tag1 may be defined as not 
extractable).
Déjà Vu X3   409



410
Extractable attributes—Certain tags may contain attributes whose values are translatable, 
and must therefore be extracted. For example, the <IMG> tag in HTML (which inserts an 
image into the text) has the ALT=“[alternate text for the image]” attribute, 
which specifies the text to display if the browser cannot load the image. This text should 
be translated, so the attribute is extractable.

Déjà Vu X3 Workgroup offers two combinable possibilities for creating an XML filter file:

from the DTD file

directly from the XML files

To create an XML filter from XML files 

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.

3 Select the XML Filter button under XML Filter.

In general, it is advisable to combine the methods to allow for greater accuracy of the 
XML filter.

You can disable the Start screen under File> Options> General> Start-up options.
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-Or-

Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.

4 The New File dialog appears.

5 Double-click SGML/XML Filter, or select it and click OK.

6 You are prompted to create an XML filter.

7 Click Create, select a folder in which you want to have the XML filter saved, and type a name 
for the filter.
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8 Click Next. The wizard prompts you to either specify a DTD file or to generate the XML filter 
directly from an XML file.

9 For this exercise we will use an XML file. Click Next.
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10 Click the Add button.

11 Select your XML file(s) and click Open. 

12 Click Next.
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13 The wizard displays the import progress.

14 Click Close after the import process has finished. 

15 The Tags and Attributes tab is displayed.

The newly created XML filter has made the following definitions:

all the tags of the imported XML file(s) are interpreted as embeddable (by having the 
...<>... column in the Tags field unchecked), 

all text between tags is defined as extractable (by having the <>...<> column in the 
Tags field checked), and
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all attributes are defined as embeddable (by not having the <=...> column in the 
Attributes field checked).

16 You will have to review each of these tags and attributes and decide whether the default 
setting is appropriate or not. To ease that process, Déjà Vu X3 Workgroup displays examples 
from the occurrences of the tags and attributes in the respective file(s) under and to the right 
of Examples.

Typically, the vast majority of tags should not be embedded. Below is an example of tags 
that could be embedded; the ...<>... column in the Tags fields is therefore checked:
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Typically, the majority of text between tags should be extracted. Below are examples of 
text that should probably not be extracted; the <>...<> column in the Tags field is 
therefore unchecked:

Most of the attributes will only contain internal, non-translatable information. Leaving 
the checkboxes in the <=...> column in the Attributes field unchecked ensures that 
they will not be extracted, i.e., displayed in the Déjà Vu X3 Workgroup project. For those 
that should be translated, add a check mark.
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17 When you are finished defining the tags and attributes, you can reduce the size of your XML 
filter by deleting all the examples.

18 Select Home> Delete All Examples.

19 Select the Entities and Characters tab. 

Here you can find definitions of the Begin Tag and the End Tag as well as for the Begin Entity 
and the End Entity. These settings are the standard settings and typically do not have to be 
changed.

This is especially helpful when you have imported a great number of XML files, which 
can blow up the size of the filter to several hundred megabytes.

Other XML-specific options include the deletion of all tags and attributes and all 
entities. These options are only used on very rare occasions.
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On this tab you can also find a great number of pre-defined special characters. The definition 
of each will determine how Déjà Vu X3 Workgroup will display the character and export it 
again. The copyright sign (©), for instance, will be displayed as &copy; in the XML file before 
and after the translation, but as © in the project file.

20 In the process of generating the XML filter file below, Déjà Vu X3 Workgroup has detected 
one character, a y with an accent (ý), that is not in its predefined lists of special characters. 
With the appropriate Unicode sequence, you can now define how you want this character to 
be handled.

21 Type the appropriate Unicode sequence into the field to the right of U+. The correct 
character will now be displayed in the adjacent field.

22 Click Add.
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23 The new entity will now be displayed correctly as ý in Déjà Vu X3 Workgroup, but as &yac; 
when exported.

To create an XML filter from the DTD file

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.

3 Select the XML Filter button under XML Filter.

-Or-

Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.

You can disable the Start screen under File> Options> General> Start-up options.
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4 The New File dialog appears.

5 Double-click SGML/XML Filter, or select it and click OK.

6 You are prompted to create an XML filter.

7 Click Create, select a folder in which you want to have the XML filter saved, and type a name 
for the filter.
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8 Click Next. The wizard prompts you to either specify a DTD file or to generate the XML filter 
directly from an XML file.

9 For this exercise, we will use an existing DTD file. Click Select and select your DTD file.
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10 Click Save. The wizard displays the current settings.

11 Click Next.

12 The wizard prompts you to specify the location of your XML files. 

13 Since there is no reason to select any for the purpose of this tutorial click Next.

14 You are informed that the project has been created.

15 Click Close. 
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16 The Tags and Attributes tab is displayed.

The newly created XML filter has made the following definitions:

most of the tags that are listed in the DTD file are interpreted as extractable (by having 
the ...<>... column in the Tags fields unchecked), 

all text between tags is defined as extractable (by having the <>...<> column in the 
Tags field checked), and

all attributes are defined as extractable (by having the <=...> column in the Attributes 
field checked).

17 You can now choose to review each of these tags and attributes and decide whether the 
default setting is appropriate or not.

For further information on how to decide how to treat the different tags and attributes, see p. 
415.

To ease this process, it is advisable to combine the DTD import with the import of some 
representative SGML/XML files. Déjà Vu X3 Workgroup will then display examples from 
the occurrences of the tags and attributes in the respective file(s) under and to the right 
of Examples. For information on how to import SGML/XML files, see "To create an XML 

filter from XML files" on page 410.
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To add data to the XML filter

1 If you want to add data at a later point from an existing XML filter or other XML files/DTDs, 
you can do that by selecting External Data> XML Files (or: XML DTD; or: Déjà Vu X3 Filter).

2 Select the XML file/DTD or the filter file and click Open.

3 The new data will be imported into your existing filter.
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THE LEXICON

If you are not familiar with Déjà Vu’s lexicon concept, get ready for something completely 
different and new. 

You probably have a relatively good understanding of how the termbase and the translation 
memory work. Both are project-unspecific, external databases that contain segments, phrases, and 
terms from a large variety of subjects, clients, and projects. While the translation memory is 
primarily used for segment matching, the termbase provides the individual components of a 
segment when no match is found in the translation memory.

So how does the lexicon fit in?

The project’s lexicon is a list of all the source language words or phrases present in the project—in 
other words, an index of all terms and phrases. Once you have created this index, you can 
translate the terms that seem relevant to you, batch delete all other terms (for instance, terms like 
"the" or "to" in the image below), and Déjà Vu X3 Workgroup will use what remains as the primary 
glossary for your project.

While creating this index, the lexicon also provides you with the number of occurrences of the 
individual terms or segments (see the Freq column in the image above), thus giving you a pretty 
good idea of what terms are central to your project. And even though the same terms may reside 
in your termbase, chances are that there will be several translations for many terms in the 
database. The word "cat," for instance, could be a feline animal, a piece of heavy equipment, or 
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"computer-assisted translation." Each of these meanings will have a different translation in different 
languages, making it difficult for Déjà Vu X3 Workgroup to know which one to choose over the 
other. By providing the one correct translation in the project-specific internal lexicon, Déjà Vu X3 
Workgroup will always choose that over any other translation.

WORKING WITH THE LEXICON

You can access the different functions and aspects of the lexicon through the Lexicon menu.

For information on how to create and translate a lexicon and how to remove rows from a lexicon, 
please see "Generating the Lexicon" on page 96.

To change the lexicon sorting

As with normal files in a project, you can change the order in which the lexicon entries appear.

1 Click the column header of the source language in the translation grid.

2 The Sort Lexicon dialog appears.

Clients will often ask you to provide them with a glossary for a project you’ve translated 
for them; this will help them keep a record of the terminology used, ensuring that the 
same terminology is used in future projects. With Déjà Vu X3 Workgroup, creating a 
glossary for your client is as simple as exporting the lexicon to a text file.

For project managers, the lexicon can provide an extremely valuable tool for quickly generating 
glossaries for large projects with multiple translators.
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3 You can sort alphabetically, by number of words, by frequency, or by any combination of the 
three in either descending or ascending order.

4 Click OK.

To manually add entries to the lexicon

1 If you want to add a selection, select the corresponding portions in the source and target cells 
of the translation grid.

2 On the Home ribbon tab, click Add to Lexicon.

–Or–

Press F10.

3 At the bottom of the screen, you will be able to see: Pair added to the Lexicon.

To modify or delete lexicon entries as you translate

See "To modify database records in the AutoSearch window" on page 182

RESOLVING THE LEXICON WITH THE DATABASES

After the lexicon has been built and you have added and removed those entries you considered 
necessary, you should translate it. You can do this manually, but you can also decide to use the 
content in your databases.

You will generally want to choose the settings shown in the image above.

There could be two reasons why you may want to add to the lexicon and not to the 
termbase. Because Déjà Vu X3 Workgroup treats the lexicon as the most relevant 
database in its assemble processes, it is helpful to add to the lexicon as you translate. 
This will overwrite anything you may have in the project-unspecific termbase. 

Furthermore, there are entries that are so project-specific that you may not want to have them in 
your termbase, but they may be very helpful in the lexicon.

The resolve options are also available during the lexicon build process (see "To create 
the lexicon" on page 97).
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To resolve the lexicon with the translation memory(s)

1 Select Lexicon> Resolve> Resolve with Translation Memory.

2 The Resolve Lexicon dialog appears and shows how many entries have been processed.

To resolve the lexicon with the termbase(s)

1 Select Lexicon> Resolve with Termbase.

2 The Resolve Lexicon dialog appears and shows how many entries have been processed.

To resolve the lexicon with Deep Miner Statistical Extraction

1 To apply subsegements that are derived from your translation memory(s) through the 
DeepMiner extraction process, select Lexicon> Resolve> Resolve with Deep Miner 
Statistical Extraction.

This process is comparable to a pretranslation; i.e., it finds both exact and fuzzy 
matches in the translation memory.
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2 The Resolve Lexicon dialog appears and shows how many entries have been processed.

SENDING THE LEXICON TO A DATABASE

After expanding, translating, and correcting the lexicon, you can send it to the termbase or the 
translation memory so that the data in the lexicon will also be available for later projects.

To send the lexicon to the translation memory

1 If you only want to send a portion of the lexicon, select the respective records (for more 
information on how to select records, see "Selecting Segments" on page 63).

2 Select Lexicon> Add to TM.

All three of the resolve processes are done with the currently selected target language. 
If there is more than one language in the project, you can choose which one to display 
by selecting a language from the Language Selector (see "The Language Selector" on 
page 54).

It is advisable to check the translations generated by the "resolve" procedures.
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3 The Send Lexicon to Translation Memory dialog appears.

4 Select whether you want to send the Current language or All target languages, any rows with 
a status other than the default options Confirmed Segments or Unmarked Manual 
Translations, and whether you want to send all of the lexicon or only a previously selected 
subset.

5 Click OK.

6 At the bottom of the dialog, you will be able to see how many entries have been sent.

7 Click Close.

To send the lexicon to the termbase

1 If you only want to send a portion of the lexicon, select the respective records (for more 
information on how to select records, see "Selecting Segments" on page 63).

2 Select Lexicon> Add to Termbase.
Déjà Vu X3    430



The Lexicon
3 The Send Lexicon to Termbase dialog appears.

4 Select whether you want to send the Current language or All target languages, any rows with 
a status other than the default options Confirmed Segments or Unmarked Manual 
Translations, and whether you want to send all of the lexicon or only a previously selected 
subset.

5 Click OK.

6 At the bottom of the dialog, you will be able to see how many entries have been sent.

7 Click Close.

EXPORTING THE LEXICON

Once you have processed the lexicon, you may want to export it to send it to your client, to have 
it translated outside of Déjà Vu X3 Workgroup, or to import it into another Déjà Vu project. 

Déjà Vu X3 Workgroup can create a text or an Excel file with the lexicon entries from the source 
language and any number of target languages.

To export the lexicon

1 In an open project with an existing lexicon, select Lexicon> Export> Export Text File (or: 
Export Excel Spreadsheet).
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–Or–

Right-click on the lexicon icon and select Export> Export Text File (or: Export Excel 
Spreadsheet). 

2 For this example, we are going to select Export Text File.

3 Select Next, choose the folder where the file is supposed to be saved, name the file, and 
select Save.

4 The wizard displays the current settings to you.
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5 Select Next and choose the target languages you are intending to export.

6 Select Next and choose whether you want to export only the currently selected subset of the 
lexicon (if applicable). 

7 Select Next and choose how the records should be separated from each other (Delimiter), 
whether you want column headings in the exported file (First Segment Contains Field 
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Names), and the codepage. Because one of our export languages is a non-Western 
language—Greek— Unicode may be a good choice as a codepage.

 

You will not be presented with these choices if you use Excel as an export format.
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8 Click Next. After the export process is finished, the wizard displays the number of exported 
records.

9 Select Close.

PREPARING A LEXICON FOR TRANSLATION OUTSIDE OF DÉJÀ VU X3 
WORKGROUP

If you are planning to prepare a lexicon for translation outside of Déjà Vu X3 Workgroup, you can 
follow these steps.

1 Determine which terms or phrase are helpful, copy them over from source to target, and 
select the desired rows.

2 On the Insert ribbon tab, select Populate> Populate Current Segment.

–Or–

Press F5.

3 Select Lexicon> Remove Lexicon.

You can also copy the content of several rows into the target with this command by 
selecting the desired rows in the selection mode (see "Selecting Segments in the 
Selection Mode" on page 63).
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4 The Remove lexicon rows dialog appears.

5 Select All entries with empty targets.

6 Click OK.

7 You can now export the remaining entries into a text or Excel file (see "Exporting the Lexicon" 
on page 431), translate the file outside of Déjà Vu X3 Workgroup by overwriting the target 
segments and, once the translation is finished, re-import the file into the lexicon.

IMPORTING INTO THE LEXICON

The option to import a lexicon can prove to be helpful in a variety of situations, including the 
following:

the lexicon has been translated, edited, or proofread outside of Déjà Vu X3 Workgroup 
and needs to be reimported into the project, 

you would like to transfer the lexicon from an earlier project to the current project, or

a project-specific glossary has to be imported into the project’s lexicon.

To import an external file into the lexicon

1 In an open project with or without an existing lexicon, select File> Import> Lexicon.

–Or–

The last item is arguably the most important one. As mentioned before, the lexicon is 
used as the primary glossary for the project, so it is very helpful to import a project-
specific glossary into the lexicon rather than the generic termbase.
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With an existing lexicon, right-click on the lexicon icon and select Import. 

2 You have the following options for a format to import from:

Text file

Access database

ODBC database (only available in the Workgroup edition)

Excel spreadsheet

3 For this example we are going to select Import Excel Spreadsheet.

4 Choose the folder where the file is located, name the file, and select Save.

5 The wizard displays the current settings to you.
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6 Select Next and select whether the First Row Contains Field Names.

7 Select Next, specify which of the available fields needs to be imported, and map it to the 
appropriate language and code page.
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8 Select Next and choose whether you want the entries in the glossary to overwrite any existing 
similar entries in the current lexicon and whether you want to recalculate the frequencies 
(i.e., add the existing number of occurrences to the one in the new glossary).

9 Click Next. After the import process is finished, the wizard displays the number of imported 
records.
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10 Click Close. If you now open the lexicon in your project, you will be able to see the imported 
entries.
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CREATING AND MAINTAINING TRANSLATION MEMORIES

TRANSLATION MEMORY INTERFACE

The translation exit memory interface consists of a number of elements.

Source Language—though you can only view one source language at a time, the 
multilingual nature of Déjà Vu X3 Workgroup’s translation memories makes it possible to 
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select a different source language from the Source Language dropdown list and have the 
present source language become a target language:

Target Language—allows you to view each individual target language or—as in the 
examples above—all target languages.

Locate Segment—this field allows you to enter the first few letters of the first word in the 
source segment you are searching for to have Déjà Vu X3 Workgroup jump to a matching 
entry.

Even though you can use this feature in any mode, it is particularly useful in 
alphabetical order. To switch to alphabetical order, click the source language header.
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Filter—allows you to enter any full word (partial word or wildcard searches are not 
possible). By clicking the Filter button to the right of the text box, the translation memory 
displays all records where the source contains that word.

Add—clicking this button in either the source or target column will open a new field in 
which you can enter a new segment or term.

Remove—clicking these buttons will remove the source or target segment.
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Consolidate—this option allows you to merge two identical source segments with 
translations into different languages. Highlight several source segments by clicking on 
them while holding down the Ctrl (+Shift) key.
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Select Consolidate.

All Segments—the standard view that displays all source segments with their associated 
target segments.
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Duplicates Only—displays all source rows.

SQL—this option opens the SQL Filter dialog in which you can enter any SQL statement 
to view a certain subset of the translation memory.

A more powerful option for managing duplicates is to select Database> Find Duplicate 
Segments.

The Find Duplicate Segments dialog gives you a wide variety of options for finding sets 
of duplicates, sets of duplicates with identical translations, or sets of duplicates with different 
translations for all possible language combinations. It also allows you to delete duplicates if both 
source and target are identical.
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OPENING TRANSLATION MEMORIES

1 Select File> Open.

–Or–

Click  on the Quick Access Toolbar.

–Or–

Press Ctrl+O.

2 The Open dialog appears.

3 Select Translation Memories under Files of type, select the database you want to open, and 
click Open.

CREATING TRANSLATION MEMORIES

There are two different ways to create a translation memory:

you can create one during the process of creating a Déjà Vu X3 Workgroup project file 
(see "Creating a New Project File" on page 81), or

you can create a translation memory as a stand-alone file.
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By creating a translation memory as a stand-alone file (which you can later associate with project 
files), a creation wizard allows you to select several customized options.

To create a translation memory as a stand-alone file

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.

3 Select the Translation Memory button under Translation Memory.

-Or-

Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.

You can disable the Start screen under File> Options> General> Start-up options.
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4 The New File dialog appears.

5 Double-click Translation Memory or select Translation Memory and click OK.

6 The wizard prompts you to create a translation memory.

7 Select a folder in which you want to have the translation memory saved, and type a name for 
the translation memory.
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8 Click Close. Déjà Vu X3 Workgroup displays an empty translation memory.

ASSOCIATING TRANSLATION MEMORIES WITH A PROJECT

Translation memories can be associated with your project during the creation of a project (see p. 
84) or at a later point.
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To associate translation memories with projects

1 In an open project, select Project> Properties> Databases.

2 If you would like to disassociate the existing translation memory from the project, select that 
translation memory and click Remove.

3 If you would like to add an additional translation memory, 

select Add Server TM to add a server-based TEAMServer translation memory or

select Add Local TM to add a translation memory that is on your hard drive or network.
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4 If you selected Add Server TM, the TEAMserver Login dialog prompts you to enter your login 
credentials.

5 If you selected Add Local TM, a file selector dialog appears.
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6 Select the additional database which can be located on a drive of your local computer or 
anywhere in your network and click Open.

7 By default, the newly added translation memory has read and write access. Translation 
memories with read access will be used to retrieve data for your project and those with write 
access will have data written to them. This means that you can write to several translation 
memories at the same time, thus allowing you, for instance, to have a copy of a large 
translation memory on your local computer that you read and write from and the original 
translation memory on a network server. You can choose to only write to the network 
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translation memory but not read from it, which would avoid increased network traffic and 
could have a significant impact on processing speed.

You can sort the order of use of the translation memories with the up and down arrows or the 
right side of the field where the translation memories are listed. If you have selected 

You can sort the order of use of the translation memories with the up and down arrows 
or the right side of the field where the translation memories are listed. If you have 
selected the option Order of Translation Memories under File> Options> Translation> 
Translation memory options> Sort matches by, the order of displayed matches will be 

determined by the order of translation memories in the Translation Memories tab.

Conversely, if you select Descending date or Ascending date, the order of displayed translation 
memory matches will be determined only by the age of the translation unit.
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8 Make the necessary changes.

9 Click Apply and/or OK.

TRANSLATION MEMORY STATISTICS

It is possible to obtain statistical data about your translation memory, such as number of records 
and languages in the translation memory.

To view translation memory statistics

1 In an open translation memory, select Home> Properties> Statistics.
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2 The Statistics tab in the Translation Memory Properties dialog is displayed.
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3  Click Calculate.

4 The statistics for the current translation memory are displayed.

IMPORTING EXTERNAL DATA

You add records to your translation memory as you translate (see "Sending Information to the 
Translation Memory" on page 177), but Déjà Vu X3 Workgroup also enables you to import external 
data into translation memories. For example, this allows you to convert data you have 
accumulated with other translation memory software, or even from data found on the Internet.

To import data

1 With an open translation memory, select the External Data ribbon tab.

2 You can see the supported formats on the ribbon tab:
Déjà Vu X3    457



458
Déjà Vu X3 TM—for merging translation memories

TMX—for importing databases from the Translation Memory EXchange format, an XML-
based exchange format between different CAT tools

Trados Workbench—for importing databases from translation memories from the Trados 
Workbench .txt format

Text—for importing delimited text files (tab, comma, etc.)

Access—for importing databases from various versions of Microsoft Access

ODBC Database—for importing databases from various ODBC data sources

Excel—for importing databases from Microsoft Excel (only .xls files)

Align—for starting the alignment process or importing data from an existing alignment 
project file

For this example, we will select Text to import a multilingual comma-separated value file 
(.csv).

3 Select Text and select the text file you want to import. The wizard displays the current 
settings.
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4 Click Next. The wizard displays the data of the file and allows you to adjust the delimiter 
settings.

5 Select the delimiter of your original file (in this case Tab), and check the appropriate option if 
the first row contains field names.

6 Click Next. The wizard now allows you to specify the field information for the fields of your 
original file.
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The available standard fields are:

Main Segment (typically the source language)

Translation

Date

User ID

Subject

Client

File ID

Segment ID

7 Select Main Segment and the appropriate language and code page settings for the source 
language, and Translation and the appropriate language and code page settings for the target 
languages.

The Preview field gives you a good overview of the appropriateness of the chosen code 
page. Compare for instance the Arabic column in the previous screenshot and this 
screenshot. Only after selecting the correct code page Unicode, the Arabic characters 
and the direction of writing are displayed correctly.
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8 Click Next.

9 You are prompted whether you want to remove Duplicate Segments.

10 Click Next.The wizard displays the import progress; when it is finished, it shows how many 
records have been added.

11 Click Close and you are returned to your translation memory view. 

ALIGNING EXISTING FILES

Alignment is the process in which pairs of already translated files that were translated in a 
monolingual environment (i.e., outside a translation memory tool) are paired up to become part of 
an existing or a new translation memory. The process of pairing up these files is done in an 
intermediary alignment file, a .dvapr file; once the alignment is completed, this file is fed into the 
translation memory.

Déjà Vu X3 Workgroup’s advanced concept of using placeholders for tags in the translation 
memory allows for:

Though this feature can be very powerful, especially for users who start without any 
existing bilingual material, you should be cautious of blindly feeding existing material 
into your translation memory, just to "make it grow." In our experience, the best 
procedure for alignment is to choose very carefully what kind of textual material you 

will benefit from most, or align in a specific situation when you have to translate a file and you have 
a set of very similar, already translated files that are not yet contained in the translation memory.
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aligning of different file types (i.e., you can align an HTML file in language A with a Word 
document in language B), or

using the translation memory that you built up from aligning from files of type A to 
translate files of type B.

In the latest edition of Déjà Vu X3 Workgroup it is also possible to have an unlimited number of 
files or differing file formats in one alignment process. 

To align several pairs of files

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.

3 Select the Alignment Workfile button under Alignment.

-Or-

You can disable the Start screen under File> Options> General> Start-up options.
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Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.

4 The New File dialog appears.

5 Double-click Alignment Workfile or select Alignment Workfile and click OK..

Alternatively, you can also align from within an existing translation memory. To do that, 
open the translation memory that you would like to align new material into and select 
External Data> Align (See p. 457)
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6 The Align Files Wizard appears, offering you a choice between creating a new alignment 
workfile and opening an existing one that already contains aligned material.

7 Select Create a new alignment workfile.

8 Click Select, give the new alignment file a name and choose a folder in which to save it.

9 Select Next.
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10 Make the following selections:

Choose the source and target files by clicking on the Add buttons.

Change the order of the source and target files so that they are listed in the same order 
by using the up and down arrows.

Choose the language for the files from the dropdown list.

Change any properties for the import process of individual files by highlighting them and 
clicking on the Properties buttons.

Note that you can mix and match any file type that is supported by Déjà Vu X3 
Workgroup within one alignment project.
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11 Select Next. The wizard shows the progress of the import process.

12 In the following screen, you will have to adjust the alignment.
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You can make adjustments in source or target by selecting one or several rows in either source 
or target (press Ctrl while selecting several rows or Ctrl+Shift while selecting a range) and 
using one of the following options to adjust the alignment:

Joining the current segment with the next or joining all selected segments by clicking one 
of the Join buttons.

Splitting the current segment at the cursor’s location by clicking one of the Split buttons.

Deleting the current segment or all selected segments by clicking one of the Delete 
buttons. 

Moving the current segment or all selected segments up by clicking one of the Move Up 
buttons. 

Moving the current segment or all selected segments down by clicking one of the Move 
Down buttons.

Sending term pairs to the termbase by highlighting them in source and target and clicking 
Add to TB. (The first time you do this, you are prompted to select a termbase. Once you 
have selected a termbase for one alignment project, you will not have to select it again.)

The most common adjustments that you will have to make are due to 

soft or hard returns that were set for formatting purposes (as in the first two lines in both 
source and target in the example above);

differences in the segment structure; or

differences in the use of segment delimiters.

You can recognize whether your selection is in the source or the target column by the 
yellow dotted line that surrounds your selection.

If you see marked differences in how sentences are delimited because of delimitation 
rules, it may be advisable to discard the current alignment workfile, change the 
delimitation rules for one or both languages, and import the files again into a new 
alignment project. For more information on sentence delimitation, see "Sentence 

Segmentation" on page 217.
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When you are finished with your adjustments, all the rows should be aligned perfectly.

13 Select the translation memory that the alignment file can be entered into by clicking Select.
 

14 Select Next.

The following step of selecting or creating a translation memory is omitted if you are 
aligning through the Import> Align command within an existing translation memory.
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15 Select a client and a subject for the aligned data that you’re going to send to the specified 
translation memory.

16 Click Next. The wizard shows you the progress of sending the segment pairs into your 
translation memory and notifies you when the process is finished.

17 Select Close.
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To open an existing alignment file

1 Select File> Open.

–Or–

Click  on the Quick Access Toolbar.

–Or–

Press Ctrl+O.

2 The Open dialog appears.

3 Select Alignment Workfiles under Files of type, select the alignment workfile you want to 
open, and click Open.

Alternatively, you can also open an alignment file from within an existing translation 
memory. To do that, open the translation memory that you would like to align new 
material into and select External Data> Align.
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4 The alignment workfile is displayed.

SPELL CHECKING THE TRANSLATION MEMORY

To activate spell checking

1 Select Home> Spelling.

–Or–

Press F7.

2 The Spell Checking Options dialog appears.
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3 Under Language, you can choose to check any language present in the project, including the 
source language.

4 Under Scope, you can choose to check all entries in that language or just those that have not 
been checked before.

5 The Check Spelling dialog appears with the assumed spelling error highlighted and its context 
displayed in the lower half of the window.

6 For more information on spelling, see "Spell checking" on page 127.

It is a good practice to include the source language in your spell checks. Any misspelling 
in the source is unlikely to occur a second time in later texts, but it will prevent Déjà Vu 
X3 Workgroup from finding exact and/or guaranteed matches.

Limiting the spell check to records that have not been checked is an efficient way to 
avoid duplicating your work.
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EXPORTING DATA FROM TRANSLATION MEMORIES

There are various situations where it may be very helpful to export parts or all of your translation 
memories, the most obvious being

storing a translation memory in a compact format, or 

sharing translation memory content with co-workers or teammates.

To export data

1 With an open translation memory, select the External Data ribbon tab.

2 You can see the supported formats on the ribbon tab:

Déjà Vu X3 TM—for merging translation memories

TEAMServer—for exporting databases onto a TEAMServer

TMX—for exporting databases into the Translation Memory EXchange format, an XML-
based exchange format between different CAT tools

Trados Workbench—for exporting databases into the text-based translation memory 
format of Trados Workbench

Text—for exporting into delimited text files (tab, comma, etc.)

Access—for exporting databases into the Microsoft Access format

ODBC Database—for exporting databases into an ODBC data sources

Excel—for importing databases into the Microsoft Excel format

In the following two examples, we will first select TMX and then Excel as the export format.

You can find information on how to export translation memory data to TEAMServer 
under "To export a Déjà Vu X3 Workgroup translation memory to TEAMserver" on page 
285 .
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To continue the export process with TMX as the data format

1 Select TMX.

2 Select the desired export path, give the file an appropriate name, and click Save. The wizard 
displays the current settings. 

3 Click Next.

The export process into the Trados Workbench database text format is similar to the 
one into TMX.
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4 The wizard displays the languages in your translation memory. 

5 Copy the desired languages over the Export languages field by selecting them and clicking on 
Add.

6 Click Next.

A TMX file can be multilingual, so you can select as many languages as you like.
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7 The wizard prompts you to enter any filtering condition, i.e., criteria by which you want to 
filter the export of your database. 

8 If you choose to enter an expression, verify it by clicking the Validate button. If the expression 
proves to be valid, select Next.

–Or–

If you choose not to enter an expression, select Next.

Unless you are very familiar with the underlying structure of the databases, you should 
probably resort to using and modifying the provided samples in the Advanced Topics 
chapter (see "Sample Regular Expressions for Export from Translation Memory and 
Termbase" on page 557).
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9 The wizard gives you a choice of the three possible ways to encode a TMX file (Unicode UTF-
16, Unicode UTF-8, and US-ASCII) and lets you select what other information besides source 
and target should be exported.

In all likelihood, UTF-8 is the right choice here. 
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10 Make the appropriate choices and select Next.

11 Click Next.

The export into the Trados WB database format differs in this step. Instead of selecting 
the correct encoding, you will have to select the Trados-specific language specifier for 
each language.
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12 The wizard displays the export progress; when it is finished, it shows how many records have 
been exported.

13 Click Close and you are returned to your translation memory view.

To continue the export process with Excel as the data format

1 Select External Data> Excel.

The export process into Access, ODBC, or text formats is similar to the procedure for 
Excel.
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2 Select the desired export path, give the file an appropriate name, and click Save. The wizard 
displays the current settings. 

3 Click Next.

4 The wizard prompts you to specify the fields you are planning to export.
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5 Click Add and specify for each exportable field the Field Type, Language, and the column 
header in the Excel file (Export As). 

6 Continue until you have selected and specified all necessary fields.

You can move the fields with the up and the down arrows to the right of the selection 
field.
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7 The wizard prompts you to enter any filtering condition, i.e., criteria by which you want to 
filter the export of your database. 

8 If you choose to enter an expression, verify it by clicking the Validate button. If the expression 
proves to be valid, select Next.

–Or–

If you choose not to enter an expression, select Next.

9 Give the worksheet within the Excel spreadsheet the desired name or leave the default name 
(Lexicon).

10 Click Next.

Unless you are very familiar with the underlying structure of the databases, you should 
probably resort to using and modifying the provided samples in the Advanced Topics 
chapter (see "Sample Regular Expressions for Export from Translation Memory and 
Termbase" on page 557).

If you are exporting to text, ODBC, or Access 97, the wizard prompts you to select the 
encoding of the resulting data.
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11 The wizard displays the import progress; when it is finished, it shows how many records have 
been added.

12 Click Close and you are returned to your translation memory view.
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CREATING AND MAINTAINING TERMBASES

OPENING A TERMBASE

1 Select File> Open. 

–Or–

Click  on the Quick Access Toolbar.

–Or–

Press Ctrl+O.

2 The Open dialog appears.

3 Select Termbases under Files of type, select the database you want to open, and click Open.

TERMBASE STATISTICS

It is possible to obtain statistical data about your termbase, such as number of records and 
languages in the termbase.
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To view termbase statistics

1 In an open termbase, select Home> Properties> Statistics.

2 The Statistics tab in the Termbase Properties dialog is displayed.
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3  Click Calculate.

4 The statistics for the current termbase are displayed.

CREATING TERMBASES

There are two different ways to create a termbase:

you can create one during the process of creating a Déjà Vu X3 Workgroup project file, 
or

you can create a termbase as a stand-alone file.

If you create a termbase in the process of creating a project file, Déjà Vu X3 Workgroup will create 
a basic termbase with a default template that you should refine at a later point.

By creating a termbase as a stand-alone file (which you can later associate with project files), a 
creation wizard allows you to select several customized options.

To create a termbase as a stand-alone file

1 Open Déjà Vu X3 Workgroup.

2 The Start screen appears.
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3 Select the Termbase button under Termbase.

-Or-

Select File> New or click the New button in the Quick Access Toolbar if the Start screen is 
disabled.

You can disable the Start screen under File> Options> General> Start-up options.
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4 The New File dialog appears.

5 Double-click Termbase or select Termbase and click OK.

6 Select a folder in which you want to have the termbase saved, and type a name for the 
termbase.
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7 Click Next and select the template to define relationships and attributes that you would like 
to associate with your termbase.

For information on templates, see "Templates" on page 491.
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8 Click Close. Déjà Vu X3 Workgroup displays an empty termbase.

TEMPLATES

Templates are small files in XML format with the extension .dvtdt (Déjà Vu termbase template) that 
are located in the \Templates folder within your Déjà Vu X3 Workgroup installation folder (by 
default C:\ProgramData\Atril\Deja Vu X on an English Windows installation—if you 
can’t view this folder you will need to unhide it by opening Folder Options in the Windows 
Control Panel and selecting View> Show hidden files, folder, and drives). 

The templates files define what kind of relations, attributes and categories your termbase will 
have—in short, how your termbase is going to behave.

You can change the default location of the termbase templates under File> Options> 
General> Shared data location.
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In the default installation of Déjà Vu X3 Workgroup, there are several preset templates:

Template Name Organization No. of 
Attr.

No of 
Rel.

Reference URL

ATRIL 
Déjà Vu X

ATRIL 5 3

Minimal ATRIL 02 1

Eurodicautom European 
Commission

11 3 http://europa.eu.int/eurodicautom/
login.jsp

TIS Council of the 
EU

9 3

Criter Corpus du 
Réseau Inter-
ministériel de 
Terminologie

13 4 http://www.culture.fr/culture/dglf/
garde.htm 

IIF Interval Project 14 2 http://www.computing.surrey. 
ac.uk/ai/new_interval/

Vintars UN at Vienna 21 3 https://cms.unov.org/vintars/
VINTARSDefault.aspx

UNTERM UN at New York 6 2 http://unterm.un.org/

Termite International 
Telecomm. 
Union

7 2 http://www.itu.int/terminology/
index.html

ILOTerm International 
Labour 
Organization

8 2 http://www.ilo.org/iloterm/

CILF Conseil 
international de 
la langue 
française

8 2 http://www.cilf.org/bt.fr.html

SilvaTerm International 
Union of 
Forestry 
Research 
Organization

8 2 http://www.iufro.org/science/
special/silvavoc/silvaterm/
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When creating a new termbase, Déjà Vu X3 Workgroup will by default assign the minimal 
template that only contains the relation "translation." You can easily assign a different template, or 
you can create your own custom templates from scratch or on the basis of existing templates.

To assign a different template

1 While you have a termbase open, select Home> Properties.

–Or–

Press Alt+F7.

2 In the left hand corner of the dialog click Templates.

3 The Termbase Templates dialog appears.

4 Select a different template and click OK.

5 The new template has now been assigned to your termbase.

TBX ISO 23 69 http://en.wikipedia.org/wiki/
Translation_memory#TBX

Template Name Organization No. of 
Attr.

No of 
Rel.

Reference URL
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To create a custom template

1 While you have a termbase open, select Home> Properties.

–Or–

Press Alt+F7.

2 In the left hand corner of the dialog click Templates.

3 The Termbase Templates dialog appears.

4 Select the existing template on which you would like to base a new template and click Save.

5 The Template Name dialog appears.

6 Type in the name you want the new template to have. For this sample, we want to create a 
template that will not hold any grammatical information, so we call it No Grammar.
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7 Click OK.

8 You are returned to the Termbase Templates dialog. Note that the new template No 
Grammar has already been added.

9 Make sure that the new template is highlighted and click OK.
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10 The Termbase Properties dialog appears again. Click the General tab if it is not already 
displayed.

11 Enter an internal name for the template, enter a description, and select whether the subject 
and client information from the project should automatically be entered for each of the 
records that you add to the termbase.
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12 Select the Relations tab.

13 The default settings—which are taken over from the ATRIL Déjà Vu X template—have three 
different relations: Translation, Synonym (a word with the same or similar meaning), and 
Antonym (a word with the opposite meaning). Each relation is defined by a number of 
properties.

Name—the internal name of the relation.

Caption—the name of the relation as it appears in the list on the left in other views of the 
termbase.

Scope—a dropdown field from which you can choose whether this is an interlanguage 
relation, i.e., a relation between different languages, or an intralanguage relation, i.e., a 
relation within one language.
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Reflexive, symmetric, and transitive—the three most basic relationships in a relational 
database model that describe the relationship of an element to itself (reflexive), to one other 
element (symmetric), or to several others (transitive).

14 Click Add to define a new relation, or Delete to delete an existing relation.

Reflexive—A reflexive relationship is a relationship that is valid for itself. For example, a 
translation relation cannot be reflexive, because a term cannot be translated with itself. 
A synonym relation is reflexive, however, because every term is also a synonym of itself. 
An antonym by definition cannot be reflexive, because a term cannot be its own 

opposite.

Symmetric—In a symmetric relationship, the relationship of A to B is also true of B to A. This is the 
classical translation relationship: if term A is the translation of term B, then term B is also the 
translation of term A. Synonym and antonym relations are symmetric relationships as well.

Transitive—In a transitive relationship, the relationship from A to B and A to C is the same as that of 
B to C. Translations from language A to B are not transitive (the German translation of the English 
term "file" can be either "Datei" or "Akte"; however, "Datei" is not the translation of "Akte"), nor are 
synonyms (though "square" is the synonym for both "four-sided figure" and "plaza," "plaza" is not a 
synonym for "four-sided figure") or—by the same logic—antonyms.
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15 Click the Attributes tab.

16 On the left-hand side, you can see the default grammatical Attributes (Part of Speech (=word 
class), Gender, and Number); their Properties are on the right-hand side (Name, Caption, and 
Type).

17 In our case we want to delete all existing grammatical attributes, so we click the Remove 
button until there are no more attributes listed.

18 Now we decide to add a new category, "Style." 

Note that the entries on the Attribute tab are the only ones that are shown during the 
translation process in the AutoSearch pane. Everything that you need to have shown 
there should be entered as an attribute.
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19 Click the Add button, change the Caption and the Name to Style, and select Category 
under Type.
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20  Click the Categories tab and select Style in the Attribute dropdown list.

21 Add as many appropriate attributes as you would like and click Apply and OK. 

22 You are returned to the termbase view.

23 To verify that your new settings have taken effect, click Add in the termbase view.
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24 The Add Term dialog appears. Click the dropdown list next to the newly created attribute 
Style, and you can see that all the new categories are listed.

ASSOCIATING TERMBASES WITH A PROJECT

Termbases can be associated with your project during the creation of a project (see p. 84) or at a 
later point.

To associate termbases with projects

1 In an open project, select Project> Properties> Termbases.
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2 If you would like to disassociate the existing termbase from the project, select that termbase 
and click Remove.

3 If you would like to add an additional termbases, 

select Add Server TB to add a server-based TEAMServer termbase or

select Add Local TB to add a termbase that is on your hard drive or network.

4 If you selected Add Server TB the TEAMserver Login dialog prompts you to enter your login 
credentials.

5 If you selected Add Local TB, a file selector dialog appears.
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6 Select the additional termbase which can be located on a drive of your local computer or 
anywhere in your network and click Open.

7 By default, the newly added termbase has read and write access. Termbases with read access 
will be used to retrieve data for your project and those with write access will have data 
written to them. This means that you can write to several termbases at the same time, thus 
allowing you, for instance, to have a copy of a large termbase on your local computer that you 
read and write from and the original termbase on a network server. You can choose to only 
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write to the network termbase but not read from it, which would avoid increased network 
traffic and could have a significant impact on processing speed.

You can sort the termbases with the up and down arrows or the right side of the field 
where the termbases are listed. If you have selected the option Order of Termbases 
under File> Options> Translation> Termbase options> Sort matches by, the order of 
displayed matches will be determined by the order of termbases in the Termbases tab.

Conversely, if you select Descending date or Ascending date, the order of displayed termbase 
matches will be determined only by the age of the termbase entry.
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8 Make the necessary changes.

9 Click Apply and/or OK.

ADDING RECORDS

Just as Déjà Vu X3 Workgroup offers you the possibility of adding term pairs of different relations 
(see "Templates" on page 491), there are different ways to enter them. Naturally, the emphasis is on 
adding translation records (see "Adding Translation Records" on page 506), for which there are a 
variety of different methods, but there are also ways in which you can add terms of other relations 
(see "Adding Non-Translation Records" on page 514). 

ADDING TRANSLATION RECORDS

There are three ways to add translation records to a termbase:

Manually in the termbase view

Manually as you translate your project

Manually as you align files 

Automatically through import processes
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Though Déjà Vu X3 Workgroup provides the opportunity to manually add entries in the termbase 
view (see p. 501), this is a rarely used and rather tedious way to enter translation information.

A much more efficient way to enter single term pairs to the terminology is during the actual 
translation process.

To manually add term pairs during the translation process

1 While you have a project open, highlight a term or phrase in the source segment and the 
corresponding term or phrase in the target segment with your mouse.
 

2 To send the highlighted terms to the termbase, click Add to Termbase on the on the Home 
ribbon tab

–Or–
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Press F11.

3 Add any specifications, including grammatical information (part of speech, gender or number) 
and semantic definition (such as context information, subject, or client).

4 You may use the Copy button to copy any of the selections from the first to the second 
column.

If you are certain that you do not need to enter any additional information (aside from 
the standard user and date/time information), you can also send the highlighted terms 
or phrases to the termbase by pressing Shift+F11 or by right-clicking and selecting Add 
to Termbase> Quick Add to Termbase on the Home ribbon tab. This method will not 

prompt you to enter any additional information.

Be as judicious and at the same time as thorough as you can by only entering the 
information that will be relevant for you or your co-workers later on. For instance, it 
obviously would not make sense to enter gender information if your language does not 
have a grammatical gender, or if any translator or editor should be familiar with this 

kind of information. On the other hand, it may very well be worthwhile to spend some time 
entering information into the Definition field to give yourself or your co-workers necessary context 
information.
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5 Click Add.

6 Your term pair is now entered into your termbase and can be accessed through the standard 
searching and assemble functions.

IMPORTING EXTERNAL DATA

You add records to your termbases as you translate (see "Adding Translation Records" on page 
506), but Déjà Vu X3 Workgroup also enables you to import external data into termbases. For 
example, this allows you to convert data you have accumulated in other glossaries or even from 
data found on the Internet.

To import data

1 With an open termbase, select the External Data ribbon tab.

You can see the supported formats on the ribbon tab:

Text—for importing delimited text files (tab, comma, etc.)

Access—for importing data from various versions of Microsoft Access

ODBC Database—for importing data from various ODBC data sources

Excel—for importing data from various versions of Microsoft Excel (only .xls files)

For this example, we will select Text to import a multilingual comma-separated value file 
(.csv).

Because you can simultaneously have several termbases assigned in Déjà Vu X3 
Workgroup, make sure that under Project> Properties> Database you assign the 
correct database as the destination database, i.e., the database that is to contain all new 
material from the current project.
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2 Select Text and select the text file you want to import. The wizard displays the current 
settings.

3 Click Next. The wizard displays the data of the file and allows you to adjust the delimiter 
settings.

4 Select the delimiter of your original file (in this case Tab), and check the appropriate option if 
the first row contains field names.
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5 Click Next. The wizard now allows you to specify the field information for the fields of your 
original file.

The available standard fields depend on the template you have assigned to that database. If 
you have attached the default ATRIL Déjà Vu X template you will see the following relations:

Main Lemma (typically the source term) 

Translation

Synonym

Antonym
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New Relation...

and the following attributes:

Part of Speech

Gender

Number

Definition

Subject

Client

New Attribute...

Selecting New Relation will open the New Relation dialog in which you can create a 
new relation and assign it to the template of the termbase.

Selecting New Attribute will open the New Attribute dialog in which you can create a 
new attribute and assign it to the template of the termbase.
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6 Select Main Lemma and the appropriate language and code page settings for the source 
language, and Translation, the appropriate language, relation and code page settings for the 
target languages.

7 Click Next.

8 You are prompted whether you want to remove Duplicate Segments.

9 Click Next.

The Preview field gives you a good overview of the appropriateness of the chosen code 
page. Compare for instance the Arabic column in the previous screenshot and this 
screenshot. Only after selecting the correct code page Unicode, the Arabic characters 
and the direction of writing are displayed correctly.
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10 The wizard displays the import progress; when it is finished, it shows how many records have 
been added.

11 Click Close and you are returned to your termbase view. If you now look for one of the 
imported segments, you will find that all languages have been imported.

ADDING NON-TRANSLATION RECORDS

1 Open the termbase to which you want to enter term pairs of non-translation relations. In this 
example we are going to add a synonym for a term.

2 Locate the term for which you would like to add a synonym.

Enter the term in the Locate Term text field.

–Or–
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Search for the term with the common search function (see "Search and Replace Features" on 
page 228).

3 Click Add in the Related Terms section of the window.

4 The Add Relation dialog appears.

5 Under Relation Type, select Synonym.

6 Under Language, select the same language as the source language.

If you want to add a completely new term, you can do that by clicking Add in the 
Source Language section of the window.
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7 Under Locate Term, enter the synonym or select one from the list of terms.

8 Click Add Term and modify or enter any attributes.
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9 Click Add.

10 You are returned to the Add Relation dialog.

11 Click Add and Close. You are returned to the termbase view.
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12 If you select All under Related Terms and All under Target Languages, you can see that there is 
now an entry under Translation and under Synonym.

EXPORTING DATA FROM A TERMBASES

There are various situations where it may be very helpful to export parts or all of your termbases, 
the most obvious being:

storing a termbase in a compact format or 

sharing termbase content with co-workers or teammates.

To export data

1 With an open termbase, select the External Data ribbon tab.

You can see the supported formats on the ribbon tab:
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TEAMServer—for exporting termbases onto a TEAMServer.)

Text—for exporting delimited text files (tab, comma, etc.)

Access—for exporting data into a Microsoft Access database

ODBC Database—for importing data from various ODBC data sources

Excel—for exporting data into Microsoft Excel

MultiTerm—for  importing termbases in the exported text format from SDL MultiTerm.

In the following example, we will select Excel as the export format.

To continue the export process with Excel as the data format

1 Select Excel and select the desired export path, give the file an appropriate name.

2 Click Next.

The export process into Access, ODBC, or text formats is similar to the procedure for 
Excel.

You can find information on how to export termbase data to TEAMServer under "To 
export a Déjà Vu X3 Workgroup termbase to TEAMserver" on page 290 
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3 The wizard prompts you to specify the fields you are planning to export.

4 Click Add.
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5 Specify for each exportable field the Field Type, Language, the column header in the Excel file 
(Export As), and the relation to other selected fields.

6 Continue until you have selected and specified all necessary fields.

You can move the fields with the up and the down arrows to the right of the selection 
field.
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7 The wizard prompts you to enter any filtering condition, i.e., criteria by which you want to 
filter the export of your database. 

8 If you choose to enter an expression, verify it by clicking the Validate button. If the expression 
proves to be valid, select Next.

–Or–

Unless you are very familiar with the underlying structure of the databases, you should 
probably resort to using and modifying the provided samples in the Advanced Topics 
chapter (see "Sample Regular Expressions for Export from Translation Memory and 
Termbase" on page 557).
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If you choose not to enter an expression, select Next.

If you are exporting to text, Access 97, or ODBC, the wizard prompts you to select the 
encoding of the resulting data. In the case of text, it will also prompt you to enter 
delimitation information:
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9 Give the worksheet within the Excel spreadsheet the desired name or leave the default name 
(Lexicon).

10 Click Next.

11 The wizard displays the export progress; when it is finished, it shows how many records have 
been exported.

12 Click Close and you are returned to your termbase view.
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13 If you open the resulting file in Excel you can see that the fields that you specified have been 
exported.

EDITING THE TERMBASE

To locate a particular term

In the termbase, terms are either sorted naturally (the order in which they were entered) or 
alphabetically.

You can enter the term that you are looking for in the Locate Term text box, or you can search for 
the term with the common search function (see "Search and Replace Features" on page 228).

When you locate the term by entering it in the Locate term text field, Déjà Vu X3 Workgroup will 
reposition to the first record that begins with the letters you have typed so far. This action is 
artificially delayed so that you will have time to type in a few letters before the repositioning 
occurs.

MODIFYING A PARTICULAR TERM

Once you have located the term that you want to modify, you can:

edit the attributes of the term or the term itself,

You can change the sorting order to alphabetical order by clicking the source language 
header.
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delete that term, or

merge that term with several other source terms.

To edit a term

1 Select the source term or (one of) the related term(s).

2 Click Edit in the Source Language section to edit the source term.

–Or–

Click Edit in the Related Terms section to edit the source term.

3 The Edit Term dialog appears.

4 Change the term or the attributes as necessary.

5 Click OK.
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6 If the term is now displayed in the AutoSearch window while translating a project, all the 
Attributes are displayed as well.

To delete a term

1 Select the source term or (one of) the related term(s).

2 Click Delete in the Source Language section to delete the source term and all related terms. 

–Or–

Click Delete in the Related Terms section to delete the source term.

To merge several source terms

1 Select several identical or nearly identical source terms. 

2 Press the Ctrl key while selecting individual records.

–Or–
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Press the Shift key while selecting a range of records. 

3 Click Merge.
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4 The source records are merged into one record with several related terms.

5 If the term is now displayed in the AutoSearch window while translating a project, the two 
target terms are displayed separately.

Only the attributes of the first of the selected source terms are preserved.
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To view all rows or certain subsets of rows

All Segments is the standard view that displays all source segments with their associated target 
segments.

If you want to view only a subset of terms, you can select SQL. This option opens the Select SQL 
dialog in which you can enter any SQL statement to view a certain subset of the termbase.

SPELL CHECKING THE TERMBASE

To activate spell checking

1 Select Home> Spelling.

–Or–

Press F7.

2 The Spell Checking Options dialog appears.
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3 Under Language, you can choose to check any language present in the project, including the 
source language.

4 Under Scope, you can choose to check all entries in that language or just those that have not 
been checked before.

5 The Check Spelling dialog appears with the assumed spelling error highlighted and its context 
displayed in the lower half of the window..

6 For more information on spelling, see "Spell checking" on page 127.

It is a good practice to include the source language in your spell checks. Any misspelling 
in the source is unlikely to occur a second time in later texts, but it will prevent Déjà Vu 
X3 Workgroup from finding exact and/or guaranteed matches.

Limiting the spell check to records that have not been checked is an efficient way to 
avoid duplicating your work.
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DIGGING IN—ADVANCED TOPICS

CREATING CUSTOMIZED HTML IMPORT FILES

Déjà Vu X3 Workgroup will usually be able to separate translatable from non-translatable content 
in HTML files and display the translatable content correctly. Because of the nature of customizable 
and regularly re-defined scripting languages, there may be situations where some text is imported 
that should not be translated. You can choose to copy this text from the source to the target 
column and possibly lock those rows, but Déjà Vu X3 Workgroup also allows you to write simple 
regular expression files that would exclude these lines. 

There are three different customizations that can be performed. These include the conditional 
extraction of attributes in HTML tags, hiding pieces of text that match specific patterns, and 
preventing line breaks in script text.

CONDITIONAL EXTRACTION OF ATTRIBUTES IN HTML TAGS

Déjà Vu X3 Workgroup includes a hard-coded list of which attributes are translatable for each tag:

Tag Attribute

A TITLE

A ONMOUSEOVER

A ONMOUSEOUT

A ONCLICK

APPLET ALT

AREA ALT

IMG ALT

INPUT VALUE

ISINDEX PROMPT

META CONTENT

OBJECT STANDBY

OBJECT TITLE

OPTGROUP LABEL
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You may wish to conditionally override items on this list. For example, you may wish to hide the 
contents of CONTENT in the META tag when NAME contains GENERATOR as in: <META 
NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">.

You can specify these exceptions in a file called HTMExcept.txt. If this is used, it must be saved in 
the directory in which the project file is saved. This file contains five columns separated by tabs, 
following this pattern:

Ordinal   Tagname   KeyToHideWhen   ReferenceKey   ReferenceKeyPattern

The following lines

1   PARAM   VALUE   NAME   [A-Z]+[a-z]+[A-Z]+.*

2   PARAM   VALUE   NAME   id

OPTION LABEL

OPTION VALUE

PARAM VALUE

TABLE SUMMARY

TD ABBR

TD ONMOUSEOVER

TD ONMOUSEOUT

TD ONCLICK

TH ABBR

Each line in the file instructs Déjà Vu X3 Workgroup to hide the contents of 
KeyToHideWhen if the contents of ReferenceKey match 
ReferenceKeyPattern when processing a tag whose name is Tagname. 

The first item is a number used to distinguish between otherwise equal Tagname/
KeyToHideWhen/ReferenceKey 3-tuples. It must be used always, even if there is no 
ambiguity.

Lines beginning with a hash mark (#) are ignored.

ReferenceKeyPattern can either be a pattern or constant text.

Tag Attribute
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1   META   CONTENT   NAME   GENERATOR

would exclude the value from these lines: 

<PARAM NAME=BgColor VALUE=WHITE>

<PARAM NAME=id VALUE=num1>

and the content from:

<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">

If you don't use the HTMExcept.txt file, Déjà Vu X3 Workgroup will default to the following 
exceptions:

1   META   CONTENT   NAME   GENERATOR

2   META   CONTENT   NAME   Generator

3   META   CONTENT   http-equiv   Content-Type

4   META   CONTENT   http-equiv   Pragma

HIDING PIECES OF TEXT THAT MATCH SPECIFIC PATTERNS

It is possible to force Déjà Vu X3 Workgroup to hide pieces of text that match certain patterns, and 
depending on what comes before or after the strings. You can place a file called HTMHide.txt in 
the directory in which the project file is saved and add lines to that file that instruct Déjà Vu X3 
Workgroup how to deal with strings. You will have to follow this structure (each of the entries is 
separated by a tab character):

   Pre   StringstoHide   Post   StringsToDisplay

Example 1:

   \WSession\("      "\)   (User1|User2)

would be interpreted by Déjà Vu X3 Workgroup as: 

a non-word character, followed by the word Session, followed by an opening 
parenthesis and a double quote (Pre); 

For specifications on regular expression in VBScript, see the MSDN library at http://
msdn.microsoft.com/library.
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followed by any string (StringstoHide); 

followed by a double quote and closing parenthesis (Post); 

followed by the strings User1 or User2 (and not User3 or UserName) 
(StringsToDisplay)

resulting in displaying User2 in Session("User2") but not User7 in 
Session("User7").

Example 2:

   \WRedirect(\W)*"      "\W   

would be interpreted by Déjà Vu X3 Workgroup as:

a non-word character, followed by the word Redirect, followed by a non-word 
character appearing zero or more times, followed by a double quote (Pre); 

followed by any string (StringstoHide); 

followed by a double quote and a non-word character (Post) with no strings to 
display (StringsToDisplay) (i.e., hide any strings that appear surrounded by Pre and 
Post)

resulting in not displaying www.atril.com/default.asp in Response.Redirect "http:/
/www.atril.com/default.asp"

Example 3:

         *[a-z]+[A-Z]+.*      

would be interpreted by Déjà Vu X3 Workgroup as:

any string (Pre); 

followed by any number of characters, followed by a lowercase letter appearing one 
or more times, followed by an uppercase letter appearing one or more times, 
followed by any number of characters (StringsToHide); 

followed by any string (Post) 

with no strings to display (StringsToDisplay)
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resulting in not displaying retValue.

PREVENTING LINE BREAKS IN SCRIPT TEXT

Bits of text found in scripts will normally go to a new segment in the Déjà Vu X3 
project. For example, in

+ "(client has " + Trim(CStr(PrevCopies)) + " copies of 
D&eacute;j&agrave;Vu X3)"

the two pieces of text will end up in two different Déjà Vu rows, unless you tell Déjà Vu X3 
that

" + Trim(CStr(PrevCopies)) + "

is a pattern that does not force a segment change.

You can place a file called ASPNoBreaks.txt in the directory in which the project file is, each of 
whose lines contains one pattern. The following two lines:

" *(\+|&) *" *

Items are separated by tabs.

Lines beginning with a hash mark (#) are ignored.

Any items may be empty, but the three tabs must be present.

Pre is a pattern that describes the characters before the string in questions; if empty, 
Déjà Vu X3 Workgroup will ignore it.

StringsToHide is a pattern that describes the string itself; if empty, Déjà Vu X3 Workgroup assumes 
"any string."

Post is a pattern that describes the characters after the string; if empty, Déjà Vu X3 Workgroup will 
ignore it.

You can use StringsToDisplay rather than StringsToHide. If you do, StringsToDisplay is a pattern that 
describes the strings that must be displayed. All other strings will be hidden. To specify a list of 
strings in StringsToDisplay, separate them with '|' and enclose the list in parentheses, as in the first 
example below.

If StringsToHide is not empty, then StringsToDisplay will be ignored.

All rows must contain exactly three tab characters even if not all the items are used.

For specifications on regular expression in VBScript, see the MSDN library at http://
msdn.microsoft.com/library.
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" *(\+|&) *(\w|\.)*[(]*(\w|\.)*[)]* +(\+|&) *" *

would mean that whenever any of the following pattern occurs:

double quote, followed by any number of spaces, followed by a plus sign or 
ampersand, followed by any number of spaces, followed by a double quote, and 
any number of spaces (for example: " + ")

double quote, followed by any number of spaces, followed by a plus sign or 
ampersand, followed by any number of spaces, followed by a word character or dot 
appearing zero or more times, followed by any number of open parentheses, 
followed by a word character or dot appearing zero or more times, followed by any 
number of close parentheses, followed by at least one space, followed by a plus sign 
or ampersand, followed by any number of spaces, followed by double quote, 
followed by any number of spaces (for example: " + 
Trim(CStr(PrevCopies)) + ")

the line would not break.

USING STRUCTURED QUERY LANGUAGE AND SAMPLE SQL STATEMENTS

Déjà Vu X3 Workgroup provides for several ways to use standard SQL commands to update or 
modify project files, translation memories, and termbases—all of which are database files.

In project files, you can enter a SELECT command with the help if an Expression Builder 
(see "To use the SQL Statement view" on page 49)

In project files, you can enter a full SQL statement under Project> Execute SQL.

In translation memories and termbases, you can enter a full SQL statement under 
Home> Execute SQL.

For specifications on regular expression in VBScript, see the MSDN library at http://
msdn.microsoft.com/library.

The above mechanisms also work when you are aligning any files. The only difference 
is that you will have to save HTMExcept.txt, HTMHide.txt, or ASPNoBreaks.txt in Déjà Vu X3 
Workgroup's installation directory rather than in the project's common source directory.

Before executing any SQL command, make sure that your files are backed up. There is 
no undo function!
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Digging In—Advanced Topics
Due to the relatively complicated nature of the database structure of Déjà Vu X3 Workgroup, we 
will give some samples of SQL statements that you can use, and if applicable, alter to your specific 
needs.

COMMANDS TO DELETE DATA FROM THE TRANSLATION MEMORY

Delete project 1234567 from translation memory

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE 
PrjID=1234567)

DELETE FROM Translations WHERE PrjID=1234567

Delete translation memory records with client "ABC"

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE 
Client='ABC')

DELETE FROM Translations WHERE Client='ABC'

Delete translation memory records with subject "123"

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE 
Subject='123')

DELETE FROM Translations WHERE Subject='123'

Delete translation memory records with client "ABC" and with subject "123"

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE 
Client='ABC' AND Subject='123')

If there are several commands listed under one heading, you will have to make sure 
that you enter all of them in successive order. To omit one of them may leave the 
database file in an unstable condition.

If you need help with more complex SQL statements, please contact Atril support at 
support@atril.com, to discuss ways in which we can help you.

After executing any DELETE command for the translation memory, you will have to 
make that you select Tools> Repair> Translation Memory to repair the translation 
memory. This is necessary to keep the index congruent with the information in the 
database.
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DELETE FROM Translations WHERE Client='ABC' AND Subject='123'

Delete translation memory records where the source is shorter than 4 characters

Replace ConditionOnSentence with: Len(Sentence)<4 AND IsSource

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
ConditionOnSentence)

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
ConditionOnSentence)

Delete translation memory records where American English records contain "ß" or "ä" or 
"ö" or "ü"

Replace ConditionOnSentence with: Lang = 9 AND SubLang = 1 AND 
(Sentence LIKE '*ß*' OR Sentence LIKE '*ä*' OR Sentence LIKE '*ö*' OR 
Sentence LIKE '*ü*')

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
ConditionOnSentence)

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
ConditionOnSentence)

Delete translation memory records with FileID "987" from translation memory

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Translations WHERE 
FileID=987)

DELETE FROM Translations WHERE FileID=987

Delete translation memory records entered on December 31, 2010

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #12/31/2009# AND Datestamp<#1/1/2010#)

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #12/31/2009# AND Datestamp<#1/1/2010#)

You need the lower and upper boundaries for the date field because the same field also 
contains the time value.
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Delete translation memory records entered on or after December 31, 2009

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #12/31/2009#)

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #12/31/2009#)

Delete translation memory records entered between January 1, 2015, and January 31, 
2015

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #1/1/2015# and Datestamp<#2/1/2015#)

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #1/1/2015# and Datestamp<#2/1/2015#)

Delete translation memory records entered on January 1, 2015, between 11 am and 3 
pm

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #1/1/2015 11:00# and Datestamp<#1/1/2015 15:00#)

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
Datestamp >= #1/1/2015 11:00# and Datestamp<#1/1/2015 15:00#)

If you surround the date with #, you will have to use the format mm/dd/yy or mm/dd/
yyyy. It is also possible to use the Datevalue function in combination with date in the 
format currently specified in the Windows Regional Options (under Start> Settings> 
Control Panel> Regional Options> Date), e.g., Datestamp >= Datevalue('31/12/

2009') for the default German setting.

You need the lower and upper boundaries for the date field because the same field also 
contains the time value.

You need the lower and upper boundaries for the date field because the same field also 
contains the time value.
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Delete all translation memory records in U.S. English starting with "ABC"

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')

Delete all translation memory records in U.S. English containing "ABC"

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
Lang = 9 AND SubLang = 1 AND Sentence LIKE '*ABC*')

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
Lang = 9 AND SubLang = 1 AND Sentence LIKE '*ABC*')

Delete all translation memory records from User "Joe"

DELETE FROM Translations WHERE ID IN (SELECT ID FROM Sentences WHERE 
UserNick = 'Joe')

DELETE FROM Sentences WHERE ID IN (SELECT ID FROM Sentences WHERE 
UserNick = 'Joe')

Delete all translation memory records where U.S. English is equal to Standard Spanish

DELETE FROM Translations WHERE ID IN (SELECT S1.ID FROM Sentences AS 
S1 INNER JOIN Sentences AS S2 ON S1.ID = S2.ID WHERE S1.Sentence = 
S2.Sentence AND S1.Lang=9 AND S1.SubLang = 1 AND S2.Lang = 10 AND 
S2.SubLang = 1))

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.
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DELETE FROM Sentences WHERE ID IN (SELECT S1.ID FROM Sentences AS S1 
INNER JOIN Sentences AS S2 ON S1.ID = S2.ID WHERE S1.Sentence = 
S2.Sentence AND S1.Lang=9 AND S1.SubLang = 1 AND S2.Lang = 10 AND 
S2.SubLang = 1))

COMMANDS TO DELETE DATA FROM THE TERMBASE

Delete termbase records with client "ABC

DELETE FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE 
AttrTypeID=6 AND Textvalue='ABC')

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT LemmaID FROM 
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC')

DELETE FROM Attributes WHERE AttrTypeID=6 AND Textvalue='ABC'

Delete termbase records with subject "123"

DELETE FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE 
AttrTypeID=5 AND Textvalue='123')

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT LemmaID FROM 
Attributes WHERE AttrTypeID=5 AND Textvalue='123')

DELETE FROM Relations WHERE DstLemmaID IN (SELECT LemmaID FROM 
Attributes WHERE AttrTypeID=5 AND Textvalue='123')

DELETE FROM Attributes WHERE AttrTypeID=5 AND Textvalue='123'

Before you execute this command, you will have to verify what AttrTypeID "client" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents client. In this example we 
assume that this code is 6, but this will not necessarily be the case for your database.

Before you execute this command, you will have to verify what AttrTypeID "subject" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents subject. In this example we 
assume that this code is 5, but this will not necessarily be the case for your database.
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Delete termbase records with client "ABC" and with subject "123"

DELETE FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE 
AttrTypeID=6 AND Textvalue='ABC') AND ID IN (SELECT LemmaID FROM 
Attributes WHERE AttrTypeID=5 AND Textvalue='123')

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT LemmaID FROM 
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC') AND OrgLemmaID IN 
(SELECT LemmaID FROM Attributes WHERE AttrTypeID=5 AND 
Textvalue='123')

DELETE FROM Relations WHERE DstLemmaID IN (SELECT LemmaID FROM 
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC') AND DstLemmaID IN 
(SELECT LemmaID FROM Attributes WHERE AttrTypeID=5 AND 
Textvalue='123')

DELETE FROM Attributes WHERE LemmaID IN (SELECT LemmaID FROM 
Attributes WHERE AttrTypeID=6 AND Textvalue='ABC') AND LemmaID IN 
(SELECT LemmaID FROM Attributes WHERE AttrTypeID=5 AND 
Textvalue='123')

Remove the association between termbase records entered on or after December 31, 
2014

DELETE FROM Relations WHERE Datestamp >= #12/31/2014#

Remove the termbase records entered on or after December 31, 2014

DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM 
Relations WHERE Datestamp >= #12/31/2014#) OR LemmaID IN (SELECT 
DstLemmaID FROM Relations WHERE Datestamp >= #12/31/2014#)

Before you execute this command, you will have to verify what AttrTypeID "client" and 
"subject" have in your termbase. You can do that by opening the AttrTypes table within 
the termbase with Microsoft Access. Look for the ID that represents client. In this 
example we assume that this code is 5 and 6, but this will not necessarily be the case 

for your database.

This command removes the association but leaves the actual terms in the database.
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DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations 
WHERE Datestamp >= #12/31/2014#) OR ID IN (SELECT DstLemmaID FROM 
Relations WHERE Datestamp >= #12/31/2014#)

DELETE FROM Relations WHERE Datestamp >= #12/31/2014#

Remove the association between termbase records entered on December 31, 2014

DELETE FROM Relations WHERE Datestamp >= #12/31/2014# and 
Datestamp<#1/1/2015#

Delete the termbase records entered on December 31, 2014

DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM 
Relations WHERE Datestamp >= #12/31/2014# and Datestamp<#1/1/2015#) 
OR LemmaID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >= 
#12/31/2014# and Datestamp<#1/1/2015#)

DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations 
WHERE Datestamp >= #12/31/2014#) OR ID IN (SELECT DstLemmaID FROM 
Relations WHERE Datestamp >= #12/31/2014# and Datestamp<#1/1/2015#)

DELETE FROM Relations WHERE Datestamp >= #12/31/2014# and 
Datestamp<#1/1/2015#

Remove the association between termbase records entered between January 1, 2015 
and January 31, 2015

DELETE FROM Relations WHERE Datestamp >= #1/1/2015# AND Datestamp<#2/
1/2015#

This command removes the association but leaves the actual terms in the database.

You need the lower and upper boundaries for the date field because the same field also 
contains the time value.

This command removes the association but leaves the actual terms in the database.
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Delete the termbase records entered between January 1, 2015, and January 31, 2015

DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM 
Relations WHERE Datestamp >= #1/1/2015# and Datestamp<#2/1/2015#) OR 
LemmaID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >= #1/1/
2015# and Datestamp<#2/1/2015#)

DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations 
WHERE Datestamp >= #1/1/2015# and Datestamp<#2/1/2015#) OR ID IN 
(SELECT DstLemmaID FROM Relations WHERE Datestamp >= #1/1/2015# and 
Datestamp<#2/1/2015#)

DELETE FROM Relations WHERE Datestamp >= #1/1/2015# AND Datestamp<#2/
1/2015#

Remove the association between termbase records entered on January 1, 2015, 
between 11 am and 3 pm

DELETE FROM Relations WHERE Datestamp >= #1/1/2015 11:00# AND 
Datestamp<#1/1/2015 15:00#

Delete termbase records entered on January 1, 2015, between 11 am and 3 pm

DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM 
Relations WHERE Datestamp >= #1/1/2015 11:00# AND Datestamp<#1/1/2015 
15:00#) OR LemmaID IN (SELECT DstLemmaID FROM Relations WHERE 
Datestamp >= #1/1/2015 11:00# AND Datestamp<#1/1/2015 15:00#)

DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations 
WHERE Datestamp >= #1/1/2015 11:00# AND Datestamp<#1/1/2015 15:00#) 
OR ID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >= #1/1/
2015 11:00# AND Datestamp<#1/1/2015 15:00#)

DELETE FROM Relations WHERE Datestamp >= #1/1/2015 11:00# AND 
Datestamp<#1/1/2015 15:00#

This command removes the association but leaves the actual terms in the database.
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Delete termbase records in U.S. English starting with "ABC"

The terms (including attributes, relations, and lemmas):

DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE 
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas 
WHERE Condition) OR DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 
AND SubLang = 1 Lemma LIKE 'ABC*')

DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*'

Related lemmas:

DELETE FROM Lemmas WHERE (ID IN (SELECT OrgLemmaID FROM Relations 
WHERE DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 
1 Lemma LIKE 'ABC*')) OR ID IN (SELECT DstLemmaID FROM Relations 
WHERE OrgLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 
1 Lemma LIKE 'ABC*')))

Break relations:

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas 
WHERE Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*') OR DstLemmaID IN 
(SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE 
'ABC*')))

Related attributes:

DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE 
Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*')

Only the lemmas:

DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*'

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.
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Delete all termbase records in U.S. English containing "ABC"

The terms (including attributes, relations, and lemmas):

DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE 
ConditionOnLemma)

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas 
WHERE Condition) OR DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 
AND SubLang = 1 Lemma LIKE '*ABC*')

DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*'

Related lemmas:

DELETE FROM Lemmas WHERE (ID IN (SELECT OrgLemmaID FROM Relations 
WHERE DstLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 
1 Lemma LIKE '*ABC*')) OR ID IN (SELECT DstLemmaID FROM Relations 
WHERE OrgLemmaID IN (SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 
1 Lemma LIKE '*ABC*')))

Break relations:

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas 
WHERE Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*') OR DstLemmaID IN 
(SELECT ID FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE 
'*ABC*')))

Only the lemmas:

DELETE FROM Lemmas WHERE Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*'

Delete all termbase records from User "Joe"

Just removing the connection between related terms without deleting the terms from the 
termbase:

DELETE FROM Relations WHERE UserNick = 'Joe'

Removing the terms (including attributes, relations, and lemmas):

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.
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DELETE FROM Attributes WHERE LemmaID IN (SELECT OrgLemmaID FROM 
Relations WHERE UserNick = 'Joe') OR LemmaID IN (SELECT DstLemmaID 
FROM Relations WHERE UserNick = 'Joe')

DELETE FROM Lemmas WHERE ID IN (SELECT OrgLemmaID FROM Relations 
WHERE UserNick = 'Joe') OR ID IN (SELECT DstLemmaID FROM Relations 
WHERE UserNick = 'Joe')

DELETE FROM Relations WHERE UserNick = 'Joe'

Delete all termbase translation records where U.S. English is equal to Standard Spanish

Deleting the attributes:

DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE 
ID IN (SELECT L1.ID FROM Lemmas AS L1, Relations, Lemmas AS L2 WHERE 
Relations.RelTypeID = 1 AND ((L1.ID = Relations.OrgLemmaID AND L2.ID 
= Relations.DstLemmaID) OR (L2.ID = Relations.OrgLemmaID AND L1.ID = 
Relations.DstLemmaID)) AND L1.Lemma = L2.Lemma AND ((L1.Lang=9 AND 
L1.SubLang = 1 AND L2.Lang = 10 AND L2.SubLang = 1) OR (L2.Lang=9 AND 
L2.SubLang = 1 AND L1.Lang = 10 AND L1.SubLang = 1))))

Deleting the terms:

DELETE FROM Lemmas WHERE ID IN (SELECT L1.ID FROM Lemmas AS L1, 
Relations, Lemmas AS L2 WHERE Relations.RelTypeID = 1 AND ((L1.ID = 
Relations.OrgLemmaID AND L2.ID = Relations.DstLemmaID) OR (L2.ID = 
Relations.OrgLemmaID AND L1.ID = Relations.DstLemmaID)) AND L1.Lemma 
= L2.Lemma AND ((L1.Lang=9 AND L1.SubLang = 1 AND L2.Lang = 10 AND 
L2.SubLang = 1) OR (L2.Lang=9 AND L2.SubLang = 1 AND L1.Lang = 10 AND 
L1.SubLang = 1)))

Delete termbase records where the source is longer than 255 characters

Replace ConditionOnLemma with: LEN(Lemma)>255

DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE 
ConditionOnLemma)

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.
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DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas 
WHERE ConditionOnLemma)

DELETE FROM Relations WHERE DstLemmaID IN (SELECT ID FROM Lemmas 
WHERE ConditionOnLemma)

DELETE FROM Lemmas WHERE ConditionOnLemma

Delete termbase records where American English records contain "ß" or "ä" or "ö" or "ü"

Replace ConditionOnLemma with: Lang = 9 AND SubLang = 1 AND (Sentence 
LIKE '*ß*' OR Sentence LIKE '*ä*' OR Sentence LIKE '*ö*' OR Sentence 
LIKE '*ü*')

DELETE FROM Attributes WHERE LemmaID IN (SELECT ID FROM Lemmas WHERE 
ConditionOnLemma)

DELETE FROM Relations WHERE OrgLemmaID IN (SELECT ID FROM Lemmas 
WHERE ConditionOnLemma)

DELETE FROM Relations WHERE DstLemmaID IN (SELECT ID FROM Lemmas 
WHERE ConditionOnLemma)

DELETE FROM Lemmas WHERE ConditionOnLemma

COMMANDS TO UPDATE RECORDS IN THE TRANSLATION MEMORY

Change client to "DEF" in translation memory

UPDATE Translations SET Client = 'DEF'

Change translation memory records with client  "ABC" in to client "DEF"

UPDATE Translations SET Client='DEF' WHERE Client='ABC'

Change translation memory records with subject "123" in to subject "456"

UPDATE Translations SET Subject='456' WHERE Subject='123'
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Change translation memory records marked as American English to British English

UPDATE Sentences SET SubLang=2 WHERE Lang = 9 AND SubLang = 1

Change client to "1234" for translation memory records entered on December 31, 2014

UPDATE TRANSLATIONS SET Client='1234' WHERE ID IN (SELECT ID FROM 
SENTENCES WHERE Datestamp >= #12/31/2014# AND Datestamp<#1/1/2015#)

Change user to "Joe" for translation memory records with client "1234"

UPDATE Sentences SET UserNick = 'Joe' WHERE ID IN (SELECT ID FROM 
Translations WHERE Client = '1234')

COMMANDS TO UPDATE RECORDS IN THE TERMBASE

Change client to "DEF" in termbase

DELETE FROM Attributes WHERE AttrTypeID = 6

INSERT INTO Attributes SELECT 'DEF' AS TextValue, 6 as AttrTypeID, ID 
AS LemmaID FROM Lemmas

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.

After executing a command of this type for the main language (rather than the 
sublanguage), you will have to make that you select Tools> Repair> Translation 
Memory to repair the translation memory.

Before you execute this command, you will have to verify what AttrTypeID "client" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents client. In this example we 
assume that this code is 6, but this will not necessarily be the case for your database.
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Change client to "DEF" in termbase for records entered on December 31, 2014

DELETE FROM Attributes WHERE AttrTypeID = 6 AND LemmaID IN (SELECT ID 
FROM Lemmas WHERE Datestamp >= #12/31/2014# AND Datestamp<#1/1/2015#)

INSERT INTO Attributes SELECT 'DEF' AS TextValue, 6 as AttrTypeID, ID 
AS LemmaID FROM Lemmas WHERE Datestamp >= #12/31/2014# AND 
Datestamp<#1/1/2015#

Change client to "DEF" in translation memory for records with subject "9876"

UPDATE TRANSLATIONS SET Client='DEF' WHERE Subject = '9876'

Change client to "DEF" in termbase for records with subject "9876"

DELETE FROM Attributes WHERE AttrTypeID = 6 AND LemmaID IN (SELECT ID 
FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE 
AttrTypeID = 5 and TextValue = '9876'))

INSERT INTO Attributes SELECT 'DEF' AS TextValue, 6 as AttrTypeID, ID 
AS LemmaID FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes 
WHERE AttrTypeID = 5 and TextValue = '9876')

Before you execute this command, you will have to verify what AttrTypeID "client" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents client. In this example we 
assume that this code is 6, but this will not necessarily be the case for your database.

Before you execute this command, you will have to verify what AttrTypeID "client" and 
"subject" have in your termbase. You can do that by opening the AttrTypes table within 
the termbase with Microsoft Access. Look for the IDs that represent client and subject. 
In this example we assume that the code for client is 6 and for subject 5, but this will 

not necessarily be the case for your database.
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Change user to "Joe" in termbase for records with client "DEF"

UPDATE Relations SET UserNick = 'Joe' WHERE OrgLemmaID IN (SELECT ID 
FROM Lemmas WHERE ID IN (SELECT LemmaID FROM Attributes WHERE 
AttrTypeID = 6 AND TextValue = 'DEF'))

Change records with client "ABC" in termbase to client "DEF"

UPDATE Attributes SET Textvalue='DEF' WHERE AttrTypeID=6 AND 
Textvalue='ABC'

Change records with subject "123" in termbase to subject "456"

UPDATE Attributes SET Textvalue='456' WHERE AttrTypeID=5 AND 
Textvalue='123'

Change termbase records marked as American English to British English

UPDATE Lemmas SET SubLang=2 WHERE Lang = 9 AND SubLang = 1

Before you execute this command, you will have to verify what AttrTypeID "client" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents client. In this example we 
assume that this code is 6, but this will not necessarily be the case for your database.

Before you execute this command, you will have to verify what AttrTypeID "client" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents client. In this example we 
assume that this code is 6, but this will not necessarily be the case for your database.

Before you execute this command, you will have to verify what AttrTypeID "subject" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents subject. In this example we 
assume that this code is 5, but this will not necessarily be the case for your database.
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COMMANDS TO UPDATE RECORDS IN THE PROJECT FILE

Prevent translation project records containing "ABC" in Standard Spanish from being sent 
to the translation memory

UPDATE Pairs SET Status_1034 = Status_1034 + 2048 WHERE Target_1034 
LIKE '*ABC*' AND ((Status_1034 \ 2048) MOD 2) <> 1

Change translation status of translation project records from fuzzy to progress status 
locked

UPDATE Pairs SET Status_1034 = Status_1034 – 2 + 512 WHERE 
((Status_1034 \ 2) MOD 2) = 1 AND ((Status_1034 \ 512) MOD 2) <> 1

SAVING SQL EXPRESSIONS

Once you have written or assembled a SQL expression, it is possible to save this for later use with 
translation memories, termbases, or project files.

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.

For commands involving any field for which the language code is part of the field name 
(such as Status_xxxx or Target_xxxx) in projects, you will have to use a four- or five-digit language 
ID that follows this formula: (Sublanguage * 1024) + Language, i.e., Standard Spanish 
would be (1 * 1024) + 10 = 1034.

For a list of codes for field attributes, see "List of Codes for Field Attributes in Projects" on page 572.

For a list of codes for field attributes, see "List of Codes for Field Attributes in Projects" 
on page 572.
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You can view all your saved expressions under Tools> Options> SQL.

Within the same dialog you can also create SQL filters or statements, but the more typical way of 
creating and saving them would be in the actual application itself.

CREATING AND SAVING A SQL STATEMENT

In our example, we’ll create and save a SQL statement for a translation memory.

1 With an open translation memory, select Translation Memory> Execute SQL.

2 Enter a valid SQL expression under SQL Statement.
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3 You can see that the Save button is still disabled.

4 Enter a name under Statement Name.

5 The Save button is now activated. Click the button.

6 In the submenu under Translation Memory> Execute SQL, you can now see the statement 
listed under that name, and you can execute it by selecting it.
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7 If you reopen the dialog under File> Options> SQL and select "Translation Memory" under 
Database Type, you can also see the new expression listed right there: 

SAMPLE REGULAR EXPRESSIONS FOR EXPORT FROM TRANSLATION 
MEMORY AND TERMBASE

The following regular expressions can be used in the Filtering Conditions window of the Termbase/
Translation Memory Export Wizards (see p. 476 and p. 522) to export only a subset of your 
databases into one of the supported formats. After you have entered or copied and pasted the 
expressions into the provided text field, you should make sure that you validate them by selecting 
the Validate button below the text field. 

Export records belonging to project 1234567 from translation memory

PrjID=1234567

Export records of subject "123" from translation memory

Subject='123'

Creating saved statements for termbases and projects follows a similar pattern.
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Export records of subject "123" from termbase

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 5 and 
TextValue = '123')

Export records of client "987" from translation memory

Client='987'

Export records of client "987" from termbase

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 6 and 
TextValue = '987')

Export records of client "987" and subject "123" from translation memory

Client='987' AND Subject='123'

Export records of client "987" and subject "123" from termbase

ID IN (SELECT LemmaID FROM Attributes WHERE AttrTypeID = 6 and 
TextValue = '987') AND ID IN (SELECT LemmaID FROM Attributes WHERE 
AttrTypeID = 5 and TextValue = '123')

Before you execute this command, you will have to verify what AttrTypeID "subject" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents subject. In this example we 
assume that this code is 5, but this will not necessarily be the case for your database.

Before you execute this command, you will have to verify what AttrTypeID "client" has 
in your termbase. You can do that by opening the AttrTypes table within the termbase 
with Microsoft Access. Look for the ID that represents client. In this example we 
assume that this code is 6, but this will not necessarily be the case for your database.

Before you execute this command, you will have to verify what AttrTypeIDs "client" and 
"subject" have in your termbase. You can do that by opening the AttrTypes table within 
the termbase with Microsoft Access. Look for the IDs that represents client and subject. 
In this example we assume that the codes are 5 and 6, but this will not necessarily be 

the case for your database.
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Export translation memory records entered on or after December 21, 2014

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/2014#)

Export termbase records entered on or after December 21, 2014

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #12/21/
2014#) OR ID IN (SELECT DstLemmaID FROM Relations WHERE Datestamp >= 
#12/21/2014#)

Export translation memory records entered on December 21, 2014

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/2014# AND 
Datestamp<#12/22/2014#)

Export termbase records entered on December 21, 2014

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #12/21/
2014# AND Datestamp<#12/22/2014#) OR ID IN (SELECT DstLemmaID FROM 
Relations WHERE Datestamp >= #12/21/2014# AND Datestamp<#12/22/2014#)

Export translation memory records entered between January 1, 2015, and January 31, 
2015

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #1/1/2015# AND 
Datestamp<#2/1/2015#)

Export termbase records entered between January 1, 2015, and January 31, 2015

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #1/1/2015# 
AND Datestamp<#2/1/2015#) OR ID IN (SELECT DstLemmaID FROM Relations 
WHERE Datestamp >= #1/1/2015# AND Datestamp<#2/1/2015#)

Because the date field also contains a time value, you have to add lower and upper 
boundaries.

Because the date field also contains a time value, you have to add lower and upper 
boundaries.
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Export translation memory records entered on December 21, 2014, between 12 pm and 
3 pm

ID IN (SELECT ID FROM Sentences WHERE Datestamp >= #12/21/2014 11:00# 
AND Datestamp<#12/21/2014 15:00#)

Export termbase records entered on December 21, 2014, between 12 pm and 3 pm

ID IN (SELECT OrgLemmaID FROM Relations WHERE Datestamp >= #12/21/
2014 11:00# AND Datestamp<#12/21/2014 15:00#) OR ID IN (SELECT 
DstLemmaID FROM Relations WHERE Datestamp >= #12/21/2014 11:00# AND 
Datestamp<#12/21/2014 15:00#)

Export all translation memory records in U.S. English starting with "ABC"

ID IN (SELECT ID FROM Sentences WHERE Lang = 9 AND SubLang = 1 AND 
Sentence LIKE 'ABC*')

Export all termbase records in U.S. English starting with "ABC"

Lang=9 AND SubLang = 1 Lemma LIKE 'ABC*'

Export all termbase records in U.S. English containing "ABC"

ID IN (SELECT ID FROM Sentences WHERE Lang = 9 AND SubLang = 1 AND 
Sentence LIKE '*ABC*')

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.
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Export all termbase records in U.S. English containing "ABC"

Lang=9 AND SubLang = 1 Lemma LIKE '*ABC*'

Export all translation memory records from User "Joe"

ID IN (SELECT ID FROM Sentences WHERE UserNick = 'Joe')

Export all termbase records from User "Joe"

ID IN (SELECT OrgLemmaID FROM Relations WHERE UserNick = 'Joe') OR ID 
IN (SELECT DstLemmaID FROM Relations WHERE UserNick = 'Joe')

For a list of language and sublanguage codes, see "List of Language and Sublanguage 
Codes" on page 562.
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LIST OF LANGUAGE AND SUBLANGUAGE CODES

The following tables provide you with a list of codes for the languages and sublanguages used in 
Déjà Vu X3 Workgroup that can be used in SQL commands and filtering expressions.

For commands involving any field for which the language code is part of the field name 
(such as Status_xxxx or Target_xxxx) in projects, you will have to use a four- or five-digit 
language ID that follows this formula: (Sublanguage * 1024) + Language, i.e., 
Standard Spanish would be (1 * 1024) + 10 = 1034.

Language Decimal Code

Afrikaans  54

Albanian  28

Amharic  94

Arabic  1

Armenian  43

Assamese  77

Azeri  44

Basque  45

Belarusian  35

Bengali  69

Bosnian  26

Bulgarian  2

Burmese  85

Catalan  3

Cherokee  92

Chinese  4

Croatian  26

Czech  5

Danish  6
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Divehi  101

Dutch  19

Dzongkha  81

Edo  102

English  9

Estonian  37

Faeroese  56

Farsi  41

Filipino  100

Finnish  11

French  12

Frisian  98

Fulfulde  103

Gaelic  60

Galician  86

Georgian  55

German  7

Greek  8

Guarani  116

Gujarati  71

Hausa  104

Hawaiian  117

Hebrew  13

Hindi  57

Hungarian  14

Language Decimal Code
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Ibibio  105

Icelandic  15

Igbo  112

Indonesian  33

Inuktitut  93

Italian  16

Japanese  17

Kannada  75

Kanuri  113

Kashmiri  96

Kazakh  63

Khmer  83

Konkani  87

Korean  18

Kyrgyz  64

Lao  84

Latin  118

Latvian  38

Lithuanian  39

Macedonian  47

Malay  62

Malayalam  76

Maltese  58

Manipuri  88

Marathi  78

Language Decimal Code
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Moldavian  24

Mongolian  80

Nepali  97

Neutral  0

Norwegian  20

Oriya  72

Oromo  114

Papiamentu  121

Pashto  99

Polish  21

Portuguese  22

Punjabi  70

Rhaeto Romanic  23

Romanian  24

Russian  25

Sami  59

Sanskrit  79

Serbian  26

Sindhi  89

Sinhalese  91

Slovak  27

Slovenian  36

Somali  119

Sorbian  46

Spanish  10

Language Decimal Code
Déjà Vu X3    565



566
Sutu  48

Swahili  65

Swedish  29

Syriac  90

Tajik  40

Tamazight  95

Tamil  73

Tatar  68

Telugu  74

Thai  30

Tibetan  81

Tigrigna  115

Tsonga  49

Tswana  50

Turkish  31

Turkmen  66

Ukrainian  34

Urdu  32

Uzbek  67

Venda  51

Vietnamese  42

Welsh  82

Xhosa  52

Yi  120

Yiddish  61

Language Decimal Code
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Yoruba  106

Zulu  53

Sublanguage Decimal Code

Neutral  0

Default  1

Sys Default  2

Arabic Saudi Arabia  1

Arabic Iraq  2

Arabic Egypt  3

Arabic Libya  4

Arabic Algeria  5

Arabic Morocco  6

Arabic Tunisia  7

Arabic Oman  8

Arabic Yemen  9

Arabic Syria  10

Arabic Jordan  11

Arabic Lebanon  12

Arabic Kuwait  13

Arabic UAE  14

Arabic Bahrain  15

Arabic Qatar  16

Azeri Latin  1

Azeri Cyrillic  2

Bengali India  1

Language Decimal Code
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Bengali Bangladesh  2

Chinese Traditional  1

Chinese Simplified  2

Chinese Hong Kong  3

Chinese Singapore  4

Chinese Macau  5

Croatian Standard  1

Croatian Bosnia  4

Dutch Standard  1

Dutch Belgium  2

English United States  1

English United Kingdom  2

English Australia  3

English Canada  4

English New Zealand  5

English Ireland  6

English South Africa  7

English Jamaica  8

English Caribbean  9

English Belize  10

English Trinidad  11

English Zimbabwe  12

English Philippines  13

English Indonesia  14

English Hong Kong  15

Sublanguage Decimal Code
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English India  16

English Malaysia  17

English Singapore  18

French Standard  1

French Belgium  2

French Canada  3

French Switzerland  4

French Luxembourg  5

French Monaco  6

French West Indies  7

French Reunion  8

French Congo DRC  9

French Senegal  10

French Cameroon  11

French Cote D'Ivoire  12

French Mali  13

French Morocco  14

French Haiti  15

French North Africa  57

Gaelic Scotland  1

Gaelic Ireland  2

German Standard  1

German Switzerland  2

German Austria  3

German Luxembourg  4

Sublanguage Decimal Code
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German Liechtenstein  5

Greek Standard  1

Greek Alternative  2

Italian Standard  1

Italian Switzerland  2

Kashmiri Pakistan  1

Kashmiri South Asia  2

Korean Standard  1

Korean Johab  2

Lithuanian Standard  1

Lithuanian Classic  2

Malay Standard  1

Malay Brunei  2

Mongolian Cyrillic  1

Mongolian Mongolian  2

Nepali Nepal  1

Nepali India  2

Norwegian Bokmål  1

Norwegian Nynorsk  2

Portuguese Standard  2

Portuguese Brazil  1

Punjabi India  1

Punjabi Pakistan  2

Romanian Standard  1

Romanian Moldova  2

Sublanguage Decimal Code
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Russian Standard  1

Russian Moldova  2

Serbian Latin  2

Serbian Cyrillic  3

Sindhi India  1

Sindhi Pakistan  2

Spanish Standard  1

Spanish Mexico  2

Spanish Modern Sort  3

Spanish Guatemala  4

Spanish Costa Rica  5

Spanish Panama  6

Spanish Dominican Republic  7

Spanish Venezuela  8

Spanish Colombia  9

Spanish Peru  10

Spanish Argentina  11

Spanish Ecuador  12

Spanish Chile  13

Spanish Uruguay  14

Spanish Paraguay  15

Spanish Bolivia  16

Spanish El Salvador  17

Spanish Honduras  18

Spanish Nicaragua  19

Sublanguage Decimal Code
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LIST OF CODES FOR FIELD ATTRIBUTES IN PROJECTS

MATCH TYPES

Normal = 0

Exact = 1

Fuzzy = 2

Assembled = 4

Fuzzy Propagated = 8

Exact Propagated = 16

Machine Translated = 32

Spanish Puerto Rico  20

Spanish United States  21

Spanish Latin America  57

Swedish Standard  1

Swedish Finland  2

Tamazight Berber  1

Tamazight Latin  2

Tigrigna Ethiopia  1

Tigrigna Eritrea  2

Tibetan Tibet  1

Tibetan Dzongkha  2

Urdu Standard  1

Urdu India  2

Uzbek Latin  1

Uzbek Cyrillic  2

Sublanguage Decimal Code
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Guaranteed = 4096

Repaired = 8192

SEGMENT STATUS

Approved = 64

Proofread = 128

Translated = 256

Locked = 512

Pending = 1024

Stop = 2048

WARNINGS

Multiple Matches = 65536

Renumbered Match = 131072

ERRORS

Wrong Tags = 16777216

For the status, Déjà Vu X3 Workgroup uses the OR operator to combine the desired 
components. For example, pending and locked is 1024 OR 512 which equals 1536. 
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Keyboard Shortcuts
KEYBOARD SHORTCUTS

The following pages contain a complete list of keyboard shortcuts that are available by default 
within Déjà Vu X3 Workgroup. It is important to keep in mind, however, that all keyboard shortcut 
associations can be reconfigured. For more information on this, see "Keyboard Shortcuts" on page 
32. 

You can find a listing of changed keyboard shortcuts between Déjà Vu X2 and Déjà Vu 
X3 under www.atril.com/sites/default/files/docs/presentation/
Deja_Vu_X3_Keyboard_shortcuts.pdf.

Command Name Keyboard Shortcut

Open File Ctrl+O

New File Ctrl+N

Exit Déjà Vu X3 Alt+F4

Copy Ctrl+C or Ctrl+Ins

Copy All Tags Alt+F8

Copy Next Tag F8 or Ctrl+D

Delete Del

Delete Tags Ctrl+Space

Delete Tags and Text Ctrl+Alt+Space

Bold (only with MS Office Live filter) Ctrl+B

Italics (only with MS Office Live filter) Ctrl+I

Underline (only with MS Office Live filter) Ctrl+U

Superscript (only with MS Office Live filter) Ctrl++

Subscript (only with MS Office Live filter) Ctrl+=

Paste Ctrl+V or Shift+Insert

Undo Ctrl+Z

Redo Ctrl+Y
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Select All Ctrl+A

Find Ctrl+F

Find Next F3 or Shift+F4

Replace Ctrl+H

Select All Ctrl+Shift+A

Pretranslate Ctrl+P

Translate Ctrl+T

Translate without Repair Ctrl+Alt+Shift+T

Assemble Ctrl+Shift+A

Machine Translate Ctrl+G

Scan Ctrl+S

Scan with Wildcards Ctrl+Shift+S

Lookup Ctrl+L

Lookup with Wildcards Ctrl+Shift+L

Check Tags Ctrl+Shift+F8

Fix Tags Ctrl+F8

Check for Multiple Exact Matches Ctrl+F3

Check Terminology (Single Segment) Ctrl+Shift+T

Check Terminology Batch Ctrl+T

Find Next Number Mismatch Ctrl+Shift+F7

Batch QA Validation Ctrl+Q

Find Next Terminology Mismatch Ctrl+F7

Change Case Shift+F3

Expand AutoText Entry Ctrl+Shift+F3

Command Name Keyboard Shortcut
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Display Code Shift+F6

Do Not Send to Translation Memory Ctrl+Shift+D

Split Segments Ctrl+Shift+J

Join Segments Ctrl+J

Swap Current and Next Words Ctrl+Shift+N

Swap Previous and Current Words Ctrl+Shift+B

Lock/Unlock Segments Ctrl+Shift+K

Pending Ctrl+Shift+P

Reset Segment Status Ctrl+Shift+U

See in Context F6

Analyze Ctrl+Shift+W

Character Map Ctrl+K

View Properties F4

View Project Explorer Ctrl+Alt+L

Spelling F7

Word Count Ctrl+W

Go to the Beginning of Table Ctrl+PgUp

Go to the End of Table Ctrl+PgDn

Confirm and Go to Next Segment Ctrl+DownArrow or Ctrl+Enter

Go to Next Segment (No AutoFeatures) Alt+RightArrow or 
Ctrl+Shift+Enter

Go to Next Segment (Overwrite Propagated 
Segments)

Alt+Ctrl+DownArrow

Confirm and Go to Next Untranslated Segment Alt+DownArrow or Alt+Enter

Command Name Keyboard Shortcut
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Co to Next Untranslated Segment (No 
AutoFeatures)

Ctrl+Shift+Alt+DownArrow

Go to Previous Segment Ctrl+UpArrow

Go to Previous Segment (No AutoFeatures) Alt+LeftArrow

Go to Previous Untranslated Segment Alt+UpArrow

Go to Next Portion (AutoSearch) Ctrl+Shift+DownArrow

Go to Next Segment (AutoSearch - Segments) Alt+Shift+DownArrow

Go to Previous Portion (AutoSearch) Ctrl+Shift+UpArrow

Go to Previous Segment (AutoSearch - 
Segments)

Alt+Shift+UpArrow

Add Translated Attribute Ctrl+Shift+T or Ctrl+Shift+F

Add Proofread Attribute Ctrl+Shift+R

Add Approved Attribute Ctrl+Shift+V

Insert AutoSearch Portion (Insert) Ctrl+1...n

Insert AutoSearch Portion (Overwrite) Ctrl+Shift+1...n

Insert Current AutoSearch Portion (Insert) Ctrl+R

Insert Current AutoSearch Portion (Overwrite) Ctrl+Shift+R

Insert Current AutoSearch Segment (Insert) Ctrl+E

Insert Current AutoSearch Segment without 
Repair

Ctrl+Alt+E

Insert Current AutoSearch Segment (Overwrite) Ctrl+Shift+E

Populate All Languages Ctrl+Alt+F5

Populate Current Language Alt+F5

Populate Current Segment F5

Populate Current Segment (Insert) Ctrl+F5

Command Name Keyboard Shortcut
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Propagate in Current File F9

Propagate in Current File (Overwrite) Shift+F9

Propagate to All Files Alt+F9

Propagate to All Files (Overwrite) Alt+Shift+F9

Filter by Source Selection Ctrl+Alt+S

Filter by Target Selection Ctrl+Alt+T

Remove Filter Ctrl+Alt+R or Ctrl+Alt+U

Delete Comment Ctrl+Shift+M

Add Comment Ctrl+M

Next Bookmark F2

Previous Bookmark Shift+F2

Toggle Bookmark Ctrl+F2

Add Pair to Lexicon F10

Add Pair to Termbase F11

Add Pair to Termbase (No Prompt) Shift+F11

Add Pair to Translation Memory F12

Add Project to Translation Memory Alt+F12

Command Name Keyboard Shortcut
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GLOSSARY

Advanced Project Explorer

A Windows Explorer-like interface from which you can import, export or delete any supported file 
or folder in and out of your project, the Explorer is also accessed from within the main Déjà Vu X3 
Workgroup interface.

alignment

Alignment is the process by which existing source and (translated) target documents are 
matched up to build or add to a translation memory.

alphabetic order

Refers to the order of source segments within a project file. In alphabetic order, segments 
are sorted by alphabet, as opposed to the natural order, where they are sorted according to 
their occurrence in the source text.

antonym

A word with the opposite meaning (compare synonym).

assemble

When scanning does not find a match, you can ask Déjà Vu X3 Workgroup to assemble a 
translation from smaller pieces found in the project lexicon, termbases, and the translation 
memories (in this order if the similarity and other properties are equal).

attribute

In HTML, SGML, and XML, an attribute is a definition within a tag that may or may not have to be 
translated. A well-known translatable example is the alt attribute within an <IMG> tag (<IMG 
alt="Atril Software" border=0 src="/atril.jpg">).

AutoCorrect

AutoCorrect is comparable to the AutoCorrect option of Microsoft Word. Its purpose is to correct 
common spelling mistakes (for instance, "segement" to "segment" or "Deja Vu" to "Déjà Vu"). See 
also AutoText.
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AutoPropagate

The process in which Déjà Vu X3 Workgroup automatically propagates a translation to the same 
segment within the project file. You can activate AutoPropagate under File> Options> General.

AutoSearch

The process in which Déjà Vu X3 Workgroup automatically scans the translation memories 
for the current segment, and searches the translation memories, termbases, and the project 

lexicon for any portions of the segment. You can activate AutoSearch and its options under 
File> Options> General.

AutoSend

The process in which Déjà Vu X3 Workgroup automatically sends a finished segment pair to the 
translation memory once you are done with the translation. You can activate AutoSend under 

File> Options> General.

AutoText

AutoText is comparable to the AutoText option of Microsoft Word. Its purpose is to save typing 
effort by expanding abbreviations into longer text (for instance, "DV" to "Déjà Vu"). See also 

AutoCorrect.

AutoTranslate

The process in which Déjà Vu X3 Workgroup automatically assembles a translation from smaller 
pieces that can be found in the project lexicon, termbase and translation memory (in this 
order). You can activate AutoAssemble and its options under File> Options> General.

AutoWrite

AutoWrite suggests content from your databases as you type. The suggestions will be displayed 
right underneath your cursor. You only have to press the Enter button to accept. You can activate 
AutoWrite under File> Options> General.

batch processes

Procedures that process many files simultaneously. This is one of the core competencies of Déjà 
Vu X3 Workgroup.
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bookmarks

Déjà Vu X3 Workgroup allows you to set a bookmark to mark a position in a project so that you 
can later easily locate certain segments.

case sensitive

The ability to distinguish between uppercase (capital) and lowercase (small) letters. Programs or 
features that distinguish between uppercase and lowercase are said to be case sensitive. For 
instance, if you enter atril to search for Atril in a case-sensitive feature, the program would not find 
it.

CAT

CAT (Computer-Aided Translation) is a term used to classify a wide variety of software tools that 
are employed to assist translators in their work, either in consistency, speed, or simply workload. 
Some definitions include machine translation tools in the CAT category, while others consider CAT 
to be exactly equivalent to translation memory tools. 

comments

Comments are fields in the source or target segment to which you can add comments or questions 
for your own or someone else’s review.

date stamp

A date stamp in a database record is the field that defines the date on which the record was 
created or modified (compare time stamp).

DeepMiner

The unique DeepMiner analyzes the attached databases and comes up with sub-segment matches 
to give you every last bit of information from the databases and allow you to enhance 
Déjà Vu X3’s fuzzy match repair.

delimiter

A punctuation character or group of characters that separates two pieces of data, or marks the 
beginning or end of a piece of data. Déjà Vu X3 Workgroup uses delimiters in defining 

segmentation rules and in database import and export processes. 
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dockable

Dockable windows are windows that align themselves with the edge of another interface element, 
usually a window or a pane. In Déjà Vu X3 Workgroup, dockable windows can be placed 
anywhere on the desktop. See also tool windows.

document window

A window that has to stay within the main window and is subject to the commands in the Window 
menu. In Déjà Vu X3 Workgroup this includes all the main grids, including project files, 

termbases, translation memories, Pack & Go packages, and XML filter. See also tool 
window.

DTD

Document Type Definition file used by SGML and XML to define mark-up languages. 

embeddable tags

An embeddable tag in Déjà Vu X3 Workgroup’s SGML/XML filter is a tag that can appear in the 
middle of a segment which should not be split before or after this tag. For example, the <B> and 
<I> tags in HTML (which specify bold and italic attributes) are embeddable, while the <P> tag 
(which specifies a paragraph change) is not.

exact match

An exact match is the perfectly identical equal match of a stored source segment in the 
translation memory (often ignoring any formatting information that may be stored with it) with the 
segment being sought. 

External View

The External View format is a format specifically created for proofing or checking unresolved issues 
outside of Déjà Vu X3 Workgroup. This allows you to export translated and commented rows into 
a Word, HTML, Trados RTF or XLIFF format in which proofing can be performed and outstanding 
questions can be answered.

The main benefit of these formats is that they can be used across platforms and thus even by 
people who could not install a copy of Déjà Vu X3 Workgroup.
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extractable attributes

While most SGML attributes are not translatable, some may be translatable, and must therefore be 
extracted. For example, the <IMG> tag in HTML (which inserts an image into the text) has the 
ALT=“[alternate text for the image]” attribute, which specifies the text to display if 
the browser cannot load the image. This text should be translated, so the attribute is extractable.

extractable text

Extractable text between tags refers to text between certain SGML/XML tags that should be 
extracted, i.e., translated, or not. Users have the option to define this property in Déjà Vu X3 
Workgroup’s SGML/XML filter.

format

Format is the term that is used to describe different file formats, such as Word, HTML, or 
FrameMaker.

format filters

Déjà Vu X3 Workgroup uses different rules to separate non-translatable code and translatable text 
for different formats. These rules are sometimes referred to as format filters.

fuzzy match

A fuzzy match is a source segment that only partially matches the segment being sought.

guaranteed match

A guaranteed match is an exact match for which Déjà Vu X3 Workgroup has also checked that 
the surrounding segments match, thus greatly increasing the likelihood of its accuracy.

hard return

A hard return, also called carriage return or paragraph marker, is an actual symbol inserted into 
text that separates one paragraph from the next, usually inserted by the Return or Enter key. If you 
select Home> Show/Hide you can view the hard return as the symbol "¶" (compare soft return).

lemma

A word or phrase.
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lexicon

The project file’s lexicon is an optional project-internal list of all the source language words or 
phrases present in the project—in other words, an index of all terms and phrases. Once you have 
translated this list, it will be used by Déjà Vu X3 Workgroup as the primary glossary for your 
project. You can build and manage the lexicon withe the help of the Lexicon ribbon. 

Microsoft Office (Live)

The Microsoft Office (Live) filter allows you to process Microsoft Office files of any version. It is one 
of the three filters for which the Live preview as well as the WYSIWYG (what-you-see-is-what-you-
get) formatting is enabled (the other filters are the PDF filter and the InDesign IDML filter.

lookup

Refers to search processes in the termbases. See also scan.

machine translation

MT (machine translation, often called automatic translation) systems are those that use linguistic 
information about the languages being translated to automatically generate translations. 

match

A match is a bilingual record of a segment or term whose source is identical or similar to the 
source in the project file. 

natural order

In Déjà Vu X3 Workgroup, the natural order refers to the original order of segments in the 
source document (compare alphabetic order). 

ODBC

Open DataBase Connectivity is a standard database access method developed by Microsoft 
Corporation. The goal of ODBC is to make it possible to access any data from any application, 
regardless of which database management system (DBMS) is handling the data. ODBC manages 
this by inserting a middle layer, a database driver, between an application and the DBMS. The 
purpose of this layer is to translate the application's data queries into commands that the DBMS 
understands. For this to work, both the application and the DBMS must be ODBC-compliant—
that is, the application must be capable of issuing ODBC commands and the DBMS must be 
capable of responding to them.
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pending

Déjà Vu X3 Workgroup allows you to mark questionable rows as pending so that you or someone 
else can come back at a later time to finish or review these rows.

populate

A process by which either a single segment or all segments of one language pair are copied over 
from source to target in the project file. The populate commands are available from the 
Insert menu.

pretranslate

The process in Déjà Vu X3 Workgroup that allows you to batch leverage the content of your 
databases—translation memory(s), termbase(s), and (optionally) the lexicon—and (optionally) 
machine translation against your source files.

primary window

A window type to which you can assign a distinct font. Includes the project files, translation 
memories, or termbases (the primary windows). See also secondary window.

Pack & Go packages

Pack & Go packages are highly compressed exports from project files that are ideal for the 
transmission of Déjà Vu X3 Workgroup data. The Pack & Go feature is available as a stand-alone 
feature for the transfer of complete projects, or as part of the satellite creation for the transfer of 
even smaller bilingual satellite projects.

Project Explorer

In a project file, a small pane on the right of your screen that displays all the files in your project so 
you can easily switch from one file to the next.

project file

Also called translation file. The .dvprj file that contains all source files and the lexicon, and in 
which all translation processes are performed.
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propagate

The process by which Déjà Vu X3 Workgroup applies a translation to the same or similar segments 
within the project file after you have translated a segment. The propagate options are accessible 
through the Translation menu. See also AutoPropagate.

Properties window

A window with import-specific options that appears when selecting files for import in the 
Advanced Project Explorer.

pseudotranslation

Pseudotranslation is a process in which a "dummy" translation with target-language-specific 
characters is performed and the length of the target text is increased by about 20% of the source. 
This is done to allow for some functional testing on the exported file in its original format.

reflexive

One of the three most basic relationships in a relational database model (compare symmetric 
and transitive). A reflexive relationship is a relationship that is valid for itself. For example, a 
translation relation cannot be reflexive, because a term is usually not translated with the very same 
term. A synonym relation is reflexive, however, because every term is also a synonym of itself. An 
antonym by definition cannot be reflexive, because a term cannot be its own opposite.

regular expressions

Any legal combination of symbols that represents a value and that you can employ to 
communicate with certain features of an application. Each programming language and application 
has its own rules for what is legal and illegal. The scripting language that Déjà Vu X3 Workgroup 
uses is VBScript. For more information on VBScript, see the MSDN library at http://
msdn.microsoft.com/library. 

satellite files

A satellite file is an export from a project file that contains only one source and one target language 
(as opposed to a full project file, which typically consists of the source language plus a number of 
target languages) with all the information needed by the translator. This information can exclude 
the formatting and image code, thus significantly reducing the file size and making it easier to 
transmit. A satellite file restricts the translator from performing any task that would have an effect 
on all the target languages, such as deleting files, splitting/joining rows, editing the source, or 
locking/unlocking rows.
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scan

Refers to search processes in the translation memories. See also lookup.

secondary window

A window type to which you can assign a distinct font. Includes the AutoSearch, lookup, or 
scan windows. See also primary window.

security

Security settings define user roles with different levels of access in Déjà Vu X3 Workgroup. The 
three major different roles are project owner, administrator, and various levels of language users. 
Project owners have access to all possible functions, administrators do not have the ability to 
disable the project security features, and users have different levels of language-specific sets of 
rights.

Segment Selector

The second of three record selectors in the selector row in a project file. You can use the rows 
selector to filter and display only certain kinds of rows, e.g., exact match

selector row

The row with the three record selection fields on the top of a project file. See Text/Record 
Locator, satellite files, and Target Language Selector.

segment

Any segment that is delimited by either a punctuation mark (such as a full stop or a question mark) 
or by any other means of separation (such as the end of a paragraph, heading, or table cell).

segmentation rules

Segmentation rules are the rules by which Déjà Vu X3 Workgroup determines how text in a 
specific language should be segmented. You can change or add default delimitation rules so that 
they correspond to your specific language and the style of the author of your source documents. 
The segmentation rules allow you to specify for each language what rules are to be used as well as 
the exceptions to these rules. You can access the delimitation rules by selecting File> Options> 
Segmentation.
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SGML

SGML stands for the Standardized General Markup Language. It is the result of generalizing and 
then standardizing a number of Rich Text Formats (RTF) developed for word processing software 
on personal computers by the International Organization for Standardization (ISO) in 1986. 

SGML is actually a metalanguage used to define mark-up languages. The definitions are called 
Document Type Definitions or DTDs. 

soft return

A marker that forces a line break without starting a new paragraph, usually inserted by a key 
combination such as Shift+Enter (compare hard return).

source

Refers to the language or segment that is being translated. See also target.

SQL

Structured Query Language is the most commonly used language to communicate with databases. 

symmetric

One of the three most basic relationships in a relational database model (compare reflexive and 
transitive). In a symmetric relationship, the relationship of A to B is also true of B to A. This is the 

classical translation relationship: if term A is the translation of term B, then term B is also the 
translation of term A. Synonym and antonym relations are symmetric relationships as well. 

synonym

A word with the same or similar meaning (compare antonym)

tag

When working with file types other than MS Office documents processed with the MS Office 
(Live) filter, Déjà Vu X3 Workgroup only displays translatable text—everything else is hidden. 
However, in formats such as HTML, FrameMaker, or Word (if it’s not processed with the MS 
Office (Live) filter), formatting information is often embedded within a segment, such as a 
particular word in bold, cursive, or small caps. Because Déjà Vu X3 Workgroup cannot 
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automatically decide which formatting belongs to which word, it lets the translator decide where 
to place this formatting information. These are "tags." If you have created a Déjà Vu X3 Workgroup 
project for HTML, for example, you will probably have noticed that many segments contain tags 
such as {142} or {835}.

target

The target language or segment in which the translation is being conducted. See also source.

Target Language Selector

The third of three record selectors in the selector row in a project file. You can use the 
selector to switch between the different target languages that you may have in your project.

TEAMServer

TEAM Server is a solution for sharing large translation memory and termbase repositories both over 
local area networks (LANs) and across the Internet. TEAMServer extends the capabilities of Déjà 
Vu X Workgroup to allow teams of translators who work on extensive, multilingual and multisite 
translation projects to share their translations in real-time. 

templates

Two kinds of XML-based templates are used in Déjà Vu X3 Workgroup: termbase templates and 
project templates.

Termbase templates have the extension .dvtdt (Déjà Vu termbase template) and are located in the 
\Templates folder within your Déjà Vu X3 Workgroup installation directory (by default 
C:\ProgramData\ATRIL\Déjà Vu X3\Templates\Termbase on an English Windows 
installation—if you can’t view this folder you will need to unhide it by opening Folder Options in 
the Windows Control Panel and selecting View> Show hidden files, folders, and drives)). These 
files define what kind of relations, attributes and categories your termbase will have.

Project templates have the extension .dvprt (Déjà Vu project template) and are located in the 
same folder. These files define project settings (including source and target languages, translation 
memories, termbases, client and subject) that can be applied to a newly created project.

termbase

Multilingual files that contain pairs of terms or short expressions (source and target) which you 
have added. Each pair is associated by additional information that is freely configurable.
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Text/Record Locator

The first of three record selectors in the selector row in a project file. You can use the selector 
to enter the number of the project line you would like to jump to (in the natural order), or any 
combination of letters at the beginning of the segment that you would like to jump to (in 

alphabetic order).

TMX

Translation Memory eXchange is an XML-based standard for data exchange between memory 
databases.

tool window

Windows that are freely dockable, i.e., that can be placed anywhere outside the main window 
on your desktop and be subject to the standard docking features. In Déjà Vu X3 Workgroup, these 
windows include the format, the AutoSearch window, the Properties window, or any of the 
toolbars. See also document window.

time stamp

A time stamp in a database record is the field that defines at what time the record was created or 
modified (compare date stamp).

transitive

One of the three most basic relationships in a relational database model (compare symmetric 
and reflexive). In a transitive relationship, the relationship from A to B and A to C is the same as 
that of B to C. Translations from language A to B are not transitive (the German translation of the 
English term "file" can be either "Datei" or "Akte"; however, "Datei" is not the translation of "Akte"), 
nor are synonyms (though "square" is the synonym for both "four-sided figure" and "plaza," "plaza" is 
not a synonym for "four-sided figure") or—by the same logic—antonyms.

translation memory

The files that store all previously translated segments (segments, headings, cell content, bullet 
points, etc.) in source and target. This file is multilingual, i.e., it can have several target languages.

wildcard

A special symbol that stands for one or more characters. Used to widen the scope of searches in 
scan processes.
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XML

XML—eXtensible Markup Language—has been developed by the World Wide Web Consortium 
as an alternative to HTML, which was not sophisticated enough for the creation of interactive con-
tent, and SGML, which proved to be too complex for web applications. Much like SGML, XML is a 
metalanguage to enable users to create their own markups in Document Type Definition (DTD) 
files.

XML filter

A file used when translating files that follow the XML definition. Because each XML file or group 
of XML files is unique, a unique filter must be created for each of them. You can do that by having 
Déjà Vu X3 Workgroup either analyze the XML files or read the DTD file.

Unicode

A standard for representing characters as integers. Because it is possible to represent all characters 
of all known languages with Unicode, there is no need for different character sets between 
languages anymore. Déjà Vu X3 Workgroup deals with two different Unicode encoding schemes, 
UTF-8 and UTF-16.

UTF-8 is an 8-bit encoding scheme. Most characters from Western-language alphabets are all 
encoded using a single byte, whereas characters for other languages are encoded using 2, 3, or 
even 4 bytes. UTF-8 therefore produces compact documents for Western languages, but for other 
languages, documents tend to be half as large as they would be if they used UTF-16.

UTF-16, a 16-bit encoding scheme, is large enough to encode all the characters from all the 
alphabets in the world. It uses 16-bits for most characters, but includes 32-bit characters for 
ideogram-based languages like Chinese. A Western-language document that uses UTF-16 will be 
twice as large as the same document encoded using UTF-8. But documents written in most Asian 
languages will be far smaller using UTF-16.
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A
abbreviation

add to termbase 514
Accept all Multiple Matches

command 103
Accept only exact matches

command 101, 142
Access

description of export 479, 519
file formats 357
import into lexicon 437
import options 357
specifying translatable fields 358
termbase export 519
termbase import 509
translation memory import 458, 473

access
different roles 297

access levels
users 297

access to open files 62
Account

File menu 31
acronyms

conversions 214
activation key 31
Add

translation memory 443
add

existing dictionaries 237
Add Approved attribute

keyboard shortcut 578
Add Comment

dialog 243
keyboard shortcut 579

Add File
command 80

Add Folder
dialog 69

Add Pair to Lexicon
keyboard shortcut 579

Add Pair to Termbase
keyboard shortcut 579

Add Pair to Termbase (No Prompt)
keyboard shortcut 579

Add Pair to Translation Memory
keyboard shortcut 579

Add Project to Translation Memory
command 179
keyboard shortcut 579

Add Proofread attribute
keyboard shortcut 578

Add Related Term
dialog 516

Add Relation
dialog 516, 517

Add Server TB
command 283
command to add TEAMServer termbase 279, 503

Add Server TM
add TEAMServer translation memory 451
command 282

Add Term
dialog 502

add terms
termbase 113

Add to Lexicon
command 427

Add to TB
command in alignment process 467

Add to Termbase
command 507
command (Lexicon) 430

Add to TM
command 178
command (Lexicon) 429

Add Translated attribute
keyboard shortcut 578

add words
dictionaries 236

adding
administrator 300
comments 242
language user 302
user 302

adding non-translation records
termbase 514

adding records
databases 110
termbase 112, 506
translation memory vs. termbase 112

adding specifications
termbase records 114, 508

adding translation records
termbase 506

additional information in databases
purpose 183

adjust
AutoSearch settings 109

administrator
add 300
use of 300

administrators
definition 297

Adobe FrameMaker. See FrameMaker
Adobe PageMaker. See PageMaker
Advanced Project Explorer 65

access 65
close 68, 71
definition 580
delete files 73
differences from Project Explorer 65
export 71
export files 65
import files 65, 66
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import folders 68
import new files into projects 78
local drive and network 65
switching with Project Explorer 24

Advanced Project Explorer view 79
Align Files Wizard 464
aligning

files 462
aligning files 461
alignment 76, 461

and code handling 461
and sentence delimitation 467
definition 461, 580
deleting lines 467
joining lines 467
moving lines 467
possible adjustments 467
splitting lines 467
use of 461

alignment file
definition 19
open 470

alignment vs. translation 76
All entries with empty targets

command (Lexicon) 436
All Files

view 61
all rows

select 64
all rows downwards

select 64
all rows upwards

select 64
All Rows view

termbase 530
translation memory 445

allow case conversion
command 215

allow decimal conversion
command 215

alphabetic order
definition 580
switch to natural order 43

alphabetical order 43
Amebis

machine translation engine 167
Analysis

dialog 320
explanation 319

analysis
internal repetition 321
number of exact matches 321
number of fuzzy matches 321
number of matches 321
project 319
save results in external file 323
translation memories 320

analysis feature
definition 319

Analyze
command 319
keyboard shortcut 577

antonym
add to termbase 514
definition 580

apply
specific import options 331

Approved
confirm status 246

Ascending date
option for display of term matches 505
option for display of translation units in TM 454

Asian languages
sentence segmentation 219

Aspose PDF converter 355
Assemble

keyboard shortcut 576
assemble

definition 580
assemble from portions

pretranslation 101
assemble matches

DeepMiner 159
Assemble options

Options dialog 164
assembled segments

status indicator 105
assign clients 186
assign subjects 194
associate

translation memories with projects 451
associate termbases

with projects 502
Atril website 13
attribute

definition 580
Attributes

tab (Termbase Properties dialog) 499
attributes

defining for termbase 499
termbase records 114, 508

Attributes (tab)
Termbase Properties dialog 499

attributes (XML)
definition 409

AutoAssemble 105
definition 105, 581
on Ctrl+DownArrow 62

AutoCorrect 224
definition 580
import entries 227
import from Microsoft Word 227
purpose 224
use of 225

Auto-Features 104
AutoFormat

use in OpenOffice.org/LibreOffice 354
automatic update 81
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automatically fix tags
uses 210

automatically translate
with MT 169

AutoPropagate 199
activate 200
benefits 200
definition 200, 581
difference to manual propagate 200
on Ctrl+DownArrow 62
review 200
shortcut 54
status indicator 200

AutoSearch 106
activate 106
cache expiry 110
client 37, 106
copy record 108
date/time 37, 106
definition 106, 581
delete records 42
differences highlighted 37, 107
displaying termbase attributes 499
EBMT 107
edit records 42
example-based machine translation 107
options 109
related information 37, 106
settings 109
shortcut 54
structure of Scan Results dialog 37, 107
subject 37, 106
translation memory 109
translation memory results 37, 107

AutoSearch - Portions
navigate 41
window 38

AutoSearch - Segments
navigate 41
window 38

AutoSearch window 37, 106
colors 108
colors of entries 37
delete data 182
deleting data 182
modify data 182
modifying data 182
navigate 38, 107
splitting 38

AutoSend 110
activate 111
definition 110, 581
on Ctrl+DownArrow 62, 111
shortcut 54

AutoText 221
add new entries as you translate 221, 224
definition 581
delete entries 222, 226
import entries 224

purpose 221
use of 222

AutoTranslate
activate 105
Ctrl+DownArrow 105

AutoWrite 105
activate 105
button 54, 176
command 176
DeepMiner 159
definition 581
enable 176
explanation 174
glossary 581
use cases 174
with machine translation 176

B
batch processes

definition 581
batch processing 61
Batch QA

command 116
dialog 116
using SQL filter 117

Batch QA Validation
keyboard shortcut 576

beginning of file
jump to 63

BIF
export options 401
import options 401, 403
language mapping 401

bif files. See Trados TagEditor
Bilingual RTF

sharing option 267
bilingual RTF

definition 250
open and edit in word processor 270

Bold
keyboard shortcut 575

bookmark
icon 239
set 239

bookmarks
adding 239
definition 239, 582
move to the next 240
move to the previous 240
remove 239
remove all 240
submenu 239

Build Lexicon
dialog 97

Build Status Expression
dialog 51
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C/C++

file formats 392
C/C++ files

definition 392
sample 393

C/C++/Java
import options 393

C/C++/Java import
Ignore Text in Single Quotes 394

Cache AutoSearch results for
command 110

cache expiry
AutoSearch 110

Calculate
command for termbase statistics 487
command for TM statistics 457

capitalization
change 231

caret character 219
cascade

windows 58
case

change 231
conversion 215

case sensitive
definition 582

CAT
definition 582

Categories
tab (Termbase Properties dialog) 501

categories
defining for termbase 501

Categories (tab)
Termbase Properties dialog 501

change
color of indicator bars 46
filter association 326
word order 158

Change Case
keyboard shortcut 576

change case 231
change cycle 231
exceptions 232
perform 231

change client in TM 550
change font 58
Change Password

dialog 300
change records with certain client in termbase to 

another client 553
change records with certain subject in termbase to 

another subject 553
change TM records from one language to another 551
change TM records with certaIn subject 550
change to certain client for TM records entered on a 

certain date 551
change to certain client in termbase 551

change to certain client in termbase for records created 
on a certain date 552

change to certain client in termbase for records with 
certain subject 552

change to certain client in TM for records with certain 
subject 552

change to certain user for TM records with certain 
client 551

change to certain user in termbase for records with 
certain client 553

change translation status of project records from one 
status to another 554

changing
fonts in FrameMaker 363
user settings 308

character count 316
Character Map 227

access 227
keyboard shortcut 577

character spacing
Word 341

check
for updates 31

check for inconsistent terminology
pretranslation 102

Check for Multiple Exact Matches
keyboard shortcut 576

Check Numerals
command 122

Check Spaces
command 124

Check Spelling
dialog 130, 236
dialog (termbase) 531
dialog (TM) 472

check spelling 127
Check spelling as you type

command 128
Check Tags

command 124, 208
keyboard shortcut 576

Check Terminology
command 121

Check Terminology (Current Segment)
command 120

Check Terminology (Single Row)
keyboard shortcut 576

Check Terminology Batch
keyboard shortcut 576

checks
terminology consistency 115

Chinese
user interface language 21

CILF
template 492

client
assigning to records 186
definition 183
delete 191
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find 191
modify 190
purpose 183
search 191
select for project 187, 194
storing settings 184

Clients
tab (Options dialog) 186

clients 183
managing 192
numerical listing 186
relevance 192

Close
File menu 30

cnt files. See Help content
Co to Next Untranslated Segment (No AutoFeatures)

keyboard shortcut 578
codes

for field attributes 572
for languages and sublanguages 562

CodeZapper
definition 338

Color
dialog 48

color
change 46

color indicator
definition 43
list 43

color indicator bar 43
column headers

hide 41
COM+ installation. See Getting Started Guide
Comment

icon 243
comment

delete 245
delete all 245
edit 245
review 244

comments
add 242
definition 582
use 242
view all rows with comments 244
Word 341

common Windows functions 227
communicating

with databases 104
compact

project file 140
reasons 140
satellite file 140
termbase 140
translation memory 140
XML filter file 140

compact database 140
complete project

select 61

view 61
concept

lexicon 425
concordance search. See scan
conditional extraction

attributes in HTML tags 533
configuration access

security restriction 297
Confirm and Move to Next

command 246
Confirm As

Dropdown 32, 246
Confirm Fuzzy Propagation

dialog 201
Confirm Segment and Move to Next Untranslated

command 246
confirm status

Approved 246
Proofread 246
Translated 246

confirm statuses 246
confirmation dialog

delete files 74
consistency checks

numbers 122
spaces 124
tags 124
terminology 121
translations for duplicate source 125

Consolidate
command for translation memory units 445

context view 212
definition 213
format limitations 213

control leading and trailing symbols
option 215

conversion
case 215
decimal 215
punctuation marks 215
spaces 215

conversions 214
acronyms 214
numbers 214
options 214
settings 214
tags 214

Convert All Objects to Office 2007-2013
command in MS Office 350

Convert Hard to Soft Spaces
FrameMaker import 362

Copy
keyboard shortcut 575

copy
all segments 216
AutoSearch record 108
single segments 216
standard features 215
tags 208, 209, 210
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Copy All Codes
keyboard shortcut 575

Copy All Tags
command 209
uses 210

Copy Next Code
keyboard shortcut 575

Copy Next Tag
command 209

CopyFlow
special discounts 374

count
characters 313
codes 313
words 313

count feature 311
create

new dictionary 236
project 81
project file 81

Create a new alignment workfile
command 464

Create a New Project wizard 82, 92
no import options 86

Create lexicon
command 97

create on a template
project 87
project file 87

Create Pack & Go
command 274

creating
translation memory 447

Criter
template 492

Ctrl+DownArrow
AutoAssemble 62
AutoPropagate 62
AutoSend 62

current file
status bar 54, 55, 61

current record
position 54

current row
check terminology mismatch 120
indicator 34

custom dictionaries 236
Customize

dialog 22, 25, 32
customize

keyboard shortcuts 32
Quick Access Toolbar 21
ribbon tabs 25

cut
standard features 215

D
database formats

source file 77
database lookup

options 144
Databases

tab (Project Properties dialog) 178, 277, 451, 502
databases

adding additional information 183
adding records 110
automatically communicating with 104
challenge of translation 357
compact utility 140
data exchange 140
feeding 110
fuzziness setting 144
lookup 146
Microsoft Jet 140
minimum score 145
newer matches 144
overview 140
performance 140
repair utility 140
scan 146
sending text 177
SQL 140
TMX import 140

date last exported
file details 74

date stamp 183
definition 582
field in databases 183

decimal conversion 215
DeepMiner

definition 582
glossary 582
various uses 159

DeepMiner and assemble 161
DeepMiner engine

explanation 158
default font 58
definition

bookmarks 582
embeddable tags 583
External View 583
extractable attributes 584
extractable tags 584
ODBC 585
Pack & Go packages 586
pending 586
satellite files 587
security 588
Unicode 592
UTF-16 592
UTF-8 592

degrees of fuzziness 101
Déjà Vu

toolbox 10
Déjà Vu user group 13
Déjà Vu X3

analysis features 311
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new features 15
Déjà Vu X3 alignment file 19
Déjà Vu X3 interface 19
Déjà Vu X3 project files 19
Déjà Vu X3 tags. See tags
Déjà Vu X3 termbases 19
Déjà Vu X3 translation features 139
Déjà Vu X3 translation memory 19
Déjà Vu X3 workflow 75
Déjà Vu X3 XML filter 19
Déjà Vu X3’s quality assurance feature 114
Déjà Vu X2

satellite support 260
Déjà Vu X3 project

connecting to TEAMServer 279
Delete

keyboard shortcut 575
delete

all tags 211
comment 245
single tag 211
tags 211

delete all
comments 245

Delete All Examples
command 417

Delete all pairs previously sent from this project
command 180

delete all termbase records from certain user 548
delete all termbase translation records where main 

lemma is equal to translation 549
Delete all Warnings

command 119
Delete Codes

keyboard shortcut 575
Delete Codes and Text

keyboard shortcut 575
Delete Comment

keyboard shortcut 579
delete data

AutoSearch window 182
delete files 73

confirmation 74
satellite files 260
security restriction 297
with Advanced Project Explorer 73

delete project from TM 539
Delete Tags

command 211
delete termbase records in certain language containing 

certain characters 548
delete termbase records in certain language starting 

with certain characters 547
delete termbase records where a certain language 

contains certain characters 550
delete termbase records where the source is longer 

than a certain length 549
delete termbase records with certain client 543
delete termbase records with certain subject 543

delete TM records containing certain characters 542
delete TM records from certain user 542
delete TM records starting with certain characters 542
delete TM records with certain characters in a certain 

language 540
delete TM records with certain client 539
delete TM records with certain file ID 540
delete TM records with certain subject 539
delete TM records with length restriction in 

source 540
delete translation memory records entered on a certain 

date 540
delete translation memory records where source and 

target are identical 542
deleting

user 308
deleting term

termbase 527
delimitation

incorrect 219
delimitation rules

definition 588
delimiter

definition 582
Deliver

File menu 29
Descending date

option for display of term match 505
option for display of translation units in TM 454

desktop publishing formats
source file 77

dictionaries
add existing 237
add words 236
create 236
custom 236
default path 237
default setting 236
definition 235
spell checking 235

digits
in propagate 199

Display
tab (Options dialog) 59

Display all subportions
command 109

Display Code
command 211
keyboard shortcut 577

Display portions from the Translation Memory
command 109

display portions from tranlation memory
command 39

Display Tag Markup
command 211

Divide & Dispatch
definition 250

Do Not Send
command 180
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remove status 181
symbol 180

Do Not Send to Translation Memory
keyboard shortcut 577

dockable
definition 583

docking
disable 57
tool window 57

document window
definition 55, 583
Window menu 55

documentation
related 13

down one screen
move 63

dragging files
Advanced Project Explorer 79

DTD
definition 583
use in XML 409

DTP formats
source file 77

duplicate rows
displaying 126
indicator 45

duplicate segments
unmark 127

Duplicates Only view
translation memory 446

Dutch
user interface language 21

E
EBU

file formats 406
edit

comment 245
edit box

translating in 35
edit mode 34

switch into 34
edit source

satellite files 260
security restriction 297

Edit Term
dialog 526

edit vs. selection mode 34
editing phase 114
editing term

termbase 526
embeddable tag

XML 409
embeddable tags

definition 583
embedded codes

in propagate 199
protection 211

embedded codes. See tags
Enable Guaranteed Matches

command 177
encoding

HTML 383
InDesign 376
PageMaker 371
text files 380
XML 390

end of file
jump to 63

end rule. See sentence segmentation
English

user interface language 21
Enter Search Expression

dialog 153
entire project

view 61
entities

adding for XML filter 418
Entities and Characters (XML)

tab 417
Environment

tab (Options dialog) 39
Eurodicautom

template 492
ex TranslationFilter

Quark conversion to XLIFF 374
exact match

definition 583
Excel

description of export 479, 519
file formats 343
import options 344, 345
installation requirements 343
joining lines 345
location of original files 343
splitting lines 345
termbase export 519
termbase import 509
translation memory export 473
translation memory import 458, 473

Excel 2003 and below
support 343

exclude files
folder import 69

Exclude Strings Heuristically
command 394

Execute SQL
command 555
submenu 556

execute SQL
security restriction 297

existing project file
select 78

existing translation
aligning 76
import 76

Exit Déjà Vu X3
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keyboard shortcut 575
Expand AutoText

keyboard shortcut 576
Explorer. See Advanced Project Explorer
Explorer. See Project Explorer
Export

command 136
export 71, 134

entire folder 71
files from project 134
folder structure 73, 135, 137
from lexicon 431
ribbon settings 25
security restriction 305
selecting several items 71
with Advanced Project Explorer 71

export all TM records from certain user 561
export all TM records in certain language starting with 

certain characters 560
Export Excel Spreadsheet

command (Lexicon) 431
Export External View

dialog 266, 268, 271
export files

with context menu command 136
with menu command 134

export folder 73, 135, 137
export for proofing 132
Export guaranteed segments as Xtranslated

command 272
Export locked segments as Xtranslated

command 272
Export Options

dialog 72, 134, 136
export options 73

BIF 401
FrameMaker 364
HTML 135, 137, 382
TagEditor 401
TMX 406
TTX 401
Word 339
XML 135, 137, 390

export records belonging to certain project from 
TM 557

export records with certain client and subject from 
termbase 558

export records with certain client and subject from 
TM 558

export records with certain client from termbase 558
export records with certain client from TM 558
export records with certain subject from termbase 558
export records with certain subject from TM 557
Export source comments as conditional text

command 364
Export source comments as Office comments

command 339
Export source comments as pop-up text

command 383

Export special characters as entities
XML export option 390

Export Subset
command 278
dialog 278

Export target comments as conditional text
command 365

Export target comments as Office comments
command 339

Export target comments as pop-up text
command 383

export termbase records entered on a certain date 559
Export termbase records from certain user 561
export termbase records in certain language starting 

with certain characters 560
Export Text File

command (Lexicon) 431
export TM records entered on a certain date 559
Export Translated Project

command 134
exporting

prompt for missing spaces 135
exporting data

termbase 518
translation memory 473

Exposable Markers
FrameMaker import 362
option for FrameMaker import 362

External Data
ribbon tab 473
ribbon tab (termbase) 291
ribbon tab (TM) 286

external databases
Access database 76
Déjà Vu X3 translation memory 76
Excel format 76
formats 76
ODBC database 76
origin 75
text files 76
TMX 76
Trados Workbench 76

external glossaries
Access 77
Déjà Vu X3 termbases 77
Excel files 77
formats 76
origin 76
text files 77

External View
definition 583
merge options 273

extractable attribute
XML 410

extractable attributes
definition 584

extractable tags
attributes 409
definition 584
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extractable text 414
XML 409

extractable text in XML
nested tags 409

F
features

translation 139
field results

import in Word 337
file details

date last exported 74
file extension

filter association 326
individual relationship with filter 330
Trados Workbench 400

file filter
individual choice 330

file formats
Access 357
C/C++ 392
EBU 406
Excel 343
FrameMaker 360
GNU gettext 396
Help content 380
HTML 381
IBM TranslationManager 397
InDesign 374
Interleaf 379
Java 392
Java properties 391
ODBC compliant data sources 360
OpenOffice.org 353
OpenTM2 397
overview 325
PageMaker 367
plain text 380
PO/POT 396
PowerPoint 342
QuarkXpress 371
RC 391
RTF 341
tags 206
text 380
TMX 404
Trados TagEditor 400
Trados Workbench 399
working with different 325

file ID 183
field in databases 183

file management 78
File menu

Account command 31
Close command 30
Deliver command 29
New command 26, 30
Open command 27

options 23
Options command 31
Save As command 27
Share command 28

files
align 462
compacting and repairing 140
import 78, 79

Filter
in Properties pane 331
translation memory 443

filter
select rows by 64
status 43

filter association
change 326

filter by selection
benefits 133

Filter by Source Selection
command 126
keyboard shortcut 579

Filter by Target Selection
keyboard shortcut 579

Filter Definition File
select 386
XML import 386

Filter on Selection
command 64

filter on selection
clear 65
editing 65

Filter Options
dialog 334

filtering conditions
for TM export 476
termbase export 522
translation memory export 476, 482

Filters
tab (Options dialog) 327
tab (Project Properties dialog) 327, 333

Find
dialog 228
keyboard shortcut 576

find
features 228
use 228

Find Duplicate Segments
dialog 125, 446
translation memory 446

Find Next
command 229
keyboard shortcut 576

Find Next Number Mismatch
keyboard shortcut 576

Find Next Terminology Mismatch
keyboard shortcut 576

Find sets of duplicate source segments
command 125
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Find sets of duplicate source segments with different 
translations

command 125
finished row

symbol 45, 246, 247, 311
Fix Tags

command 210
keyboard shortcut 576

fixing
tags 210

flagged categories
in count 311

floating license
request 31
requesting 293
return 293

floating licenses 292
folder

import 79
folder import

exclude files 69
folder structure

import 79
font

change 58
default 58
set 58

Font Mapping 363
font size

change 58
Fonts

dialog 60
fonts

changing in FrameMaker 363
Force Confirm Segment and Move to Next

command 246
Force Propagate

command 202
Force Propagate to All Files

command 202
format

definition 584
format filter

individual choice 330
format filters

definition 584
formats

external glossaries 76
source files 77
tags 206
working with different 325

Found Source
Scan Results dialog 147

Found Target
Scan Results dialog 147

FrameMaker
.fm vs. .mif 360
change bars 367
Convert Hard to Soft Spaces 362

converting .fm to .mif 360
export options 364
Exposable Markers 362
file formats 360
font mapping 363
Ignore Automatic Numbering 362
Ignore Cross-Reference Definitions 362
Ignore Text on Master Page 362
Ignore Variable Definitions 362
import options 362
support 360
tips and tricks 367
use of Ignore options in book 367

French
user interface language 21

French bracket codes. See tags
full name

user 300
full word count 311
functionality testing

Pseudotranslation 203
fuzziness

recommended setting 145
fuzziness setting

adjusting 144
fuzziness setting for termbase

adjusting 145
fuzzy match

definition 584
percentage bar 44

fuzzy match repair
with machine translation 171

G
General

tab (Options dialog) 185, 214
tab (Project Properties dialog) 187, 194, 277
tab (Termbase Properties dialog) 496

German
user interface 21

Global Font Replacement
dialog 364

glossaries
Access 77
Déjà Vu X3 termbases 77
Excel files 77
text files 77

glossary 580
Advanced Project Explorer 580
alignment 580
alphabetic order 580
antonym 580
assemble 580
attribute 580
AutoAssemble 581
AutoCorrect 580
AutoPropagate 581
AutoSearch 581
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AutoSend 581
AutoText 581
AutoWrite 581
batch processes 581
case sensitive 582
CAT 582
comments 582
date stamp 582
DeepMiner 582
delimitation rules 588
delimiter 582
dockable 583
document window 583
DTD 583
exact match 583
format 584
format filters 584
fuzzy match 584
guaranteed match 584
hard return 584
lemma 584
lexicon 585
lookup 585
machine translation 585
match 585
Microsoft Office (Live) 585
natural order 585
populate 586
pretranslate 586
primary window 586
Project Explorer 586
project file 586
propagate 587
Properties window 587
pseudotranslation 587
reflexive 587
regular expressions 587
scan 588
secondary window 588
Segment Selector 588
segments 588
selector row 588
SGML 589
soft return 589
source 589
SQL 589
symmetric 589
synonym 589
tag 589
target 590
Target Language Selector 590
TEAMServer 590
template 590
termbase 590
Text/Record Locator 591
time stamp 591
TMX 591
tool window 591
transitive 591

translation memory 591
wildcard 591
XML 592
XML filter 592

glossary for clients
lexicon 96

GNU gettext
definition 396
file formats 396

Go to Next Portion (AutoSearch)
keyboard shortcut 578

Go to Next Segment
keyboard shortcut 577

Go to Next Segment (AutoSearch - Segments)
keyboard shortcut 578

Go to Next Segment (no AutoFeatures)
keyboard shortcut 577

Go to Next Segment (Overwrite)
keyboard shortcut 577

Go to Next Untranslated Segment
keyboard shortcut 577

Go to Previous Portion (AutoSearch)
keyboard shortcut 578

Go to Previous Segment
keyboard shortcut 578

Go to Previous Segment (AutoSearch - Segments)
keyboard shortcut 578

Go to Previous Segment (no AutoFeatures)
keyboard shortcut 578

Go to Previous Untranslated Segment
keyboard shortcut 578

Go to the Beginning of Table
keyboard shortcut 577

Go to the End of Table
keyboard shortcut 577

Google Translate
machine translation engine 167

graphics
in PowerPoint 343

guaranteed match
definition 584

guaranteed matches
context size 102
locking 102

H
hard return

definition 584
hard returns

PowerPoint 343
sentence delimitation 220

Help content
definition 380
file formats 380
sample 381

Help formats
source file 77

hidden text
Déjà Vu X3   604



ignore in Word 337
Hide column headers

command 110
hide column headers

command 41
Hide tags

command 110
hiding text

in HTML import 535
hierarchy

subjects 193
Highlight options

command 339
Highlight order of preference

command 339
Highlight text in exported files

command 339, 365, 383
Home ribbon tab 23
HTML

customized filter 382
editor 385
encoding 383
export options 135, 137, 382
file formats 381
Ignore Strings in Script 381
import options 381
missing images 385
special characters 382
tips and tricks 385
Unicode 383

HTML import
customized options 533

I
IBM TranslationManager

file formats 397
translate 398
untranslated segment file 398

IDML
support 374

IDML filter
WYSIWYG formatting 377

Ignore Automatic Numbering
FrameMaker import 362
option for FrameMaker import 362

Ignore Classes
Interleaf/Quicksilver import option 380

Ignore Cross-Reference Definitions
FrameMaker 362

Ignore Document Properties
command for MS Office import 347

Ignore Embedded Objects
command for MS Office import 348

Ignore Exact Matches
Trados import option 399

Ignore Hidden Text
import option for Word 337
use 337

Ignore Hidden Text in Document
Interleaf/Quicksilver import option 380

Ignore Line Breaks
InDesign IDML import options 378

Ignore Locked Text Frames
InDesign IDML import options 378

Ignore Red Text
Excel import option 344

Ignore Regex Matches
command for MS Office import 347
XML import option 389

Ignore Strings in Script
HTML import 381

Ignore Text in Neutral Language
Interleaf/Quicksilver import option 380

Ignore Text in Other Language
Interleaf/Quicksilver import option 380

Ignore Text in Single Quotes
C/C++/Java import 394

Ignore Text on Master Page
FrameMaker import 362

Ignore Variable Definitions
FrameMaker import 362
option for FrameMaker import 362

IIF
template 492

ILOTerm
template 492

images
HTML 385

Import
command 79

import
external file into lexicon 436
folder 79
folder structure 79
ribbon settings 25
security restriction 305
selecting several items 67
subfolder 79

Import Comments
C/C++/Java import option 393
command for Microsoft Office (Live) 353
YAML format import option 396

Import Field Results
Word import option 337

import files 66, 78, 79
with Advanced Project Explorer 66

import folders 68
with Advanced Project Explorer 68

import of glossaries
Access 77
Déjà Vu X3 termbases 77
Excel files 77
text files 77

import options
Access 357
apply specific 331
BIF 401, 403
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C/C++/Java 393
Create a New Project wizard 86
Excel 344, 345
FrameMaker 362
HTML 381
PowerPoint 342
project-wide settings 333
RTF 341
TagEditor 401, 403
TMX 405
Trados 399
TTX 401, 403
XML 386

imported comments
Microsoft Office (Live) 351

importing
user lists 307

importing data
into termbase 509
into translation memory 457

importing databases
Access database 76
Déjà Vu X3 translation memory 76
Excel format 76
ODBC database 76
text files 76
TMX 76
Trados Workbench 76

importing glossaries
preparing 77

Include segment ID
command 269

InDesign
encoding 376
export a story 374
file formats 374
tagged text file 374

InDesign IDML
support 374

index
lexicon 425

indicator
current row 34
duplicate rows 45

indicator bars
change color 46

individual translation files
display 61
select 61

Inline Tag
dialog 212

insert
current target with source 216

Insert AutoSearch Portion (Insert)
keyboard shortcut 578

Insert AutoSearch Portion (Overwrite)
keyboard shortcut 578

Insert Current AutoSearch Portion (Insert)
keyboard shortcut 578

Insert Current AutoSearch Portion (Overwrite)
keyboard shortcut 578

Insert Current AutoSearch Segment (Insert)
keyboard shortcut 578

Insert Current AutoSearch Segment (Overwrite)
keyboard shortcut 578

Insert Current AutoSearch Segment without Repair
keyboard shortcut 578

Insert ribbon tab 24
options 24

Insert source text
command 101

integrated development environment 55
interface

Déjà Vu X3 19
project 20

Interleaf
ASCII files 379
file formats 379
save as ASCII file 379

internal codes. See tags
internal repetition

how it works 321
inter-project

analysis 319
intra-project analysis 319
Italics

keyboard shortcut 575
ITD

support 404
workarounds with problems 404

iTranslate4.eu
machine translation engine 167

J
Java

file formats 392
Java files

definition 392
Java properties

definition 391
file formats 391
sample 391

Jet engine 140
join lines

Excel 345
Join Segments

command 220
keyboard shortcut 577

join segments
satellite files 260
security restriction 297

joining segments 219, 220
reasons 219
tag 221

jump to
previous segments 62
previous untranslated segment 62
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untranslated segment 62
jump to next segment

no status change 62

K
keyboard shortcuts 32

access to Déjà Vu X3 features 32
add new 32
customize 32
list of 575
modify 32

L
language

selecting in project 54
language mapping

BIF 401
TMX 405
TTX 401
XLIFF 403

language selector 54
language setting

user 304
language user

add 302
language users

definition 297
languages

available for spell check 127
display order 83
select 83
switch user interface 20
vs. sub-languages 83

leading symbols 215
legacy Office files

how to detect 349
lemma

definition 584
Lexicon

ribbon tab options 23
lexicon

change sorting 426
concept 96
create 97
create command 97
current language 429
current vs. all files 97
definition 96, 425, 585
export 431
for project manager 96, 426
frequency (Freq) 98
generating 96
glossary for clients 96, 426
importing external file 436
in comparison to other databases 96
language 429
manual translation 98
manually add entries 427

new concept 425
number of words 98
open from Project Explorer 98
optional workflow component 96
reasons for adding entries 427
removal options 99
remove entries 99, 435
remove rows 99
resolve with databases 98
resolve with termbases 428
resolving the translation memories 428
resolving with databases 427
send to termbase 430
sending data 181
sending text 177
sending to translation memories 429
sorting options 427
translate 98
translating outside of Déjà Vu 435
translating with other databases 97
useful vs. useless entries 97
uses 426
vs. termbase 426

lexicon export
into text format 432
supported formats 432

lexicon import
supported formats 437
uses 436

LibreOffice
support 354

license
activate

license
deactivate 31

Limit the number of Translation Memory segments 
displayed to

command 110
Limit to current view

option 180
lines

moving 62
switching 62

Linguatec
machine translation engine 167

Live Preview
Microsoft Office (Live) 351

Live Preview feature 133
load

Microsoft Office spell checker 132
local drive

Advanced Project Explorer 65
Locate Segment

translation memory 442
Locate Term

termbase 516
locating term

termbase 525
location of source files 78
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Lock
symbol 181

lock
group of segments 181
unlock segments 181

Lock guaranteed matches
command 102

lock segments
benefit for project manager 182
satellite files 260
security restriction 297

Lock Strings Heuristically
command 394

Lock vertical scrolling in the translation grid
command 63

Lock/Unlock Segments
keyboard shortcut 577

locked row
symbol 45

locked segments
and propagate 200
view 182

Locking Segments
command 181

Log in
command 309

log in
project 309
repeat 309
termbase 309
translation memory 309

Log out
command 310

log out
project 310
termbase 310
translation memory 310

login name 297
Lookup

keyboard shortcut 576
lookup

database 146
definition 146, 585
termbase 146, 151
with wildcards 152
with word stems 152

Lookup with Wildcards
command 153
keyboard shortcut 576

M
machine translation 165

definition 585
for assemble 173
for fuzzy match repair 171
usage 165
with AutoWrite 176

machine translation engines

activate 168
Macintosh

change code page 371
macros disabled

Word 341
main interface

translation grid 33
main sentence

in translation memory 460
manual

convention 12
how to use 9
index 10
menu commands 12
notes 12
overview 9
path names 12
related documentation 13
sample text 12
user interface controls 12

manual assemble 157
manual propagate 199, 201

difference to AutoPropagate 200
manual translate process 158
manually adding records

termbase 507
manually resize

windows 58
manually translate

with MT 170
mapping

fonts 363
marking segments as pending 241
match

definition 585
maximum number of words

lexicon 97
memoQ

support through XLIFF 402
memory databases. See translation memory
menu bar 22
Merge

command for termbase units 528
merge

translation memory 444
Merge External View Data

dialog 273
merge segments

security restriction 297
merging

termbase 527
Microsoft Access. See Access
Microsoft Bing Translator

machine translation engine 167
Microsoft Excel. See Excel
Microsoft Jet

databases 140
Microsoft Office (Live)

definition 585
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import options 351
supported versions of Office 351

Microsoft Office (Live) Filter
WYSIWYG formatting 206

Microsoft Office spell checker 234
loading 132

Microsoft Word 2003 and below
support 336

Microsoft Word 2013/365 PDF converter 355
MIF Font Mapping

tab (Project Properties dialog) 363
minimum score 145, 146

recommended setting 145
missing spaces

prompt at export 135
mode

edit 34
edit vs. selection 34
selection 63

model
workflow 75

modify
sentence segmentation rules 218
tags 211

modify data
AutoSearch window 182

modifying term
termbase 525

monitor
working with several 56

MorphoLogic
machine translation engine 167

mouse
move 63

move
beginning of file 63
context menu 63
end of file 63
lines 62
mouse 63
screen up and down 63
scrollbar 63
tags 208, 211
wheelmouse 63

moving around
project file 61

mqxliff
support 402

mqxlz
support 402

MS Office 2007 and above
support 345

MS Word
word counts 318

multiple exact matches 103
multiple matches

accept all 103
MyMemory

machine translation engine 167

N
natural order 42

definition 585
switch to alphabetic order 43

nested tags
extractable text in XML 409

network drive
Advanced Project Explorer 65

New
command 81, 411, 419, 448, 463, 488
File menu 26, 30

New Attribute
dialog 512

new features
overview 15

New File
dialog 82, 92, 411, 420, 449, 463, 489
keyboard shortcut 575

new files
import into old vs. new projects 180

new project
create 81, 87

New Relation
dialog 512

New User
dialog 301, 304, 305

newer matches
databases 144
termbases 146

Next Bookmark
dialog 240
keyboard shortcut 579

next segment
jump to 62

nickname. See user
Non-translatable Notes

WinHelp example 338
WinHelp files 337
Word import option 337

notes
import option for PowerPoint 343
non-translatable in Word 337
OpenOffice.org/LibreOffice 354

number conversions
limitations 214

number of characters
RC files 392
status bar 54

number of records
termbase 485
translation memory 455

numbers
consistency checks 122
conversions 214
in propagate 199

numerical listing
clients 186
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O
OBDC compliant data sources

data formats 360
ODBC

definition 585
description of export 479, 519

ODBC compliant data sources. See Access
ODBC data source

termbase export 519
termbase import 509
translation memory import 458, 473

ODBC Import Options
dialog 358

Office 2007 and above
support 345

Office Proofing Tools
reload 132

Only show matches with the requested sublanguage
command 83

Open
File menu 27

Open Document
support 353

Open File
keyboard shortcut 575

open files
access from selector bar 62

Open XML
support 345

opening
alignment file 470
translation memory 447

OpenOffice 2 and above
support 354

OpenOffice.org
file formats 353

OpenOffice.org/LibreOffice
notes 354
record changes 354
use AutoFormat 354

OpenTM2
file formats 397

Options
File menu 31

options
import 331
spelling 233

options for pretranslation 101
order

alphabetical 43
natural 42

Order of Termbases
option 505

Order of Translation Memories
option 454

order of words
change 158

overview
databases 140

manual 9
overwriting

pretranslation 102

P
Pack & Go Export Progress

dialog 275
Pack & Go packages 274

create 274
definition 274, 586
open 275
return 278
satellite files 264
sharing option 274
size reduction 275
translate 277
uses 274

PageMaker
encoding 371
export a story 367
file formats 367
re-import the story 370, 376
tagged text file 367
tips and tricks 371
working with double-byte languages 371
working with Mac files 371

password
change 300

Paste
keyboard shortcut 575

paste
standard features 215

PDF
support 354

Pending
keyboard shortcut 577

pending
definition 586
mark segments 241

pending symbol 241
pending, mark as

benefits 133
performance

databases 140
permissions

user settings 305
plain text

file formats 380
PO/POT

file formats 396
populate

all segments 216
definition 216, 586
one vs. all segments 217
overwrite 217
single segments 216

Populate All Languages
keyboard shortcut 578
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Populate Current Language
keyboard shortcut 578

Populate Current Segment
command 216, 217, 435
keyboard shortcut 578

Populate Current Segment (Insert)
keyboard shortcut 578

populating
all target languages 217

Portions found window. See AutoSearch - Portions
position indicator 392
position of characters

status bar 54
position of current record

status bar 54
Power Scan 148

use 148
PowerPoint

check for graphics 343
file formats 342
import options 342
installation requirements 342
location of original files 342
prepare files 343
tips and tricks 343

PowerPoint 2003 and below
support 342

PPF
support 403

preparing glossaries for import 77
preprocessed files

source files 78
presentation formats

source file 77
Pretranslate

dialog 101
keyboard shortcut 576

pretranslate
definition 586

pretranslation
accept only exact matches 101
assemble from portions 101
benefits 100
check for inconsistent terminology 102
DeepMiner 159, 165
definition 100
insert source text 101
lock guaranteed matches 102
options 101
overwriting 102
process 100
Use DeepMiner statistical extraction 101
Use Machine Translation 101

pretranslation phase 100
prevent project records containing certain characters in 

certain language from being sent to 
TM 554

prevent row
sending to translation memory 180

preventing line breaks in script text
in HTML import 537

Preview feature 133
Previous Bookmark

dialog 241
keyboard shortcut 579

previous segment
jump to 62

previous untranslated segment
jump to 62

primary window 59
definition 586

Process Embedded HTML
XML import option 388

Process embedded HTML
command for MS Office import 346

Process notes
import option for PowerPoint 343

Process Slide Master
import option for PowerPoint 343

Project
ribbon tab options 23

project
analysis 319
associate termbases 502
associate translation memories 450

project building phase 78
Project Explorer 36, 87

definition 36, 586
differences from Advanced Project Explorer 65
navigating the project 65
selecting files to view 61
switching with Advanced Project Explorer 24

project file 19
compact 140
create 81
create on a template 87
definition 586
moving around 61
reading 114
reading a hard copy 114
reading in Déjà Vu X3 114
repair 141

Project From Template
command 92

Project from Template
command 91

project glossary
lexicon 425

project ID 183
field in databases 183
on General tab 187, 194

project interface 20
project owner

configuring profile 299
project owners

definition 297
project security

enable 298
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Project Templates
dialog 88

Proofing
tab (Options dialog) 234

proofing
export into original format 132
within Déjà Vu X3 133

proofing in Déjà Vu X3
pros and cons 133

proofing in original format
pros and cons 132

Proofread
confirm status 246

propagate 199
AutoPropagate 200
definition 199, 587
manually 201
manually to all files 201
overwrite 200

Propagate in Current File
command 202
keyboard shortcut 579

Propagate in Current File (Overwrite)
keyboard shortcut 579

Propagate to All Files
command 201
keyboard shortcut 579

Propagate to All Files (Overwrite)
keyboard shortcut 579

propagation
differences between different modes 200

propagation. See propagate
Properties

dialog (New Project Wizard) 330
pane (Project Explorer) 330, 332

properties files. See Java properties
Properties window 67, 70, 79

definition 587
in Advanced Project Explorer 70, 79
in Project Explorer 67

Proposed Translation
Scan Results dialog 147

protect
segments 181

Pseudotranslate
dialog 203

Pseudotranslation
functions 202

pseudotranslation 202
and double-byte languages 202
definition 587

pwn.pl
machine translation engine 167

Q
quality assurance features 114
Quality Assurance options

category 115

quality assurance phase 114
Quark files

process with ex TranslationFilter 374
QuarkXPress

batch export .xtg files 374
CopyFlow 374
export .xtg file 371
file formats 371
re-import .xtg file 372
Tag file 371
tips and tricks 374

Quick Access Toolbar 21
customization 21
customize 21
New command 81, 91, 411, 419, 448, 463, 488

QuickSilver. See Interleaf

R
range of rows

select 64
RC

file formats 391
RC files

character count 392
converting quotes 392
copyright note 392
definition 391
sample 392
tips and tricks 392

read access
termbase 505
translation memory 454

read attribute
termbase 112
translation memory 178

reading the project file
different methods 114

readme file 13
rearrange windows 55
recently opened files 27
record

jumping to specific 62
record changes

OpenOffice.org/LibreOffice 354
record locator 42
red text

ignore in Excel 344
Redo

keyboard shortcut 575
redo

perform 230
reflexive

definition 498, 587
reflexive relation

definition 498
regular expressions

definition 587
for filtering export from termbase 557
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for filtering export from translation memory 557
Reimport Package

dialog 265, 272
reimporting a file 272
related documentation

readme 13
user group 13
website 13

Relations
tab (Termbase Properties dialog) 497

relations
defining for termbase 497

Relations (tab)
Termbase Properties dialog 497

reload
image of the embedded file in MS Word 350

Reload Office Proofing Tools
command 132

Remember password
command 280

Remove
translation memory 443

remove
duplicate segments indicator 127
sentence segmentation rule 219
status indicators 49

remove association between termbase records entered 
on a certain date 544

Remove Filter
command 127
keyboard shortcut 579

Remove Lexicon
command 435

Remove lexicon entries
dialog 99

Remove lexicon rows
dialog 436

renumbered matches 312
repair

project file 141
reasons 141
satellite file 141
termbase 141
translation memory 141

repair database 140
Repair fuzzy matches

command 143
repairing installation. See Getting Started Guide
repairing of fuzzy matches

DeepMiner 159
reparing of fuzzy matches

example 159
Replace

command 229
dialog 229
keyboard shortcut 576

replace 229
features 228

Request Floating License

command 293
dialog 293

Require Control key to Insert AutoSearch results
command 109

reset
status indicators 49

Reset Segment Status
keyboard shortcut 577

resize
windows 58

Resolve
lexicon 98

Resolve Lexicon
dialog 428, 429

Resolve with Deep Miner Statistical Extraction
command (Lexicon) 428

Resolve with Termbase
command (Lexicon) 428

Resolve with Translation Memory
command (Lexicon) 428

resource files. See RC
RESX files

support 394
RESX-Specific Import Options 394, 396
review

comment 244
review features 239
Review ribbon tab 24

options 24
ribbon tab

Home 23
Insert 24
Lexicon 23
Project 23
View 24

ribbon tabs
customize 25

ribbon tabs for Déjà Vu in MS Office 349
Rich Text Format. See RTF
roles

different 297
rows selector 43
RTF

file formats 341
import options 341
Microsoft standard 341
non-Microsoft versions 341
security settings 341

RTF import options. See Word
rules

segmentation 217
Run CodeZapper

command for MS Word import 338
Russian

user interface language 21

S
Satellite
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definition 250
Satellite Export Wizard 261
satellite file

compact 140
repair 141

satellite files 260
compact 263
create 261
definition 260, 587
full 263
import 265
Pack & Go packages 264
restrictions 260
security options 260
vs. project files 260

Satellite vs. Divide & Dispatch
differences 250

save 230
project 230
SQL expressions 554
SQL statement 53

Save As
File menu 27

Scan
keyboard shortcut 576

scan
database 146
definition 146, 588
navigate matches 148
translation memories 146
translation memory 146
with wildcards 149
with word stems 149

Scan Results
dialog 147

Scan with Wildcards
keyboard shortcut 576

sci files
support 353

script-based files 381
scrollbar

move 63
SDL MultiTerm

termbase export 519
SDLX

support through ITD 404
sdlxliff

support 402
search

features 228
termbase 151
with wildcards 149, 152

search and replace 229
secondary window 59

definition 588
security

definition 588
security features

in Déjà Vu X3 297

security options
satellite files 260

security restriction
configuration access 297
delete files 297
edit source 297
execute SQL 297
export 305
import 305
lock segments 297
merge segments 297
split join 297
split rows 297

security settings
translators vs. editors 307

See in Context
command 213
keyboard shortcut 577

Segment Highlight Options
dialog for FrameMaker export 365
dialog for HTML export 383
dialog for Word export 339

segment pairs
duplicates in translation memory 179
overwriting in translation memory 179

segment scan 146
Segment Selector

definition 588
Duplicate Segments 126

segment selector
view pending rows 242

Segmentation
tab (Options dialog) 218

segmentation
sentences 217

segmentation rule. See sentence delimitation
segments

definition 588
joining 219, 220
locking 181
mark as pending 241
protecting 181
splitting 219, 220

Segments Found window. See AutoSearch - Segments
select

all rows 64
all rows downwards 64
all rows upwards 64
existing project file 78
languages 83
range of rows 64
rows by filtering 64
rows by status 64
SQL 49

Select All
keyboard shortcut 576

Select Location of "New Pack & Go Package"
dialog 275

select rows 63
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in selection mode 63
Select SQL

dialog 50, 446, 530
selection mode 34, 63

moving in the project 63
switch into 34, 63

selection vs. edit mode 34
selector row 42

definition 588
selector rows

language selector 54
rows selector 43
text/record locator 42

Send Lexicon to Termbase
dialog 431

Send Lexicon to Terminbase
dialog 431

Send Lexicon to Translation Memory
dialog 430

Send Project to Translation Memory
dialog 179

sending data
lexicon 181
termbase 181

sentence delimitation
alignment 467
correcting errors 220

sentence pairs
overwriting in translation memory 180

sentence segmentation 217, 219
Asian languages 219
common abbreviations 217
common rules 217
definition 217
differing punctuation between languages 218
exceptions 217, 218
modify rules 218
non-Western punctuation systems 219
remove rule 219
symbols and definition 218

separate sentences. See sentence segmentation
set font 58
settings.dvset file

changing location 184
SGML

definition 409, 589
SGML files

supported with XML filter 386
Share

File menu 28
Shared settings location

option 185
sharing

different options 249
shortcuts

keyboard 32
Show Machine Translation results for whole segments

command 110
Show segments and portions in separate windows

command 109
SilvaTerm

template 492
simple word count 311
single translation files

select 61
slide master

import option for PowerPoint 343
soft return

definition 589
soft returns

PowerPoint 343
sentence delimitation 220

software development formats
source file 77

sort alphabetically
benefits 133

sort by status
benefits 133

Sort Lexicon
dialog 426
toolbar 426

sort order
switch 43

sorting
lexicon 426

Sought Source
Scan Results dialog 147

Source
Terminology Lookup dialog 151

source
definition 589

Source Attributes
Terminology Lookup 151

source files
database format 77
desktop publishing format 77
EBU files 77
file management 78
formats 77
Help format 77
location 78
network 78
originating application 78
preprocessed files 78
presentation format 77
selecting in Create a New Project wizard 85
software development formats 77
spreadsheet format 77
tagged formats 77
word processing formats 77

source language
termbase interface 515

Source Segment in Context
dialog 213

source view. See context view
spaces

consistency checks 124
missing at export 135
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QA command 124
Spanish

user interface language 21
special characters

HTML 382
specific record

jumping to 62
spell check

Déjà Vu X3’s spell checker 129
with MS Office 131

spell check with MS Office
condition 131

spell checker
Microsoft Office 234

spell checking 127
dictionaries 235
integrated languages 127
options 130
termbase 530
translation memory 471

Spell Checking Options
dialog (termbase) 530
dialog (TM) 471

Spelling
keyboard shortcut 577

spelling
options 233

spelling option
use the Microsoft Office spell checker 234

split lines
Excel 345

split rows
security restriction 297

Split Segments
command 220
keyboard shortcut 577

split segments 220
satellite files 260

splitting segments 219
reasons 219
tag 221

spreadsheet formats
source file 77

SQL
access to databases 140
definition 589
tab in Options dialog 555
with Batch QA 117

SQL command
delete data from termbase 539
delete data from TM 539
update records in the project file 550, 551, 554
update records in the termbase 550, 551
update records in the TM 550, 551

SQL expressions
save 554

SQL select 49
termbase 530
translation memory 446

SQL Statement
record locator 46
view 49

SQL statement
create and save 555
save 53

squiggly red underline 128
Start screen 90
Start-up options

command 91
Statistics

tab (Termbase Properties dialog) 486
tab (Translation Memory Properties dialog) 456

statistics
translation memory 455

statisticstermbase 485
status

select rows by 64
tooltip 46

status bar 54
number of characters 54
position of current record 54
position of cursor 54
shortcut to automated options 54
stacked 54

status filter 43
status indicator

assembled segments 105
AutoPropagate 200
reference 46
review 46

status indicator bar 43
status indicators

remove 49
reset 49

subfolder
import 79

subject
add to list of subjects 195
assigning to records 194
definition 183
delete 198
find 198
modify 196
purpose 183
search 198
storing settings 184

Subjects
tab (Options dialog) 193

subjects 183
associated codes 193
hierarchical listing 193
managing 199
non-numeric codes 193
preset list 193
relevance 199
relevance of hierarchy 193
select for project 194

sub-languages
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matching hierarchy 83
Subscript

keyboard shortcut 575
subsegments

count with internal repetition 321
subtitle formats

source file 77
Sunda Systems Oy

machine translation engine 167
Superscript

keyboard shortcut 575
Swap Current and Next Words

keyboard shortcut 577
Swap Previous and Current Words

keyboard shortcut 577
switching lines 62
sxc files

support 353
sxw files

support 353
symbol

Do Not Send 180
finished row 45, 246, 247, 311
Lock 181
locked row 45
pending 241
Warning 208
wrong codes 45

symbols
sentence segmentation 218

symmetric
definition 498, 589

symmetric relation
definition 498

synonym
add to termbase 514
definition 589

SYSTRAN
machine translation engine 167

T
tab

Review 24
tabbed interface 58
tag

definition 589
joining/splitting segments 221

tag count 316
TagEditor

export options 401
import options 401, 403

TagEditor. See Trados TagEditor
tagged formats

source files 77
tags 204

across formats 206
across tags 206
automatically copying all 209

automatically fixing 210
consistency checks 124
conversions 214
copying 208
copying automatically 209
definition 204
deleting 211
deleting all 211
deleting single 211
drawbacks of modifying 212
example 204
manually copying 210
modifying 211
moving 208
moving from source to target 211
positioning 207
problems when reversing 208
relative positioning 207
relevance 204
safety features 208
translate process 157

tags (XML)
definition 409

Tags and Attributes (XML)
tab 414, 423

Target
Terminology Lookup dialog 151

target
definition 590

Target Attributes
Terminology Lookup 152

Target Language Selector
definition 590

TBX
template 493

TEAMServer
connecting a new project to 281
connecting to 279
connecting to projects 279
definition 590
export a Déjà Vu X3 TM to 285
export option for translation memories 473
exporting local termbases to 290
exporting termbases 519
TM export to 286
tracking 293

TEAMserver
exporting local TMs to 285
working with 279

TEAMserver Login
dialog 280, 282, 452, 503

teamwork features
benefits 249

template
create project with 87

Template Name
dialog 494

Templates
command 87
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templates
assigning 493
creating 494
defining in wizard 490
definition 491, 590
Eurodicautom 492
termbases 491

Templates folder
typical location 491

termbase
add terms 113
adding additional information 183
adding non-translation records 514
adding records 112, 506
adding translation records 506
All Rows view 530
associate with project 502
compact 140
create 84
create as stand-alone file 487
create with Create a New Project wizard 84
creating 487
defining attributes 499
defining categories 501
defining relations 497
definition 19, 590
deleting term 527
displaying attributes in AutoSearch pane 499
editing 525
editing term 526
exporting data 518
filtering the export 522
fuzziness setting 144, 145
importing data 509
importing glossaries 76
Locate Term 516
locating term 525
lookup 146, 151
manually adding records 507
merging 527
modifying term 525
opening 485
options to create 487
read and write access 505
read and write attributes 112
remove from project 503
select 84
select with Create a New Project wizard 84
sending data 181
sending text 177
spell checking 235, 530
SQL select 530
standard fields 511
statistics 485
supported import formats 509
templates 491
views 530

termbase attributes
considerations 114

termbase interface
source language 515

termbase lookups
options 145

Termbase Properties
dialog 486, 496

termbase records
specifications 114, 508

termbase statistics
view of 486

Termbase Templates
dialog 493, 494

termbase templates
change location of 90, 491

Termbases
tab (Project Properties dialog) 112

termbases
creating and maintaining 485
export subset 264, 278
minimum score 146
newer matches 146

terminology
consistency checks 121

terminology consistency checks 115
terminology database

repair 141
search 151

Terminology Lookup
dialog 151, 154

terminology mismatch
check current row 120

Termite
template 492

text
description of import 479, 519
file formats 380

text area
translating in 35

text box
translating in 35

text expansion
and Pseudotranslation 202

text files
encoding 380
termbase export 519
termbase import 509
translation memory import 458, 473

text locator 42
Text/Record Locator

definition 591
text/record locator 42
Thai

support on Windows 202
third-party databases

Access database 76
Déjà Vu X3 translation memory 76
Excel format 76
formats 76
import in translation memory 75
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ODBC database 76
text files 76
TMX 76
Trados Workbench 76

third-party glossaries
Access 77
Déjà Vu X3 termbases 77
Excel files 77
formats 76
import in termbase 76
origin 76
text files 77

tile horizontally
windows 58

tile vertically
windows 58

time stamp 183
definition 591
field in databases 183

tips and tricks
FrameMaker 367
HTML 385
PageMaker 371
PowerPoint 343
QuarkXPress 374
RC 392
Trados Workbench 400
Word 341
XML 390

TIS
template 492

TMX
definition 591
description of import 474
export options 406
file formats 404
import options 405
language mapping 405
source and target 404
translation memory import 458, 473
use as a translation format 404
vs. Trados export 474

Toggle Bookmark
keyboard shortcut 579

tool window
closing 58
definition 55, 56, 591
disable docking 57
docking 56

tool windows
tabbed interface 58

toolbar
Sort Lexicon 426

toolbox
Déjà Vu 10

tooltip
status 46

track changes
Word 341

Track in TEAMserver
command 294

Tracking
in TEAMServer 293

tracking data
upload to TEAMServer 295

Trados
import options 399
vs. TMX export 474

Trados RTF. See Trados Workbench
Trados Studio

support through XLIFF 402
Trados TagEditor

file formats 400
fuzzy matches 401, 404
XTranslated units 401

Trados Word
fuzzy matches 399

TRADOS Workbench
sharing option 270

Trados Workbench
configure file extension 400
definition 250
description of import 474
file formats 399
installation requirements 399
location of original file 400
Segment Unknown Sentences 400
split/join sentences 400
tips and tricks 400

Trados Workbench databases
translation memory import 458, 473

Trados-specific language specifier
TM export 478

trailing symbols 215
Transit NXT

support 403
transitive

definition 498, 591
transitive relation

definition 498
Translate

keyboard shortcut 576
translate process 154

context menu 157
definition 156
manually 157, 158
several choices 157
tags 157
vs. AutoTranslate 157
vs. pretranslation 157

Translate with Google Translate
keyboard shortcut 576

Translate without Repair
keyboard shortcut 576

Translated
confirm status 246

translation features
Déjà Vu X3 139
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translation grid 33
automatic resizing 34

translation memories
creating and maintaining 441
export subset 264, 278

translation memory 19
Add 443
adding additional information 183
adding records manually 111
All Rows view 445
associate with project 450
compact 140
create 84
create with Create a New Project wizard 84
creating 447
creating as stand-alone file 448
definition 19, 591
Duplicates Only view 446
exporting data 473
Filter 443
filtering the export 476, 482
Find Duplicate Segments 446
fuzziness setting 144
importing data 457
importing databases 75
interface 441
Locate Segment 442
manually sending data 178
merge 444
opening 447
options to create 447
order of use 454
prevent sending row 180
read and write attributes 178
reads and write access 454
Remove 443
remove from project 451
repair 141
scan 146
select 84
select with Create a New Project wizard 84
send portion of sentence 179
send project options 180
send whole project 179
sending data 177
sending text 177
spell checking 235, 471
SQL select 446
standard fields 460
statistics 455
supported import formats 457, 473, 518
write attribute 111

translation memory interface
source language 441
target language 442

translation phase 103
translation status categories

in count 311
translation users

different levels of access 297
translation workflow 75
TranslationManager. See IBM TranslationManager
translations for duplicate source

consistency checks 125
Transref website 13
Trident MT

machine translation engine 167
TTX

export options 401
import options 401, 403
language mapping 401

TXML
support 404

type of project
on General tab 187, 194

U
UDC. See Universal Decimal Classification
Underline

keyboard shortcut 575
Undo

keyboard shortcut 575
Unfilter

command 65
unfilter

filter on selection 65
Unicode

definition 592
HTML 383

uninstalling Déjà Vu. See Getting Started Guide
Universal Decimal Classification 193
unlock segments 181
unmark

duplicate segments indicator 127
Unmark Duplicates

command 127
Unmarked Manual Translation

option 180
Unterm

template 492
untranslated segment

jump to 62
up one screen

move 63
upload

tracking data 295
Use DeepMiner engine

command in Options dialog 164
command in Pretranslate dialog 165

Use DeepMiner statistical extraction
command 143
commans 101

Use Machine Translation
command 101, 143
command in Options dialog 171
command in Pretranslate dialog 172

Use Machine Translation for whole segments
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command 173
Use PDF converter in Word 2013

command for PDF import 355
Use textboxes for layout

command for PDF import 357
use the Microsoft Office spell checker

spelling option 234
User

tab (Properties dialog) 298
user 183

add 302
delete 308
field in databases 183
full name 300
language setting 304

user dictionaries. See dictionaries
user group

Déjà Vu 13
user interface

Déjà Vu X3 19
project 20
switch language 20

User Interface Language
change 20

user list 299
User Login

dialog 309
user name 297, 309

default Windows logon 55
in databases 55
in the translation memory or termbase 309
on status bar 309

User Properties
dialog 299, 308

user settings
change 308

user types 10
beginner 10
convert 11
power user 12
upgrader 11

Users
tab (Properties dialog) 300, 303

users
adding for several languages 307
definition 297
different levels of access 297
import lists of 307

UTF-16
definition 592

UTF-8
definition 592

V
Validate

for TM export 476
Vietnamese

support on Windows 202

view
All Files 61
context 212
SQL Statement 49

View Project Explorer
keyboard shortcut 577

View Properties
keyboard shortcut 577

View ribbon tab 24
options 24

views
termbase 530

Vintars
template 492

W
Warning

symbol 208
wheelmouse

move 63
wildcard

definition 591
wildcards

client search 192
lookup with 152
scan with 149
subject search 198

window
primary 59
secondary 59

Window Type
option 59

windows
rearrange 55

Windows Character Map 24
Windows functions

common 227
Windows logon

user name 55
wizard

Create a New Project 92
New Project 82

Word
character spacing 341
comments 341
export options 339
macros 341
security setting 341
tips and tricks 341
track changes 341

Word Count
command 313
dialog 314
keyboard shortcut 577

word count 313
full 313
MS Word’s logic 314
save in external file 317
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simple 312
word count modules

simple vs. full 311
word counts

according to MS Word 318
word processing formats

source file 77
word stems

lookup 152
scan 149

Wordfast Pro
support through TXML 404

Wordfast TXML
support 404

Words Freq
lexicon 98

workflow
editing and QA phase 114
editing phase 114
export phase 134
preparation phase 75
pretranslation 100
project building phase 78
quality assurance phase 114
suggestions 75
translation phase 103

workflow phase
preparation 75

WorldServer
support through XLIFF 402

write access
termbase 505
translation memory 454

write attribute
destination database 111
termbase 112
translation memory 178

wrong codes
symbol 45

WYSIWYG
IDML filter 377

WYSIWYG formatting
Microsoft Office (Live) 351
of MS Office files 206

X
XLIFF

export format 266
language mapping 403

XLIFF file
opening and editing in other tools 267

XLIFF files
sharing option 266
support for import for translation 402

xlz
support 402

XML
defining the filter 390

definition 385, 592
definition of attributes 409
definition of tags 409
encoding 390
export options 135, 137, 390
extractable attribute 410
extractable text 409
Filter Definition File 386
filter file 19
how to recognize 386
import options 386
support 386
tips and tricks 390

XML attributes
extracted 416

XML filter
adding data 424
create from DTD 419
create from XML file 410
definition 19, 592
delete examples 417

XML filter files
compact 140
creating 409
maintaining 409

XML tags
embedded 415, 416

Y
YAML files

support 395
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